commit
9b9c950230
@ -0,0 +1 @@
|
|||||||
|
b1ef06942ff00b4d0c8dc361213a1542717855cc SOURCES/gavl-1.4.0.tar.gz
|
@ -0,0 +1 @@
|
|||||||
|
SOURCES/gavl-1.4.0.tar.gz
|
@ -0,0 +1,60 @@
|
|||||||
|
diff -up gavl-1.1.1/configure.ac.gdither gavl-1.1.1/configure.ac
|
||||||
|
--- gavl-1.1.1/configure.ac.gdither 2009-07-13 22:42:38.000000000 +0200
|
||||||
|
+++ gavl-1.1.1/configure.ac 2009-10-28 00:02:31.461428785 +0100
|
||||||
|
@@ -217,6 +217,27 @@ TOP_SRCDIR=`cd ${srcdir} && pwd`
|
||||||
|
AC_SUBST(TOP_SRCDIR)
|
||||||
|
|
||||||
|
dnl
|
||||||
|
+dnl System libraries
|
||||||
|
+dnl
|
||||||
|
+
|
||||||
|
+AC_ARG_ENABLE(libgdither,
|
||||||
|
+ [ --enable-libgdither System libgdither (experimental)])
|
||||||
|
+if test "${enable_libgdither}" = "yes"
|
||||||
|
+then
|
||||||
|
+ PKG_CHECK_MODULES(LIBGDITHER, libgdither,
|
||||||
|
+ [
|
||||||
|
+ AC_DEFINE(HAVE_LIBGDITHER, 1, [Define to 1 if you have the `libgdither' library (-lgdither).])
|
||||||
|
+ have_libgdither="true"
|
||||||
|
+ ],
|
||||||
|
+ [
|
||||||
|
+ have_libgdither="false"
|
||||||
|
+ ]
|
||||||
|
+ )
|
||||||
|
+fi
|
||||||
|
+AM_CONDITIONAL(HAVE_LIBGDITHER, [test x$have_libgdither = xtrue])
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+dnl
|
||||||
|
dnl Output variables
|
||||||
|
dnl
|
||||||
|
|
||||||
|
diff -up gavl-1.1.1/gavl/Makefile.am.gdither gavl-1.1.1/gavl/Makefile.am
|
||||||
|
--- gavl-1.1.1/gavl/Makefile.am.gdither 2009-05-13 17:10:37.000000000 +0200
|
||||||
|
+++ gavl-1.1.1/gavl/Makefile.am 2009-10-28 00:04:37.837435280 +0100
|
||||||
|
@@ -40,8 +40,15 @@ threednow_libs =
|
||||||
|
threednow_subdirs =
|
||||||
|
endif
|
||||||
|
|
||||||
|
+if HAVE_LIBGDITHER
|
||||||
|
+ MAYBE_LIBGDITHER_LA = @LIBGDITHER_LIBS@
|
||||||
|
+else
|
||||||
|
+ MAYBE_LIBGDITHER = libgdither
|
||||||
|
+ MAYBE_LIBGDITHER_LA = libgdither/libgdither.la
|
||||||
|
+endif
|
||||||
|
+
|
||||||
|
|
||||||
|
-SUBDIRS = hq c libgdither libsamplerate $(mmx_subdirs) \
|
||||||
|
+SUBDIRS = hq c $(MAYBE_LIBGDITHER) libsamplerate $(mmx_subdirs) \
|
||||||
|
$(sse_subdirs) \
|
||||||
|
$(sse2_subdirs) \
|
||||||
|
$(sse3_subdirs) \
|
||||||
|
@@ -109,7 +116,7 @@ $(sse3_libs) \
|
||||||
|
$(threednow_libs) \
|
||||||
|
c/libgavl_c.la \
|
||||||
|
hq/libgavl_hq.la \
|
||||||
|
-libgdither/libgdither.la \
|
||||||
|
+$(MAYBE_LIBGDITHER_LA) \
|
||||||
|
libsamplerate/libsamplerate.la \
|
||||||
|
@LIBGAVL_LIBS@ \
|
||||||
|
-lm
|
@ -0,0 +1,21 @@
|
|||||||
|
Include <string.h> for memset, to avoid an implicit function
|
||||||
|
declaration and build failures with future compilers.
|
||||||
|
|
||||||
|
Fixed upstream as part of:
|
||||||
|
|
||||||
|
r5451 | gmerlin | 2018-11-27 20:38:42 +0100 (Tue, 27 Nov 2018) | 2 lines
|
||||||
|
|
||||||
|
* Update
|
||||||
|
|
||||||
|
diff --git a/src/fill_test.c b/src/fill_test.c
|
||||||
|
index 1d362bea4af85745..6fd97dab9e192baa 100644
|
||||||
|
--- a/src/fill_test.c
|
||||||
|
+++ b/src/fill_test.c
|
||||||
|
@@ -23,6 +23,7 @@
|
||||||
|
//#include "colorspace.h" // Common routines
|
||||||
|
#include <stdio.h>
|
||||||
|
#include <png.h>
|
||||||
|
+#include <string.h>
|
||||||
|
|
||||||
|
static void
|
||||||
|
write_png(char * filename, gavl_video_format_t * format, gavl_video_frame_t * frame)
|
@ -0,0 +1,22 @@
|
|||||||
|
Avoid an implicit int in the clock_gettime test, to keep the same test
|
||||||
|
outcome with future compilers that do not support implicit ints.
|
||||||
|
|
||||||
|
Fixed upstream as part of:
|
||||||
|
|
||||||
|
r6246 | gmerlin | 2021-09-01 11:46:30 +0200 (Wed, 01 Sep 2021) | 2 lines
|
||||||
|
|
||||||
|
Applied cross-building.patch by Helmut Grohne
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 90b0be6c89df4b3b..1df85ad6c222ce8d 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -162,7 +162,7 @@ AC_MSG_CHECKING(for CLOCK_MONOTONIC)
|
||||||
|
AC_TRY_RUN([
|
||||||
|
#include <time.h>
|
||||||
|
#include <errno.h>
|
||||||
|
-main()
|
||||||
|
+int main(void)
|
||||||
|
{
|
||||||
|
struct timespec tp;
|
||||||
|
if(clock_gettime(CLOCK_MONOTONIC, &tp))
|
@ -0,0 +1,235 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.7.2)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 37;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
Name: gavl
|
||||||
|
Version: 1.4.0
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: A library for handling uncompressed audio and video data
|
||||||
|
|
||||||
|
# Automatically converted from old format: GPLv3+ - review is highly recommended.
|
||||||
|
License: GPL-3.0-or-later
|
||||||
|
URL: http://gmerlin.sourceforge.net/
|
||||||
|
Source0: http://downloads.sourceforge.net/gmerlin/gavl-%{version}.tar.gz
|
||||||
|
Patch1: gavl-1.1.1-system_libgdither.patch
|
||||||
|
Patch2: gavl-configure-c99.patch
|
||||||
|
Patch3: gavl-c99.patch
|
||||||
|
|
||||||
|
BuildRequires: libtool
|
||||||
|
|
||||||
|
BuildRequires: doxygen
|
||||||
|
|
||||||
|
BuildRequires: libpng-devel >= 1.0.8
|
||||||
|
BuildRequires: libgdither-devel
|
||||||
|
BuildRequires: make
|
||||||
|
# Gavl use an internal tweaked libsamplerate version
|
||||||
|
# ufortunately the libsamplerate doesn't want a patch
|
||||||
|
# that will break ABI
|
||||||
|
#BuildRequires: libsamplerate-devel
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
%description
|
||||||
|
Gavl is a library for handling and converting uncompressed audio and
|
||||||
|
video data. It provides datatypes for audio/video formats and standardized
|
||||||
|
structures to store the data. It supports converting between all formats.
|
||||||
|
Some conversion functions are available in multiple versions (MMX...),
|
||||||
|
which are selected by compile time configuration, CPU autodetection and
|
||||||
|
user options.
|
||||||
|
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development files for %{name}
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Requires: pkgconfig
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
The %{name}-devel package contains libraries and header files for
|
||||||
|
developing applications that use %{name}.
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch -P1 -p1 -b .gdither
|
||||||
|
%patch -P2 -p1
|
||||||
|
%patch -P3 -p1
|
||||||
|
|
||||||
|
#Disable buildtime cpu detection
|
||||||
|
sed -i -i 's/LQT_TRY_CFLAGS/dnl LQT_TRY_CFLAGS/g' configure.ac
|
||||||
|
sed -i -i 's/LQT_OPT_CFLAGS/dnl LQT_OPT_CFLAGS/g' configure.ac
|
||||||
|
|
||||||
|
#Regenerate build tool
|
||||||
|
sh autogen.sh
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure \
|
||||||
|
--disable-static \
|
||||||
|
--disable-cpu-clip \
|
||||||
|
--enable-libgdither
|
||||||
|
|
||||||
|
|
||||||
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
|
||||||
|
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
|
||||||
|
|
||||||
|
# Prevent timestamps build difference
|
||||||
|
touch -r include/gavl/gavl.h $RPM_BUILD_ROOT%{_includedir}/gavl/gavl_version.h
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
%ldconfig_scriptlets
|
||||||
|
|
||||||
|
|
||||||
|
%files
|
||||||
|
%doc AUTHORS COPYING README TODO
|
||||||
|
%exclude %{_docdir}/gavl/apiref
|
||||||
|
%{_libdir}/*.so.*
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%doc %{_docdir}/gavl/apiref/
|
||||||
|
%{_includedir}/gavl/
|
||||||
|
%{_libdir}/*.so
|
||||||
|
%{_libdir}/pkgconfig/gavl.pc
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sat Dec 21 2024 Dmitriy Samoylik <samoylikdv@msvsphere-os.ru> - 1.4.0-37
|
||||||
|
- Rebuilt for MSVSphere 10
|
||||||
|
|
||||||
|
## START: Generated by rpmautospec
|
||||||
|
* Thu Jul 25 2024 Miroslav Suchý <msuchy@redhat.com> - 1.4.0-28
|
||||||
|
- convert license to SPDX
|
||||||
|
|
||||||
|
* Thu Jul 18 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-27
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jan 24 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-26
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-25
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-24
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Apr 14 2023 Florian Weimer <fweimer@redhat.com> - 1.4.0-23
|
||||||
|
- Port to C99
|
||||||
|
|
||||||
|
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-22
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-21
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-20
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 21 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-19
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-18
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-17
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-16
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-15
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-14
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-13
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-12
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-11
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-10
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-9
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-8
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0-6
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Oct 07 2013 Nicolas Chauvet <kwizart@gmail.com> - 1.4.0-4
|
||||||
|
- Fix apiref bundled as %%doc in main - rhbz#1014820
|
||||||
|
|
||||||
|
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Sep 08 2012 Nicolas Chauvet <kwizart@gmail.com> - 1.4.0-1
|
||||||
|
- Update to 1.4.0
|
||||||
|
|
||||||
|
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Mar 26 2011 Nicolas Chauvet <kwizart@gmail.com> - 1.2.0-1
|
||||||
|
- update to 1.2.0
|
||||||
|
|
||||||
|
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.2-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat May 01 2010 Nicolas Chauvet <kwizart@fedoraproject.org> - 1.1.2-1
|
||||||
|
- Update to 1.1.2
|
||||||
|
|
||||||
|
* Tue Oct 27 2009 kwizart < kwizart at gmail.com > - 1.1.1-1
|
||||||
|
- Update to 1.1.1
|
||||||
|
|
||||||
|
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Mar 24 2009 kwizart < kwizart at gmail.com > - 1.1.0-1
|
||||||
|
- Update to 1.1.0
|
||||||
|
- Disable buildtime CPU detection.
|
||||||
|
|
||||||
|
* Tue Jul 29 2008 kwizart < kwizart at gmail.com > - 1.0.1-1
|
||||||
|
- Update to 1.0.1
|
||||||
|
|
||||||
|
* Tue Jul 22 2008 kwizart < kwizart at gmail.com > - 1.0.0-2
|
||||||
|
- Add --enable-libgdither for system libgdither
|
||||||
|
- Add --enable-debug to disable LQT_OPT_CFLAGS
|
||||||
|
- Add -DHAVE_GAVLCONFIG_H to include gavlconfig.h when needed
|
||||||
|
|
||||||
|
* Mon May 19 2008 kwizart < kwizart at gmail.com > - 1.0.0-1
|
||||||
|
- Update to 1.0.0 api stable
|
||||||
|
|
||||||
|
* Mon May 19 2008 kwizart < kwizart at gmail.com > - 0.2.7-4
|
||||||
|
- Initial package for Fedora
|
||||||
|
|
||||||
|
## END: Generated by rpmautospec
|
Loading…
Reference in new issue