commit
2e29566618
@ -0,0 +1 @@
|
|||||||
|
b2c04d2b5e0896b3164c01deda39f58933c8055f SOURCES/freealut-1.1.0.tar.gz
|
@ -0,0 +1 @@
|
|||||||
|
SOURCES/freealut-1.1.0.tar.gz
|
@ -0,0 +1,57 @@
|
|||||||
|
--- admin/pkgconfig/freealut-config.in.orig 2008-01-02 23:12:54.000000000 +0100
|
||||||
|
+++ admin/pkgconfig/freealut-config.in 2008-01-02 23:15:49.000000000 +0100
|
||||||
|
@@ -4,7 +4,6 @@
|
||||||
|
exec_prefix="@exec_prefix@"
|
||||||
|
bindir="@bindir@"
|
||||||
|
includedir="@includedir@"
|
||||||
|
-libdir="@libdir@"
|
||||||
|
PACKAGE_VERSION="@PACKAGE_VERSION@"
|
||||||
|
|
||||||
|
freealut_dynamic_ldflags="-lalut"
|
||||||
|
@@ -19,8 +18,6 @@
|
||||||
|
echo_bindir=no
|
||||||
|
includedir_set=no
|
||||||
|
echo_includedir=no
|
||||||
|
-libdir_set=no
|
||||||
|
-echo_libdir=no
|
||||||
|
echo_version=no
|
||||||
|
echo_cflags=no
|
||||||
|
static_libs=no
|
||||||
|
@@ -85,10 +82,8 @@
|
||||||
|
;;
|
||||||
|
--libdir=*)
|
||||||
|
libdir="${optarg}"
|
||||||
|
- libdir_set="yes"
|
||||||
|
;;
|
||||||
|
--libdir)
|
||||||
|
- echo_libdir="yes"
|
||||||
|
;;
|
||||||
|
--version)
|
||||||
|
echo_version="yes"
|
||||||
|
@@ -138,14 +133,6 @@
|
||||||
|
echo "${includedir}"
|
||||||
|
fi
|
||||||
|
|
||||||
|
-if test "${libdir_set}" = "no" && test "${exec_prefix_set}" = "yes"; then
|
||||||
|
- libdir="${exec_prefix}/lib"
|
||||||
|
-fi
|
||||||
|
-
|
||||||
|
-if test "$echo_libdir" = "yes"; then
|
||||||
|
- echo "${libdir}"
|
||||||
|
-fi
|
||||||
|
-
|
||||||
|
if test "$echo_version" = "yes"; then
|
||||||
|
echo "${PACKAGE_VERSION}"
|
||||||
|
fi
|
||||||
|
@@ -160,11 +147,6 @@
|
||||||
|
fi
|
||||||
|
|
||||||
|
if test "$echo_libs" = "yes"; then
|
||||||
|
- if test "${libdir}" = "/usr/lib" ; then
|
||||||
|
- libpathflag=""
|
||||||
|
- else
|
||||||
|
- libpathflag="-L${libdir}"
|
||||||
|
- fi
|
||||||
|
if test "${static_libs}" = "yes"; then
|
||||||
|
ldflags="${freealut_static_ldflags}"
|
||||||
|
else
|
@ -0,0 +1,77 @@
|
|||||||
|
--- configure.ac.orig 2006-02-05 01:48:05.000000000 +0100
|
||||||
|
+++ configure.ac 2006-02-05 01:46:52.000000000 +0100
|
||||||
|
@@ -35,8 +35,11 @@
|
||||||
|
|
||||||
|
# Checks for libraries. (not perfect yet)
|
||||||
|
AC_SEARCH_LIBS([pthread_self], [pthread])
|
||||||
|
-AC_SEARCH_LIBS([alGetError], [openal32 openal])
|
||||||
|
|
||||||
|
+
|
||||||
|
+PKG_CHECK_MODULES(openal,openal)
|
||||||
|
+AC_SUBST(openal_CFLAGS)
|
||||||
|
+AC_SUBST(openal_LIBS)
|
||||||
|
################################################################################
|
||||||
|
# Checks for header files.
|
||||||
|
################################################################################
|
||||||
|
--- examples/Makefile.am.orig 2006-02-05 01:49:09.000000000 +0100
|
||||||
|
+++ examples/Makefile.am 2006-02-05 01:50:40.000000000 +0100
|
||||||
|
@@ -1,8 +1,11 @@
|
||||||
|
+OPENAL_LIBS = @openal_LIBS@
|
||||||
|
+OPENAL_CFLAGS = @openal_CFLAGS@
|
||||||
|
+
|
||||||
|
# Build, but do not install the following test programs:
|
||||||
|
noinst_PROGRAMS = hello_world playfile
|
||||||
|
|
||||||
|
# We need to link against our *own* libalut.
|
||||||
|
-LDADD = ../src/libalut.la
|
||||||
|
+LDADD = ../src/libalut.la $(OPENAL_LIBS)
|
||||||
|
|
||||||
|
# Specifying the following path is needed to find <AL/alut.h>.
|
||||||
|
-AM_CPPFLAGS = -I$(top_srcdir)/include
|
||||||
|
+AM_CPPFLAGS = -I$(top_srcdir)/include $(OPENAL_CFLAGS)
|
||||||
|
--- src/Makefile.am.orig 2006-05-08 05:28:07.000000000 -0400
|
||||||
|
+++ src/Makefile.am 2018-10-30 19:28:36.214575682 -0400
|
||||||
|
@@ -1,3 +1,6 @@
|
||||||
|
+OPENAL_LIBS = @openal_LIBS@
|
||||||
|
+OPENAL_CFLAGS = @openal_CFLAGS@
|
||||||
|
+
|
||||||
|
# The following files should be in our source distribution in addition to the
|
||||||
|
# standard ones included by automake itself:
|
||||||
|
EXTRA_DIST = helloworld.wav README
|
||||||
|
@@ -20,7 +23,7 @@ libalut_la_SOURCES = \
|
||||||
|
alutWaveform.c
|
||||||
|
|
||||||
|
# We use sin and floor, so we might need -lm, autoconf takes care of this.
|
||||||
|
-libalut_la_LIBADD = $(LIBM)
|
||||||
|
+libalut_la_LIBADD = $(LIBM) $(OPENAL_LIBS)
|
||||||
|
|
||||||
|
# The following libtool flag is neccessary for building DLLs on Windows.
|
||||||
|
libalut_la_LDFLAGS = -no-undefined
|
||||||
|
@@ -29,4 +32,4 @@ libalut_la_LDFLAGS = -no-undefined
|
||||||
|
libalut_la_LDFLAGS += -version-info @VERSIONINFO@
|
||||||
|
|
||||||
|
# Specifying the following path is needed to find <AL/alut.h>.
|
||||||
|
-libalut_la_CPPFLAGS = -I$(top_srcdir)/include
|
||||||
|
+libalut_la_CPPFLAGS = -I$(top_srcdir)/include $(OPENAL_CFLAGS)
|
||||||
|
--- test_suite/Makefile.am.orig 2006-02-05 02:08:56.000000000 +0100
|
||||||
|
+++ test_suite/Makefile.am 2006-02-05 02:10:13.000000000 +0100
|
||||||
|
@@ -1,3 +1,6 @@
|
||||||
|
+OPENAL_LIBS = @openal_LIBS@
|
||||||
|
+OPENAL_CFLAGS = @openal_CFLAGS@
|
||||||
|
+
|
||||||
|
# The following files should be in our source distribution in addition to the
|
||||||
|
# standard ones included by automake itself:
|
||||||
|
EXTRA_DIST = \
|
||||||
|
@@ -15,10 +18,10 @@
|
||||||
|
test_waveforms
|
||||||
|
|
||||||
|
# We need to link against our *own* libalut.
|
||||||
|
-LDADD = ../src/libalut.la
|
||||||
|
+LDADD = ../src/libalut.la $(OPENAL_LIBS)
|
||||||
|
|
||||||
|
# Specifying the following path is needed to find <AL/alut.h>.
|
||||||
|
-AM_CPPFLAGS = -I$(top_srcdir)/include
|
||||||
|
+AM_CPPFLAGS = -I$(top_srcdir)/include $(OPENAL_CFLAGS)
|
||||||
|
|
||||||
|
# test_retrostuff tests deprecated functions, but we don't want to get compiler
|
||||||
|
# warnings because of that.
|
@ -0,0 +1,200 @@
|
|||||||
|
Name: freealut
|
||||||
|
Version: 1.1.0
|
||||||
|
Release: 36%{?dist}
|
||||||
|
Summary: Implementation of OpenAL's ALUT standard
|
||||||
|
|
||||||
|
License: LGPLv2
|
||||||
|
URL: http://openal.org/
|
||||||
|
Source0: http://openal.org/openal_webstf/downloads/freealut-1.1.0.tar.gz
|
||||||
|
Patch0: freealut-openal.patch
|
||||||
|
Patch1: freealut-multiarch.patch
|
||||||
|
|
||||||
|
BuildRequires: openal-soft-devel
|
||||||
|
BuildRequires: libtool
|
||||||
|
BuildRequires: make
|
||||||
|
|
||||||
|
%description
|
||||||
|
freealut is a free implementation of OpenAL's ALUT standard. See the file
|
||||||
|
AUTHORS for the people involved.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development files for freealut
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Requires: pkgconfig
|
||||||
|
Requires: openal-soft-devel
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
Development headers and libraries needed for freealut development
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0
|
||||||
|
%patch1
|
||||||
|
libtoolize
|
||||||
|
autoreconf
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure --disable-static
|
||||||
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
make install DESTDIR=$RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
rm -f $RPM_BUILD_ROOT/%{_libdir}/libalut.la
|
||||||
|
|
||||||
|
# don't have dsp devices in buildroot
|
||||||
|
#%check
|
||||||
|
#pushd test_suite
|
||||||
|
#./test_errorstuff || exit $?
|
||||||
|
#./test_fileloader || exit $?
|
||||||
|
#./test_memoryloader || exit $?
|
||||||
|
#./test_retrostuff || exit $?
|
||||||
|
#./test_version || exit $?
|
||||||
|
#./test_waveforms || exit $?
|
||||||
|
#popd
|
||||||
|
|
||||||
|
touch -r ChangeLog $RPM_BUILD_ROOT/%{_bindir}/freealut-config
|
||||||
|
|
||||||
|
%ldconfig_scriptlets
|
||||||
|
|
||||||
|
%files
|
||||||
|
%doc AUTHORS ChangeLog COPYING README
|
||||||
|
%{_libdir}/libalut.so.*
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%doc doc/* examples/*.c
|
||||||
|
%{_bindir}/freealut-config
|
||||||
|
%{_includedir}/AL
|
||||||
|
%{_libdir}/libalut.so
|
||||||
|
%{_libdir}/pkgconfig/freealut.pc
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-36
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-35
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 21 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-34
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-33
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-32
|
||||||
|
- Second attempt - Rebuilt for
|
||||||
|
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-31
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-30
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-29
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-28
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Oct 30 2018 Scott Talbert <swt@techie.net> - 1.1.0-27
|
||||||
|
- Ensure libalut is linked against openal
|
||||||
|
|
||||||
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-26
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-25
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-24
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-23
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-22
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-21
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-20
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-19
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-18
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-17
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-16
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-15
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 29 2012 Jon Ciesla <limburgher@gmail.com> - 1.1.0-14
|
||||||
|
- Rebuild for GCC4.7 ABI bugfix.
|
||||||
|
|
||||||
|
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-13
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-12
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Nov 07 2009 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
|
||||||
|
- 1.1.0-11
|
||||||
|
- require openal-soft in devel (#533599)
|
||||||
|
|
||||||
|
* Tue Aug 11 2009 Jochen Schmitt <Jochen herr-schmitt de> 1.1.0-10
|
||||||
|
- Build agains openal-soft
|
||||||
|
|
||||||
|
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-9
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Mar 18 2009 Robert Scheck <robert@fedoraproject.org> - 1.1.0-8
|
||||||
|
- Rebuilt against libtool 2.2 to avoid libtool errors
|
||||||
|
|
||||||
|
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.1.0-6
|
||||||
|
- Autorebuild for GCC 4.3
|
||||||
|
|
||||||
|
* Wed Jan 02 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
|
||||||
|
- 1.1.0-5
|
||||||
|
- fix #341161 multiarch conflicts
|
||||||
|
|
||||||
|
* Wed Aug 22 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
|
||||||
|
- 1.1.0-4
|
||||||
|
- fix license tag
|
||||||
|
- rebuild for buildid
|
||||||
|
|
||||||
|
* Mon Mar 12 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
|
||||||
|
1.1.0-3
|
||||||
|
- fix #231132
|
||||||
|
|
||||||
|
* Fri Sep 15 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
|
||||||
|
1.1.0-2
|
||||||
|
- FE6 rebuild
|
||||||
|
|
||||||
|
* Tue Jun 13 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
|
||||||
|
1.1.0-1
|
||||||
|
- version upgrade
|
||||||
|
|
||||||
|
* Fri Feb 17 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
|
||||||
|
1.0.0-3
|
||||||
|
- Rebuild for Fedora Extras 5
|
||||||
|
|
||||||
|
* Sun Feb 05 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
|
||||||
|
1.0.0-2
|
||||||
|
- Add examples to devel doc
|
||||||
|
- Fix openal linking
|
||||||
|
|
||||||
|
* Sat Feb 04 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
|
||||||
|
1.0.0-1
|
||||||
|
- Initial release
|
Loading…
Reference in new issue