parent
9f7651fffd
commit
d1531b2f43
@ -1,7 +1,7 @@
|
|||||||
b963b16f6879c5dbe6e33a3a3da058b494453922 SOURCES/cbindgen-vendor.tar.xz
|
5012b69e54cbebe3b5e74011dacf3a2097f49921 SOURCES/cbindgen-vendor.tar.xz
|
||||||
309028cb524f6d3fe0be98d0a2a96355f14062f6 SOURCES/firefox-115.14.0esr.b2.processed-source.tar.xz
|
3d283a197f4363b9afc187586213b76e95374511 SOURCES/firefox-128.2.0esr.processed-source.tar.xz
|
||||||
cdda589c895c141a06840d0565bb2b84d14abf04 SOURCES/firefox-langpacks-115.14.0esr-20240801.tar.xz
|
1303d0fc410be228a4e24e61db40939b4f9f8de0 SOURCES/firefox-langpacks-128.2.0esr-20240827.tar.xz
|
||||||
2d8a6b2b30d5496735f49ffe8c8a7ede3a78a5ca SOURCES/mochitest-python.tar.gz
|
2d8a6b2b30d5496735f49ffe8c8a7ede3a78a5ca SOURCES/mochitest-python.tar.gz
|
||||||
d744f92e874688cc4b5376477dfdd639a97a6cd4 SOURCES/nspr-4.35.0-1.el8_1.src.rpm
|
d744f92e874688cc4b5376477dfdd639a97a6cd4 SOURCES/nspr-4.35.0-1.el8_1.src.rpm
|
||||||
9555ba179bc1398fbacfa2896e45f3808d94ecd2 SOURCES/nss-3.90.0-3.el8_1.src.rpm
|
cd19fc0ba6e05b5930cfcc7c85ec8508a6d3f284 SOURCES/nss-3.101.0-6.el8_2.src.rpm
|
||||||
df0dd588680f6ade6728a1fd3ff2d71e7a46255d SOURCES/nss-3.90.0-3.el9_0.src.rpm
|
c3665cbe283450a49ab446d3044916132f1b9699 SOURCES/nss-3.101.0-6.el9_0.src.rpm
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
SOURCES/cbindgen-vendor.tar.xz
|
SOURCES/cbindgen-vendor.tar.xz
|
||||||
SOURCES/firefox-115.14.0esr.b2.processed-source.tar.xz
|
SOURCES/firefox-128.2.0esr.processed-source.tar.xz
|
||||||
SOURCES/firefox-langpacks-115.14.0esr-20240801.tar.xz
|
SOURCES/firefox-langpacks-128.2.0esr-20240827.tar.xz
|
||||||
SOURCES/mochitest-python.tar.gz
|
SOURCES/mochitest-python.tar.gz
|
||||||
SOURCES/nspr-4.35.0-1.el8_1.src.rpm
|
SOURCES/nspr-4.35.0-1.el8_1.src.rpm
|
||||||
SOURCES/nss-3.90.0-3.el8_1.src.rpm
|
SOURCES/nss-3.101.0-6.el8_2.src.rpm
|
||||||
SOURCES/nss-3.90.0-3.el9_0.src.rpm
|
SOURCES/nss-3.101.0-6.el9_0.src.rpm
|
||||||
|
@ -1,127 +0,0 @@
|
|||||||
From 263682c9a29395055f3b3afe2d97be1828a6223f Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jerome Jiang <jianj@google.com>
|
|
||||||
Date: Thu, 30 Jun 2022 13:48:56 -0400
|
|
||||||
Subject: [PATCH] Fix bug with smaller width bigger size
|
|
||||||
|
|
||||||
Fixed previous patch that clusterfuzz failed on.
|
|
||||||
|
|
||||||
Bug: webm:1642
|
|
||||||
Change-Id: If0e08e72abd2e042efe4dcfac21e4cc51afdfdb9
|
|
||||||
---
|
|
||||||
test/resize_test.cc | 11 +++--------
|
|
||||||
vp9/common/vp9_alloccommon.c | 13 ++++++-------
|
|
||||||
vp9/encoder/vp9_encoder.c | 27 +++++++++++++++++++++++++--
|
|
||||||
3 files changed, 34 insertions(+), 17 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/test/resize_test.cc b/test/resize_test.cc
|
|
||||||
index fd1c2a92de6..20ad2229b46 100644
|
|
||||||
--- a/test/resize_test.cc
|
|
||||||
+++ b/test/resize_test.cc
|
|
||||||
@@ -102,11 +102,8 @@ void ScaleForFrameNumber(unsigned int frame, unsigned int initial_w,
|
|
||||||
if (frame < 30) {
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
- if (frame < 100) {
|
|
||||||
- *w = initial_w * 7 / 10;
|
|
||||||
- *h = initial_h * 16 / 10;
|
|
||||||
- return;
|
|
||||||
- }
|
|
||||||
+ *w = initial_w * 7 / 10;
|
|
||||||
+ *h = initial_h * 16 / 10;
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
if (frame < 10) {
|
|
||||||
@@ -559,9 +556,7 @@ TEST_P(ResizeRealtimeTest, TestExternalResizeWorks) {
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
-// TODO(https://crbug.com/webm/1642): This causes a segfault in
|
|
||||||
-// init_encode_frame_mb_context().
|
|
||||||
-TEST_P(ResizeRealtimeTest, DISABLED_TestExternalResizeSmallerWidthBiggerSize) {
|
|
||||||
+TEST_P(ResizeRealtimeTest, TestExternalResizeSmallerWidthBiggerSize) {
|
|
||||||
ResizingVideoSource video;
|
|
||||||
video.flag_codec_ = true;
|
|
||||||
video.smaller_width_larger_size_ = true;
|
|
||||||
diff --git a/vp9/common/vp9_alloccommon.c b/vp9/common/vp9_alloccommon.c
|
|
||||||
index e53883f621d..9e73e40ea09 100644
|
|
||||||
--- a/vp9/common/vp9_alloccommon.c
|
|
||||||
+++ b/vp9/common/vp9_alloccommon.c
|
|
||||||
@@ -135,13 +135,6 @@ int vp9_alloc_context_buffers(VP9_COMMON *cm, int width, int height) {
|
|
||||||
cm->free_mi(cm);
|
|
||||||
if (cm->alloc_mi(cm, new_mi_size)) goto fail;
|
|
||||||
}
|
|
||||||
-
|
|
||||||
- if (cm->seg_map_alloc_size < cm->mi_rows * cm->mi_cols) {
|
|
||||||
- // Create the segmentation map structure and set to 0.
|
|
||||||
- free_seg_map(cm);
|
|
||||||
- if (alloc_seg_map(cm, cm->mi_rows * cm->mi_cols)) goto fail;
|
|
||||||
- }
|
|
||||||
-
|
|
||||||
if (cm->above_context_alloc_cols < cm->mi_cols) {
|
|
||||||
vpx_free(cm->above_context);
|
|
||||||
cm->above_context = (ENTROPY_CONTEXT *)vpx_calloc(
|
|
||||||
@@ -156,6 +149,12 @@ int vp9_alloc_context_buffers(VP9_COMMON *cm, int width, int height) {
|
|
||||||
cm->above_context_alloc_cols = cm->mi_cols;
|
|
||||||
}
|
|
||||||
|
|
||||||
+ if (cm->seg_map_alloc_size < cm->mi_rows * cm->mi_cols) {
|
|
||||||
+ // Create the segmentation map structure and set to 0.
|
|
||||||
+ free_seg_map(cm);
|
|
||||||
+ if (alloc_seg_map(cm, cm->mi_rows * cm->mi_cols)) goto fail;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
if (vp9_alloc_loop_filter(cm)) goto fail;
|
|
||||||
|
|
||||||
return 0;
|
|
||||||
diff --git a/vp9/encoder/vp9_encoder.c b/vp9/encoder/vp9_encoder.c
|
|
||||||
index 69a4e3c314f..e3ba294c32f 100644
|
|
||||||
--- a/vp9/encoder/vp9_encoder.c
|
|
||||||
+++ b/vp9/encoder/vp9_encoder.c
|
|
||||||
@@ -2047,6 +2047,17 @@ static void alloc_copy_partition_data(VP9_COMP *cpi) {
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
+static void free_copy_partition_data(VP9_COMP *cpi) {
|
|
||||||
+ vpx_free(cpi->prev_partition);
|
|
||||||
+ cpi->prev_partition = NULL;
|
|
||||||
+ vpx_free(cpi->prev_segment_id);
|
|
||||||
+ cpi->prev_segment_id = NULL;
|
|
||||||
+ vpx_free(cpi->prev_variance_low);
|
|
||||||
+ cpi->prev_variance_low = NULL;
|
|
||||||
+ vpx_free(cpi->copied_frame_cnt);
|
|
||||||
+ cpi->copied_frame_cnt = NULL;
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
void vp9_change_config(struct VP9_COMP *cpi, const VP9EncoderConfig *oxcf) {
|
|
||||||
VP9_COMMON *const cm = &cpi->common;
|
|
||||||
RATE_CONTROL *const rc = &cpi->rc;
|
|
||||||
@@ -2126,6 +2137,8 @@ void vp9_change_config(struct VP9_COMP *cpi, const VP9EncoderConfig *oxcf) {
|
|
||||||
new_mi_size = cm->mi_stride * calc_mi_size(cm->mi_rows);
|
|
||||||
if (cm->mi_alloc_size < new_mi_size) {
|
|
||||||
vp9_free_context_buffers(cm);
|
|
||||||
+ vp9_free_pc_tree(&cpi->td);
|
|
||||||
+ vpx_free(cpi->mbmi_ext_base);
|
|
||||||
alloc_compressor_data(cpi);
|
|
||||||
realloc_segmentation_maps(cpi);
|
|
||||||
cpi->initial_width = cpi->initial_height = 0;
|
|
||||||
@@ -2144,8 +2157,18 @@ void vp9_change_config(struct VP9_COMP *cpi, const VP9EncoderConfig *oxcf) {
|
|
||||||
update_frame_size(cpi);
|
|
||||||
|
|
||||||
if (last_w != cpi->oxcf.width || last_h != cpi->oxcf.height) {
|
|
||||||
- memset(cpi->consec_zero_mv, 0,
|
|
||||||
- cm->mi_rows * cm->mi_cols * sizeof(*cpi->consec_zero_mv));
|
|
||||||
+ vpx_free(cpi->consec_zero_mv);
|
|
||||||
+ CHECK_MEM_ERROR(
|
|
||||||
+ &cm->error, cpi->consec_zero_mv,
|
|
||||||
+ vpx_calloc(cm->mi_rows * cm->mi_cols, sizeof(*cpi->consec_zero_mv)));
|
|
||||||
+
|
|
||||||
+ vpx_free(cpi->skin_map);
|
|
||||||
+ CHECK_MEM_ERROR(
|
|
||||||
+ &cm->error, cpi->skin_map,
|
|
||||||
+ vpx_calloc(cm->mi_rows * cm->mi_cols, sizeof(cpi->skin_map[0])));
|
|
||||||
+
|
|
||||||
+ free_copy_partition_data(cpi);
|
|
||||||
+ alloc_copy_partition_data(cpi);
|
|
||||||
if (cpi->oxcf.aq_mode == CYCLIC_REFRESH_AQ)
|
|
||||||
vp9_cyclic_refresh_reset_resize(cpi);
|
|
||||||
rc->rc_1_frame = 0;
|
|
@ -1,105 +0,0 @@
|
|||||||
diff -up thunderbird-115.13.0/third_party/rust/bindgen/.cargo-checksum.json.bindgen-clang18 thunderbird-115.13.0/third_party/rust/bindgen/.cargo-checksum.json
|
|
||||||
--- thunderbird-115.13.0/third_party/rust/bindgen/.cargo-checksum.json.bindgen-clang18 2024-07-15 10:44:05.862917093 +0200
|
|
||||||
+++ thunderbird-115.13.0/third_party/rust/bindgen/.cargo-checksum.json 2024-07-15 10:44:27.756985290 +0200
|
|
||||||
@@ -1 +1 @@
|
|
||||||
-{"files":{"Cargo.toml":"ae6de5b309f8bf07c259436b1113ccf405b2d7dd862e1b289bfef47a550956d1","LICENSE":"c23953d9deb0a3312dbeaf6c128a657f3591acee45067612fa68405eaa4525db","build.rs":"4a9c4ac3759572e17de312a9d3f4ced3b6fd3c71811729e5a8d06bfbd1ac8f82","callbacks.rs":"9cbda648159897f93a07dbe90a1ee9ba92e2b020a02bc9725b87db4d025df3b6","clang.rs":"a38d153516c6685b46723010793b2f4e8b16468f3cd3296781dea6e485cd66da","codegen/bitfield_unit.rs":"fddeaeab5859f4e82081865595b7705f5c0774d997df95fa5c655b81b9cae125","codegen/bitfield_unit_tests.rs":"9df86490de5e9d66ccea583dcb686dd440375dc1a3c3cf89a89d5de3883bf28a","codegen/dyngen.rs":"7d727a737c616f7f2d3a07d825be8baad9078b3f35ad96277904559b4534ffcc","codegen/error.rs":"5e308b8c54b68511fc8ea2ad15ddac510172c4ff460a80a265336440b0c9653d","codegen/helpers.rs":"5f24007a09e50db7bd2b49b07100cfed649c7b22232558e28c99c759d5d14152","codegen/impl_debug.rs":"71d8e28873ba2de466f2637a824746963702f0511728037d72ee5670c51194cb","codegen/impl_partialeq.rs":"f4599e32c66179ae515a6518a3e94b686689cf59f7dd9ab618c3fb69f17d2c77","codegen/mod.rs":"25ef86b9dd894b40724d78b99e2743654f09bb427a23ccf5940a620c6408688e","codegen/postprocessing/merge_extern_blocks.rs":"be5c5ff6d3d3d4e940814c4dc77f8d687aa6b053dcfbd2185c09616ba9022bf2","codegen/postprocessing/mod.rs":"d1e8c2864d5194a4cb2f6731c0ef582a55b363df9c4f888c26942ff37f728e1c","codegen/postprocessing/sort_semantically.rs":"3071dd509f2e5d3dfd99cafa6ee19bbacb9fec1c61a0b3f6e284a75c1f2c3db6","codegen/serialize.rs":"b1d8fff0bd9717ee7ca883fd3f376cf7b93adb65dc5bb89ede467b087e985a5f","codegen/struct_layout.rs":"7dfc814d3c914a0c53d8ed031baf543dab1def5959e8ab85220cad69a506383a","deps.rs":"5ee2332fdb10325f3b0a0c6d9ba94e13eb631ef39e955fa958afc3625bdb5448","extra_assertions.rs":"494534bd4f18b80d89b180c8a93733e6617edcf7deac413e9a73fd6e7bc9ced7","features.rs":"af20bd617cce27f6716ab3d61a1c8ddfaa46227f4a0d435b08a19d5f277cf8ba","ir/analysis/derive.rs":"ec514585eb40f0e3306bf3302aec0152a2e95e8dce13a67c36b5f00c0cbb76ef","ir/analysis/has_destructor.rs":"7a82f01e7e0595a31b56f7c398fa3019b3fe9100a2a73b56768f7e6943dcc3ce","ir/analysis/has_float.rs":"58ea1e38a59ef208400fd65d426cb5b288949df2d383b3a194fa01b99d2a87fa","ir/analysis/has_type_param_in_array.rs":"d1b9eb119dc14f662eb9bd1394c859f485479e4912589709cdd33f6752094e22","ir/analysis/has_vtable.rs":"368cf30fbe3fab7190fab48718b948caac5da8c9e797b709488716b919315636","ir/analysis/mod.rs":"0c10d8eeb26d7e6f4ce18e9dfb74ea1f9deff5cd350298aca3dc1041b17c20c4","ir/analysis/sizedness.rs":"944443d6aab35d2dd80e4f5e59176ac1e1c463ba2f0eb25d33f1d95dfac1a6d0","ir/analysis/template_params.rs":"d3cc41041b1c45e0b5be2c9f3f1cc0c2341481b9ff51589cba2428df4e6a1ea9","ir/annotations.rs":"f79de09803a3f3ccb33e366a10a707da98cd00a56ba18312ea927d6c977220a4","ir/comment.rs":"5dcfab0095d967daad9b2927093fce3786b1a2146171580afbf526ba56855e36","ir/comp.rs":"b7b28b96e4206b3215881d814661c63c5dd182f34b1163d54bcedbe85998cb06","ir/context.rs":"a7608f7d3dd607647f2af5f45fc7c09483d2a694f91265bba353a71652e2d419","ir/derive.rs":"e5581852eec87918901a129284b4965aefc8a19394187a8095779a084f28fabe","ir/dot.rs":"2d79d698e6ac59ce032840e62ff11103abed1d5e9e700cf383b492333eeebe1f","ir/enum_ty.rs":"0b612e0b57112068455eee519f894016d0a8f425d6a67b98c56b858f57d99f4a","ir/function.rs":"60407267473d785ea33ac854a70c8ca34749bc868024270992deca68a951f74c","ir/int.rs":"68a86182743ec338d58e42203364dc7c8970cb7ec3550433ca92f0c9489b4442","ir/item.rs":"880c982df0843cbdff38b9f9c3829a2d863a224e4de2260c41c3ac69e9148ad4","ir/item_kind.rs":"7666a1ff1b8260978b790a08b4139ab56b5c65714a5652bbcec7faa7443adc36","ir/layout.rs":"61a0e4250ceab889606973f930f4d692837a13a69ae2579738ff09843fed3d65","ir/mod.rs":"713cd537434567003197a123cbae679602c715e976d22f7b23dafd0826ea4c70","ir/module.rs":"7cae5561bcf84a5c3b1ee8f1c3336a33b7f44f0d5ffe885fb108289983fe763e","ir/objc.rs":"4eecdb754542d78acea27d2f547d18d49164047e6efaff8a8d283d6c2dc9875b","ir/template.rs":"4f0e3736558aa8ec359cd9749dc48f87bfff494dd195a67b39cfee7d8a7542ef","ir/traversal.rs":"0c37a0898801ad39bffc8dddd1ee8baa61bb7cf4f3fdc25c8fdd56b6c96ada65","ir/ty.rs":"ba0d7b16a1080caf4960cc7dea0d0800365da0dd5c6e735d508ec448e87b1d40","ir/var.rs":"ced3496cf0683fef91ce94aa09b0ee37255db8425ea8634d52bd73b1b5c160f6","lib.rs":"0bed6f10b2dd25753a40e6e7fa11239f08c05be414ad264c6d7e2f7a8b71f1b2","log_stubs.rs":"9f974e041e35c8c7e29985d27ae5cd0858d68f8676d1dc005c6388d7d011707f","parse.rs":"ccb2c506f08123708ae673b8216404fb22b4c951330662f9b7140b412b063260","regex_set.rs":"7dcc1ad52194f057ea00e8ebc9c23c465ffa6761eed6ba41560d2d02e03c43a6","time.rs":"8efe317e7c6b5ba8e0865ce7b49ca775ee8a02590f4241ef62f647fa3c22b68e"},"package":"c4243e6031260db77ede97ad86c27e501d646a27ab57b59a574f725d98ab1fb4"}
|
|
||||||
\ No newline at end of file
|
|
||||||
+{"files":{"Cargo.toml":"ae6de5b309f8bf07c259436b1113ccf405b2d7dd862e1b289bfef47a550956d1","LICENSE":"c23953d9deb0a3312dbeaf6c128a657f3591acee45067612fa68405eaa4525db","build.rs":"4a9c4ac3759572e17de312a9d3f4ced3b6fd3c71811729e5a8d06bfbd1ac8f82","callbacks.rs":"9cbda648159897f93a07dbe90a1ee9ba92e2b020a02bc9725b87db4d025df3b6","clang.rs":"a38d153516c6685b46723010793b2f4e8b16468f3cd3296781dea6e485cd66da","codegen/bitfield_unit.rs":"fddeaeab5859f4e82081865595b7705f5c0774d997df95fa5c655b81b9cae125","codegen/bitfield_unit_tests.rs":"9df86490de5e9d66ccea583dcb686dd440375dc1a3c3cf89a89d5de3883bf28a","codegen/dyngen.rs":"7d727a737c616f7f2d3a07d825be8baad9078b3f35ad96277904559b4534ffcc","codegen/error.rs":"5e308b8c54b68511fc8ea2ad15ddac510172c4ff460a80a265336440b0c9653d","codegen/helpers.rs":"5f24007a09e50db7bd2b49b07100cfed649c7b22232558e28c99c759d5d14152","codegen/impl_debug.rs":"71d8e28873ba2de466f2637a824746963702f0511728037d72ee5670c51194cb","codegen/impl_partialeq.rs":"f4599e32c66179ae515a6518a3e94b686689cf59f7dd9ab618c3fb69f17d2c77","codegen/mod.rs":"25ef86b9dd894b40724d78b99e2743654f09bb427a23ccf5940a620c6408688e","codegen/postprocessing/merge_extern_blocks.rs":"be5c5ff6d3d3d4e940814c4dc77f8d687aa6b053dcfbd2185c09616ba9022bf2","codegen/postprocessing/mod.rs":"d1e8c2864d5194a4cb2f6731c0ef582a55b363df9c4f888c26942ff37f728e1c","codegen/postprocessing/sort_semantically.rs":"3071dd509f2e5d3dfd99cafa6ee19bbacb9fec1c61a0b3f6e284a75c1f2c3db6","codegen/serialize.rs":"b1d8fff0bd9717ee7ca883fd3f376cf7b93adb65dc5bb89ede467b087e985a5f","codegen/struct_layout.rs":"7dfc814d3c914a0c53d8ed031baf543dab1def5959e8ab85220cad69a506383a","deps.rs":"5ee2332fdb10325f3b0a0c6d9ba94e13eb631ef39e955fa958afc3625bdb5448","extra_assertions.rs":"494534bd4f18b80d89b180c8a93733e6617edcf7deac413e9a73fd6e7bc9ced7","features.rs":"af20bd617cce27f6716ab3d61a1c8ddfaa46227f4a0d435b08a19d5f277cf8ba","ir/analysis/derive.rs":"ec514585eb40f0e3306bf3302aec0152a2e95e8dce13a67c36b5f00c0cbb76ef","ir/analysis/has_destructor.rs":"7a82f01e7e0595a31b56f7c398fa3019b3fe9100a2a73b56768f7e6943dcc3ce","ir/analysis/has_float.rs":"58ea1e38a59ef208400fd65d426cb5b288949df2d383b3a194fa01b99d2a87fa","ir/analysis/has_type_param_in_array.rs":"d1b9eb119dc14f662eb9bd1394c859f485479e4912589709cdd33f6752094e22","ir/analysis/has_vtable.rs":"368cf30fbe3fab7190fab48718b948caac5da8c9e797b709488716b919315636","ir/analysis/mod.rs":"0c10d8eeb26d7e6f4ce18e9dfb74ea1f9deff5cd350298aca3dc1041b17c20c4","ir/analysis/sizedness.rs":"944443d6aab35d2dd80e4f5e59176ac1e1c463ba2f0eb25d33f1d95dfac1a6d0","ir/analysis/template_params.rs":"d3cc41041b1c45e0b5be2c9f3f1cc0c2341481b9ff51589cba2428df4e6a1ea9","ir/annotations.rs":"f79de09803a3f3ccb33e366a10a707da98cd00a56ba18312ea927d6c977220a4","ir/comment.rs":"5dcfab0095d967daad9b2927093fce3786b1a2146171580afbf526ba56855e36","ir/comp.rs":"b7b28b96e4206b3215881d814661c63c5dd182f34b1163d54bcedbe85998cb06","ir/context.rs":"a7608f7d3dd607647f2af5f45fc7c09483d2a694f91265bba353a71652e2d419","ir/derive.rs":"e5581852eec87918901a129284b4965aefc8a19394187a8095779a084f28fabe","ir/dot.rs":"2d79d698e6ac59ce032840e62ff11103abed1d5e9e700cf383b492333eeebe1f","ir/enum_ty.rs":"0b612e0b57112068455eee519f894016d0a8f425d6a67b98c56b858f57d99f4a","ir/function.rs":"60407267473d785ea33ac854a70c8ca34749bc868024270992deca68a951f74c","ir/int.rs":"68a86182743ec338d58e42203364dc7c8970cb7ec3550433ca92f0c9489b4442","ir/item.rs":"b3909d9050994491642e143e6902dfbbb9d6b96cc9056f797c08a8e4f1477fa0","ir/item_kind.rs":"7666a1ff1b8260978b790a08b4139ab56b5c65714a5652bbcec7faa7443adc36","ir/layout.rs":"61a0e4250ceab889606973f930f4d692837a13a69ae2579738ff09843fed3d65","ir/mod.rs":"713cd537434567003197a123cbae679602c715e976d22f7b23dafd0826ea4c70","ir/module.rs":"7cae5561bcf84a5c3b1ee8f1c3336a33b7f44f0d5ffe885fb108289983fe763e","ir/objc.rs":"4eecdb754542d78acea27d2f547d18d49164047e6efaff8a8d283d6c2dc9875b","ir/template.rs":"4f0e3736558aa8ec359cd9749dc48f87bfff494dd195a67b39cfee7d8a7542ef","ir/traversal.rs":"0c37a0898801ad39bffc8dddd1ee8baa61bb7cf4f3fdc25c8fdd56b6c96ada65","ir/ty.rs":"ba0d7b16a1080caf4960cc7dea0d0800365da0dd5c6e735d508ec448e87b1d40","ir/var.rs":"ced3496cf0683fef91ce94aa09b0ee37255db8425ea8634d52bd73b1b5c160f6","lib.rs":"0bed6f10b2dd25753a40e6e7fa11239f08c05be414ad264c6d7e2f7a8b71f1b2","log_stubs.rs":"9f974e041e35c8c7e29985d27ae5cd0858d68f8676d1dc005c6388d7d011707f","parse.rs":"ccb2c506f08123708ae673b8216404fb22b4c951330662f9b7140b412b063260","regex_set.rs":"7dcc1ad52194f057ea00e8ebc9c23c465ffa6761eed6ba41560d2d02e03c43a6","time.rs":"8efe317e7c6b5ba8e0865ce7b49ca775ee8a02590f4241ef62f647fa3c22b68e"},"package":"c4243e6031260db77ede97ad86c27e501d646a27ab57b59a574f725d98ab1fb4"}
|
|
||||||
\ No newline at end of file
|
|
||||||
diff -up thunderbird-115.13.0/third_party/rust/bindgen/ir/item.rs.bindgen-clang18 thunderbird-115.13.0/third_party/rust/bindgen/ir/item.rs
|
|
||||||
--- thunderbird-115.13.0/third_party/rust/bindgen/ir/item.rs.bindgen-clang18 2024-07-09 23:46:38.000000000 +0200
|
|
||||||
+++ thunderbird-115.13.0/third_party/rust/bindgen/ir/item.rs 2024-07-15 10:42:30.498619993 +0200
|
|
||||||
@@ -1427,53 +1427,52 @@ impl Item {
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
- // Guess how does clang treat extern "C" blocks?
|
|
||||||
- if cursor.kind() == CXCursor_UnexposedDecl {
|
|
||||||
- Err(ParseError::Recurse)
|
|
||||||
- } else {
|
|
||||||
- // We allowlist cursors here known to be unhandled, to prevent being
|
|
||||||
- // too noisy about this.
|
|
||||||
- match cursor.kind() {
|
|
||||||
- CXCursor_MacroDefinition |
|
|
||||||
- CXCursor_MacroExpansion |
|
|
||||||
- CXCursor_UsingDeclaration |
|
|
||||||
- CXCursor_UsingDirective |
|
|
||||||
- CXCursor_StaticAssert |
|
|
||||||
- CXCursor_FunctionTemplate => {
|
|
||||||
- debug!(
|
|
||||||
+ match cursor.kind() {
|
|
||||||
+ // On Clang 18+, extern "C" is reported accurately as a LinkageSpec.
|
|
||||||
+ // Older LLVM treat it as UnexposedDecl.
|
|
||||||
+ CXCursor_LinkageSpec | CXCursor_UnexposedDecl => {
|
|
||||||
+ Err(ParseError::Recurse)
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ // We allowlist cursors here known to be unhandled, to prevent being
|
|
||||||
+ // too noisy about this.
|
|
||||||
+ CXCursor_MacroDefinition |
|
|
||||||
+ CXCursor_MacroExpansion |
|
|
||||||
+ CXCursor_UsingDeclaration |
|
|
||||||
+ CXCursor_UsingDirective |
|
|
||||||
+ CXCursor_StaticAssert |
|
|
||||||
+ CXCursor_FunctionTemplate => {
|
|
||||||
+ debug!(
|
|
||||||
+ "Unhandled cursor kind {:?}: {:?}",
|
|
||||||
+ cursor.kind(),
|
|
||||||
+ cursor
|
|
||||||
+ );
|
|
||||||
+ Err(ParseError::Continue)
|
|
||||||
+ }
|
|
||||||
+ CXCursor_InclusionDirective => {
|
|
||||||
+ let file = cursor.get_included_file_name();
|
|
||||||
+ match file {
|
|
||||||
+ None => {
|
|
||||||
+ warn!("Inclusion of a nameless file in {:?}", cursor);
|
|
||||||
+ }
|
|
||||||
+ Some(filename) => {
|
|
||||||
+ ctx.include_file(filename);
|
|
||||||
+ }
|
|
||||||
+ }
|
|
||||||
+ Err(ParseError::Continue)
|
|
||||||
+ }
|
|
||||||
+ _ => {
|
|
||||||
+ // ignore toplevel operator overloads
|
|
||||||
+ let spelling = cursor.spelling();
|
|
||||||
+ if !spelling.starts_with("operator") {
|
|
||||||
+ warn!(
|
|
||||||
"Unhandled cursor kind {:?}: {:?}",
|
|
||||||
cursor.kind(),
|
|
||||||
cursor
|
|
||||||
);
|
|
||||||
}
|
|
||||||
- CXCursor_InclusionDirective => {
|
|
||||||
- let file = cursor.get_included_file_name();
|
|
||||||
- match file {
|
|
||||||
- None => {
|
|
||||||
- warn!(
|
|
||||||
- "Inclusion of a nameless file in {:?}",
|
|
||||||
- cursor
|
|
||||||
- );
|
|
||||||
- }
|
|
||||||
- Some(filename) => {
|
|
||||||
- ctx.include_file(filename);
|
|
||||||
- }
|
|
||||||
- }
|
|
||||||
- }
|
|
||||||
- _ => {
|
|
||||||
- // ignore toplevel operator overloads
|
|
||||||
- let spelling = cursor.spelling();
|
|
||||||
- if !spelling.starts_with("operator") {
|
|
||||||
- warn!(
|
|
||||||
- "Unhandled cursor kind {:?}: {:?}",
|
|
||||||
- cursor.kind(),
|
|
||||||
- cursor
|
|
||||||
- );
|
|
||||||
- }
|
|
||||||
- }
|
|
||||||
+ Err(ParseError::Continue)
|
|
||||||
}
|
|
||||||
-
|
|
||||||
- Err(ParseError::Continue)
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
@ -0,0 +1,12 @@
|
|||||||
|
diff -up firefox-128.0/dom/gamepad/moz.build.gamepad firefox-128.0/dom/gamepad/moz.build
|
||||||
|
--- firefox-128.0/dom/gamepad/moz.build.gamepad 2024-07-30 16:24:07.326519645 +0200
|
||||||
|
+++ firefox-128.0/dom/gamepad/moz.build 2024-07-30 16:24:15.817492673 +0200
|
||||||
|
@@ -60,7 +60,7 @@ elif CONFIG["MOZ_WIDGET_TOOLKIT"] == "wi
|
||||||
|
elif CONFIG["MOZ_WIDGET_TOOLKIT"] == "android":
|
||||||
|
UNIFIED_SOURCES += ["android/AndroidGamepad.cpp"]
|
||||||
|
elif CONFIG["OS_ARCH"] in ("Linux", "FreeBSD", "DragonFly"):
|
||||||
|
- UNIFIED_SOURCES += ["linux/LinuxGamepad.cpp"]
|
||||||
|
+ UNIFIED_SOURCES += ["fallback/FallbackGamepad.cpp"]
|
||||||
|
else:
|
||||||
|
UNIFIED_SOURCES += ["fallback/FallbackGamepad.cpp"]
|
||||||
|
|
@ -0,0 +1,24 @@
|
|||||||
|
diff -up thunderbird-128.0/media/ffvpx/libavcodec/av1dec.c.build-ffvpx thunderbird-128.0/media/ffvpx/libavcodec/av1dec.c
|
||||||
|
--- thunderbird-128.0/media/ffvpx/libavcodec/av1dec.c.build-ffvpx 2024-06-24 22:43:40.000000000 +0200
|
||||||
|
+++ thunderbird-128.0/media/ffvpx/libavcodec/av1dec.c 2024-07-10 11:20:23.200948767 +0200
|
||||||
|
@@ -887,7 +887,7 @@ static av_cold int av1_decode_init(AVCod
|
||||||
|
ff_cbs_fragment_reset(&s->current_obu);
|
||||||
|
}
|
||||||
|
|
||||||
|
- s->dovi.logctx = avctx;
|
||||||
|
+ s->dovi.logctx = (AVContext *) avctx;
|
||||||
|
s->dovi.dv_profile = 10; // default for AV1
|
||||||
|
sd = ff_get_coded_side_data(avctx, AV_PKT_DATA_DOVI_CONF);
|
||||||
|
if (sd && sd->size > 0)
|
||||||
|
diff -up thunderbird-128.0/media/ffvpx/libavcodec/libdav1d.c.build-ffvpx thunderbird-128.0/media/ffvpx/libavcodec/libdav1d.c
|
||||||
|
--- thunderbird-128.0/media/ffvpx/libavcodec/libdav1d.c.build-ffvpx 2024-07-10 12:46:57.005539959 +0200
|
||||||
|
+++ thunderbird-128.0/media/ffvpx/libavcodec/libdav1d.c 2024-07-10 12:47:19.067507705 +0200
|
||||||
|
@@ -289,7 +289,7 @@ static av_cold int libdav1d_init(AVCodec
|
||||||
|
c->delay = res > 1 ? res : 0;
|
||||||
|
#endif
|
||||||
|
|
||||||
|
- dav1d->dovi.logctx = c;
|
||||||
|
+ dav1d->dovi.logctx = (AVContext *) c;
|
||||||
|
dav1d->dovi.dv_profile = 10; // default for AV1
|
||||||
|
sd = ff_get_coded_side_data(c, AV_PKT_DATA_DOVI_CONF);
|
||||||
|
if (sd && sd->size > 0)
|
@ -0,0 +1,20 @@
|
|||||||
|
diff -up firefox-128.0/config/external/moz.build.libaom firefox-128.0/config/external/moz.build
|
||||||
|
--- firefox-128.0/config/external/moz.build.libaom 2024-07-31 15:32:39.460374047 +0200
|
||||||
|
+++ firefox-128.0/config/external/moz.build 2024-07-31 15:34:41.646064796 +0200
|
||||||
|
@@ -39,8 +39,8 @@ if CONFIG["MOZ_VORBIS"]:
|
||||||
|
if not CONFIG["MOZ_SYSTEM_LIBVPX"]:
|
||||||
|
external_dirs += ["media/libvpx"]
|
||||||
|
|
||||||
|
+external_dirs += ["media/libaom"]
|
||||||
|
if CONFIG["MOZ_AV1"]:
|
||||||
|
- external_dirs += ["media/libaom"]
|
||||||
|
external_dirs += ["media/libdav1d"]
|
||||||
|
|
||||||
|
if not CONFIG["MOZ_SYSTEM_PNG"]:
|
||||||
|
diff -up firefox-128.0/third_party/aom/third_party/fastfeat/README.libaom firefox-128.0/third_party/aom/third_party/fastfeat/README
|
||||||
|
diff -up firefox-128.0/third_party/aom/third_party/googletest/README.libaom firefox-128.0/third_party/aom/third_party/googletest/README
|
||||||
|
diff -up firefox-128.0/third_party/aom/third_party/libwebm/README.libaom firefox-128.0/third_party/aom/third_party/libwebm/README
|
||||||
|
diff -up firefox-128.0/third_party/aom/third_party/libyuv/README.libaom firefox-128.0/third_party/aom/third_party/libyuv/README
|
||||||
|
diff -up firefox-128.0/third_party/aom/third_party/SVT-AV1/README.libaom firefox-128.0/third_party/aom/third_party/SVT-AV1/README
|
||||||
|
diff -up firefox-128.0/third_party/aom/third_party/vector/README.libaom firefox-128.0/third_party/aom/third_party/vector/README
|
||||||
|
diff -up firefox-128.0/third_party/aom/third_party/x86inc/README.libaom firefox-128.0/third_party/aom/third_party/x86inc/README
|
@ -1,9 +1,9 @@
|
|||||||
[Global]
|
[Global]
|
||||||
id=fedora
|
id=redhat
|
||||||
version=1.0
|
version=1.0
|
||||||
about=Mozilla Firefox for Fedora
|
about=Mozilla Firefox for Red Hat Enterprise Linux
|
||||||
|
|
||||||
[Preferences]
|
[Preferences]
|
||||||
app.distributor=fedora
|
app.distributor=redhat
|
||||||
app.distributor.channel=fedora
|
app.distributor.channel=redhat
|
||||||
app.partner.fedora=fedora
|
app.partner.redhat=redhat
|
||||||
|
@ -1,9 +0,0 @@
|
|||||||
diff -up firefox-73.0/build/unix/run-mozilla.sh.old firefox-73.0/build/unix/run-mozilla.sh
|
|
||||||
--- firefox-73.0/build/unix/run-mozilla.sh.old 2020-02-12 09:58:00.150895904 +0100
|
|
||||||
+++ firefox-73.0/build/unix/run-mozilla.sh 2020-02-12 09:58:06.505860696 +0100
|
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
-#!/bin/sh
|
|
||||||
+#!/usr/bin/sh
|
|
||||||
#
|
|
||||||
# This Source Code Form is subject to the terms of the Mozilla Public
|
|
||||||
# License, v. 2.0. If a copy of the MPL was not distributed with this
|
|
@ -1,14 +0,0 @@
|
|||||||
diff -up firefox-88.0/testing/xpcshell/runxpcshelltests.py.old firefox-88.0/testing/xpcshell/runxpcshelltests.py
|
|
||||||
--- firefox-88.0/testing/xpcshell/runxpcshelltests.py.old 2021-04-30 10:45:14.466616224 +0200
|
|
||||||
+++ firefox-88.0/testing/xpcshell/runxpcshelltests.py 2021-04-30 10:45:21.339525085 +0200
|
|
||||||
@@ -1382,8 +1382,8 @@ class XPCShellTests(object):
|
|
||||||
self.log.info("Process %s" % label)
|
|
||||||
self.log.info(msg)
|
|
||||||
|
|
||||||
- dumpOutput(proc.stdout, "stdout")
|
|
||||||
- dumpOutput(proc.stderr, "stderr")
|
|
||||||
+ #dumpOutput(proc.stdout, "stdout")
|
|
||||||
+ #dumpOutput(proc.stderr, "stderr")
|
|
||||||
self.nodeProc = {}
|
|
||||||
|
|
||||||
def startHttp3Server(self):
|
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in new issue