Update to 4.0.0 (#1963311)

epel9
Philippe Makowski 4 years ago
parent c542988b4a
commit 4c04d2ce89

1
.gitignore vendored

@ -1,3 +1,4 @@
/Firebird-3.0.5.33220-0.tar.bz2
/Firebird-3.0.6.33328-0.tar.bz2
/Firebird-3.0.7.33374-0.tar.bz2
/Firebird-4.0.0.2496-0.tar.xz

@ -1,36 +0,0 @@
From: Michal Kubecek <mkubecek@suse.cz>
Date: Mon, 25 Apr 2016 08:55:36 +0200
Subject: Provide sized global delete operators when compiled in C++14 mode
Patch-mainline: submitted
Git-commit: 038f9fbf559e56032e4cb49eb7ce4c3ead23fda9
References: bsc#964466 CORE-5099
---
src/common/classes/alloc.h | 10 ++++++++++
1 file changed, 10 insertions(+)
diff --git a/src/common/classes/alloc.h b/src/common/classes/alloc.h
index b1026ce2aac4..fda5bfebb0cc 100644
--- a/src/common/classes/alloc.h
+++ b/src/common/classes/alloc.h
@@ -331,6 +331,16 @@ inline void operator delete[](void* mem, Firebird::MemoryPool& pool ALLOC_PARAMS
MemoryPool::globalFree(mem);
}
+#if __cplusplus >= 201402L
+inline void operator delete(void* mem, std::size_t s ALLOC_PARAMS) throw()
+{
+ MemoryPool::globalFree(mem);
+}
+inline void operator delete[](void* mem, std::size_t s ALLOC_PARAMS) throw()
+{
+ MemoryPool::globalFree(mem);
+}
+#endif
#ifdef DEBUG_GDS_ALLOC
#ifdef __clang__
--
2.8.2

@ -8,13 +8,10 @@ Differences between upstream and the Fedora package
* By default, Firebird is set as superserver mode.
Please read the Firebird doc if you want to change the mode.
To help you, you have systemd units in /usr/share/firebird/misc.
* According to Fedora packaging rules, firebird service is not started
automatically. You need to start it, as root :
for SuperServer :
systemctl start firebird-superserver.service
systemctl start firebird.service
If you want to have firebird started at each boot, as root :
for SuperServer :
systemctl enable firebird-superserver.service
systemctl enable firebird.service

@ -1,16 +1,6 @@
From: Michal Kubecek <mkubecek@suse.cz>
Date: Tue, 12 Jun 2012 14:32:44 +0200
Subject: add pkgconfig files
---
builds/install/arch-specific/linux/misc/fbclient.pc.in | 10 ++++++++++
configure.ac | 1 +
2 files changed, 11 insertions(+)
create mode 100644 builds/install/arch-specific/linux/misc/fbclient.pc.in
diff --git a/builds/install/arch-specific/linux/misc/fbclient.pc.in b/builds/install/arch-specific/linux/misc/fbclient.pc.in
new file mode 100644
index 000000000000..d49fdc5821c5
index 0000000..d49fdc5
--- /dev/null
+++ b/builds/install/arch-specific/linux/misc/fbclient.pc.in
@@ -0,0 +1,10 @@
@ -25,18 +15,14 @@ index 000000000000..d49fdc5821c5
+Cflags: -I${includedir}/firebird
+Libs: -L${libdir} -lfbclient
diff --git a/configure.ac b/configure.ac
index 717f5eccc53d..60b3aaa5b08b 100644
index 0a3de36..922c778 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1200,6 +1200,7 @@ case "$PLATFORM" in
@@ -1307,6 +1307,7 @@ case "$PLATFORM" in
gen/install/misc/firebird.init.d.gentoo:builds/install/arch-specific/linux/firebird.init.d.gentoo.in
gen/install/misc/firebird.init.d.slackware:builds/install/arch-specific/linux/firebird.init.d.slackware.in
gen/install/misc/rc.config.firebird:builds/install/arch-specific/linux/rc.config.firebird.in
+ gen/install/misc/fbclient.pc:builds/install/arch-specific/linux/misc/fbclient.pc.in
gen/Release/firebird/bin/linuxLibrary.sh:builds/install/arch-specific/linux/linuxLibrary.sh.in
gen/install/misc/firebird-classic@.service:builds/install/arch-specific/linux/firebird-classic.service.in
gen/install/misc/firebird-classic.socket:builds/install/arch-specific/linux/firebird-classic.socket.in
--
2.3.4
gen/install/misc/firebird.service:builds/install/arch-specific/linux/firebird.service.in
],

@ -1,7 +1,5 @@
Description: make cloop build honor compiler/linker flags from the environment
Author: Damyan Ivanov <dmn@debian.org>
Forwarded: no
diff --git a/extern/cloop/Makefile b/extern/cloop/Makefile
index 08516c2..1573dc2 100644
--- a/extern/cloop/Makefile
+++ b/extern/cloop/Makefile
@@ -6,7 +6,7 @@ TARGET := release
@ -13,7 +11,7 @@ Forwarded: no
SRC_DIR := src
BUILD_DIR := build
@@ -27,8 +27,9 @@ SRCS_CPP := $(foreach sdir,$(SRC_DIRS),$
@@ -27,8 +27,9 @@ SRCS_CPP := $(foreach sdir,$(SRC_DIRS),$(wildcard $(sdir)/*.cpp))
OBJS_C := $(patsubst $(SRC_DIR)/%.c,$(OBJ_DIR)/%.o,$(SRCS_C))
OBJS_CPP := $(patsubst $(SRC_DIR)/%.cpp,$(OBJ_DIR)/%.o,$(SRCS_CPP))
@ -24,4 +22,17 @@ Forwarded: no
+CXX_FLAGS := $(COMMON_C_FLAGS) $(CXXFLAGS) $(CPPFLAGS)
FPC_FLAGS := -Mdelphi
ifeq ($(TARGET),release)
ifeq ($(shell uname),FreeBSD)
diff --git a/extern/btyacc/Makefile b/extern/btyacc/Makefile
index f432965..52d8443 100644
--- a/extern/btyacc/Makefile
+++ b/extern/btyacc/Makefile
@@ -12,7 +12,7 @@ HDRS = defs.h mstring.h
# across all of our supported compilers/platforms.
# Vanilla CFLAGS
-CFLAGS=
+CFLAGS=-fPIE
# No LDFLAGS
#LDFLAGS=

@ -1,5 +1,5 @@
[Unit]
Description=Firebird Database Server ( SuperServer )
Description=Firebird Database Server
After=network.target
Conflicts=firebird-classic.socket

@ -1,8 +1,12 @@
%global upversion 3.0.7.33374
%global upversion 4.0.0.2496
%global pkgversion Firebird-%{upversion}-0
%global major 3.0
%global major 4.0
%global _hardened_build 1
# firebird is mis-compiled when LTO is enabled. A root
# cause analysis has not yet been completed. Reported upstream.
# Disable LTO for now
%global _lto_cflags %nil
Name: firebird
Version: %{upversion}
@ -12,27 +16,23 @@ Summary: SQL relational database management system
License: Interbase
URL: http://www.firebirdsql.org/
Source0: https://github.com/FirebirdSQL/firebird/releases/download/R3_0_7/%{pkgversion}.tar.bz2
Source0: https://github.com/FirebirdSQL/firebird/releases/download/v4.0.0/%{pkgversion}.tar.xz
Source1: firebird-logrotate
Source2: README.Fedora
Source3: firebird-superserver.service
Source3: firebird.service
Source4: fb_config
# from OpenSuse
Patch101: add-pkgconfig-files.patch
Patch103: Provide-sized-global-delete-operators-when-compiled.patch
# from Debian to be sent upstream
Patch201: obsolete-syslogd.target.patch
Patch202: honour-buildflags.patch
Patch203: no-copy-from-icu.patch
Patch205: cloop-honour-build-flags.patch
# from upstream
# Support for riscv64, sent upstream:
# http://tracker.firebirdsql.org/browse/CORE-5779
Patch401: 0001-Port-to-RISC-V-64-bit-riscv64.patch
# Firebird 4 have build issues (bz 1969393)
ExcludeArch: s390x
BuildRequires: autoconf
BuildRequires: automake
@ -47,6 +47,10 @@ BuildRequires: systemd-units
BuildRequires: chrpath
BuildRequires: zlib-devel
BuildRequires: procmail
BuildRequires: make
BuildRequires: libtomcrypt-devel
BuildRequires: unzip
BuildRequires: sed
Requires(postun): /usr/sbin/userdel
Requires(postun): /usr/sbin/groupdel
@ -60,18 +64,18 @@ Requires: libfbclient2 = %{version}-%{release}
Requires: libib-util = %{version}-%{release}
Requires: %{name}-utils = %{version}-%{release}
Obsoletes: firebird-arch < 3.0
Obsoletes: firebird-filesystem < 3.0
Obsoletes: firebird-classic-common < 3.0
Obsoletes: firebird-classic < 3.0
Obsoletes: firebird-superclassic < 3.0
Obsoletes: firebird-superserver < 3.0
Conflicts: firebird-arch < 3.0
Conflicts: firebird-filesystem < 3.0
Conflicts: firebird-classic-common < 3.0
Conflicts: firebird-classic < 3.0
Conflicts: firebird-superclassic < 3.0
Conflicts: firebird-superserver < 3.0
Obsoletes: firebird-arch < 4.0
Obsoletes: firebird-filesystem < 4.0
Obsoletes: firebird-classic-common < 4.0
Obsoletes: firebird-classic < 4.0
Obsoletes: firebird-superclassic < 4.0
Obsoletes: firebird-superserver < 4.0
Conflicts: firebird-arch < 4.0
Conflicts: firebird-filesystem < 4.0
Conflicts: firebird-classic-common < 4.0
Conflicts: firebird-classic < 4.0
Conflicts: firebird-superclassic < 4.0
Conflicts: firebird-superserver < 4.0
%description
@ -114,9 +118,9 @@ in production systems, under a variety of names, since 1981.
%package -n libfbclient2
Summary: Firebird SQL server client library
Obsoletes: firebird-libfbclient < 3.0
Conflicts: firebird-libfbclient < 3.0
Obsoletes: firebird-libfbembed < 3.0
Obsoletes: firebird-libfbclient < 4.0
Conflicts: firebird-libfbclient < 4.0
Obsoletes: firebird-libfbembed < 4.0
%description -n libfbclient2
Shared client library for Firebird SQL server.
@ -191,43 +195,39 @@ in production systems, under a variety of names, since 1981.
%prep
%setup -q -n %{pkgversion}
%patch101 -p1
%patch103 -p1
%patch201 -p1
%patch202 -p1
%patch203 -p1
%patch205 -p1
%patch401 -p1
%build
export CFLAGS="%{optflags} -fno-strict-aliasing"
export CXXFLAGS="${CFLAGS} -fno-delete-null-pointer-checks"
NOCONFIGURE=1 ./autogen.sh
%configure --prefix=%{_prefix} \
--disable-binreloc \
%configure --disable-rpath --prefix=%{_prefix} \
--with-system-editline \
--with-fbbin=%{_bindir} --with-fbsbin=%{_sbindir} \
--with-fbconf=%{_sysconfdir}/%{name} \
--with-fblib=%{_libdir} --with-fbinclude=%{_includedir}/%{name} \
--with-fblib=%{_libdir} --with-fbinclude=%{_includedir} \
--with-fbdoc=%{_defaultdocdir}/%{name} \
--with-fbudf=%{_libdir}/%{name}/udf \
--with-fbsample=%{_defaultdocdir}/%{name}/sample \
--with-fbsample-db=%{_localstatedir}/lib/%{name}/data/ \
--with-fbhelp=%{_localstatedir}/lib/%{name}/system/ \
--with-fbsample-db=%{_localstatedir}/lib/%{name}/data \
--with-fbhelp=%{_localstatedir}/lib/%{name}/system \
--with-fbintl=%{_libdir}/%{name}/intl \
--with-fbmisc=%{_datadir}/%{name}/misc \
--with-fbsecure-db=%{_localstatedir}/lib/%{name}/secdb/ \
--with-fbmsg=%{_localstatedir}/lib/%{name}/system/ \
--with-fbsecure-db=%{_localstatedir}/lib/%{name}/secdb \
--with-fbmsg=%{_localstatedir}/lib/%{name}/system \
--with-fblog=%{_localstatedir}/log/%{name} \
--with-fbglock=%{_var}/run/%{name} \
--with-fbplugins=%{_libdir}/%{name}/plugins
--with-fbglock=/run/%{name} \
--with-fbplugins=%{_libdir}/%{name}/plugins \
--with-fbtzdata=%{_localstatedir}/lib/%{name}/tzdata
make %{?_smp_mflags}
cd gen
make -f Makefile.install buildRoot
sed -i '/linkFiles "/d' ./install/makeInstallImage.sh
./install/makeInstallImage.sh
chmod -R u+w buildroot%{_docdir}/%{name}
%install
chmod u+rw,a+rx gen/buildroot/usr/include/firebird/firebird/impl
chmod u+rw,a+rx gen/buildroot/%{_includedir}/firebird/impl
cp -r gen/buildroot/* ${RPM_BUILD_ROOT}/
mkdir -p ${RPM_BUILD_ROOT}%{_libdir}/pkgconfig
cp -v gen/install/misc/*.pc ${RPM_BUILD_ROOT}%{_libdir}/pkgconfig/
@ -236,30 +236,27 @@ cd ${RPM_BUILD_ROOT}
rm -vf .%{_sbindir}/*.sh
mv -v .%{_sbindir}/fb_config .%{_libdir}/
install -p -m 0755 %{SOURCE4} %{buildroot}%{_sbindir}/fb_config
rm -vf .%{_includedir}/%{name}/perf.h
rm -vf .%{_includedir}/perf.h
rm -vf .%{_libdir}/libicu*.so
rm -vf .%{_includedir}/*.h
chmod -R u+w .%{_docdir}/%{name}
rm -vf .%{_datadir}/%{name}/misc/firebird.init.*
rm -vf .%{_datadir}/%{name}/misc/firebird.xinetd
rm -vf .%{_datadir}/%{name}/misc/rc.config.firebird
mv -v .%{_sysconfdir}/%{name}/README .%{_sysconfdir}/%{name}/WhatsNew \
mv -v .%{_datadir}/%{name}/misc/upgrade/udf/* .%{_docdir}/%{name}/
rm -rvf .%{_datadir}/%{name}/misc
mv -v .%{_sysconfdir}/%{name}/README.md .%{_sysconfdir}/%{name}/CHANGELOG.md \
.%{_docdir}/%{name}/
mv -v .%{_sysconfdir}/%{name}/IDPLicense.txt .%{_docdir}/%{name}/
mv -v .%{_sysconfdir}/%{name}/IPLicense.txt .%{_docdir}/%{name}/
install -p -m 0644 -D %{SOURCE2} .%{_docdir}/%{name}/README.Fedora
mv -v .%{_bindir}/gstat .%{_bindir}/gstat-fb
mv -v .%{_bindir}/isql .%{_bindir}/isql-fb
rm -rvf .%{_defaultdocdir}/%{name}/sample/prebuilt
mkdir -p .%{_localstatedir}/log/%{name}
mkdir -p .%{_sysconfdir}/logrotate.d
echo 1 > .%{_localstatedir}/log/%{name}/%{name}.log
sed "s@%{name}.log@%{_localstatedir}/log/%{name}/%{name}.log@g" %{SOURCE1} > .%{_sysconfdir}/logrotate.d/%{name}
cp -f %{SOURCE3} .%{_datadir}/%{name}/misc/%{name}-superserver.service
mkdir -p .%{_unitdir}
cp .%{_datadir}/%{name}/misc/%{name}-superserver.service .%{_unitdir}/%{name}-superserver.service
cp -f %{SOURCE3} .%{_unitdir}/%{name}.service
%pre
@ -277,15 +274,15 @@ fi
%post
%systemd_post firebird-superserver.service
%systemd_post firebird.service
%postun
%systemd_postun_with_restart firebird-superserver.service
%systemd_postun_with_restart firebird.service
%preun
%systemd_preun firebird-superserver.service
%systemd_preun firebird.service
%files
@ -301,30 +298,32 @@ fi
%config(noreplace) %{_sysconfdir}/%{name}/fbtrace.conf
%config(noreplace) %{_sysconfdir}/%{name}/firebird.conf
%config(noreplace) %{_sysconfdir}/%{name}/plugins.conf
%config(noreplace) %{_sysconfdir}/%{name}/replication.conf
%dir %{_libdir}/%{name}
%dir %{_datadir}/%{name}
%{_libdir}/%{name}/intl
%{_libdir}/%{name}/plugins
%{_libdir}/%{name}/udf
%{_datadir}/%{name}/misc
%dir %{_localstatedir}/lib/%{name}
%dir %attr(0700,%{name},%{name}) %{_localstatedir}/lib/%{name}/secdb
%dir %attr(0700,%{name},%{name}) %{_localstatedir}/lib/%{name}/data
%dir %attr(0755,%{name},%{name}) %{_localstatedir}/lib/%{name}/system
%attr(0600,firebird,firebird) %config(noreplace) %{_localstatedir}/lib/%{name}/secdb/security3.fdb
%dir %attr(0755,%{name},%{name}) %{_localstatedir}/lib/%{name}/tzdata
%attr(0600,firebird,firebird) %config(noreplace) %{_localstatedir}/lib/%{name}/secdb/security4.fdb
%attr(0644,firebird,firebird) %{_localstatedir}/lib/%{name}/system/help.fdb
%attr(0644,firebird,firebird) %{_localstatedir}/lib/%{name}/system/firebird.msg
%ghost %dir %attr(0775,%{name},%{name}) %{_var}/run/%{name}
%ghost %attr(0644,%{name},%{name}) %{_var}/run/%{name}/fb_guard
%attr(0644,firebird,firebird) %{_localstatedir}/lib/%{name}/tzdata/*.res
%ghost %dir %attr(0775,%{name},%{name}) /run/%{name}
%ghost %attr(0644,%{name},%{name}) /run/%{name}/fb_guard
%dir %{_localstatedir}/log/%{name}
%config(noreplace) %attr(0664,%{name},%{name}) %{_localstatedir}/log/%{name}/%{name}.log
%config(noreplace) %attr(0644,root,root) %{_sysconfdir}/logrotate.d/%{name}
%attr(0644,root,root) %{_unitdir}/%{name}-superserver.service
%attr(0644,root,root) %{_unitdir}/%{name}.service
%files devel
%{_includedir}/*.h
%{_includedir}/%{name}
%{_libdir}/fb_config
%{_sbindir}/fb_config
@ -369,6 +368,9 @@ fi
%changelog
* Tue Jun 08 2021 Philippe Makowski <makowski@fedoraproject.org> - 4.0.0.2496-1
- Update to 4.0.0 (#1963311)
* Fri Oct 23 2020 Philippe Makowski <makowski@fedoraproject.org> - 3.0.7.33374-1
- new upstream release fix #1887991

@ -1,78 +0,0 @@
Description: improved support for build flags
The first change makes linking makeHeader use the same CPP/CXX/LD flags as the
rest of the sources.
The second change stops btyacc/Makefile from ignoring CFLAGS from the
environment.
The third change stops overriding CXXFLAGS
The result is using hardening flags from the environment when compiling and
linking.
Author: Damyan Ivanov <dmn@debian.org>
--- a/builds/posix/Makefile.in
+++ b/builds/posix/Makefile.in
@@ -623,7 +623,7 @@ MAKE_HEADER_Src = $(addprefix $(SRC_ROOT
MAKE_HEADER_Bin = ./makeHeader
$(INCLUDE_DEST)/ibase.h: $(SRC_IBASE_ExtraFiles)
- $(STATICEXE_LINK) -o $(MAKE_HEADER_Bin) $(MAKE_HEADER_Src)
+ $(STATICEXE_LINK) $(EXE_LINK_OPTIONS) $(LINK_OPTS) $(CPPFLAGS) -o $(MAKE_HEADER_Bin) $(MAKE_HEADER_Src)
$(CP) $^ .
$(MAKE_HEADER_Bin) <ibase.h >$@
$(RM) -f ibase.h
--- a/extern/btyacc/Makefile
+++ b/extern/btyacc/Makefile
@@ -42,7 +42,7 @@ OTHERS = README README.BYACC \
all: $(PROGRAM)
$(PROGRAM): $(OBJS) $(LIBS)
- $(CC) $(LDFLAGS) -o $(PROGRAM) $(OBJS) $(LIBS)
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $(PROGRAM) $(OBJS) $(LIBS)
clean:; rm -f $(OBJS)
--- a/builds/posix/make.defaults
+++ b/builds/posix/make.defaults
@@ -166,8 +166,8 @@ LD = @CXX@
LIB_LINK = $(CXX) $(GLOB_OPTIONS) $(CXXFLAGS)
STATICLIB_LINK = $(AR) crus
-EXE_LINK = $(CXX) $(GLOB_OPTIONS) $(CXXFLAGS)
-STATICEXE_LINK = $(CXX) $(GLOB_OPTIONS) $(CXXFLAGS)
+EXE_LINK = $(CXX) $(GLOB_OPTIONS) $(CXXFLAGS) $(LDFLAGS)
+STATICEXE_LINK = $(CXX) $(GLOB_OPTIONS) $(CXXFLAGS) $(LDFLAGS)
LINK_LIBS = @LIBS@
STATICLINK_LIBS = @LIBS@
--- a/builds/posix/prefix.linux
+++ b/builds/posix/prefix.linux
@@ -19,7 +19,7 @@
# 2 Oct 2002, Nickolay Samofatov - Major cleanup
COMMON_FLAGS=-ggdb -DFB_SEND_FLAGS=MSG_NOSIGNAL -DLINUX -pipe -MMD -fPIC -fmessage-length=0 -fno-delete-null-pointer-checks
-CXXFLAGS=-std=gnu++03
+CXXFLAGS+=-std=gnu++03
OPTIMIZE_FLAGS=-O3 -march=i586 -mtune=i686 -fno-omit-frame-pointer
WARN_FLAGS=-Wall -Wno-switch -Wno-parentheses -Wno-unknown-pragmas -Wno-unused-variable -Wno-narrowing
--- a/builds/posix/prefix.linux_amd64
+++ b/builds/posix/prefix.linux_amd64
@@ -19,7 +19,7 @@
# 2 Oct 2002, Nickolay Samofatov - Major cleanup
COMMON_FLAGS=-ggdb -DFB_SEND_FLAGS=MSG_NOSIGNAL -DLINUX -DAMD64 -pipe -MMD -fPIC -fmessage-length=0 -fno-delete-null-pointer-checks
-CXXFLAGS=-std=gnu++03
+CXXFLAGS+=-std=gnu++03
OPTIMIZE_FLAGS=-O3 -fno-omit-frame-pointer
WARN_FLAGS=-Wall -Wno-switch -Wno-parentheses -Wno-unknown-pragmas -Wno-unused-variable -Wno-invalid-offsetof -Wno-narrowing -Wno-unused-local-typedefs
--- a/builds/posix/prefix.linux_generic
+++ b/builds/posix/prefix.linux_generic
@@ -19,7 +19,7 @@
# 2 Oct 2002, Nickolay Samofatov - Major cleanup
COMMON_FLAGS=-DLINUX -pipe -MMD -fPIC -DFB_SEND_FLAGS=MSG_NOSIGNAL -fno-delete-null-pointer-checks
-CXXFLAGS=-std=gnu++03
+CXXFLAGS+=-std=gnu++03
PROD_FLAGS=-ggdb -O3 $(COMMON_FLAGS)
DEV_FLAGS=-ggdb -p -Wall -Wno-switch $(COMMON_FLAGS) -Wno-non-virtual-dtor

@ -1,9 +1,21 @@
Description: Link isql with ICU instead of embedding part of it in the source
Author: Damyan Ivanov <dmn@debian.org>
diff --git a/builds/posix/Makefile.in b/builds/posix/Makefile.in
index bb4ceb1..87e75a2 100644
--- a/builds/posix/Makefile.in
+++ b/builds/posix/Makefile.in
@@ -534,7 +534,7 @@ $(GSTAT): $(GSTAT_Objects) $(COMMON_LIB)
isql: $(ISQL)
$(ISQL): $(ISQL_Objects) $(COMMON_LIB)
- $(EXE_LINK) $(EXE_LINK_OPTIONS) $^ -o $@ $(FIREBIRD_LIBRARY_LINK) $(LIBEDITLINE) $(TERMLIB) $(LINK_LIBS) $(call LINK_DARWIN_RPATH,..)
+ $(EXE_LINK) $(EXE_LINK_OPTIONS) $^ -o $@ $(FIREBIRD_LIBRARY_LINK) $(LIBEDITLINE) $(TERMLIB) $(LINK_LIBS) $(ICU_LIBS) $(call LINK_DARWIN_RPATH,..)
nbackup: $(NBACKUP)
diff --git a/src/isql/isql.epp b/src/isql/isql.epp
index 79da1f7..4554252 100644
--- a/src/isql/isql.epp
+++ b/src/isql/isql.epp
@@ -167,34 +167,6 @@ const char* UNKNOWN = "*unknown*";
@@ -173,34 +173,6 @@ const char* UNKNOWN = "*unknown*";
namespace IcuUtil
{
@ -38,14 +50,3 @@ Author: Damyan Ivanov <dmn@debian.org>
// Return the number of characters of a string.
static unsigned charLength(SSHORT charset, unsigned len, const char* str)
{
--- a/builds/posix/Makefile.in
+++ b/builds/posix/Makefile.in
@@ -481,7 +481,7 @@ $(GSTAT): $(GSTAT_Objects) $(COMMON_LIB
isql: $(ISQL)
$(ISQL): $(ISQL_Objects) $(COMMON_LIB)
- $(EXE_LINK) $(EXE_LINK_OPTIONS) $^ -o $@ $(FIREBIRD_LIBRARY_LINK) $(LIBEDITLINE) $(LINK_LIBS) $(call LINK_DARWIN_RPATH,..)
+ $(EXE_LINK) $(EXE_LINK_OPTIONS) $^ -o $@ $(FIREBIRD_LIBRARY_LINK) $(LIBEDITLINE) $(LINK_LIBS) $(ICU_LIBS) $(call LINK_DARWIN_RPATH,..)
nbackup: $(NBACKUP)

@ -1,14 +0,0 @@
Description: remove reference to obsolete syslog.target
Syslog is socket-activated, so no need to declare a dependency on it
Author: Damyan Ivanov <dmn@debian.org>
--- a/builds/install/arch-specific/linux/firebird-superserver.service.in
+++ b/builds/install/arch-specific/linux/firebird-superserver.service.in
@@ -1,6 +1,6 @@
[Unit]
Description=Firebird Database Server ( SuperServer )
-After=syslog.target network.target
+After=network.target
Conflicts=firebird-classic.socket
[Service]

@ -1 +1 @@
SHA512 (Firebird-3.0.7.33374-0.tar.bz2) = ee89cda6d9ace16419515689ed245fbd1bb0e2464bd2d50637e0f474a6aca2e5b86e874ce8bd9714431705a93c038d46de6be1806f0c37d236880a855e725943
SHA512 (Firebird-4.0.0.2496-0.tar.xz) = 110f1e9b245631ba04fb1f3f3fe16209e432157615c5c23046a277f3e6a164a2142c6732e793d9cc6650d65239a0da8bf37a74329134bd006b7d2cb070812bd6

Loading…
Cancel
Save