fix libm linking

epel9
Bastien Nocera 15 years ago
parent 704ca5ba86
commit ba0744c4cc

@ -0,0 +1,31 @@
From 84c17b017f258c0394973ac05c044c33b81d42e6 Mon Sep 17 00:00:00 2001
From: Bastien Nocera <hadess@hadess.net>
Date: Wed, 10 Feb 2010 17:47:08 +0000
Subject: [PATCH] Fix libm linking
Otherwise we fail to link against libm:
/usr/bin/ld: dlg-batch-add.o: undefined reference to symbol 'floor@@GLIBC_2.2.5'
/usr/bin/ld: note: 'floor@@GLIBC_2.2.5' is defined in DSO /lib64/libm.so.6 so try adding it to the linker command line
/lib64/libm.so.6: could not read symbols: Invalid operation
https://bugzilla.gnome.org/show_bug.cgi?id=609565
---
configure.ac | 2 ++
1 files changed, 2 insertions(+), 0 deletions(-)
diff --git a/configure.ac b/configure.ac
index 9a0de5a..37bffc7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -91,6 +91,8 @@ AC_CHECK_FUNC(mkdtemp,
mkdtemp_missing=true)
AM_CONDITIONAL(MKDTEMP_MISSING, test x$mkdtemp_missing = xtrue)
+AC_CHECK_LIB(m, floor)
+
dnl ==========================================================================
AC_ARG_ENABLE(packagekit,
--
1.6.6

@ -37,6 +37,10 @@ Requires(post): GConf2
Requires(preun): GConf2 Requires(preun): GConf2
Requires: GConf2 Requires: GConf2
# https://bugzilla.gnome.org/show_bug.cgi?id=609565
Patch0: 0001-Fix-libm-linking.patch
BuildRequires: autoconf automake gnome-common libtool intltool
# The context menu API changed in 2.2.0: # The context menu API changed in 2.2.0:
Conflicts: nautilus < 2.2.0 Conflicts: nautilus < 2.2.0
@ -46,6 +50,8 @@ such as tar or zip files.
%prep %prep
%setup -q %setup -q
%patch0 -p1 -b .libm
autoreconf -f
%build %build
%configure --disable-scrollkeeper \ %configure --disable-scrollkeeper \

Loading…
Cancel
Save