parent
bfa93eda3c
commit
80641f3aad
@ -1,31 +0,0 @@
|
|||||||
From 84c17b017f258c0394973ac05c044c33b81d42e6 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Bastien Nocera <hadess@hadess.net>
|
|
||||||
Date: Wed, 10 Feb 2010 17:47:08 +0000
|
|
||||||
Subject: [PATCH] Fix libm linking
|
|
||||||
|
|
||||||
Otherwise we fail to link against libm:
|
|
||||||
/usr/bin/ld: dlg-batch-add.o: undefined reference to symbol 'floor@@GLIBC_2.2.5'
|
|
||||||
/usr/bin/ld: note: 'floor@@GLIBC_2.2.5' is defined in DSO /lib64/libm.so.6 so try adding it to the linker command line
|
|
||||||
/lib64/libm.so.6: could not read symbols: Invalid operation
|
|
||||||
|
|
||||||
https://bugzilla.gnome.org/show_bug.cgi?id=609565
|
|
||||||
---
|
|
||||||
configure.ac | 2 ++
|
|
||||||
1 files changed, 2 insertions(+), 0 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index 9a0de5a..37bffc7 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -91,6 +91,8 @@ AC_CHECK_FUNC(mkdtemp,
|
|
||||||
mkdtemp_missing=true)
|
|
||||||
AM_CONDITIONAL(MKDTEMP_MISSING, test x$mkdtemp_missing = xtrue)
|
|
||||||
|
|
||||||
+AC_CHECK_LIB(m, floor)
|
|
||||||
+
|
|
||||||
dnl ==========================================================================
|
|
||||||
|
|
||||||
AC_ARG_ENABLE(packagekit,
|
|
||||||
--
|
|
||||||
1.6.6
|
|
||||||
|
|
@ -1,24 +0,0 @@
|
|||||||
diff -up file-roller-2.28.1/src/fr-window.c.property-get file-roller-2.28.1/src/fr-window.c
|
|
||||||
--- file-roller-2.28.1/src/fr-window.c.property-get 2009-12-14 00:59:59.792797354 -0500
|
|
||||||
+++ file-roller-2.28.1/src/fr-window.c 2009-12-14 01:01:49.141546600 -0500
|
|
||||||
@@ -4138,13 +4138,14 @@ get_xds_atom_value (GdkDragContext *cont
|
|
||||||
g_return_val_if_fail (context != NULL, NULL);
|
|
||||||
g_return_val_if_fail (context->source_window != NULL, NULL);
|
|
||||||
|
|
||||||
- gdk_property_get (context->source_window,
|
|
||||||
- XDS_ATOM, TEXT_ATOM,
|
|
||||||
- 0, MAX_XDS_ATOM_VAL_LEN,
|
|
||||||
- FALSE, NULL, NULL, NULL,
|
|
||||||
- (unsigned char **) &ret);
|
|
||||||
+ if (gdk_property_get (context->source_window,
|
|
||||||
+ XDS_ATOM, TEXT_ATOM,
|
|
||||||
+ 0, MAX_XDS_ATOM_VAL_LEN,
|
|
||||||
+ FALSE, NULL, NULL, NULL,
|
|
||||||
+ (unsigned char **) &ret))
|
|
||||||
+ return ret;
|
|
||||||
|
|
||||||
- return ret;
|
|
||||||
+ return NULL;
|
|
||||||
}
|
|
||||||
|
|
||||||
|
|
Loading…
Reference in new issue