commit
64cdb97bc1
@ -0,0 +1 @@
|
|||||||
|
540229f58381acc068de79ef37e5208e22180559 SOURCES/fence-virt-1.0.0.tar.bz2
|
@ -0,0 +1 @@
|
|||||||
|
SOURCES/fence-virt-1.0.0.tar.bz2
|
@ -0,0 +1,11 @@
|
|||||||
|
--- a/client/options.c 2019-11-20 14:13:42.000000000 +0100
|
||||||
|
+++ b/client/options.c 2021-10-15 14:29:42.933127346 +0200
|
||||||
|
@@ -760,7 +760,7 @@
|
||||||
|
|
||||||
|
printf("<?xml version=\"1.0\" ?>\n");
|
||||||
|
printf("<resource-agent name=\"%s\" shortdesc=\"Fence agent for virtual machines\">\n", basename(progname));
|
||||||
|
- printf("<longdesc>%s is an I/O Fencing agent which can be used with"
|
||||||
|
+ printf("<longdesc>%s is an I/O Fencing agent which can be used with "
|
||||||
|
"virtual machines.</longdesc>\n", basename(progname));
|
||||||
|
printf("<parameters>\n");
|
||||||
|
|
@ -0,0 +1,36 @@
|
|||||||
|
diff --color -uNr a/client/options.c b/client/options.c
|
||||||
|
--- a/client/options.c 2022-10-05 15:57:12.661717853 +0200
|
||||||
|
+++ b/client/options.c 2022-10-05 15:56:44.854549898 +0200
|
||||||
|
@@ -729,9 +729,9 @@
|
||||||
|
|
||||||
|
if (!print_stdin) {
|
||||||
|
if (progname) {
|
||||||
|
- printf("usage: %s [args]\n", progname);
|
||||||
|
+ printf("usage: %s [args]\n\nNOTE: reboot-action does not power on nodes that are powered off.\n\n", progname);
|
||||||
|
} else {
|
||||||
|
- printf("usage: fence_virt [args]\n");
|
||||||
|
+ printf("usage: fence_virt [args]\n\nNOTE: reboot-action does not power on nodes that are powered off.\n\n");
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -761,7 +761,8 @@
|
||||||
|
printf("<?xml version=\"1.0\" ?>\n");
|
||||||
|
printf("<resource-agent name=\"%s\" shortdesc=\"Fence agent for virtual machines\">\n", basename(progname));
|
||||||
|
printf("<longdesc>%s is an I/O Fencing agent which can be used with "
|
||||||
|
- "virtual machines.</longdesc>\n", basename(progname));
|
||||||
|
+ "virtual machines.\n\nNOTE: reboot-action does not power on nodes that are powered off."
|
||||||
|
+ "</longdesc>\n", basename(progname));
|
||||||
|
printf("<parameters>\n");
|
||||||
|
|
||||||
|
for (x = 0; x < strlen(optstr); x++) {
|
||||||
|
diff --color -uNr a/man/fence_virt.8 b/man/fence_virt.8
|
||||||
|
--- a/man/fence_virt.8 2019-11-14 16:29:26.000000000 +0100
|
||||||
|
+++ b/man/fence_virt.8 2022-10-05 16:01:44.001358622 +0200
|
||||||
|
@@ -15,6 +15,7 @@
|
||||||
|
For compatibility, fence_xvm may talk to fence_xvmd from linux-cluster
|
||||||
|
release 2 or later.
|
||||||
|
|
||||||
|
+NOTE: reboot-action does not power on nodes that are powered off.
|
||||||
|
.P
|
||||||
|
fence_virt and fence_xvm accept options on the command line as well
|
||||||
|
as from stdin. The fencing daemon sends parameters through stdin
|
@ -0,0 +1,29 @@
|
|||||||
|
From 6817d9ff018aa1af6fb9775bc9ae1f1cc07fa1ea Mon Sep 17 00:00:00 2001
|
||||||
|
From: Oyvind Albrigtsen <oalbrigt@redhat.com>
|
||||||
|
Date: Mon, 31 Oct 2022 10:54:10 +0100
|
||||||
|
Subject: [PATCH] fence_virtd: add link and non-user socket example to man page
|
||||||
|
|
||||||
|
---
|
||||||
|
man/fence_virt.conf.5 | 9 +++++++++
|
||||||
|
1 file changed, 9 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/man/fence_virt.conf.5 b/man/fence_virt.conf.5
|
||||||
|
index c23ffd943..c8434ed65 100644
|
||||||
|
--- a/man/fence_virt.conf.5
|
||||||
|
+++ b/man/fence_virt.conf.5
|
||||||
|
@@ -230,6 +230,15 @@ by a user running a cluster of virtual machines on a single desktop computer.
|
||||||
|
.
|
||||||
|
the URI to use when connecting to libvirt.
|
||||||
|
|
||||||
|
+All libvirt URIs are accepted and passed as-is.
|
||||||
|
+
|
||||||
|
+See https://libvirt.org/uri.html#remote-uris for examples.
|
||||||
|
+
|
||||||
|
+NOTE: When VMs are run as non-root user the socket path must be set as part
|
||||||
|
+of the URI.
|
||||||
|
+
|
||||||
|
+Example: qemu:///session?socket=/run/user/<UID>/libvirt/virtqemud-sock
|
||||||
|
+
|
||||||
|
.SS libvirt-qmf
|
||||||
|
|
||||||
|
The libvirt-qmf plugin acts as a QMFv2 Console to the libvirt-qmf daemon in
|
@ -0,0 +1,118 @@
|
|||||||
|
diff --color -uNr a/config/Makefile.am b/config/Makefile.am
|
||||||
|
--- a/config/Makefile.am 2019-11-20 14:13:42.000000000 +0100
|
||||||
|
+++ b/config/Makefile.am 2022-11-22 10:12:51.764545658 +0100
|
||||||
|
@@ -37,5 +37,8 @@
|
||||||
|
config.c: y.tab.c config.l
|
||||||
|
$(LEX) -oconfig.c $(srcdir)/config.l
|
||||||
|
|
||||||
|
+install-exec-hook:
|
||||||
|
+ chmod 600 $(DESTDIR)$(sysconfdir)/fence_virt.conf
|
||||||
|
+
|
||||||
|
clean-local:
|
||||||
|
rm -f config.tab.c config.tab.h config.c y.tab.c y.tab.h
|
||||||
|
diff --color -uNr a/include/simpleconfig.h b/include/simpleconfig.h
|
||||||
|
--- a/include/simpleconfig.h 2018-01-15 15:02:31.000000000 +0100
|
||||||
|
+++ b/include/simpleconfig.h 2022-11-22 10:15:06.440335062 +0100
|
||||||
|
@@ -49,4 +49,8 @@
|
||||||
|
/* Frees a previously-allocated copy of our simple config object */
|
||||||
|
void sc_release(config_object_t *c);
|
||||||
|
|
||||||
|
+int check_file_permissions(const char *fname);
|
||||||
|
+
|
||||||
|
+int do_configure(config_object_t *config, const char *filename);
|
||||||
|
+
|
||||||
|
#endif
|
||||||
|
diff --color -uNr a/include/simpleconfig.h.rej b/include/simpleconfig.h.rej
|
||||||
|
--- a/include/simpleconfig.h.rej 1970-01-01 01:00:00.000000000 +0100
|
||||||
|
+++ b/include/simpleconfig.h.rej 2022-11-22 10:12:51.764545658 +0100
|
||||||
|
@@ -0,0 +1,11 @@
|
||||||
|
+--- include/simpleconfig.h
|
||||||
|
++++ include/simpleconfig.h
|
||||||
|
+@@ -49,6 +49,8 @@ config_object_t *sc_init(void);
|
||||||
|
+ /* Frees a previously-allocated copy of our simple config object */
|
||||||
|
+ void sc_release(config_object_t *c);
|
||||||
|
+
|
||||||
|
++int check_file_permissions(const char *fname);
|
||||||
|
++
|
||||||
|
+ int do_configure(config_object_t *config, const char *filename);
|
||||||
|
+
|
||||||
|
+ #endif
|
||||||
|
diff --color -uNr a/server/config.c b/server/config.c
|
||||||
|
--- a/server/config.c 2019-11-20 14:13:42.000000000 +0100
|
||||||
|
+++ b/server/config.c 2022-11-22 10:17:25.539150364 +0100
|
||||||
|
@@ -11,6 +11,7 @@
|
||||||
|
#include <fcntl.h>
|
||||||
|
#include <net/if.h>
|
||||||
|
#include <arpa/inet.h>
|
||||||
|
+#include <errno.h>
|
||||||
|
|
||||||
|
#include "simpleconfig.h"
|
||||||
|
#include "static_map.h"
|
||||||
|
@@ -590,6 +591,31 @@
|
||||||
|
|
||||||
|
|
||||||
|
int
|
||||||
|
+check_file_permissions(const char *fname)
|
||||||
|
+{
|
||||||
|
+ struct stat st;
|
||||||
|
+ mode_t file_perms = 0600;
|
||||||
|
+ int ret;
|
||||||
|
+
|
||||||
|
+ ret = stat(fname, &st);
|
||||||
|
+ if (ret != 0) {
|
||||||
|
+ printf("stat failed on file '%s': %s\n",
|
||||||
|
+ fname, strerror(errno));
|
||||||
|
+ return 1;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ if ((st.st_mode & 0777) != file_perms) {
|
||||||
|
+ printf("WARNING: invalid permissions on file "
|
||||||
|
+ "'%s': has 0%o should be 0%o\n", fname,
|
||||||
|
+ (unsigned int)(st.st_mode & 0777),
|
||||||
|
+ (unsigned int)file_perms);
|
||||||
|
+ return 1;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ return 0;
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+int
|
||||||
|
do_configure(config_object_t *config, const char *config_file)
|
||||||
|
{
|
||||||
|
FILE *fp = NULL;
|
||||||
|
diff --color -uNr a/server/main.c b/server/main.c
|
||||||
|
--- a/server/main.c 2019-11-27 09:19:52.000000000 +0100
|
||||||
|
+++ b/server/main.c 2022-11-22 10:19:06.647742990 +0100
|
||||||
|
@@ -14,11 +14,12 @@
|
||||||
|
/* Local includes */
|
||||||
|
#include "simpleconfig.h"
|
||||||
|
#include "static_map.h"
|
||||||
|
+#include "xvm.h"
|
||||||
|
#include "server_plugin.h"
|
||||||
|
+#include "simple_auth.h"
|
||||||
|
#include "debug.h"
|
||||||
|
|
||||||
|
/* configure.c */
|
||||||
|
-int do_configure(config_object_t *config, const char *filename);
|
||||||
|
int daemon_init(const char *prog, const char *pid_file, int nofork);
|
||||||
|
int daemon_cleanup(void);
|
||||||
|
|
||||||
|
@@ -206,6 +207,18 @@
|
||||||
|
snprintf(pid_file, PATH_MAX, "/var/run/%s.pid", basename(argv[0]));
|
||||||
|
}
|
||||||
|
|
||||||
|
+ check_file_permissions(config_file);
|
||||||
|
+
|
||||||
|
+ sprintf(val, "listeners/%s/@key_file", listener_name);
|
||||||
|
+ if (sc_get(config, val,
|
||||||
|
+ val, sizeof(val)-1) == 0) {
|
||||||
|
+ dbg_printf(1, "Got %s for key_file\n", val);
|
||||||
|
+ } else {
|
||||||
|
+ snprintf(val, sizeof(val), "%s", DEFAULT_KEY_FILE);
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ check_file_permissions(val);
|
||||||
|
+
|
||||||
|
openlog(basename(argv[0]), LOG_NDELAY | LOG_PID, LOG_DAEMON);
|
||||||
|
|
||||||
|
daemon_init(basename(argv[0]), pid_file, foreground);
|
@ -0,0 +1,55 @@
|
|||||||
|
From 6f213eb637bf7d957ba035e3aa09ce1f1bbccf84 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Oyvind Albrigtsen <oalbrigt@redhat.com>
|
||||||
|
Date: Tue, 29 Nov 2022 16:21:18 +0100
|
||||||
|
Subject: [PATCH] fence_virtd: add info about using multiple uuid/ip entries
|
||||||
|
for groups
|
||||||
|
|
||||||
|
---
|
||||||
|
man/fence_virt.conf.5 | 17 +++++++++++------
|
||||||
|
1 file changed, 11 insertions(+), 6 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/man/fence_virt.conf.5 b/man/fence_virt.conf.5
|
||||||
|
index c8434ed65..dfb3504f5 100644
|
||||||
|
--- a/man/fence_virt.conf.5
|
||||||
|
+++ b/man/fence_virt.conf.5
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-.TH fence_virtd.conf 5
|
||||||
|
+.TH fence_virt.conf 5
|
||||||
|
|
||||||
|
.SH NAME
|
||||||
|
fence_virt.conf - configuration file for fence_virtd
|
||||||
|
@@ -304,15 +304,17 @@ This defines a group.
|
||||||
|
.TP
|
||||||
|
.B uuid
|
||||||
|
.
|
||||||
|
-defines UUID as a member of a group.
|
||||||
|
+Defines UUID as a member of a group. It can be used multiple times
|
||||||
|
+to specify both node name and UUID values that can be fenced.
|
||||||
|
|
||||||
|
.TP
|
||||||
|
.B ip
|
||||||
|
.
|
||||||
|
-defines an IP which is allowed to send fencing requests
|
||||||
|
-for members of this group (e.g. for multicast). It is
|
||||||
|
-highly recommended that this be used in conjunction with
|
||||||
|
-a key file.
|
||||||
|
+Defines an IP which is allowed to send fencing requests
|
||||||
|
+for members of this group (e.g. for multicast). It can be used
|
||||||
|
+multiple times to allow more than 1 IP to send fencing requests to
|
||||||
|
+the group. It is highly recommended that this be used in conjunction
|
||||||
|
+with a key file.
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
@@ -340,8 +342,11 @@ a key file.
|
||||||
|
groups {
|
||||||
|
group {
|
||||||
|
ip = "192.168.1.1";
|
||||||
|
+ ip = "192.168.1.2";
|
||||||
|
uuid = "44179d3f-6c63-474f-a212-20c8b4b25b16";
|
||||||
|
uuid = "1ce02c4b-dfa1-42cb-b5b1-f0b1091ece60";
|
||||||
|
+ uuid = "node1";
|
||||||
|
+ uuid = "node2";
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
@ -0,0 +1,386 @@
|
|||||||
|
###############################################################################
|
||||||
|
###############################################################################
|
||||||
|
##
|
||||||
|
## Copyright (C) 2019 Red Hat, Inc. All rights reserved.
|
||||||
|
##
|
||||||
|
## This copyrighted material is made available to anyone wishing to use,
|
||||||
|
## modify, copy, or redistribute it subject to the terms and conditions
|
||||||
|
## of the GNU General Public License v.2.
|
||||||
|
##
|
||||||
|
###############################################################################
|
||||||
|
###############################################################################
|
||||||
|
|
||||||
|
Name: fence-virt
|
||||||
|
Summary: A pluggable fencing framework for virtual machines
|
||||||
|
Version: 1.0.0
|
||||||
|
Release: 6%{?numcomm:.%{numcomm}}%{?alphatag:.%{alphatag}}%{?dirty:.%{dirty}}%{?dist}
|
||||||
|
License: GPLv2+
|
||||||
|
Group: System Environment/Base
|
||||||
|
URL: https://github.com/ClusterLabs/fence-virt
|
||||||
|
Source0: %{name}-%{version}%{?rcver:%{rcver}}%{?numcomm:.%{numcomm}}%{?alphatag:-%{alphatag}}%{?dirty:-%{dirty}}.tar.bz2
|
||||||
|
Patch0: bz1927171-fence_xvm-fix-typo.patch
|
||||||
|
Patch1: bz2132010-fence_virt-add-note-reboot-action.patch
|
||||||
|
Patch2: bz2138825-fence_virtd-update-manpage.patch
|
||||||
|
Patch3: bz2144530-fence_virtd-warn-files-not-mode-600.patch
|
||||||
|
Patch4: bz2149649-fence_virtd-update-fence_virt.conf-manpage.patch
|
||||||
|
|
||||||
|
%if 0%{?rhel}
|
||||||
|
ExclusiveArch: i686 x86_64
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%if 0%{?suse_version}
|
||||||
|
%define nss_devel mozilla-nss-devel
|
||||||
|
%define nspr_devel mozilla-nspr-devel
|
||||||
|
%define systemd_units systemd
|
||||||
|
%else
|
||||||
|
%define nss_devel nss-devel
|
||||||
|
%define nspr_devel nspr-devel
|
||||||
|
%define systemd_units systemd-units
|
||||||
|
%endif
|
||||||
|
|
||||||
|
BuildRequires: gcc
|
||||||
|
BuildRequires: corosynclib-devel libvirt-devel
|
||||||
|
BuildRequires: automake autoconf libtool libxml2-devel %{nss_devel} %{nspr_devel}
|
||||||
|
BuildRequires: flex bison libuuid-devel
|
||||||
|
|
||||||
|
BuildRequires: systemd-units
|
||||||
|
Requires(post): systemd-sysv systemd-units
|
||||||
|
Requires(preun): systemd-units
|
||||||
|
Requires(postun): systemd-units
|
||||||
|
|
||||||
|
Conflicts: fence-agents < 3.0.5-2
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n %{name}-%{version}%{?rcver:%{rcver}}%{?numcomm:.%{numcomm}}%{?alphatag:-%{alphatag}}%{?dirty:-%{dirty}}
|
||||||
|
%patch0 -p1
|
||||||
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
%patch3 -p1
|
||||||
|
%patch4 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
./autogen.sh
|
||||||
|
%{configure} --disable-libvirt-qmf-plugin --enable-cpg-plugin
|
||||||
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf %{buildroot}
|
||||||
|
make install DESTDIR=%{buildroot}
|
||||||
|
|
||||||
|
# Systemd unit file
|
||||||
|
mkdir -p %{buildroot}/%{_unitdir}/
|
||||||
|
install -m 0644 fence_virtd.service %{buildroot}/%{_unitdir}/
|
||||||
|
|
||||||
|
rm -f %{buildroot}/%{_libdir}/%{name}/*.*a
|
||||||
|
|
||||||
|
%post
|
||||||
|
ccs_update_schema > /dev/null 2>&1 ||:
|
||||||
|
# https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
|
||||||
|
if [ $1 -eq 1 ]; then
|
||||||
|
# Initial installation
|
||||||
|
/bin/systemctl daemon-reload >/dev/null 2>&1 || :
|
||||||
|
fi
|
||||||
|
|
||||||
|
%preun
|
||||||
|
# https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
|
||||||
|
if [ $1 -eq 0 ]; then
|
||||||
|
# Package removal, not upgrade
|
||||||
|
/bin/systemctl --no-reload disable fence_virtd.service &> /dev/null || :
|
||||||
|
/bin/systemctl stop fence_virtd.service &> /dev/null || :
|
||||||
|
fi
|
||||||
|
|
||||||
|
%postun
|
||||||
|
# https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
|
||||||
|
/bin/systemctl daemon-reload &> /dev/null || :
|
||||||
|
if [ $1 -ge 1 ]; then
|
||||||
|
# Package upgrade, not uninstall
|
||||||
|
/bin/systemctl try-restart fence_virtd.service &> /dev/null || :
|
||||||
|
fi
|
||||||
|
|
||||||
|
%triggerun -- fence_virtd < 0.3.0-1
|
||||||
|
# https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Packages_migrating_to_a_systemd_unit_file_from_a_SysV_initscript
|
||||||
|
/usr/bin/systemd-sysv-convert --save fence_virtd &> /dev/null || :
|
||||||
|
/sbin/chkconfig --del fence_virtd &> /dev/null || :
|
||||||
|
/bin/systemctl daemon-reload >/dev/null 2>&1 || :
|
||||||
|
/bin/systemctl try-restart fence_virtd.service &> /dev/null || :
|
||||||
|
|
||||||
|
%description
|
||||||
|
Fencing agent for virtual machines.
|
||||||
|
|
||||||
|
%files
|
||||||
|
%doc COPYING TODO README
|
||||||
|
%{_sbindir}/fence_virt
|
||||||
|
%{_sbindir}/fence_xvm
|
||||||
|
%{_mandir}/man8/fence_virt.*
|
||||||
|
%{_mandir}/man8/fence_xvm.*
|
||||||
|
|
||||||
|
%package -n fence-virtd
|
||||||
|
Summary: Daemon which handles requests from fence-virt
|
||||||
|
Group: System Environment/Base
|
||||||
|
%description -n fence-virtd
|
||||||
|
This package provides the host server framework, fence_virtd,
|
||||||
|
for fence_virt. The fence_virtd host daemon is resposible for
|
||||||
|
processing fencing requests from virtual machines and routing
|
||||||
|
the requests to the appropriate physical machine for action.
|
||||||
|
%files -n fence-virtd
|
||||||
|
%{_sbindir}/fence_virtd
|
||||||
|
%{_unitdir}/fence_virtd.service
|
||||||
|
%config(noreplace) %{_sysconfdir}/fence_virt.conf
|
||||||
|
%dir %{_libdir}/%{name}
|
||||||
|
%{_libdir}/%{name}/vsock.so
|
||||||
|
%{_mandir}/man5/fence_virt.conf.*
|
||||||
|
%{_mandir}/man8/fence_virtd.*
|
||||||
|
|
||||||
|
%package -n fence-virtd-multicast
|
||||||
|
Summary: Multicast listener for fence-virtd
|
||||||
|
Group: System Environment/Base
|
||||||
|
Requires: fence-virtd
|
||||||
|
%description -n fence-virtd-multicast
|
||||||
|
Provides multicast listener capability for fence-virtd.
|
||||||
|
%files -n fence-virtd-multicast
|
||||||
|
%{_libdir}/%{name}/multicast.so
|
||||||
|
|
||||||
|
%package -n fence-virtd-serial
|
||||||
|
Summary: Serial VMChannel listener for fence-virtd
|
||||||
|
Group: System Environment/Base
|
||||||
|
Requires: libvirt >= 0.6.2
|
||||||
|
Requires: fence-virtd
|
||||||
|
%description -n fence-virtd-serial
|
||||||
|
Provides serial VMChannel listener capability for fence-virtd.
|
||||||
|
%files -n fence-virtd-serial
|
||||||
|
%{_libdir}/%{name}/serial.so
|
||||||
|
|
||||||
|
%package -n fence-virtd-tcp
|
||||||
|
Summary: TCP listener for fence-virtd
|
||||||
|
Group: System Environment/Base
|
||||||
|
Requires: fence-virtd
|
||||||
|
%description -n fence-virtd-tcp
|
||||||
|
Provides TCP listener capability for fence-virtd.
|
||||||
|
%files -n fence-virtd-tcp
|
||||||
|
%{_libdir}/%{name}/tcp.so
|
||||||
|
|
||||||
|
%package -n fence-virtd-libvirt
|
||||||
|
Summary: Libvirt backend for fence-virtd
|
||||||
|
Group: System Environment/Base
|
||||||
|
Requires: libvirt >= 0.6.0
|
||||||
|
Requires: fence-virtd
|
||||||
|
%description -n fence-virtd-libvirt
|
||||||
|
Provides fence_virtd with a connection to libvirt to fence
|
||||||
|
virtual machines. Useful for running a cluster of virtual
|
||||||
|
machines on a desktop.
|
||||||
|
%files -n fence-virtd-libvirt
|
||||||
|
%{_libdir}/%{name}/virt.so
|
||||||
|
|
||||||
|
%package -n fence-virtd-cpg
|
||||||
|
Summary: CPG/libvirt backend for fence-virtd
|
||||||
|
Group: System Environment/Base
|
||||||
|
Requires: corosynclib
|
||||||
|
Requires: fence-virtd
|
||||||
|
%description -n fence-virtd-cpg
|
||||||
|
Provides fence_virtd with a connection to libvirt to fence
|
||||||
|
virtual machines. Uses corosync CPG to keep track of VM
|
||||||
|
locations to allow for non-local VMs to be fenced when VMs
|
||||||
|
are located on corosync cluster nodes.
|
||||||
|
%files -n fence-virtd-cpg
|
||||||
|
%{_libdir}/%{name}/cpg.so
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Dec 2 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 1.0.0-6
|
||||||
|
- fence_virtd: add info about multiple uuid/ip entries to manpage
|
||||||
|
|
||||||
|
Resolves: rhbz#2149649
|
||||||
|
|
||||||
|
* Tue Nov 22 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 1.0.0-5
|
||||||
|
- fence_virtd: warn if config or key file(s) are not mode 600
|
||||||
|
|
||||||
|
Resolves: rhbz#bz2144530
|
||||||
|
|
||||||
|
* Mon Oct 31 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 1.0.0-4
|
||||||
|
- fence_virtd: add link to uri examples and uri w/socket path
|
||||||
|
example for when VMS are run as non-root user to manpage
|
||||||
|
|
||||||
|
Resolves: rhbz#2138825
|
||||||
|
|
||||||
|
* Wed Oct 5 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 1.0.0-3
|
||||||
|
- fence_virt: add note that reboot-action doesnt power on nodes that
|
||||||
|
are powered off
|
||||||
|
Resolves: rhbz#2132010
|
||||||
|
|
||||||
|
* Fri Oct 15 2021 Oyvind Albrigtsen <oalbrigt@redhat.com> - 1.0.0-2
|
||||||
|
- fence_xvm: fix typo
|
||||||
|
Resolves: rhbz#1927171
|
||||||
|
|
||||||
|
* Wed Mar 11 2020 Oyvind Albrigtsen <oalbrigt@redhat.com> - 1.0.0-1
|
||||||
|
- Rebase to fence-virt-1.0.0
|
||||||
|
Resolves: rhbz#1774394
|
||||||
|
|
||||||
|
* Thu Jan 30 2020 Oyvind Albrigtsen <oalbrigt@redhat.com> - 0.4.0-9
|
||||||
|
- fence_virtd: fix segfault when no domains are found
|
||||||
|
Resolves: rhbz#1766993
|
||||||
|
|
||||||
|
* Tue Jul 23 2019 Oyvind Albrigtsen <oalbrigt@redhat.com> - 0.4.0-7
|
||||||
|
- fence_xvm/fence_virt: dont report success for incorrect parameter
|
||||||
|
Resolves: rhbz#1668357
|
||||||
|
|
||||||
|
* Tue Apr 9 2019 Oyvind Albrigtsen <oalbrigt@redhat.com> - 0.4.0-6
|
||||||
|
- Harden with -fPIE and -Wl,-z,now
|
||||||
|
Resolves: rhbz#1624110
|
||||||
|
- Add CI gating tests
|
||||||
|
Resolves: rhbz#1682883
|
||||||
|
|
||||||
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.0-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.0-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jun 05 2017 Ryan McCabe <rmccabe@redhat.com> - 0.4.0-1
|
||||||
|
- Rebase to fence-virt-0.4.0
|
||||||
|
|
||||||
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.2-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.2-6
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.2-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 0.3.2-4
|
||||||
|
- Rebuilt for GCC 5 C++11 ABI change
|
||||||
|
|
||||||
|
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.2-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.2-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Nov 04 2013 Ryan McCabe <rmccabe@redhat.com> - 0.3.2-1
|
||||||
|
- New upstream version 0.3.2
|
||||||
|
|
||||||
|
* Sun Nov 03 2013 Ryan McCabe <rmccabe@redhat.com> - 0.3.1-1
|
||||||
|
- Drop executable flags of manual pages
|
||||||
|
- Fix for missed libvirtd events
|
||||||
|
- Fix for broken systemd service file
|
||||||
|
|
||||||
|
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-15
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 10 2013 Ryan McCabe <rmccabe@redhat.com> - 0.3.0-14
|
||||||
|
- Fail properly when unable to bind the TCP listener socket.
|
||||||
|
- Resolves: rhbz#814515
|
||||||
|
|
||||||
|
* Tue May 07 2013 Ryan McCabe <rmccabe@redhat.com> - 0.3.0-13
|
||||||
|
- Rebuild
|
||||||
|
|
||||||
|
* Tue May 07 2013 Ryan McCabe <rmccabe@redhat.com> - 0.3.0-12
|
||||||
|
- Drop libvirt-qmf-plugin
|
||||||
|
|
||||||
|
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-11
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Nov 02 2012 Ryan McCabe <rmccabe@redhat.com> - 0.3.0-10
|
||||||
|
- bswap fix for big endian
|
||||||
|
|
||||||
|
* Fri Nov 02 2012 Ryan McCabe <rmccabe@redhat.com> - 0.3.0-9
|
||||||
|
- Return success if a domain exists but is already off.
|
||||||
|
|
||||||
|
* Thu Oct 25 2012 Ryan McCabe <rmccabe@redhat.com> - 0.3.0-8
|
||||||
|
- Version bump
|
||||||
|
|
||||||
|
* Thu Oct 25 2012 Ryan McCabe <rmccabe@redhat.com> - 0.3.0-7
|
||||||
|
- Fix uninitialized variable for the -w option.
|
||||||
|
|
||||||
|
* Mon Oct 15 2012 Ryan McCabe <rmccabe@redhat.com> - 0.3.0-6
|
||||||
|
- Add a -w (delay) option.
|
||||||
|
- Return failure when attempting to fence a nonexistent domain
|
||||||
|
- Improve man pages
|
||||||
|
|
||||||
|
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Mar 27 2012 Ryan McCabe <rmccabe@fedoraproject.org> 0.3.0-4
|
||||||
|
- Add QPid build fix patch from upstream.
|
||||||
|
|
||||||
|
* Fri Feb 10 2012 Lon Hohberger <lon@fedoraproject.org> 0.3.0-2
|
||||||
|
- Fix URL / Source0 lines
|
||||||
|
Resolves: Fedora#706560
|
||||||
|
|
||||||
|
* Tue Feb 07 2012 Lon Hohberger <lhh@redhat.com> 0.3.0-1
|
||||||
|
- Rebase from upstream to 0.3.0
|
||||||
|
- Systemd unit file integration
|
||||||
|
- Pacemaker backend
|
||||||
|
- Various fixes for startup
|
||||||
|
- Rename libvirt-qpid to libvirt-qmf backend
|
||||||
|
- Updated default configuration for easier deployment on
|
||||||
|
Fedora systems
|
||||||
|
|
||||||
|
* Tue Feb 07 2012 Lon Hohberger <lhh@redhat.com> - 0.2.3-6
|
||||||
|
- Bump and rebuild
|
||||||
|
|
||||||
|
* Tue Feb 07 2012 Lon Hohberger <lhh@redhat.com> - 0.2.3-5
|
||||||
|
- Fixup changelog
|
||||||
|
|
||||||
|
* Mon Feb 06 2012 Lon Hohberger <lhh@redhat.com> - 0.2.3-4
|
||||||
|
- Drop checkpoint backend since cman and openais are gone
|
||||||
|
|
||||||
|
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jul 8 2011 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.2.3-2
|
||||||
|
- add post call to fence-virt to integrate with cluster 3.1.4
|
||||||
|
|
||||||
|
* Wed Jun 29 2011 Fabio M. Di Nitto <fdinitto@redhat.com> 0.2.3-1
|
||||||
|
- new upstream release fix compat regression
|
||||||
|
|
||||||
|
* Mon Jun 27 2011 Fabio M. Di Nitto <fdinitto@redhat.com> 0.2.2-1
|
||||||
|
- new upstream release
|
||||||
|
|
||||||
|
* Mon May 09 2011 Fabio M. Di Nitto <fdinitto@redhat.com> 0.2.1-5
|
||||||
|
- Rebuilt for libqmfconsole soname change
|
||||||
|
|
||||||
|
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.1-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Apr 01 2010 Lon Hohberger <lhh@redhat.com> 0.2.1-3
|
||||||
|
- Update specfile to require correct qpid/qmf libraries
|
||||||
|
- Resolves: bz#565111
|
||||||
|
|
||||||
|
* Tue Feb 23 2010 Fabio M. Di Nitto <fdinitto@redhat.com> 0.2.1-2
|
||||||
|
- Update spec file to handle correctly versioned Requires
|
||||||
|
|
||||||
|
* Fri Jan 15 2010 Lon Hohberger <lhh@redhat.com> 0.2.1-1
|
||||||
|
- Update to latest upstream version
|
||||||
|
- Fix bug around status return codes for VMs which are 'off'
|
||||||
|
|
||||||
|
* Thu Jan 14 2010 Lon Hohberger <lhh@redhat.com> 0.2-1
|
||||||
|
- Update to latest upstream version
|
||||||
|
- Serial & VMChannel listener support
|
||||||
|
- Static permission map support
|
||||||
|
- Man pages
|
||||||
|
- Init script
|
||||||
|
- Various bugfixes
|
||||||
|
|
||||||
|
* Mon Sep 21 2009 Lon Hohberger <lhh@redhat.com> 0.1.3-1
|
||||||
|
- Update to latest upstream version
|
||||||
|
- Adds libvirt-qpid backend support
|
||||||
|
- Fixes UUID operation with libvirt backend
|
||||||
|
- Adds man page for fence_xvm and fence_virt
|
||||||
|
- Provides fence_xvm compatibility for cluster 3.0.6
|
||||||
|
|
||||||
|
* Mon Sep 21 2009 Lon Hohberger <lhh@redhat.com> 0.1.2-1
|
||||||
|
- Update to latest upstream version
|
||||||
|
- Fix build issue on i686
|
||||||
|
|
||||||
|
* Mon Sep 21 2009 Lon Hohberger <lhh@redhat.com> 0.1.1-1
|
||||||
|
- Update to latest upstream version
|
||||||
|
- Clean up spec file
|
||||||
|
|
||||||
|
* Mon Sep 21 2009 Lon Hohberger <lhh@redhat.com> 0.1-2
|
||||||
|
- Spec file cleanup
|
||||||
|
|
||||||
|
* Thu Sep 17 2009 Lon Hohberger <lhh@redhat.com> 0.1-1
|
||||||
|
- Initial build for rawhide
|
Loading…
Reference in new issue