Initial import into devel.

Modified Files: devel/fdupes.spec Added Files:
    devel/fdupes-1.40-destdir.patch devel/fdupes-1.40-string.patch
epel9
Debarshi Ray 17 years ago
parent d5f2fc447b
commit 75563b0655

@ -0,0 +1,20 @@
diff -urNp fdupes-1.40.orig/Makefile fdupes-1.40/Makefile
--- fdupes-1.40.orig/Makefile 2001-03-15 08:19:11.000000000 +0530
+++ fdupes-1.40/Makefile 2007-11-25 20:34:21.000000000 +0530
@@ -1,3 +1,5 @@
+DESTDIR =
+
#
# INSTALLDIR indicates directory where program is to be installed.
# Suggested values are "/usr/local/bin" or "/usr/bin".
@@ -38,8 +40,8 @@ fdupes: fdupes.c md5/md5.c
gcc fdupes.c md5/md5.c -Wall -o fdupes -DVERSION=\"$(VERSION)\" $(EXTERNAL_MD5) $(EXPERIMENTAL_RBTREE)
install: fdupes
- cp fdupes $(INSTALLDIR)
- cp fdupes.1 $(MANPAGEDIR)/man1
+ cp fdupes $(DESTDIR)$(INSTALLDIR)
+ cp fdupes.1 $(DESTDIR)$(MANPAGEDIR)/man1
tarball: clean
tar --directory=.. -c -z -v -f ../fdupes-$(VERSION).tar.gz fdupes-$(VERSION)

@ -0,0 +1,19 @@
diff -urNp fdupes-1.40.orig/md5/md5.c fdupes-1.40/md5/md5.c
--- fdupes-1.40.orig/md5/md5.c 1999-11-05 06:34:36.000000000 +0530
+++ fdupes-1.40/md5/md5.c 2007-11-25 20:56:36.000000000 +0530
@@ -39,6 +39,7 @@
*/
#include "md5.h"
+#include <string.h>
#ifdef TEST
/*
@@ -46,7 +47,6 @@
* The test program should print out the same values as given in section
* A.5 of RFC 1321, reproduced below.
*/
-#include <string.h>
main()
{
static const char *const test[7] = {

@ -1,72 +1,62 @@
Name: fdupes Summary: Finds duplicate files in a given set of directories
Version: 1.40 Name: fdupes
Release: 8%{?dist} Version: 1.40
Summary: Identifies and optionally deletes duplicate files Release: 9%{?dist}
License: MIT
Group: Applications/File
URL: http://netdial.caribe.net/~adrian2/fdupes.html
Source0: http://netdial.caribe.net/~adrian2/programs/%{name}-%{version}.tar.gz
Group: Applications/File Patch0: %{name}-%{version}-destdir.patch
License: MIT Patch1: %{name}-%{version}-string.patch
URL: http://netdial.caribe.net/~adrian2/fdupes.html
Source0: http://netdial.caribe.net/~adrian2/programs/%{name}-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
#BuildRequires: BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
#Requires:
%description %description
fdupes is a program for identifying or deleting duplicate files. FDUPES is a program for identifying duplicate files residing within specified
Such files are found by comparing file sizes and MD5 signatures, followed by a directories.
byte-by-byte comparison.
%prep %prep
%setup -q %setup -q
%patch0 -p1
%patch1 -p1
sed --expression "s/-Wall/$RPM_OPT_FLAGS/" Makefile > Makefile.tmp
touch --reference Makefile Makefile.tmp
mv Makefile.tmp Makefile
%build %build
#%%configure
%{__sed} -i -e "s/-Wall/${RPM_OPT_FLAGS}/" Makefile
make %{?_smp_mflags} make %{?_smp_mflags}
%check
./%{name} testdir
./%{name} --omitfirst testdir
./%{name} --recurse testdir
./%{name} --size testdir
# ... etc..
%install %install
rm -rf ${RPM_BUILD_ROOT} rm -rf $RPM_BUILD_ROOT
mkdir -p ${RPM_BUILD_ROOT}%{_bindir} ${RPM_BUILD_ROOT}%{_mandir}/man1 mkdir -p $RPM_BUILD_ROOT%{_bindir}
install -m 0755 fdupes ${RPM_BUILD_ROOT}%{_bindir}/fdupes mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
install -m 0644 fdupes.1 ${RPM_BUILD_ROOT}%{_mandir}/man1/fdupes.1
make install INSTALLDIR=%{_bindir} MANPAGEDIR=%{_mandir} \
DESTDIR=$RPM_BUILD_ROOT
%clean %clean
rm -rf ${RPM_BUILD_ROOT} rm -rf $RPM_BUILD_ROOT
%files %files
%defattr(-,root,root,-) %defattr(-,root,root,-)
%doc CHANGES CONTRIBUTORS INSTALL README TODO %doc CHANGES
%doc %{_mandir}/man1/fdupes.1* %doc CONTRIBUTORS
%{_bindir}/fdupes %doc README
%doc TODO
%{_bindir}/%{name}
%{_mandir}/man1/%{name}.1.gz
%changelog %changelog
* Sat Sep 02 2006 Simon Bellwood <simonb@thoughtpolice.co.uk> - 1.40-8 * Sun Nov 25 2007 Debarshi Ray <rishi@fedoraproject.org> - 1.40-9
- Bump again for rebuild. - Initial build. Imported SPEC from Rawhide.
- Fixed Makefile to use DESTDIR correctly.
* Sat Sep 02 2006 Simon Bellwood <simonb@thoughtpolice.co.uk> - 1.40-7 - Fixed sources to include string.h.
- Rebuilt for FC6T3/Rawhide.
* Sat Feb 18 2006 Simon Bellwood <simonb@thoughtpolice.co.uk> - 1.40-6
- Rebuilt for FC5T3/Rawhide.
* Wed Nov 30 2005 Simon Bellwood <simonb@thoughtpolice.co.uk> - 1.40-5
- Initial attempt to import into Extras.
* Wed Nov 30 2005 Simon Bellwood <simonb@thoughtpolice.co.uk> - 1.40-4
- Updated spec file to include dist in Release: field.
* Thu Nov 24 2005 Simon Bellwood <simonb@thoughtpolice.co.uk> - 1.40-3
- Spec file cleanup.
* Tue Nov 22 2005 Simon Bellwood <simonb@thoughtpolice.co.uk> - 1.40-2
- Spec file cleanup.
* Sat Nov 12 2005 Simon Bellwood <simonb@thoughtpolice.co.uk> - 1.40-1
- Initial build for Fedora Extras.

Loading…
Cancel
Save