commit
3a8255233b
@ -0,0 +1 @@
|
|||||||
|
2329404159e8b8315e524b9eaf1de763202c6e6a SOURCES/fcgi-2.4.0.tar.gz
|
@ -0,0 +1 @@
|
|||||||
|
SOURCES/fcgi-2.4.0.tar.gz
|
@ -0,0 +1,36 @@
|
|||||||
|
diff -ru fcgi-2.4.0-orig/cgi-fcgi/Makefile.am fcgi-2.4.0/cgi-fcgi/Makefile.am
|
||||||
|
--- fcgi-2.4.0-orig/cgi-fcgi/Makefile.am 2007-03-05 18:09:31.000000000 +0100
|
||||||
|
+++ fcgi-2.4.0/cgi-fcgi/Makefile.am 2007-03-05 19:38:14.000000000 +0100
|
||||||
|
@@ -2,7 +2,7 @@
|
||||||
|
bin_PROGRAMS = cgi-fcgi
|
||||||
|
|
||||||
|
INCLUDEDIR = ../include
|
||||||
|
-CPPFLAGS = @CPPFLAGS@ -I$(top_srcdir)/include
|
||||||
|
+AM_CPPFLAGS = @CPPFLAGS@ -I$(top_srcdir)/include
|
||||||
|
|
||||||
|
INCLUDE_FILES = $(INCLUDEDIR)/fastcgi.h \
|
||||||
|
$(INCLUDEDIR)/fcgiapp.h \
|
||||||
|
diff -ru fcgi-2.4.0-orig/examples/Makefile.am fcgi-2.4.0/examples/Makefile.am
|
||||||
|
--- fcgi-2.4.0-orig/examples/Makefile.am 2007-03-05 18:09:31.000000000 +0100
|
||||||
|
+++ fcgi-2.4.0/examples/Makefile.am 2007-03-05 19:38:34.000000000 +0100
|
||||||
|
@@ -11,7 +11,7 @@
|
||||||
|
EXTRA_PROGRAMS = threaded echo-cpp
|
||||||
|
|
||||||
|
INCLUDEDIR = ../include
|
||||||
|
-CPPFLAGS = @CPPFLAGS@ -I$(top_srcdir)/include
|
||||||
|
+AM_CPPFLAGS = @CPPFLAGS@ -I$(top_srcdir)/include
|
||||||
|
|
||||||
|
INCLUDE_FILES = $(INCLUDEDIR)/fastcgi.h \
|
||||||
|
$(INCLUDEDIR)/fcgiapp.h \
|
||||||
|
diff -ru fcgi-2.4.0-orig/libfcgi/Makefile.am fcgi-2.4.0/libfcgi/Makefile.am
|
||||||
|
--- fcgi-2.4.0-orig/libfcgi/Makefile.am 2007-03-05 18:09:31.000000000 +0100
|
||||||
|
+++ fcgi-2.4.0/libfcgi/Makefile.am 2007-03-05 19:38:03.000000000 +0100
|
||||||
|
@@ -1,7 +1,7 @@
|
||||||
|
# $Id: fcgi-2.4.0-Makefile.am-CPPFLAGS.patch,v 1.1 2007/06/28 23:15:26 till Exp $
|
||||||
|
|
||||||
|
INCLUDEDIR = ../include
|
||||||
|
-CPPFLAGS = @CPPFLAGS@ -I$(top_srcdir)/include
|
||||||
|
+AM_CPPFLAGS = @CPPFLAGS@ -I$(top_srcdir)/include
|
||||||
|
|
||||||
|
INCLUDE_FILES = $(INCLUDEDIR)/fastcgi.h \
|
||||||
|
$(INCLUDEDIR)/fcgiapp.h \
|
File diff suppressed because it is too large
Load Diff
@ -0,0 +1,19 @@
|
|||||||
|
diff -ru fcgi-2.4.0-orig/configure.in fcgi-2.4.0/configure.in
|
||||||
|
--- fcgi-2.4.0-orig/configure.in 2003-01-19 18:19:41.000000000 +0100
|
||||||
|
+++ fcgi-2.4.0/configure.in 2007-03-05 20:48:14.000000000 +0100
|
||||||
|
@@ -4,11 +4,13 @@
|
||||||
|
dnl generate the file "configure", which is run during the build
|
||||||
|
dnl to configure the system for the local environment.
|
||||||
|
|
||||||
|
-AC_INIT
|
||||||
|
-AM_INIT_AUTOMAKE(fcgi, 2.4.0)
|
||||||
|
+AC_INIT(fcgi, 2.4.0)
|
||||||
|
+AM_INIT_AUTOMAKE(1.9 foreign)
|
||||||
|
|
||||||
|
AM_CONFIG_HEADER(fcgi_config.h)
|
||||||
|
|
||||||
|
+AM_MAINTAINER_MODE
|
||||||
|
+
|
||||||
|
AC_PROG_CC
|
||||||
|
AC_PROG_CPP
|
||||||
|
AC_PROG_INSTALL
|
@ -0,0 +1,11 @@
|
|||||||
|
diff -up fcgi-2.4.0/libfcgi/fcgio.cpp.gcc44_fixes fcgi-2.4.0/libfcgi/fcgio.cpp
|
||||||
|
--- fcgi-2.4.0/libfcgi/fcgio.cpp.gcc44_fixes 2002-02-24 21:12:22.000000000 +0100
|
||||||
|
+++ fcgi-2.4.0/libfcgi/fcgio.cpp 2009-02-15 11:35:18.000000000 +0100
|
||||||
|
@@ -23,6 +23,7 @@
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#include <limits.h>
|
||||||
|
+#include <cstdio>
|
||||||
|
#include "fcgio.h"
|
||||||
|
|
||||||
|
using std::streambuf;
|
@ -0,0 +1,86 @@
|
|||||||
|
Author: Anton Kortunov <toshic.toshic@gmail.com>
|
||||||
|
Bug-Ubuntu: https://bugs.launchpad.net/ubuntu/+source/libfcgi/+bug/933417
|
||||||
|
Description: use poll in os_unix.c instead of select to avoid problem with > 1024 connections
|
||||||
|
Forwarded: yes, fastcgi-developers@mailman.fastcgi.com
|
||||||
|
|
||||||
|
diff --git a/libfcgi/os_unix.c b/libfcgi/os_unix.c
|
||||||
|
index 73e6a7f..af35aee 100755
|
||||||
|
--- a/libfcgi/os_unix.c
|
||||||
|
+++ b/libfcgi/os_unix.c
|
||||||
|
@@ -42,6 +42,7 @@ static const char rcsid[] = "$Id: os_unix.c,v 1.37 2002/03/05 19:14:49 robs Exp
|
||||||
|
#include <sys/time.h>
|
||||||
|
#include <sys/un.h>
|
||||||
|
#include <signal.h>
|
||||||
|
+#include <poll.h>
|
||||||
|
|
||||||
|
#ifdef HAVE_NETDB_H
|
||||||
|
#include <netdb.h>
|
||||||
|
@@ -103,6 +104,9 @@ static int volatile maxFd = -1;
|
||||||
|
static int shutdownPending = FALSE;
|
||||||
|
static int shutdownNow = FALSE;
|
||||||
|
|
||||||
|
+static int libfcgiOsClosePollTimeout = 2000;
|
||||||
|
+static int libfcgiIsAfUnixKeeperPollTimeout = 2000;
|
||||||
|
+
|
||||||
|
void OS_ShutdownPending()
|
||||||
|
{
|
||||||
|
shutdownPending = TRUE;
|
||||||
|
@@ -168,6 +172,16 @@ int OS_LibInit(int stdioFds[3])
|
||||||
|
if(libInitialized)
|
||||||
|
return 0;
|
||||||
|
|
||||||
|
+ char *libfcgiOsClosePollTimeoutStr = getenv( "LIBFCGI_OS_CLOSE_POLL_TIMEOUT" );
|
||||||
|
+ if(libfcgiOsClosePollTimeoutStr) {
|
||||||
|
+ libfcgiOsClosePollTimeout = atoi(libfcgiOsClosePollTimeoutStr);
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ char *libfcgiIsAfUnixKeeperPollTimeoutStr = getenv( "LIBFCGI_IS_AF_UNIX_KEEPER_POLL_TIMEOUT" );
|
||||||
|
+ if(libfcgiIsAfUnixKeeperPollTimeoutStr) {
|
||||||
|
+ libfcgiIsAfUnixKeeperPollTimeout = atoi(libfcgiIsAfUnixKeeperPollTimeoutStr);
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
asyncIoTable = (AioInfo *)malloc(asyncIoTableSize * sizeof(AioInfo));
|
||||||
|
if(asyncIoTable == NULL) {
|
||||||
|
errno = ENOMEM;
|
||||||
|
@@ -755,19 +769,16 @@ int OS_Close(int fd)
|
||||||
|
|
||||||
|
if (shutdown(fd, 1) == 0)
|
||||||
|
{
|
||||||
|
- struct timeval tv;
|
||||||
|
- fd_set rfds;
|
||||||
|
+ struct pollfd pfd;
|
||||||
|
int rv;
|
||||||
|
char trash[1024];
|
||||||
|
|
||||||
|
- FD_ZERO(&rfds);
|
||||||
|
+ pfd.fd = fd;
|
||||||
|
+ pfd.events = POLLIN;
|
||||||
|
|
||||||
|
do
|
||||||
|
{
|
||||||
|
- FD_SET(fd, &rfds);
|
||||||
|
- tv.tv_sec = 2;
|
||||||
|
- tv.tv_usec = 0;
|
||||||
|
- rv = select(fd + 1, &rfds, NULL, NULL, &tv);
|
||||||
|
+ rv = poll(&pfd, 1, libfcgiOsClosePollTimeout);
|
||||||
|
}
|
||||||
|
while (rv > 0 && read(fd, trash, sizeof(trash)) > 0);
|
||||||
|
}
|
||||||
|
@@ -1116,13 +1127,11 @@ static int is_reasonable_accept_errno (const int error)
|
||||||
|
*/
|
||||||
|
static int is_af_unix_keeper(const int fd)
|
||||||
|
{
|
||||||
|
- struct timeval tval = { READABLE_UNIX_FD_DROP_DEAD_TIMEVAL };
|
||||||
|
- fd_set read_fds;
|
||||||
|
-
|
||||||
|
- FD_ZERO(&read_fds);
|
||||||
|
- FD_SET(fd, &read_fds);
|
||||||
|
+ struct pollfd pfd;
|
||||||
|
+ pfd.fd = fd;
|
||||||
|
+ pfd.events = POLLIN;
|
||||||
|
|
||||||
|
- return select(fd + 1, &read_fds, NULL, NULL, &tval) >= 0 && FD_ISSET(fd, &read_fds);
|
||||||
|
+ return poll(&pfd, 1, libfcgiIsAfUnixKeeperPollTimeout) >= 0 && (pfd.revents & POLLIN);
|
||||||
|
}
|
||||||
|
|
||||||
|
/*
|
@ -0,0 +1,6 @@
|
|||||||
|
#!/bin/sh
|
||||||
|
libtoolize --automake --copy --force
|
||||||
|
aclocal-1.9
|
||||||
|
autoheader
|
||||||
|
automake-1.9 --add-missing --force-missing --copy
|
||||||
|
autoconf
|
@ -0,0 +1,205 @@
|
|||||||
|
%global _hardened_build 1
|
||||||
|
|
||||||
|
Name: fcgi
|
||||||
|
Version: 2.4.0
|
||||||
|
Release: 36%{?dist}
|
||||||
|
Summary: FastCGI development kit
|
||||||
|
|
||||||
|
License: OML
|
||||||
|
URL: http://www.fastcgi.com/#TheDevKit
|
||||||
|
Source0: http://fastcgi.com/dist/fcgi-%{version}.tar.gz
|
||||||
|
Source1: fcgi-autogen.sh
|
||||||
|
Patch0: fcgi-2.4.0-autotools.patch
|
||||||
|
# Patch0 created with Source1 after patching Patch1 and Patch2
|
||||||
|
Patch1: fcgi-2.4.0-configure.in.patch
|
||||||
|
Patch2: fcgi-2.4.0-Makefile.am-CPPFLAGS.patch
|
||||||
|
Patch3: fcgi-2.4.0-gcc44_fixes.patch
|
||||||
|
# CVE-2012-6687
|
||||||
|
Patch4: fcgi-2.4.0-poll.patch
|
||||||
|
BuildRequires: gcc
|
||||||
|
BuildRequires: gcc-c++
|
||||||
|
|
||||||
|
%description
|
||||||
|
FastCGI is a language independent, scalable, open extension to CGI that
|
||||||
|
provides high performance without the limitations of server specific APIs.
|
||||||
|
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development files for %{name}
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
The %{name}-devel package contains libraries and header files for
|
||||||
|
developing applications that use %{name}.
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
%patch3 -p1 -b .gcc44_fixes
|
||||||
|
%patch4 -p1 -b .poll
|
||||||
|
|
||||||
|
# remove DOS End Of Line Encoding
|
||||||
|
sed -i 's/\r//' doc/fastcgi-prog-guide/ch2c.htm
|
||||||
|
# fix file permissions
|
||||||
|
chmod a-x include/fcgios.h libfcgi/os_unix.c
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure
|
||||||
|
# does not build with parallel make flags
|
||||||
|
make
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
mkdir $RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
make install DESTDIR=$RPM_BUILD_ROOT
|
||||||
|
rm $RPM_BUILD_ROOT/%{_libdir}/libfcgi{++,}.{l,}a
|
||||||
|
install -p -m 0644 -D doc/cgi-fcgi.1 $RPM_BUILD_ROOT%{_mandir}/man1/cgi-fcgi.1
|
||||||
|
for manpage in doc/*.3
|
||||||
|
do
|
||||||
|
install -p -m 0644 -D $manpage $RPM_BUILD_ROOT%{_mandir}/man3/$(basename $manpage)
|
||||||
|
done
|
||||||
|
rm -f -- doc/*.1
|
||||||
|
rm -f -- doc/*.3
|
||||||
|
|
||||||
|
|
||||||
|
%ldconfig_scriptlets
|
||||||
|
|
||||||
|
|
||||||
|
%files
|
||||||
|
%{_bindir}/cgi-fcgi
|
||||||
|
%{_libdir}/libfcgi.so.*
|
||||||
|
%{_libdir}/libfcgi++.so.*
|
||||||
|
%{_mandir}/man1/*
|
||||||
|
%defattr(0644,root,root,0755)
|
||||||
|
%license LICENSE.TERMS
|
||||||
|
%doc LICENSE.TERMS
|
||||||
|
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%{_includedir}/*
|
||||||
|
%{_libdir}/libfcgi.so
|
||||||
|
%{_libdir}/libfcgi++.so
|
||||||
|
%{_mandir}/man3/*
|
||||||
|
%defattr(0644,root,root,0755)
|
||||||
|
%doc doc/
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sat Apr 06 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 2.4.0-36
|
||||||
|
- Rebuilt for MSVSphere 8.9
|
||||||
|
|
||||||
|
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.0-36
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.0-35
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.0-34
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.0-33
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.0-32
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.0-31
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.0-30
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.0-29
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-28
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 2.4.0-27
|
||||||
|
- Rebuilt for GCC 5 C++11 ABI change
|
||||||
|
|
||||||
|
* Fri Feb 06 2015 Till Maas <opensource@till.name> - 2.4.0-26
|
||||||
|
- Use %%license
|
||||||
|
|
||||||
|
* Fri Feb 06 2015 Till Maas <opensource@till.name> - 2.4.0-25
|
||||||
|
- Fix crash when too many connections are used (CVE-2012-6687)
|
||||||
|
- Make gcc build dependencies obvious for local builds
|
||||||
|
|
||||||
|
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-24
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-23
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Feb 03 2014 Till Maas <opensource@till.name> - 2.4.0-22
|
||||||
|
- Harden build
|
||||||
|
|
||||||
|
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-21
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-20
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-19
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-18
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Sep 09 2011 Iain Arnell <iarnell@gmail.com> 2.4.0-17
|
||||||
|
- drop perl sub-package; it's been replaced by perl-FCGI (rhbz#736612)
|
||||||
|
|
||||||
|
* Thu Jun 16 2011 Marcela Mašláňová <mmaslano@redhat.com> - 2.4.0-16
|
||||||
|
- Perl mass rebuild & clean spec & clean Makefile.PL
|
||||||
|
|
||||||
|
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-15
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jun 01 2010 Marcela Maslanova <mmaslano@redhat.com> - 2.4.0-14
|
||||||
|
- Mass rebuild with perl-5.12.0
|
||||||
|
|
||||||
|
* Sun May 16 2010 Till Maas <opensource@till.name> - 2.4.0-13
|
||||||
|
- Fix license tag. It's OML instead of BSD
|
||||||
|
|
||||||
|
* Mon Jan 18 2010 Chris Weyl <cweyl@alumni.drew.edu> - 2.4.0-12
|
||||||
|
- drop perl .so provides filtering, as it may have multiarch rpm implications
|
||||||
|
|
||||||
|
* Fri Dec 4 2009 Stepan Kasal <skasal@redhat.com> - 2.4.0-11
|
||||||
|
- rebuild against perl 5.10.1
|
||||||
|
|
||||||
|
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-10
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Mar 01 2009 Chris Weyl <cweyl@alumni.drew.edu> - 2.4.0-9
|
||||||
|
- Stripping bad provides of private Perl extension libs
|
||||||
|
|
||||||
|
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-8
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Feb 15 2009 Till Maas <opensource@till.name> - 2.4.0-7
|
||||||
|
- Add missing #include <cstdio> to make it compile with gcc 4.4
|
||||||
|
|
||||||
|
* Tue Oct 14 2008 Chris Weyl <cweyl@alumni.drew.edu> - 2.4.0-6
|
||||||
|
- package up the perl bindings in their own subpackage
|
||||||
|
|
||||||
|
* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.4.0-5
|
||||||
|
- Autorebuild for GCC 4.3
|
||||||
|
|
||||||
|
* Thu Aug 23 2007 Till Maas <opensource till name> - 2.4.0-4
|
||||||
|
- bump release for rebuild
|
||||||
|
|
||||||
|
* Wed Jul 11 2007 Till Maas <opensource till name> - 2.4.0-3
|
||||||
|
- remove parallel make flags
|
||||||
|
|
||||||
|
* Tue Apr 17 2007 Till Maas <opensource till name> - 2.4.0-2
|
||||||
|
- add some documentation
|
||||||
|
- add mkdir ${RPM_BUILD_ROOT} to %%install
|
||||||
|
- install man-pages
|
||||||
|
|
||||||
|
* Mon Mar 5 2007 Till Maas <opensource till name> - 2.4.0-1
|
||||||
|
- Initial spec for fedora
|
Loading…
Reference in new issue