- Rebase init patch, drop jail.d and notmp patch applied upstreami9ce
parent
51345ece57
commit
a1783e1929
@ -1,20 +0,0 @@
|
||||
--- fail2ban-0.8.3/files/redhat-initd.init 2008-03-10 23:36:22.000000000 +0100
|
||||
+++ fail2ban-0.8.3/files/redhat-initd 2008-08-24 20:46:01.000000000 +0200
|
||||
@@ -1,6 +1,6 @@
|
||||
#!/bin/bash
|
||||
#
|
||||
-# chkconfig: 345 92 08
|
||||
+# chkconfig: - 92 08
|
||||
# description: Fail2ban daemon
|
||||
# http://fail2ban.sourceforge.net/wiki/index.php/Main_Page
|
||||
# process name: fail2ban-server
|
||||
@@ -27,8 +27,7 @@
|
||||
echo -n $"Starting fail2ban: "
|
||||
getpid
|
||||
if [ -z "$pid" ]; then
|
||||
- rm -rf /var/run/fail2ban/fail2ban.sock # in case of unclean shutdown
|
||||
- $FAIL2BAN start > /dev/null
|
||||
+ $FAIL2BAN -x start > /dev/null
|
||||
RETVAL=$?
|
||||
fi
|
||||
if [ $RETVAL -eq 0 ]; then
|
@ -0,0 +1,11 @@
|
||||
diff -up fail2ban-0.9-1f1a561/files/redhat-initd.init fail2ban-0.9-1f1a561/files/redhat-initd
|
||||
--- fail2ban-0.9-1f1a561/files/redhat-initd.init 2013-09-24 16:57:09.515712728 -0600
|
||||
+++ fail2ban-0.9-1f1a561/files/redhat-initd 2013-09-24 16:57:52.435590284 -0600
|
||||
@@ -1,6 +1,6 @@
|
||||
#!/bin/bash
|
||||
#
|
||||
-# chkconfig: 345 92 08
|
||||
+# chkconfig: - 92 08
|
||||
# processname: fail2ban-server
|
||||
# config: /etc/fail2ban/fail2ban.conf
|
||||
# pidfile: /var/run/fail2ban/fail2ban.pid
|
@ -1,14 +0,0 @@
|
||||
diff --git a/setup.py b/setup.py
|
||||
index b61ecce..27ad17b 100755
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -66,6 +66,9 @@ setup(
|
||||
('/etc/fail2ban/action.d',
|
||||
glob("config/action.d/*.conf")
|
||||
),
|
||||
+ ('/etc/fail2ban/jail.d',
|
||||
+ ''
|
||||
+ ),
|
||||
('/var/run/fail2ban',
|
||||
''
|
||||
),
|
@ -1,12 +0,0 @@
|
||||
diff -up fail2ban-0.9-d529151/fail2ban/client/fail2banreader.py.notmp fail2ban-0.9-d529151/fail2ban/client/fail2banreader.py
|
||||
--- fail2ban-0.9-d529151/fail2ban/client/fail2banreader.py.notmp 2013-07-28 03:43:54.000000000 -0600
|
||||
+++ fail2ban-0.9-d529151/fail2ban/client/fail2banreader.py 2013-08-08 20:15:19.997686089 -0600
|
||||
@@ -39,7 +39,7 @@ class Fail2banReader(ConfigReader):
|
||||
ConfigReader.read(self, "fail2ban")
|
||||
|
||||
def getEarlyOptions(self):
|
||||
- opts = [["string", "socket", "/tmp/fail2ban.sock"],
|
||||
+ opts = [["string", "socket", "/var/run/fail2ban/fail2ban.sock"],
|
||||
["string", "pidfile", "/var/run/fail2ban/fail2ban.pid"]]
|
||||
return ConfigReader.getOptions(self, "Definition", opts)
|
||||
|
Loading…
Reference in new issue