Added yandex support(fix)

i9 changed/i9/evolution-data-server-3.40.4-6.el9.inferit.2
Alexey Berezhok 2 years ago
parent f899fc08f5
commit 2661b39541

@ -4,8 +4,6 @@ Date: Mon, 15 May 2023 19:07:27 +0300
Subject: [PATCH] Added yandex backend support(prebuild) Subject: [PATCH] Added yandex backend support(prebuild)
--- ---
.gitignore | 1 +
.vscode/c_cpp_properties.json | 3 +-
CMakeLists.txt | 11 + CMakeLists.txt | 11 +
config.h.in | 6 + config.h.in | 6 +
...gnome.evolution-data-server.gschema.xml.in | 10 + ...gnome.evolution-data-server.gschema.xml.in | 10 +
@ -38,29 +36,6 @@ Subject: [PATCH] Added yandex backend support(prebuild)
create mode 100644 src/modules/yandex-backend/CMakeLists.txt create mode 100644 src/modules/yandex-backend/CMakeLists.txt
create mode 100644 src/modules/yandex-backend/module-yandex-backend.c create mode 100644 src/modules/yandex-backend/module-yandex-backend.c
diff --git a/.gitignore b/.gitignore
index 726890e..575a9f0 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@ _build
.build
*.orig
*.rej
+.vscode/
diff --git a/.vscode/c_cpp_properties.json b/.vscode/c_cpp_properties.json
index a070080..6cc85df 100644
--- a/.vscode/c_cpp_properties.json
+++ b/.vscode/c_cpp_properties.json
@@ -6,7 +6,8 @@
"${workspaceFolder}/**",
"/usr/include/goa-1.0",
"/usr/include/glib-2.0",
- "/usr/lib64/glib-2.0/include/"
+ "/usr/lib64/glib-2.0/include/",
+ "/usr/include/libsoup-2.4"
],
"defines": [],
"compilerPath": "/usr/bin/gcc",
diff --git a/CMakeLists.txt b/CMakeLists.txt diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2bad65e..d7deb4a 100644 index 2bad65e..d7deb4a 100644
--- a/CMakeLists.txt --- a/CMakeLists.txt

@ -54,7 +54,7 @@
Name: evolution-data-server Name: evolution-data-server
Version: 3.40.4 Version: 3.40.4
Release: 6%{?dist}.inferit.1 Release: 6%{?dist}.inferit.2
Summary: Backend data server for Evolution Summary: Backend data server for Evolution
License: LGPLv2+ License: LGPLv2+
URL: https://wiki.gnome.org/Apps/Evolution URL: https://wiki.gnome.org/Apps/Evolution
@ -411,6 +411,7 @@ find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
%{modules_dir}/module-trust-prompt.so %{modules_dir}/module-trust-prompt.so
%{modules_dir}/module-webdav-backend.so %{modules_dir}/module-webdav-backend.so
%{modules_dir}/module-yahoo-backend.so %{modules_dir}/module-yahoo-backend.so
%{modules_dir}/module-yandex-backend.so
%files devel %files devel
%{_includedir}/evolution-data-server %{_includedir}/evolution-data-server
@ -481,8 +482,8 @@ find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
%{_datadir}/installed-tests %{_datadir}/installed-tests
%changelog %changelog
* Tue May 23 2023 Alexey Berezhok <alexey.berezhok@msvsphere.ru> - 3.40.4-6.inferit.1 * Tue May 23 2023 Alexey Berezhok <alexey.berezhok@msvsphere.ru> - 3.40.4-6.inferit.2
- Added fix for pesign-client for db unlocking - Added yandex provider support
* Wed Mar 15 2023 MSVSphere Packaging Team <packager@msvsphere.ru> - 3.40.4-6 * Wed Mar 15 2023 MSVSphere Packaging Team <packager@msvsphere.ru> - 3.40.4-6
- Rebuilt for MSVSphere 9.1. - Rebuilt for MSVSphere 9.1.

Loading…
Cancel
Save