parent
eb422b682e
commit
2ff7c61710
@ -0,0 +1,86 @@
|
|||||||
|
From 8fc4e2ed8cad8f6d63b77e667c2e954e47a88bc2 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Sergey Cherevko <s.cherevko@msvsphere-os.ru>
|
||||||
|
Date: Mon, 9 Oct 2023 17:21:02 +0300
|
||||||
|
Subject: [PATCH] Added MSVSphere support
|
||||||
|
|
||||||
|
---
|
||||||
|
CommonInstall/util_init.pl | 2 ++
|
||||||
|
MakeTools/funcs-ext.sh | 1 +
|
||||||
|
OpenIb_Host/build_packages.sh | 2 +-
|
||||||
|
OpenIb_Host/get_id_and_versionid.sh | 1 +
|
||||||
|
build_package.sh | 2 +-
|
||||||
|
5 files changed, 6 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/CommonInstall/util_init.pl b/CommonInstall/util_init.pl
|
||||||
|
index 452b93d..d3f5a4a 100755
|
||||||
|
--- a/CommonInstall/util_init.pl
|
||||||
|
+++ b/CommonInstall/util_init.pl
|
||||||
|
@@ -246,6 +246,7 @@ sub determine_os_version()
|
||||||
|
"centos" => "redhat",
|
||||||
|
"rocky" => "redhat",
|
||||||
|
"almalinux" => "redhat",
|
||||||
|
+ "msvsphere" => "redhat",
|
||||||
|
"circle" => "redhat",
|
||||||
|
"oracle" => "redhat",
|
||||||
|
"opencloudos" => "opencloudos",
|
||||||
|
@@ -258,6 +259,7 @@ sub determine_os_version()
|
||||||
|
"centos" => $NETWORK_CONF_DIR,
|
||||||
|
"rocky" => $NETWORK_CONF_DIR,
|
||||||
|
"almalinux" => $NETWORK_CONF_DIR,
|
||||||
|
+ "msvsphere" => $NETWORK_CONF_DIR,
|
||||||
|
"circle" => $NETWORK_CONF_DIR,
|
||||||
|
"oracle" => $NETWORK_CONF_DIR,
|
||||||
|
"opencloudos" => $NETWORK_CONF_DIR,
|
||||||
|
diff --git a/MakeTools/funcs-ext.sh b/MakeTools/funcs-ext.sh
|
||||||
|
index c97531e..b51ceea 100755
|
||||||
|
--- a/MakeTools/funcs-ext.sh
|
||||||
|
+++ b/MakeTools/funcs-ext.sh
|
||||||
|
@@ -738,6 +738,7 @@ function os_vendor()
|
||||||
|
[fedora]="redhat"
|
||||||
|
[rocky]="redhat"
|
||||||
|
[almalinux]="redhat"
|
||||||
|
+ [msvsphere]="redhat"
|
||||||
|
[circle]="redhat"
|
||||||
|
[ol]="redhat"
|
||||||
|
[opencloudos]="opencloudos"
|
||||||
|
diff --git a/OpenIb_Host/build_packages.sh b/OpenIb_Host/build_packages.sh
|
||||||
|
index b8cd62c..7a11acd 100755
|
||||||
|
--- a/OpenIb_Host/build_packages.sh
|
||||||
|
+++ b/OpenIb_Host/build_packages.sh
|
||||||
|
@@ -42,7 +42,7 @@ echo "Packages version [$pkgversion] release [$pkgrelease], args [$BUILD_ARGS]"
|
||||||
|
build_deb="no"
|
||||||
|
spec_mpi="UNDEFINED"
|
||||||
|
spec_ff="UNDEFINED"
|
||||||
|
-if [ "$id" = "rhel" -o "$id" = "centos" -o "$id" = "rocky" -o "$id" = "almalinux" -o "$id" = "circle" -o "$id" = "ol" ]; then
|
||||||
|
+if [ "$id" = "rhel" -o "$id" = "centos" -o "$id" = "rocky" -o "$id" = "almalinux" -o "$id" = "msvsphere" -o "$id" = "circle" -o "$id" = "ol" ]; then
|
||||||
|
GE_8_0=$(echo "$versionid >= 8.0" | bc)
|
||||||
|
if [ $GE_8_0 = 1 ]; then
|
||||||
|
spec_mpi="mpi-apps.spec.rh8+"
|
||||||
|
diff --git a/OpenIb_Host/get_id_and_versionid.sh b/OpenIb_Host/get_id_and_versionid.sh
|
||||||
|
index 36f5500..41b4ee9 100755
|
||||||
|
--- a/OpenIb_Host/get_id_and_versionid.sh
|
||||||
|
+++ b/OpenIb_Host/get_id_and_versionid.sh
|
||||||
|
@@ -13,6 +13,7 @@ declare -A vendor_map=(
|
||||||
|
[centos]="rhel"
|
||||||
|
[rocky]="rhel"
|
||||||
|
[almalinux]="rhel"
|
||||||
|
+ [msvsphere]="rhel"
|
||||||
|
[circle]="rhel"
|
||||||
|
[ol]="ol"
|
||||||
|
[opencloudos]="ocs"
|
||||||
|
diff --git a/build_package.sh b/build_package.sh
|
||||||
|
index 58beffe..4bd6c18 100755
|
||||||
|
--- a/build_package.sh
|
||||||
|
+++ b/build_package.sh
|
||||||
|
@@ -3,7 +3,7 @@
|
||||||
|
read id versionid <<< $(OpenIb_Host/get_id_and_versionid.sh)
|
||||||
|
|
||||||
|
case $id in
|
||||||
|
- rhel|centos|rocky|almalinux|circle|ol)
|
||||||
|
+ rhel|centos|rocky|almalinux|msvsphere|circle|ol)
|
||||||
|
spec_ff="OpenIb_Host/eth-tools.spec.rh" ;;
|
||||||
|
fedora)
|
||||||
|
spec_ff="OpenIb_Host/eth-tools.spec.fedora" ;;
|
||||||
|
--
|
||||||
|
2.41.0
|
||||||
|
|
Loading…
Reference in new issue