Build with fix on dpkg (#1923609) and (#1714442)

epel9
Sérgio M. Basto 4 years ago
parent b3ebe3a5ef
commit 0598391bf4

@ -1,25 +0,0 @@
https://lists.debian.org/debian-dpkg/2017/07/msg00040.html
The problem is that your compiler gives a different triplet than the
one used by dpkg itself.
--- ./t/buildsystems/04-dh_auto_do_autoconf.t.orig 2018-09-21 19:49:13.357781723 +0100
+++ ./t/buildsystems/04-dh_auto_do_autoconf.t 2018-09-21 20:03:14.744324612 +0100
@@ -2,7 +2,7 @@
use strict;
use warnings;
-use Test::More tests => 31;
+use Test::More tests => 29;
use File::Temp qw(tempdir);
use File::Basename qw(dirname);
@@ -52,7 +52,7 @@ sub dh_auto_do_autoconf {
@lines = @{readlines(\*FILE)};
close(FILE);
}
- is_deeply( \@lines, \@extra_args, "$buildpath/stamp_configure contains extra args" );
+ # is_deeply( \@lines, \@extra_args, "$buildpath/stamp_configure contains extra args" );
&$do_dh_auto('build');
ok ( -f "$buildpath/stamp_build", "$buildpath/stamp_build exists" );

@ -8,7 +8,7 @@
Name: debhelper Name: debhelper
Version: 12.7.3 Version: 12.7.3
Release: 7%{?dist} Release: 8%{?dist}
Summary: Helper programs for debian/rules Summary: Helper programs for debian/rules
License: GPLv2+ License: GPLv2+
@ -16,7 +16,6 @@ URL: https://tracker.debian.org/pkg/debhelper
Source0: http://ftp.debian.org/debian/pool/main/d/%{name}/%{name}_%{version}.tar.xz Source0: http://ftp.debian.org/debian/pool/main/d/%{name}/%{name}_%{version}.tar.xz
Patch1: debhelper-10.2.5-ignore-dh-systemd-transitional-package.patch Patch1: debhelper-10.2.5-ignore-dh-systemd-transitional-package.patch
Patch2: no_layout_deb.patch Patch2: no_layout_deb.patch
Patch3: debhelper-skip_archtest.patch
BuildArch: noarch BuildArch: noarch
BuildRequires: gcc BuildRequires: gcc
@ -125,7 +124,6 @@ cc -dumpmachine
%setup -q -n %{name} %setup -q -n %{name}
%patch1 -p1 -b .no-transitional-package %patch1 -p1 -b .no-transitional-package
%patch2 -p1 -b .no-debian-layout %patch2 -p1 -b .no-debian-layout
%patch3 -p1 -b .skip-arm-fail-test
%build %build
%make_build build %make_build build
@ -168,6 +166,9 @@ make test
%{perl_vendorlib}/* %{perl_vendorlib}/*
%changelog %changelog
* Mon Feb 15 2021 Sérgio Basto <sergio@serjux.com> - 12.7.3-8
- Build with fix on dpkg (#1923609) and (#1714442)
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 12.7.3-7 * Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 12.7.3-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild

Loading…
Cancel
Save