import compiler-rt-16.0.6-3.module+el8.9.0+20599+53352ad4

i8c-stream-rhel8 changed/i8c-stream-rhel8/compiler-rt-16.0.6-3.module+el8.9.0+20599+53352ad4
MSVSphere Packaging Team 1 year ago
parent 75e42e19eb
commit 0e54e2fb8b

@ -0,0 +1,36 @@
From ce15f52198639e9195b8833ed60dc1a49c293956 Mon Sep 17 00:00:00 2001
From: Tom Stellard <tstellar@redhat.com>
Date: Tue, 29 Aug 2023 15:49:55 -0700
Subject: [PATCH] compiler-rt: Fix FLOAT16 feature detection
CMAKE_TRY_COMPILE_TARGET_TYPE defaults to EXECUTABLE, which causes
any feature detection code snippet without a main function to fail,
so we need to make sure it gets explicitly set to STATIC_LIBRARY.
---
compiler-rt/lib/builtins/CMakeLists.txt | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/compiler-rt/lib/builtins/CMakeLists.txt b/compiler-rt/lib/builtins/CMakeLists.txt
index 2fc70522895f..e83a1ecea50b 100644
--- a/compiler-rt/lib/builtins/CMakeLists.txt
+++ b/compiler-rt/lib/builtins/CMakeLists.txt
@@ -12,7 +12,6 @@ if (CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
"at least 3.20.0 now to avoid issues in the future!")
endif()
- set(CMAKE_TRY_COMPILE_TARGET_TYPE STATIC_LIBRARY)
project(CompilerRTBuiltins C ASM)
set(COMPILER_RT_STANDALONE_BUILD TRUE)
set(COMPILER_RT_BUILTINS_STANDALONE_BUILD TRUE)
@@ -56,6 +55,8 @@ if (COMPILER_RT_STANDALONE_BUILD)
"Turns on or off -fPIC for the builtin library source"
ON)
endif()
+
+set(CMAKE_TRY_COMPILE_TARGET_TYPE STATIC_LIBRARY)
include(builtin-config-ix)
include(CMakePushCheckState)
--
2.40.1

@ -14,7 +14,7 @@
Name: compiler-rt Name: compiler-rt
Version: %{compiler_rt_version}%{?rc_ver:~rc%{rc_ver}} Version: %{compiler_rt_version}%{?rc_ver:~rc%{rc_ver}}
Release: 1%{?dist} Release: 3%{?dist}
Summary: LLVM "compiler-rt" runtime libraries Summary: LLVM "compiler-rt" runtime libraries
License: NCSA or MIT License: NCSA or MIT
@ -28,9 +28,9 @@ Source4: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{compil
# RHEL-specific patches # RHEL-specific patches
Patch100: 0001-Drop-fno-stack-protector-from-the-compiler-flags.patch Patch100: 0001-Drop-fno-stack-protector-from-the-compiler-flags.patch
Patch101: fix-page-size-constant.patch Patch101: fix-page-size-constant.patch
Patch102: 0001-compiler-rt-Fix-FLOAT16-feature-detection.patch
BuildRequires: gcc BuildRequires: clang
BuildRequires: gcc-c++
BuildRequires: cmake BuildRequires: cmake
BuildRequires: ninja-build BuildRequires: ninja-build
BuildRequires: python3 BuildRequires: python3
@ -72,6 +72,8 @@ cd %{_vpath_builddir}
-DCMAKE_BUILD_TYPE=RelWithDebInfo \ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_MODULE_PATH=%{_libdir}/cmake/llvm \ -DCMAKE_MODULE_PATH=%{_libdir}/cmake/llvm \
-DCMAKE_SKIP_RPATH:BOOL=ON \ -DCMAKE_SKIP_RPATH:BOOL=ON \
-DCMAKE_C_COMPILER=clang \
-DCMAKE_CXX_COMPILER=clang++ \
\ \
%if 0%{?__isa_bits} == 64 %if 0%{?__isa_bits} == 64
-DLLVM_LIBDIR_SUFFIX=64 \ -DLLVM_LIBDIR_SUFFIX=64 \
@ -131,9 +133,15 @@ popd
%endif %endif
%changelog %changelog
* Sun Dec 10 2023 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 16.0.6-1 * Sun Dec 10 2023 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 16.0.6-3
- Rebuilt for MSVSphere 8.8 - Rebuilt for MSVSphere 8.8
* Fri Oct 13 2023 Nikita Popov <npopov@redhat.com> - 16.0.6-3
- Build with clang
* Tue Aug 29 2023 Tom Stellard <tstellar@redhat.com> - 16.0.6-2
- Fix FLOAT16 detection
* Fri Jun 23 2023 Tom Stellard <tstellar@redhat.com> - 16.0.6-1 * Fri Jun 23 2023 Tom Stellard <tstellar@redhat.com> - 16.0.6-1
- 16.0.6 Release - 16.0.6 Release

Loading…
Cancel
Save