commit
b36981c511
@ -0,0 +1 @@
|
|||||||
|
3b25f861990ea9372b2a7e1aa35389a982189b31 SOURCES/colm-0.14.7.tar.gz
|
@ -0,0 +1 @@
|
|||||||
|
SOURCES/colm-0.14.7.tar.gz
|
@ -0,0 +1,23 @@
|
|||||||
|
From 28b6e0a01157049b4cb279b0ef25ea9dcf3b46ed Mon Sep 17 00:00:00 2001
|
||||||
|
From: Adrian Thurston <thurston@colm.net>
|
||||||
|
Date: Sun, 12 Mar 2023 13:17:42 -0700
|
||||||
|
Subject: [PATCH] include an extern C function in libfsm so we can use
|
||||||
|
AC_CHECK_LIB
|
||||||
|
|
||||||
|
---
|
||||||
|
src/libfsm/codegen.cc | 2 ++
|
||||||
|
1 file changed, 2 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/src/libfsm/codegen.cc b/src/libfsm/codegen.cc
|
||||||
|
index 21edb5ac..1150384e 100644
|
||||||
|
--- a/src/libfsm/codegen.cc
|
||||||
|
+++ b/src/libfsm/codegen.cc
|
||||||
|
@@ -30,6 +30,8 @@
|
||||||
|
#include <assert.h>
|
||||||
|
#include <iomanip>
|
||||||
|
|
||||||
|
+// Convenience: for checking for the presence of the libfsm.
|
||||||
|
+extern "C" void libfsm_present() {}
|
||||||
|
|
||||||
|
using std::ostream;
|
||||||
|
using std::ostringstream;
|
@ -0,0 +1,45 @@
|
|||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index aa127b68..fc034f28 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -45,6 +45,7 @@ AC_PROG_CXX
|
||||||
|
AC_CHECK_TOOL(AR, ar)
|
||||||
|
AC_PROG_RANLIB
|
||||||
|
AC_PROG_LIBTOOL
|
||||||
|
+
|
||||||
|
SED_SUBST=["\
|
||||||
|
-e 's|@CXX@|${CXX}|g' \
|
||||||
|
-e 's|@CC@|${CC}|g' \
|
||||||
|
@@ -420,6 +421,13 @@ test -e src/include/colm || ln -s .. src/include/colm
|
||||||
|
echo "#define VERSION \"$VERSION\"" > src/version.h
|
||||||
|
echo "#define PUBDATE \"$PUBDATE\"" >> src/version.h
|
||||||
|
|
||||||
|
+if test "x$enable_static" = "xyes"; then
|
||||||
|
+ AC_DEFINE([LINK_STATIC], [1], [Link static lib when invoking C compile and link])
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
+if test "x$enable_shared" = "xyes"; then
|
||||||
|
+ AC_DEFINE([LINK_SHARED], [1], [Link shared lib when invoking C compile and link])
|
||||||
|
+fi
|
||||||
|
|
||||||
|
dnl
|
||||||
|
dnl Wrap up.
|
||||||
|
diff --git a/src/main.cc b/src/main.cc
|
||||||
|
index 301fae91..8ca395f0 100644
|
||||||
|
--- a/src/main.cc
|
||||||
|
+++ b/src/main.cc
|
||||||
|
@@ -485,7 +485,14 @@ void compileOutput( const char *argv0, const bool inSource, char *srcLocation )
|
||||||
|
" -I%s/../aapl"
|
||||||
|
" -I%s/include"
|
||||||
|
" -L%s"
|
||||||
|
+#if defined(LINK_STATIC)
|
||||||
|
" %s/libcolm.a",
|
||||||
|
+#elif defined(LINK_SHARED)
|
||||||
|
+ " %s/libcolm.so",
|
||||||
|
+#else
|
||||||
|
+# error "must enabled at least one of shared or static libs"
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
binaryFn, intermedFn, srcLocation,
|
||||||
|
srcLocation, location, location );
|
||||||
|
}
|
@ -0,0 +1,141 @@
|
|||||||
|
Name: colm
|
||||||
|
Version: 0.14.7
|
||||||
|
Release: 3%{?dist}
|
||||||
|
Summary: Programming language designed for the analysis of computer languages
|
||||||
|
|
||||||
|
# aapl/ and some headers from src/ are the LGPLv2+
|
||||||
|
License: MIT and LGPLv2+
|
||||||
|
URL: https://www.colm.net/open-source/colm/
|
||||||
|
Source0: https://www.colm.net/files/%{name}/%{name}-%{version}.tar.gz
|
||||||
|
Patch0: fc61ecb3a22b89864916ec538eaf04840e7dd6b5.diff
|
||||||
|
# backport commit that allows AC_CHECK_LIB to detect libfsm
|
||||||
|
Patch1: https://github.com/adrian-thurston/colm/commit/28b6e0a01157049b4cb279b0ef25ea9dcf3b46ed.patch#/%{name}-libfsm-ac_check_lib.diff
|
||||||
|
BuildRequires: gcc
|
||||||
|
BuildRequires: gcc-c++
|
||||||
|
BuildRequires: autoconf
|
||||||
|
BuildRequires: automake
|
||||||
|
BuildRequires: libtool
|
||||||
|
BuildRequires: make
|
||||||
|
BuildRequires: asciidoc
|
||||||
|
|
||||||
|
# Unfortunately, upstream doesn't exist and not possible to find version
|
||||||
|
Provides: bundled(aapl)
|
||||||
|
|
||||||
|
%description
|
||||||
|
Colm is a programming language designed for the analysis and transformation
|
||||||
|
of computer languages. Colm is influenced primarily by TXL. It is
|
||||||
|
in the family of program transformation languages.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development libraries and header files for %{name}
|
||||||
|
Requires: %{name}%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -p1
|
||||||
|
# Do not pollute with docs
|
||||||
|
sed -i -e "/dist_doc_DATA/d" Makefile.am
|
||||||
|
|
||||||
|
%build
|
||||||
|
autoreconf -vfi
|
||||||
|
%configure --disable-static
|
||||||
|
%make_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%make_install
|
||||||
|
find %{buildroot}%{_libdir} -type f -name '*.la' -print -delete
|
||||||
|
install -p -m 0644 -D %{name}.vim %{buildroot}%{_datadir}/vim/vimfiles/syntax/%{name}.vim
|
||||||
|
|
||||||
|
%ldconfig_scriptlets
|
||||||
|
|
||||||
|
%files
|
||||||
|
%license COPYING
|
||||||
|
%doc README
|
||||||
|
%{_bindir}/%{name}*
|
||||||
|
%{_libdir}/lib%{name}-%{version}.so
|
||||||
|
%dir %{_datadir}/vim
|
||||||
|
%dir %{_datadir}/vim/vimfiles
|
||||||
|
%dir %{_datadir}/vim/vimfiles/syntax
|
||||||
|
%{_datadir}/vim/vimfiles/syntax/%{name}.vim
|
||||||
|
%{_datadir}/doc/%{name}/*
|
||||||
|
%{_datadir}/*.lm
|
||||||
|
%{_datadir}/runtests
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%{_libdir}/lib%{name}.so
|
||||||
|
%{_libdir}/libfsm*
|
||||||
|
%{_includedir}/%{name}/
|
||||||
|
%{_includedir}/libfsm*
|
||||||
|
%{_includedir}/aapl*
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed Dec 25 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.14.7-3
|
||||||
|
- Rebuilt for MSVSphere 10
|
||||||
|
|
||||||
|
* Wed Jul 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.14.7-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon May 08 2023 Michel Alexandre Salim <salimma@fedoraproject.org> - 0.14.7-2
|
||||||
|
- Backport commit that allows AC_CHECK_LIB to detect libfsm
|
||||||
|
|
||||||
|
* Tue Apr 25 2023 Filipe Rosset <rosset.filipe@gmail.com> - 0.14.7-1
|
||||||
|
- Update to 0.14.7 fixes rhbz#1825150
|
||||||
|
|
||||||
|
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.0.7-8
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.0.7-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jan 19 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.0.7-6
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 21 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.0.7-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.0.7-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.0.7-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.0.7-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Jul 28 2019 Christian Glombek <lorbus@fedoraproject.org> - 0.13.0.7-1
|
||||||
|
- Updated to version 0.13.0.7
|
||||||
|
|
||||||
|
* Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.0.6-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.0.6-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.0.6-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jul 06 2018 Christian Glombek <lorbus@fedoraproject.org> - 0.13.0.6-1
|
||||||
|
- Updated to version 0.13.0.6
|
||||||
|
|
||||||
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.0.5-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Dec 10 2017 Jason Taylor <jtfas90@gmail.com> - 0.13.0.5-1
|
||||||
|
- Upstream bugfix release
|
||||||
|
- Correction to spec license add MIT license
|
||||||
|
- Added asciidoc BuildRequires and docdir files
|
||||||
|
|
||||||
|
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.0.4-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.0.4-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.0.4-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Dec 01 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.13.0.4-1
|
||||||
|
- Initial package
|
Loading…
Reference in new issue