import cockpit-323-1.el9

i9.5-beta changed/i9.5-beta/cockpit-323-1.el9.inferit
Arkady L. Shane 2 months ago
parent a6241bce01
commit 0b8a72ac65
Signed by: tigro
GPG Key ID: 1EC08A25C9DB2503

@ -1 +1 @@
c24d50c29aef687b03f60888cbfd983040c195d7 SOURCES/cockpit-311.2.tar.xz
01e638f2a8958f1caef65d36d66de764037f8f40 SOURCES/cockpit-323.tar.xz

2
.gitignore vendored

@ -1 +1 @@
SOURCES/cockpit-311.2.tar.xz
SOURCES/cockpit-323.tar.xz

@ -1,8 +1,7 @@
From 383c67ef13d6a7060b3ed249804f0948e667510f Mon Sep 17 00:00:00 2001
From b940ed8871dbf30313622cc4aa163e467e742fb9 Mon Sep 17 00:00:00 2001
From: tigro <tigro@msvsphere-os.ru>
Date: Tue, 2 Apr 2024 16:50:30 +0300
Date: Thu, 17 Oct 2024 12:57:35 +0300
Subject: [PATCH] Added support GOST and PAM-GOST profiles for crypto-policies
in the UI interface
---
pkg/systemd/overview-cards/cryptoPolicies.jsx | 7 +++++
@ -10,7 +9,7 @@ Subject: [PATCH] Added support GOST and PAM-GOST profiles for crypto-policies
2 files changed, 35 insertions(+)
diff --git a/pkg/systemd/overview-cards/cryptoPolicies.jsx b/pkg/systemd/overview-cards/cryptoPolicies.jsx
index 4da83868b..acbfaef3f 100644
index dc8b996ec..c8766348c 100644
--- a/pkg/systemd/overview-cards/cryptoPolicies.jsx
+++ b/pkg/systemd/overview-cards/cryptoPolicies.jsx
@@ -121,6 +121,13 @@ const CryptoPolicyDialog = ({
@ -28,12 +27,12 @@ index 4da83868b..acbfaef3f 100644
const policies = Object.keys(cryptopolicies)
diff --git a/po/ru.po b/po/ru.po
index df7e755b5..2ceb4d063 100644
index 95c4c9c52..0684e36e8 100644
--- a/po/ru.po
+++ b/po/ru.po
@@ -2438,6 +2438,34 @@ msgstr "Настраиваемые зоны"
@@ -2329,6 +2329,34 @@ msgstr "Настраиваемые зоны"
msgid "DEFAULT with SHA-1 signature verification allowed."
msgstr ""
msgstr "DEFAULT с разрешённой проверкой подписи SHA-1."
+#: pkg/systemd/overview-cards/cryptoPolicies.jsx:124
+msgid "DEFAULT with GOST algorithms enabled."
@ -67,5 +66,5 @@ index df7e755b5..2ceb4d063 100644
msgid "DNS"
msgstr "DNS"
--
2.44.0
2.47.0

@ -1,7 +1,7 @@
From c1e377389f4e613e9707de8ea09bd5fc9179f8d4 Mon Sep 17 00:00:00 2001
From: Eugene Zamriy <ezamriy@msvsphere-os.ru>
Date: Mon, 20 Nov 2023 21:46:51 +0300
Subject: [PATCH 3/6] Show MSVSPHERE_PRETTY_NAME instead of NAME for
From d39261b354f47b66d348f0d8b5adbbc0df0d5e68 Mon Sep 17 00:00:00 2001
From: tigro <tigro@msvsphere-os.ru>
Date: Thu, 17 Oct 2024 13:02:16 +0300
Subject: [PATCH 4/4] Show MSVSPHERE_PRETTY_NAME instead of NAME for
documentation link
---
@ -9,18 +9,18 @@ Subject: [PATCH 3/6] Show MSVSPHERE_PRETTY_NAME instead of NAME for
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/pkg/shell/topnav.jsx b/pkg/shell/topnav.jsx
index 1ad8c3dcb..e1a8e4c66 100644
index 156ff62fa..79aaf2a84 100644
--- a/pkg/shell/topnav.jsx
+++ b/pkg/shell/topnav.jsx
@@ -149,7 +149,7 @@ export class TopNav extends React.Component {
@@ -151,7 +151,7 @@ export class TopNav extends React.Component {
if (this.state.osRelease.DOCUMENTATION_URL)
docItems.push(<DropdownItem key="os-doc" href={this.state.osRelease.DOCUMENTATION_URL} target="blank" rel="noopener noreferrer" icon={<ExternalLinkAltIcon />}>
docItems.push(<DropdownItem key="os-doc" to={this.state.osRelease.DOCUMENTATION_URL} target="blank" rel="noopener noreferrer" icon={<ExternalLinkAltIcon />}>
- {cockpit.format(_("$0 documentation"), this.state.osRelease.NAME)}
+ {cockpit.format(_("$0 documentation"), this.state.osRelease.MSVSPHERE_PRETTY_NAME)}
</DropdownItem>);
// global documentation for cockpit as a whole
--
2.43.0
2.47.0

@ -1,32 +1,25 @@
From a62c5236b9b660803c98da943f2fdbca5faaf588 Mon Sep 17 00:00:00 2001
From: Eugene Zamriy <ezamriy@msvsphere-os.ru>
Date: Tue, 21 Nov 2023 00:36:55 +0300
Subject: [PATCH 5/6] Show MSVSPHERE_PRETTY_NAME instead of PRETTY_NAME in
overview
From 142ff58b85f5267c55e7ae5d77793ad1a412585d Mon Sep 17 00:00:00 2001
From: tigro <tigro@msvsphere-os.ru>
Date: Thu, 17 Oct 2024 13:11:41 +0300
Subject: [PATCH] Show MSVSPHERE_PRETTY_NAME instead of PRETTY_NAME in overview
---
pkg/systemd/overview.jsx | 13 ++++++++++---
1 file changed, 10 insertions(+), 3 deletions(-)
pkg/systemd/overview.jsx | 12 +++++++++---
1 file changed, 9 insertions(+), 3 deletions(-)
diff --git a/pkg/systemd/overview.jsx b/pkg/systemd/overview.jsx
index e780a1c5d..3527b02b6 100644
index 7ade0dc27..7ac476b94 100644
--- a/pkg/systemd/overview.jsx
+++ b/pkg/systemd/overview.jsx
@@ -28,6 +28,7 @@ import { Page, PageSection, PageSectionVariants } from "@patternfly/react-core/d
import { Gallery } from "@patternfly/react-core/dist/esm/layouts/Gallery/index.js";
import { Dropdown, DropdownItem, DropdownPosition, DropdownToggle, DropdownToggleAction } from '@patternfly/react-core/dist/esm/deprecated/components/Dropdown/index.js';
@@ -29,6 +29,7 @@ import { Gallery } from "@patternfly/react-core/dist/esm/layouts/Gallery/index.j
import { Dropdown, DropdownItem, DropdownList } from '@patternfly/react-core/dist/esm/components/Dropdown/index.js';
import { MenuToggle, MenuToggleAction } from "@patternfly/react-core/dist/esm/components/MenuToggle";
+import { read_os_release } from "os-release.js";
import { superuser } from "superuser";
import { SystemInformationCard } from './overview-cards/systemInformationCard.jsx';
@@ -53,11 +54,14 @@ class OverviewPage extends React.Component {
this.state = {
actionIsOpen: false,
privileged: true,
+ osRelease: {},
};
this.hostnameMonitor = this.hostnameMonitor.bind(this);
@@ -59,6 +60,8 @@ class OverviewPage extends React.Component {
this.onPermissionChanged = this.onPermissionChanged.bind(this);
this.superuser = cockpit.dbus(null, { bus: "internal" }).proxy("cockpit.Superuser", "/superuser");
@ -35,7 +28,7 @@ index e780a1c5d..3527b02b6 100644
}
componentDidMount() {
@@ -154,9 +158,12 @@ class OverviewPage extends React.Component {
@@ -164,9 +167,12 @@ class OverviewPage extends React.Component {
<h1>
{this.hostname_text()}
</h1>
@ -52,5 +45,5 @@ index e780a1c5d..3527b02b6 100644
<div className='ct-overview-header-actions'>
{ show_superuser && <SuperuserIndicator proxy={this.superuser} /> }
--
2.43.0
2.47.0

@ -1,39 +1,39 @@
From a0a076d4b2b5770c35c63fff4e5ed80abd5fade9 Mon Sep 17 00:00:00 2001
From: Eugene Zamriy <ezamriy@msvsphere-os.ru>
Date: Tue, 21 Nov 2023 00:48:25 +0300
Subject: [PATCH 6/6] Disable upstream documentation links
From 912ee633e6320b5cfa5a346899f29721be7d08cb Mon Sep 17 00:00:00 2001
From: tigro <tigro@msvsphere-os.ru>
Date: Thu, 17 Oct 2024 13:13:06 +0300
Subject: [PATCH] Disable upstream documentation links
---
pkg/shell/topnav.jsx | 16 ----------------
1 file changed, 16 deletions(-)
diff --git a/pkg/shell/topnav.jsx b/pkg/shell/topnav.jsx
index e1a8e4c66..111563118 100644
index 79aaf2a84..4559d1ed8 100644
--- a/pkg/shell/topnav.jsx
+++ b/pkg/shell/topnav.jsx
@@ -152,22 +152,6 @@ export class TopNav extends React.Component {
@@ -154,22 +154,6 @@ export class TopNav extends React.Component {
{cockpit.format(_("$0 documentation"), this.state.osRelease.MSVSPHERE_PRETTY_NAME)}
</DropdownItem>);
- // global documentation for cockpit as a whole
- (cockpit.manifests.shell?.docs ?? []).forEach(doc => {
- docItems.push(<DropdownItem key={doc.label} href={doc.url} target="blank" rel="noopener noreferrer" icon={<ExternalLinkAltIcon />}>
- docItems.push(<DropdownItem key={doc.label} to={doc.url} target="blank" rel="noopener noreferrer" icon={<ExternalLinkAltIcon />}>
- {doc.label}
- </DropdownItem>);
- });
-
- if (docs.length > 0)
- docItems.push(<DropdownSeparator key="separator" />);
- docItems.push(<Divider key="separator" />);
-
- docs.forEach(e => {
- docItems.push(<DropdownItem key={e.label} href={e.url} target="blank" rel="noopener noreferrer" icon={<ExternalLinkAltIcon />}>
- docItems.push(<DropdownItem key={e.label} to={e.url} target="blank" rel="noopener noreferrer" icon={<ExternalLinkAltIcon />}>
- {_(e.label)}
- </DropdownItem>);
- });
-
docItems.push(<DropdownSeparator key="separator1" />);
docItems.push(<Divider key="separator1" />);
docItems.push(<DropdownItem key="about" component="button"
onClick={() => Dialogs.show(<AboutCockpitModal />)}>
onClick={() => Dialogs.run(AboutCockpitModal, {})}>
--
2.43.0
2.47.0

@ -12,7 +12,7 @@
# Lesser General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with Cockpit; If not, see <http://www.gnu.org/licenses/>.
# along with Cockpit; If not, see <https://www.gnu.org/licenses/>.
#
# This file is maintained at the following location:
@ -49,33 +49,42 @@ Summary: Web Console for Linux servers
License: LGPL-2.1-or-later
URL: https://cockpit-project.org/
Version: 311.2
Version: 323
Release: 1%{?dist}.inferit
# We need to patch official source (000* patches in SOURCE) and
# repack tarball to recompile javascript.
# Use script cockpit-inferit-patch.sh <version> to create
# tarball
Source0: cockpit-%{version}.tar.xz
Source1: cockpit-inferit-patch.sh
Source0: cockpit-%{version}.tar.xz
Source1: cockpit-inferit-patch.sh
# Do not apply these patches
Patch0: 0001-Adds-MSVSphere-branding-directory.patch
Patch1: 0002-Show-MSVSPHERE_PRETTY_NAME-instead-of-NAME-on-login-.patch
Patch2: 0003-Show-MSVSPHERE_PRETTY_NAME-instead-of-NAME-for-docum.patch
Patch3: 0004-Include-pkg-shell-module-translations-in-other-modul.patch
Patch4: 0005-Show-MSVSPHERE_PRETTY_NAME-instead-of-PRETTY_NAME-in.patch
Patch5: 0006-Disable-upstream-documentation-links.patch
Patch6: 0001-Added-support-GOST-and-PAM-GOST-profiles-for-crypto-.patch
Patch7: 0007-Update-Russian-translation.patch
Patch9: 0009-Change-chpasswd-to-passwd-to-support-PAM-crypto-algo.patch
# pcp stopped building on ix86
Patch0: 0001-Adds-MSVSphere-branding-directory.patch
Patch1: 0002-Show-MSVSPHERE_PRETTY_NAME-instead-of-NAME-on-login-.patch
Patch2: 0003-Show-MSVSPHERE_PRETTY_NAME-instead-of-NAME-for-docum.patch
Patch3: 0004-Include-pkg-shell-module-translations-in-other-modul.patch
Patch4: 0005-Show-MSVSPHERE_PRETTY_NAME-instead-of-PRETTY_NAME-in.patch
Patch5: 0006-Disable-upstream-documentation-links.patch
Patch6: 0001-Added-support-GOST-and-PAM-GOST-profiles-for-crypto-.patch
Patch7: 0007-Update-Russian-translation.patch
Patch9: 0009-Change-chpasswd-to-passwd-to-support-PAM-crypto-algo.patch
%if 0%{?fedora} >= 41 || 0%{?rhel}
ExcludeArch: %{ix86}
%endif
# pcp stopped building on ix86 in Fedora 40+, and broke hard on 39: https://bugzilla.redhat.com/show_bug.cgi?id=2284431
%define build_pcp 1
%if 0%{?fedora} >= 40 || 0%{?rhel} >= 10
%if 0%{?fedora} >= 39 || 0%{?rhel} >= 10
%ifarch %ix86
%define build_pcp 0
%endif
%endif
%define enable_multihost 1
%if 0%{?fedora} >= 41 || 0%{?rhel} >= 10
%define enable_multihost 0
%endif
# Ship custom SELinux policy
%define selinuxtype targeted
%define selinux_configure_arg --enable-selinux-policy=%{selinuxtype}
@ -153,7 +162,7 @@ Requires: subscription-manager-cockpit
BuildRequires: python3-devel
BuildRequires: python3-pip
%if 0%{?rhel} == 0
%if 0%{?rhel} == 0 && !0%{?suse_version}
# All of these are only required for running pytest (which we only do on Fedora)
BuildRequires: procps-ng
BuildRequires: pyproject-rpm-macros
@ -169,8 +178,6 @@ BuildRequires: python3-tox-current-env
%build
%configure \
%{?selinux_configure_arg} \
--with-cockpit-user=cockpit-ws \
--with-cockpit-ws-instance-user=cockpit-wsinstance \
%if 0%{?suse_version}
--docdir=%_defaultdocdir/%{name} \
%endif
@ -178,6 +185,9 @@ BuildRequires: python3-tox-current-env
%if %{build_pcp} == 0
--disable-pcp \
%endif
%if %{enable_multihost}
--enable-multihost \
%endif
%make_build
@ -345,11 +355,11 @@ Provides: cockpit-users = %{version}-%{release}
Obsoletes: cockpit-dashboard < %{version}-%{release}
%if 0%{?rhel}
Requires: NetworkManager >= 1.6
Requires: kexec-tools
Requires: sos
Requires: sudo
Recommends: PackageKit
Recommends: setroubleshoot-server >= 3.3.3
Recommends: /usr/bin/kdumpctl
Suggests: NetworkManager-team
Provides: cockpit-kdump = %{version}-%{release}
Provides: cockpit-networkmanager = %{version}-%{release}
@ -360,55 +370,20 @@ Provides: cockpit-sosreport = %{version}-%{release}
Recommends: (reportd if abrt)
%endif
Provides: bundled(npm(@patternfly/patternfly)) = 5.1.0
Provides: bundled(npm(@patternfly/react-core)) = 5.1.2
Provides: bundled(npm(@patternfly/react-icons)) = 5.1.2
Provides: bundled(npm(@patternfly/react-styles)) = 5.1.2
Provides: bundled(npm(@patternfly/react-table)) = 5.1.2
Provides: bundled(npm(@patternfly/react-tokens)) = 5.1.2
Provides: bundled(npm(@patternfly/patternfly)) = 5.3.1
Provides: bundled(npm(@patternfly/react-core)) = 5.3.4
Provides: bundled(npm(@patternfly/react-icons)) = 5.3.2
Provides: bundled(npm(@patternfly/react-styles)) = 5.3.1
Provides: bundled(npm(@patternfly/react-table)) = 5.3.4
Provides: bundled(npm(@patternfly/react-tokens)) = 5.3.1
Provides: bundled(npm(@xterm/addon-canvas)) = 0.7.0
Provides: bundled(npm(@xterm/xterm)) = 5.5.0
Provides: bundled(npm(argparse)) = 1.0.10
Provides: bundled(npm(array-buffer-byte-length)) = 1.0.1
Provides: bundled(npm(attr-accept)) = 2.2.2
Provides: bundled(npm(autolinker)) = 3.16.2
Provides: bundled(npm(available-typed-arrays)) = 1.0.6
Provides: bundled(npm(call-bind)) = 1.0.7
Provides: bundled(npm(date-fns)) = 3.3.1
Provides: bundled(npm(deep-equal)) = 2.2.3
Provides: bundled(npm(define-data-property)) = 1.1.4
Provides: bundled(npm(define-properties)) = 1.2.1
Provides: bundled(npm(es-define-property)) = 1.0.0
Provides: bundled(npm(es-errors)) = 1.3.0
Provides: bundled(npm(es-get-iterator)) = 1.1.3
Provides: bundled(npm(dequal)) = 2.0.3
Provides: bundled(npm(file-selector)) = 0.6.0
Provides: bundled(npm(focus-trap)) = 7.5.2
Provides: bundled(npm(for-each)) = 0.3.3
Provides: bundled(npm(function-bind)) = 1.1.2
Provides: bundled(npm(functions-have-names)) = 1.2.3
Provides: bundled(npm(get-intrinsic)) = 1.2.4
Provides: bundled(npm(gopd)) = 1.0.1
Provides: bundled(npm(has-bigints)) = 1.0.2
Provides: bundled(npm(has-property-descriptors)) = 1.0.2
Provides: bundled(npm(has-proto)) = 1.0.1
Provides: bundled(npm(has-symbols)) = 1.0.3
Provides: bundled(npm(has-tostringtag)) = 1.0.2
Provides: bundled(npm(hasown)) = 2.0.1
Provides: bundled(npm(internal-slot)) = 1.0.7
Provides: bundled(npm(is-arguments)) = 1.1.1
Provides: bundled(npm(is-array-buffer)) = 3.0.4
Provides: bundled(npm(is-bigint)) = 1.0.4
Provides: bundled(npm(is-boolean-object)) = 1.1.2
Provides: bundled(npm(is-callable)) = 1.2.7
Provides: bundled(npm(is-date-object)) = 1.0.5
Provides: bundled(npm(is-map)) = 2.0.2
Provides: bundled(npm(is-number-object)) = 1.0.7
Provides: bundled(npm(is-regex)) = 1.1.4
Provides: bundled(npm(is-set)) = 2.0.2
Provides: bundled(npm(is-shared-array-buffer)) = 1.0.2
Provides: bundled(npm(is-string)) = 1.0.7
Provides: bundled(npm(is-symbol)) = 1.0.4
Provides: bundled(npm(is-weakmap)) = 2.0.1
Provides: bundled(npm(is-weakset)) = 2.0.2
Provides: bundled(npm(isarray)) = 2.0.5
Provides: bundled(npm(js-sha1)) = 0.7.0
Provides: bundled(npm(js-sha256)) = 0.11.0
Provides: bundled(npm(js-tokens)) = 4.0.0
@ -416,32 +391,18 @@ Provides: bundled(npm(json-stable-stringify-without-jsonify)) = 1.0.1
Provides: bundled(npm(lodash)) = 4.17.21
Provides: bundled(npm(loose-envify)) = 1.4.0
Provides: bundled(npm(object-assign)) = 4.1.1
Provides: bundled(npm(object-inspect)) = 1.13.1
Provides: bundled(npm(object-is)) = 1.1.5
Provides: bundled(npm(object-keys)) = 1.1.1
Provides: bundled(npm(object.assign)) = 4.1.5
Provides: bundled(npm(prop-types)) = 15.8.1
Provides: bundled(npm(react-dom)) = 18.2.0
Provides: bundled(npm(react-dom)) = 18.3.1
Provides: bundled(npm(react-dropzone)) = 14.2.3
Provides: bundled(npm(react-is)) = 16.13.1
Provides: bundled(npm(react)) = 18.2.0
Provides: bundled(npm(regexp.prototype.flags)) = 1.5.2
Provides: bundled(npm(react)) = 18.3.1
Provides: bundled(npm(remarkable)) = 2.0.1
Provides: bundled(npm(scheduler)) = 0.23.0
Provides: bundled(npm(set-function-length)) = 1.2.1
Provides: bundled(npm(set-function-name)) = 2.0.1
Provides: bundled(npm(side-channel)) = 1.0.5
Provides: bundled(npm(scheduler)) = 0.23.2
Provides: bundled(npm(sprintf-js)) = 1.0.3
Provides: bundled(npm(stop-iteration-iterator)) = 1.0.0
Provides: bundled(npm(tabbable)) = 6.2.0
Provides: bundled(npm(throttle-debounce)) = 5.0.0
Provides: bundled(npm(tslib)) = 2.6.2
Provides: bundled(npm(uuid)) = 9.0.1
Provides: bundled(npm(which-boxed-primitive)) = 1.0.2
Provides: bundled(npm(which-collection)) = 1.0.1
Provides: bundled(npm(which-typed-array)) = 1.1.14
Provides: bundled(npm(xterm-addon-canvas)) = 0.5.0
Provides: bundled(npm(xterm)) = 5.3.0
Provides: bundled(npm(throttle-debounce)) = 5.0.2
Provides: bundled(npm(tslib)) = 2.6.3
Provides: bundled(npm(uuid)) = 10.0.0
%description system
This package contains the Cockpit shell and system configuration interfaces.
@ -491,6 +452,7 @@ authentication via sssd/FreeIPA.
%{_unitdir}/cockpit.service
%{_unitdir}/cockpit-motd.service
%{_unitdir}/cockpit.socket
%{_unitdir}/cockpit-ws-user.service
%{_unitdir}/cockpit-wsinstance-http.socket
%{_unitdir}/cockpit-wsinstance-http.service
%{_unitdir}/cockpit-wsinstance-https-factory.socket
@ -498,7 +460,8 @@ authentication via sssd/FreeIPA.
%{_unitdir}/cockpit-wsinstance-https@.socket
%{_unitdir}/cockpit-wsinstance-https@.service
%{_unitdir}/system-cockpithttps.slice
%{_prefix}/%{__lib}/tmpfiles.d/cockpit-tempfiles.conf
%{_prefix}/%{__lib}/tmpfiles.d/cockpit-ws.conf
%{_sysusersdir}/cockpit-wsinstance.conf
%{pamdir}/pam_ssh_add.so
%{pamdir}/pam_cockpit_cert.so
%{_libexecdir}/cockpit-ws
@ -517,8 +480,8 @@ authentication via sssd/FreeIPA.
%ghost %{_sharedstatedir}/selinux/%{selinuxtype}/active/modules/200/%{name}
%pre ws
getent group cockpit-ws >/dev/null || groupadd -r cockpit-ws
getent passwd cockpit-ws >/dev/null || useradd -r -g cockpit-ws -d /nonexisting -s /sbin/nologin -c "User for cockpit web service" cockpit-ws
# HACK: old RPM and even Fedora's current RPM don't properly support sysusers
# https://github.com/rpm-software-management/rpm/issues/3073
getent group cockpit-wsinstance >/dev/null || groupadd -r cockpit-wsinstance
getent passwd cockpit-wsinstance >/dev/null || useradd -r -g cockpit-wsinstance -d /nonexisting -s /sbin/nologin -c "User for cockpit-ws instances" cockpit-wsinstance
@ -543,7 +506,7 @@ if [ "$1" = 1 ]; then
chmod 644 /etc/cockpit/disallowed-users
fi
%tmpfiles_create cockpit-tempfiles.conf
%tmpfiles_create cockpit-ws.conf
%systemd_post cockpit.socket cockpit.service
# firewalld only partially picks up changes to its services files without this
test -f %{_bindir}/firewall-cmd && firewall-cmd --reload --quiet || true
@ -575,7 +538,7 @@ fi
Summary: Cockpit user interface for kernel crash dumping
Requires: cockpit-bridge >= %{required_base}
Requires: cockpit-shell >= %{required_base}
Requires: kexec-tools
Requires: /usr/bin/kdumpctl
BuildArch: noarch
%description kdump
@ -711,11 +674,7 @@ via PackageKit.
# The changelog is automatically generated and merged
%changelog
* Tue Apr 02 2024 Martin Pitt <mpitt@redhat.com> - 311.2-1
- sosreport: Fix command injection with crafted report names [CVE-2024-2947]
(jira#RHEL-31074)
* Mon Apr 1 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 311.1-1.inferit.1
* Thu Oct 17 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 323-1.inferit
- Change chpasswd to passwd to support PAM crypto algorithms
- Update Russian translation
- Added support GOST and PAM-GOST profiles for crypto-policies in the UI interface
@ -725,40 +684,61 @@ via PackageKit.
- Fix sudo button translation issue
- Remove upstream documentation links from UI
* Tue Feb 20 2024 Packit <hello@packit.dev> - 311.1-1
- Update documentation links to RHEL 9 (RHEL-3954)
- Storage: Various bug fixes
* Wed Feb 14 2024 Packit <hello@packit.dev> - 311-1
- Bug fixes and stability improvements
* Tue Aug 20 2024 Packit <hello@packit.dev> - 323-1
- metrics: Install valkey instead of redis on RHEL/CentOS 10
- login: Prevent multiple logins in a single browser session
- Update documentation links
* Wed Feb 07 2024 Packit <hello@packit.dev> - 310.2-1
- selinux: Cover migration to /run
- ws: Handle HEAD requests correctly, for curl 8.6.0
* Thu Aug 08 2024 Packit <hello@packit.dev> - 322-1
- shell: Deprecate host switcher
* Fri Feb 02 2024 Packit <hello@packit.dev> - 310.1-1
- bridge: Fix race condition/crash in file watching channels
* Wed Jul 17 2024 Fedora Release Engineering <releng@fedoraproject.org> - 321-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
* Wed Jan 31 2024 Packit <hello@packit.dev> - 310-1
- Storage: support for btrfs
- Storage: improved support for swap
* Wed Jul 10 2024 Packit <hello@packit.dev> - 321-1
- Bug fixes and performance improvements
* Wed Jan 24 2024 Fedora Release Engineering <releng@fedoraproject.org> - 309-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Wed Jul 03 2024 Packit <hello@packit.dev> - 320-1
- pam-ssh-add: Fix insecure killing of session ssh-agent [CVE-2024-6126]
- sosreport: Read report directory from sos config (fix page on Debian/Ubuntu)
* Fri Jan 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 309-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Wed Jun 26 2024 Packit <hello@packit.dev> - 319-1
- List btrfs snapshots in subvolume detail view
* Thu Jan 18 2024 Packit <hello@packit.dev> - 309-1
- Storage: Introduce btrfs support
* Mon Jun 17 2024 Martin Pitt <mpitt@redhat.com> - 318-2
- Rebuilt for Python 3.13
* Wed Jan 03 2024 Packit <hello@packit.dev> - 308-1
- Fix connecting to remote hosts with OpenSSH 0.9.6
* Wed Jun 12 2024 Packit <hello@packit.dev> - 318-1
- Storage: Extra confirmation before deleting non-empty partitions in Anaconda's Web UI
- Discontinue Intel 32-bit support in Fedora, CentOS, and RHEL
- cockpit.js: Get user primary group ID
* Sun Jun 09 2024 Python Maint <python-maint@redhat.com> - 317-2
- Rebuilt for Python 3.13
* Wed May 29 2024 Packit <hello@packit.dev> - 317-1
- webserver: System user changes
- metrics: Prefer valkey over redis on Fedora
* Thu Apr 25 2024 Packit <hello@packit.dev> - 316-1
- cockpit.js API: Fix format_bytes() units
* Mon Dec 18 2023 Martin Pitt <mpitt@redhat.com> - 300.4-1.inferit
- client: Provide fallback for GLib.get_user_state_dir() (RHEL-18989)
- bridge: Add back menu/tool names to cockpit-bridge --packages (RHEL-19004)
- bridge: Add back support for x.min.js files (RHEL-19005)
* Wed Apr 10 2024 Packit <hello@packit.dev> - 315-1
- systemd: Check proper ssh service unit on Debian/Ubuntu
- Translation updates
* Thu Mar 28 2024 Packit <hello@packit.dev> - 314-1
- Diagnostic reports: Fix command injection vulnerability with crafted report names
- Storage: Improvements to read-only encrypted filesystems
* Wed Mar 13 2024 Packit <hello@packit.dev> - 313-1
- assorted bug fixes and improvements
* Wed Feb 28 2024 Packit <hello@packit.dev> - 312-1
- Accounts: support lastlog2 and make the page faster
- Storage: Various Anaconda mode fixes
- Fix package build if cockpit-bridge package is installed
* Tue Feb 20 2024 Packit <hello@packit.dev> - 311.1-1
- Update documentation links to RHEL 9 (RHEL-3954)
@ -885,9 +865,6 @@ Storage: Support for RAID layouts with LVM2
- API removal: Remove cockpit.dbus.publish() and .meta()
- Development: Cockpit now supports the esbuild bundler
* Wed Mar 15 2023 MSVSphere Packaging Team <packager@msvsphere.ru> - 287-1
- Rebuilt for MSVSphere 9.1.
* Thu Mar 09 2023 Packit <hello@packit.dev> - 287-1
- Metrics: Column visiblity
- Services: Pinned units need to be re-done

Loading…
Cancel
Save