commit
1d773fa836
@ -0,0 +1 @@
|
|||||||
|
cf332727ac863cc0c86ac4f8cd3b711d05a5e417 SOURCES/cmake-3.28.3.tar.gz
|
@ -0,0 +1 @@
|
|||||||
|
SOURCES/cmake-3.28.3.tar.gz
|
@ -0,0 +1,22 @@
|
|||||||
|
Index: cmake-3.23.0-rc2/Modules/FindRuby.cmake
|
||||||
|
===================================================================
|
||||||
|
--- cmake-3.23.0-rc2.orig/Modules/FindRuby.cmake
|
||||||
|
+++ cmake-3.23.0-rc2/Modules/FindRuby.cmake
|
||||||
|
@@ -315,14 +315,9 @@ if(Ruby_EXECUTABLE AND NOT Ruby_VERSION_
|
||||||
|
_RUBY_CONFIG_VAR("sitearchdir" Ruby_SITEARCH_DIR)
|
||||||
|
_RUBY_CONFIG_VAR("sitelibdir" Ruby_SITELIB_DIR)
|
||||||
|
|
||||||
|
- # vendor_ruby available ?
|
||||||
|
- execute_process(COMMAND ${Ruby_EXECUTABLE} -r vendor-specific -e "print 'true'"
|
||||||
|
- OUTPUT_VARIABLE Ruby_HAS_VENDOR_RUBY ERROR_QUIET)
|
||||||
|
-
|
||||||
|
- if(Ruby_HAS_VENDOR_RUBY)
|
||||||
|
- _RUBY_CONFIG_VAR("vendorlibdir" Ruby_VENDORLIB_DIR)
|
||||||
|
- _RUBY_CONFIG_VAR("vendorarchdir" Ruby_VENDORARCH_DIR)
|
||||||
|
- endif()
|
||||||
|
+ # vendor_ruby
|
||||||
|
+ _RUBY_CONFIG_VAR("vendorlibdir" Ruby_VENDORLIB_DIR)
|
||||||
|
+ _RUBY_CONFIG_VAR("vendorarchdir" Ruby_VENDORARCH_DIR)
|
||||||
|
|
||||||
|
# save the results in the cache so we don't have to run ruby the next time again
|
||||||
|
set(Ruby_VERSION_MAJOR ${Ruby_VERSION_MAJOR} CACHE PATH "The Ruby major version" FORCE)
|
@ -0,0 +1,9 @@
|
|||||||
|
;;
|
||||||
|
;; Setup cmake-mode for autoloading
|
||||||
|
;;
|
||||||
|
(autoload 'cmake-mode "cmake-mode" "Major mode for editing CMake listfiles." t)
|
||||||
|
(setq auto-mode-alist
|
||||||
|
(append
|
||||||
|
'(("CMakeLists\\.txt\\'" . cmake-mode))
|
||||||
|
'(("\\.cmake\\'" . cmake-mode))
|
||||||
|
auto-mode-alist))
|
@ -0,0 +1,3 @@
|
|||||||
|
%__cmake_provides %{_rpmconfigdir}/cmake.prov
|
||||||
|
%__cmake_requires %{_rpmconfigdir}/cmake.req
|
||||||
|
%__cmake_path ^(%{_libdir}|%{_datadir})/cmake/.*/.*(Config\.cmake|-config\.cmake)$
|
@ -0,0 +1,82 @@
|
|||||||
|
#!/usr/bin/python3
|
||||||
|
# -*- coding:utf-8 -*-
|
||||||
|
#
|
||||||
|
# Copyright (C) 2015 Daniel Vrátil <dvratil@redhat.com>
|
||||||
|
# Copyright (C) 2017 Daniel Vrátil <dvratil@fedoraproject.org>
|
||||||
|
#
|
||||||
|
#
|
||||||
|
# This program is free software; you can redistribute it and/or modify
|
||||||
|
# it under the terms of the GNU Library General Public License as
|
||||||
|
# published by the Free Software Foundation; either version 2 of the
|
||||||
|
# License, or (at your option) any later version.
|
||||||
|
#
|
||||||
|
# This program is distributed in the hope that it will be useful,
|
||||||
|
# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||||
|
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||||
|
# GNU General Public License for more details.
|
||||||
|
#
|
||||||
|
# You should have received a copy of the GNU Library General Public
|
||||||
|
# License along with this program; if not, write to the
|
||||||
|
# Free Software Foundation, Inc.,
|
||||||
|
# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
|
||||||
|
#
|
||||||
|
|
||||||
|
import sys
|
||||||
|
import re
|
||||||
|
import glob
|
||||||
|
|
||||||
|
class CMakeParser:
|
||||||
|
def __init__(self, filelist = None):
|
||||||
|
if filelist == None:
|
||||||
|
filelist = sys.stdin
|
||||||
|
|
||||||
|
paths = map(lambda x: x.rstrip(), filelist.readlines())
|
||||||
|
for path in paths:
|
||||||
|
modulePath, cmakeModule, lowercase = self.parseCmakeModuleConfig(path)
|
||||||
|
if modulePath and cmakeModule:
|
||||||
|
version = self.resolveCMakeModuleVersion(modulePath, cmakeModule, lowercase)
|
||||||
|
|
||||||
|
if version:
|
||||||
|
string = "cmake(" + cmakeModule + ") = " + version
|
||||||
|
else:
|
||||||
|
string = "cmake(" + cmakeModule + ")"
|
||||||
|
if string == string.lower():
|
||||||
|
print(string)
|
||||||
|
else:
|
||||||
|
# Temporarily print both variants to satisfy requires
|
||||||
|
# by the old version of this generator which made mistakes
|
||||||
|
print(string)
|
||||||
|
print(string.lower())
|
||||||
|
|
||||||
|
|
||||||
|
def parseCmakeModuleConfig(self, configFile):
|
||||||
|
paths = configFile.rsplit("/", 3)
|
||||||
|
|
||||||
|
modulePath = "%s/cmake/%s" % (paths[0], paths[2])
|
||||||
|
cfgFile = paths[3]
|
||||||
|
if cfgFile.endswith("Config.cmake"):
|
||||||
|
return (modulePath, cfgFile[0:-len("Config.cmake")], False)
|
||||||
|
elif cfgFile.endswith("-config.cmake"):
|
||||||
|
return (modulePath, cfgFile[0:-len("-config.cmake")], True)
|
||||||
|
else:
|
||||||
|
return (None, None, False)
|
||||||
|
|
||||||
|
def resolveCMakeModuleVersion(self, modulePath, cmakeModule, lowercase):
|
||||||
|
versionFile = ("%s/%s-config-version.cmake" if lowercase else "%s/%sConfigVersion.cmake") % (modulePath, cmakeModule)
|
||||||
|
try:
|
||||||
|
f = open(versionFile, 'r')
|
||||||
|
except:
|
||||||
|
return None
|
||||||
|
|
||||||
|
for line in f:
|
||||||
|
line = line.strip()
|
||||||
|
|
||||||
|
# set(PACKAGE_VERSION <version>)
|
||||||
|
version = re.match(r"^set[\ ]*\([\ ]*PACKAGE_VERSION[\ ]+[\"]*([0-9\.]+)[\"]*[\ ]*[.]*\)", line)
|
||||||
|
if version:
|
||||||
|
return version.groups(1)[0]
|
||||||
|
|
||||||
|
return None
|
||||||
|
|
||||||
|
if __name__ == "__main__":
|
||||||
|
parser = CMakeParser()
|
@ -0,0 +1,70 @@
|
|||||||
|
#!/usr/bin/python3
|
||||||
|
# -*- coding:utf-8 -*-
|
||||||
|
#
|
||||||
|
# Copyright (C) 2017 Björn Esser <besser82@fedoraproject.org>
|
||||||
|
#
|
||||||
|
# based on cmake.prov, which is
|
||||||
|
# Copyright (C) 2015 Daniel Vrátil <dvratil@redhat.com>
|
||||||
|
# Copyright (C) 2017 Daniel Vrátil <dvratil@fedoraproject.org>
|
||||||
|
#
|
||||||
|
#
|
||||||
|
# This program is free software; you can redistribute it and/or modify
|
||||||
|
# it under the terms of the GNU Library General Public License as
|
||||||
|
# published by the Free Software Foundation; either version 2 of the
|
||||||
|
# License, or (at your option) any later version.
|
||||||
|
#
|
||||||
|
# This program is distributed in the hope that it will be useful,
|
||||||
|
# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||||
|
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||||
|
# GNU General Public License for more details.
|
||||||
|
#
|
||||||
|
# You should have received a copy of the GNU Library General Public
|
||||||
|
# License along with this program; if not, write to the
|
||||||
|
# Free Software Foundation, Inc.,
|
||||||
|
# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
|
||||||
|
#
|
||||||
|
|
||||||
|
import sys
|
||||||
|
import re
|
||||||
|
import subprocess
|
||||||
|
|
||||||
|
class CMakeParser:
|
||||||
|
def __init__(self, filelist = None):
|
||||||
|
if filelist == None:
|
||||||
|
filelist = sys.stdin
|
||||||
|
|
||||||
|
has_module = False
|
||||||
|
is_arched = False
|
||||||
|
|
||||||
|
isa_suf = subprocess.check_output(["/usr/bin/rpm", "-E %{?_isa}"]).decode().strip()
|
||||||
|
|
||||||
|
paths = map(lambda x: x.rstrip(), filelist.readlines())
|
||||||
|
for path in paths:
|
||||||
|
modulePath, cmakeModule, lowercase = self.parseCmakeModuleConfig(path)
|
||||||
|
if modulePath and cmakeModule:
|
||||||
|
has_module = True
|
||||||
|
if re.match(".*/usr/lib(64)?/cmake/.*", modulePath):
|
||||||
|
is_arched = True
|
||||||
|
|
||||||
|
if has_module:
|
||||||
|
if is_arched:
|
||||||
|
print("cmake-filesystem%s" % isa_suf)
|
||||||
|
else:
|
||||||
|
print("cmake-filesystem")
|
||||||
|
|
||||||
|
|
||||||
|
def parseCmakeModuleConfig(self, configFile):
|
||||||
|
paths = configFile.rsplit("/", 3)
|
||||||
|
|
||||||
|
modulePath = "%s/cmake/%s" % (paths[0], paths[2])
|
||||||
|
cfgFile = paths[3]
|
||||||
|
if cfgFile.endswith("Config.cmake"):
|
||||||
|
return (modulePath, cfgFile[0:-len("Config.cmake")], False)
|
||||||
|
elif cfgFile.endswith("-config.cmake"):
|
||||||
|
return (modulePath, cfgFile[0:-len("-config.cmake")], True)
|
||||||
|
else:
|
||||||
|
return (None, None, False)
|
||||||
|
|
||||||
|
|
||||||
|
if __name__ == "__main__":
|
||||||
|
parser = CMakeParser()
|
@ -0,0 +1,60 @@
|
|||||||
|
#
|
||||||
|
# Macros for cmake
|
||||||
|
#
|
||||||
|
%_cmake_lib_suffix64 -DLIB_SUFFIX=64
|
||||||
|
%_cmake_shared_libs -DBUILD_SHARED_LIBS:BOOL=ON
|
||||||
|
%_cmake_skip_rpath -DCMAKE_SKIP_RPATH:BOOL=ON
|
||||||
|
%_cmake_version @@CMAKE_VERSION@@
|
||||||
|
%__cmake /usr/bin/cmake
|
||||||
|
%__ctest /usr/bin/ctest
|
||||||
|
%__cmake_builddir %{!?__cmake_in_source_build:%{_vpath_builddir}}%{?__cmake_in_source_build:.}
|
||||||
|
|
||||||
|
|
||||||
|
# - Set default compile flags
|
||||||
|
# - CMAKE_*_FLAGS_RELEASE are added *after* the *FLAGS environment variables
|
||||||
|
# and default to -O3 -DNDEBUG. Strip the -O3 so we can override with *FLAGS
|
||||||
|
# - Turn on verbose makefiles so we can see and verify compile flags
|
||||||
|
# - Turn off stripping by default so RPM can do it separately
|
||||||
|
# - Set default install prefixes and library install directories
|
||||||
|
# - Turn on shared libraries by default
|
||||||
|
%cmake \
|
||||||
|
%{set_build_flags} \
|
||||||
|
%__cmake \\\
|
||||||
|
%{!?__cmake_in_source_build:-S "%{_vpath_srcdir}"} \\\
|
||||||
|
%{!?__cmake_in_source_build:-B "%{__cmake_builddir}"} \\\
|
||||||
|
-DCMAKE_C_FLAGS_RELEASE:STRING="-DNDEBUG" \\\
|
||||||
|
-DCMAKE_CXX_FLAGS_RELEASE:STRING="-DNDEBUG" \\\
|
||||||
|
-DCMAKE_Fortran_FLAGS_RELEASE:STRING="-DNDEBUG" \\\
|
||||||
|
-DCMAKE_VERBOSE_MAKEFILE:BOOL=ON \\\
|
||||||
|
-DCMAKE_INSTALL_DO_STRIP:BOOL=OFF \\\
|
||||||
|
-DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \\\
|
||||||
|
-DINCLUDE_INSTALL_DIR:PATH=%{_includedir} \\\
|
||||||
|
-DLIB_INSTALL_DIR:PATH=%{_libdir} \\\
|
||||||
|
-DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \\\
|
||||||
|
-DSHARE_INSTALL_PREFIX:PATH=%{_datadir} \\\
|
||||||
|
%if "%{?_lib}" == "lib64" \
|
||||||
|
%{?_cmake_lib_suffix64} \\\
|
||||||
|
%endif \
|
||||||
|
%{?_cmake_shared_libs}
|
||||||
|
|
||||||
|
%cmake_build \
|
||||||
|
%__cmake --build "%{__cmake_builddir}" %{?_smp_mflags} --verbose
|
||||||
|
|
||||||
|
%cmake_install \
|
||||||
|
DESTDIR="%{buildroot}" %__cmake --install "%{__cmake_builddir}"
|
||||||
|
|
||||||
|
%ctest(:-:h:j:u:v:A:C:D:E:F:H:I:L:M:N:O:Q:R:S:T:U:V:) \
|
||||||
|
%__ctest --test-dir "%{__cmake_builddir}" \\\
|
||||||
|
--output-on-failure \\\
|
||||||
|
--force-new-ctest-process \\\
|
||||||
|
%ifarch riscv64 \
|
||||||
|
--timeout 6000 \\\
|
||||||
|
%endif \
|
||||||
|
%{?_smp_mflags} %{**}
|
||||||
|
|
||||||
|
|
||||||
|
%cmake@@CMAKE_MAJOR_VERSION@@ %cmake
|
||||||
|
%cmake@@CMAKE_MAJOR_VERSION@@_build %cmake_build
|
||||||
|
%cmake@@CMAKE_MAJOR_VERSION@@_install %cmake_install
|
||||||
|
%ctest@@CMAKE_MAJOR_VERSION@@(:-:h:j:u:v:A:C:D:E:F:H:I:L:M:N:O:Q:R:S:T:U:V:) \
|
||||||
|
%ctest %{**}
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in new issue