- 20130812 git snapshot - fix tests - %prep: explicitly delete bundled boost,zlibf41
parent
b4add81f3f
commit
3693cab5ba
@ -1,2 +1,3 @@
|
|||||||
clucene-core-0.9.21b.tar.bz2
|
clucene-core-0.9.21b.tar.bz2
|
||||||
/clucene-core-2.3.3.4.tar.gz
|
/clucene-core-2.3.3.4.tar.gz
|
||||||
|
/clucene-core-2.3.3.4-e8e3d20.tar.xz
|
||||||
|
@ -0,0 +1,14 @@
|
|||||||
|
diff -up clucene-core-2.3.3.4/src/core/CMakeLists.txt.CLuceneConfig.cmake clucene-core-2.3.3.4/src/core/CMakeLists.txt
|
||||||
|
--- clucene-core-2.3.3.4/src/core/CMakeLists.txt.CLuceneConfig.cmake 2011-03-16 19:21:07.000000000 -0500
|
||||||
|
+++ clucene-core-2.3.3.4/src/core/CMakeLists.txt 2014-10-07 19:32:17.042894690 -0500
|
||||||
|
@@ -251,8 +251,8 @@ file(WRITE "${CMAKE_CURRENT_BINARY_DIR}/
|
||||||
|
set(CLUCENE_VERSION ${CLUCENE_VERSION})
|
||||||
|
set(CLUCENE_SOVERSION ${CLUCENE_SOVERSION})
|
||||||
|
")
|
||||||
|
-install(FILES "${CMAKE_CURRENT_BINARY_DIR}/CLuceneConfig.cmake"
|
||||||
|
- DESTINATION ${LIB_DESTINATION}/CLuceneConfig.cmake)
|
||||||
|
+#install(FILES "${CMAKE_CURRENT_BINARY_DIR}/CLuceneConfig.cmake"
|
||||||
|
+# DESTINATION ${LIB_DESTINATION}/CLuceneConfig.cmake)
|
||||||
|
|
||||||
|
# install pkg-config file
|
||||||
|
IF(NOT WIN32)
|
@ -0,0 +1,11 @@
|
|||||||
|
diff -up clucene-core-2.3.3.4/src/test/search/TestIndexSearcher.cpp.usleep clucene-core-2.3.3.4/src/test/search/TestIndexSearcher.cpp
|
||||||
|
--- clucene-core-2.3.3.4/src/test/search/TestIndexSearcher.cpp.usleep 2011-03-16 19:21:07.000000000 -0500
|
||||||
|
+++ clucene-core-2.3.3.4/src/test/search/TestIndexSearcher.cpp 2014-10-07 19:35:20.854480798 -0500
|
||||||
|
@@ -4,6 +4,7 @@
|
||||||
|
* Distributable under the terms of either the Apache License (Version 2.0) or
|
||||||
|
* the GNU Lesser General Public License, as specified in the COPYING file.
|
||||||
|
------------------------------------------------------------------------------*/
|
||||||
|
+#include <unistd.h>
|
||||||
|
#include "test.h"
|
||||||
|
|
||||||
|
DEFINE_MUTEX(searchMutex);
|
Loading…
Reference in new issue