Remove rpath in utilities

epel9
Sergio Pascual 3 years ago
parent 151f1ef875
commit 3026cf547b

@ -1,36 +0,0 @@
diff -ur cfitsio-3.47/configure cfitsio-3.47.soname/configure
--- cfitsio-3.47/configure 2019-08-01 15:59:50.735018203 +0200
+++ cfitsio-3.47.soname/configure 2019-08-01 16:04:16.277042668 +0200
@@ -2293,7 +2293,7 @@
CFITSIO_MINOR=47
# Increment soname each time the interface changes:
-CFITSIO_SONAME=8
+CFITSIO_SONAME=7
#--------------------------------------------------------------------
diff -ur cfitsio-3.47/configure.in cfitsio-3.47.soname/configure.in
--- cfitsio-3.47/configure.in 2019-05-21 21:42:37.000000000 +0200
+++ cfitsio-3.47.soname/configure.in 2019-08-01 16:03:15.723124934 +0200
@@ -17,7 +17,7 @@
AC_SUBST(CFITSIO_MAJOR,3)
AC_SUBST(CFITSIO_MINOR,47)
# Increment soname each time the interface changes:
-AC_SUBST(CFITSIO_SONAME,8)
+AC_SUBST(CFITSIO_SONAME,7)
#--------------------------------------------------------------------
# Command options
diff -ur cfitsio-3.47/fitsio.h cfitsio-3.47.soname/fitsio.h
--- cfitsio-3.47/fitsio.h 2019-05-08 17:34:50.000000000 +0200
+++ cfitsio-3.47.soname/fitsio.h 2019-08-01 16:05:22.684049113 +0200
@@ -37,7 +37,7 @@
#define CFITSIO_VERSION 3.47
#define CFITSIO_MINOR 47
#define CFITSIO_MAJOR 3
-#define CFITSIO_SONAME 8
+#define CFITSIO_SONAME 7
/* the SONAME is incremented in a new release if the binary shared */
/* library (on linux and Mac systems) is not backward compatible */

@ -0,0 +1,12 @@
diff -ur cfitsio-3.49/configure cfitsio-3.49.rpath/configure
--- cfitsio-3.49/configure 2021-08-01 10:11:12.159237384 +0200
+++ cfitsio-3.49.rpath/configure 2021-08-01 10:24:32.504218725 +0200
@@ -4673,7 +4673,7 @@
$as_echo "#define _FILE_OFFSET_BITS 64" >>confdefs.h
# LDFLAGS used by utilities:
- LDFLAGS_BIN="$LDFLAGS_BIN -Wl,-rpath,\${CFITSIO_LIB}"
+ LDFLAGS_BIN="$LDFLAGS_BIN"
;;
*mingw32*)
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for large file support" >&5

@ -1,35 +0,0 @@
diff -ur cfitsio-3.47/drvrnet.c cfitsio-3.47.sformat/drvrnet.c
--- cfitsio-3.47/drvrnet.c 2019-05-21 21:41:54.000000000 +0200
+++ cfitsio-3.47.sformat/drvrnet.c 2019-08-01 13:52:41.461958938 +0200
@@ -1257,9 +1257,9 @@
urlname = (char *)clientp;
if (urlname)
{
- fprintf(stderr,"Downloading ");
- fprintf(stderr,urlname);
- fprintf(stderr,"...\n");
+ fprintf(stderr,"%s","Downloading ");
+ fprintf(stderr,"%s",urlname);
+ fprintf(stderr,"%s","...\n");
}
isFirst = 0;
}
@@ -1270,13 +1270,13 @@
nToDisplay = fullBar;
fprintf(stderr,"%3d%% [",percent);
for (i=0; i<nToDisplay; ++i)
- fprintf(stderr,"=");
+ fprintf(stderr,"%s","=");
/* print remaining spaces */
for (i=nToDisplay; i<fullBar; ++i)
- fprintf(stderr," ");
- fprintf(stderr,"]\r");
+ fprintf(stderr,"%s"," ");
+ fprintf(stderr,"%s","]\r");
if (isComplete)
- fprintf(stderr,"\n");
+ fprintf(stderr,"%s","\n");
fflush(stderr);
}
return 0;
Sólo en cfitsio-3.47: .drvrnet.c.swp

@ -1,6 +1,6 @@
Name: cfitsio
Version: 3.490
Release: 3%{?dist}
Release: 4%{?dist}
Summary: Library for manipulating FITS data files
License: MIT
@ -14,10 +14,8 @@ Patch1: cfitsio-noversioncheck.patch
Patch2: cfitsio-pkgconfig.patch
# Use builder linker flags
Patch3: cfitsio-ldflags.patch
# Patch some printf format errors
Patch4: cfitsio-sformat.patch
# Revert wrong soname increase
Patch5: cfitsio-3.47-soname.patch
# Remove rpath
Patch4: cfitsio-remove-rpath.patch
BuildRequires: gcc-gfortran zlib-devel
BuildRequires: bzip2-devel
@ -82,8 +80,7 @@ compression algorithm.
%patch1 -p1
%patch2 -p1
%patch3 -p1
#%patch4 -p1
#%patch5 -p1
%patch4 -p1
# remove bundled zlib
# not all the files inside zlib belong to zlib
@ -144,6 +141,9 @@ chmod 755 %{buildroot}%{_bindir}/f{,un}pack
%{_bindir}/funpack
%changelog
* Sun Aug 01 2021 Sergio Pascual <sergiopr@fedoraproject.org> - 3.490-4
- Remove rpath in utilities
* Wed Jul 21 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.490-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild

Loading…
Cancel
Save