commit
e7ae158e79
@ -0,0 +1 @@
|
||||
8b66e4546089c30670b4f3e59bd1a170b17d9ba7 SOURCES/bcunit-5.3.5.tar.gz
|
@ -0,0 +1 @@
|
||||
SOURCES/bcunit-5.3.5.tar.gz
|
@ -0,0 +1,44 @@
|
||||
Index: bcunit-20210211/BCUnit/Sources/Curses/Curses.c
|
||||
===================================================================
|
||||
--- bcunit-20210211/BCUnit/Sources/Curses/Curses.c
|
||||
+++ bcunit-20210211/BCUnit/Sources/Curses/Curses.c 2022-11-05 09:29:49.595687772 -0700
|
||||
@@ -952,11 +952,11 @@
|
||||
|
||||
snprintf(szTemp, STRING_LENGTH, _("Commands: R - run all tests in suite %s"),
|
||||
pSuite->pName);
|
||||
- mvwprintw(details_pad.pPad, 0, 0, szTemp);
|
||||
+ mvwprintw(details_pad.pPad, 0, 0, "%s", szTemp);
|
||||
mvwprintw(details_pad.pPad, 1, 0, _(" S - Select and run a test"));
|
||||
snprintf(szTemp, STRING_LENGTH, _(" L - List all tests registered in suite %s"),
|
||||
pSuite->pName);
|
||||
- mvwprintw(details_pad.pPad, 2, 0, szTemp);
|
||||
+ mvwprintw(details_pad.pPad, 2, 0, "%s", szTemp);
|
||||
mvwprintw(details_pad.pPad, 3, 0, _(" A - Activate or deactivate a test (toggle)"));
|
||||
mvwprintw(details_pad.pPad, 4, 0, _(" F - Show failures from last test run"));
|
||||
mvwprintw(details_pad.pPad, 5, 0, _(" M - Move up to main menu"));
|
||||
@@ -1068,14 +1068,14 @@
|
||||
}
|
||||
|
||||
snprintf(szTemp, STRING_LENGTH, "%s: %s", _("Suite"), pSuite->pName);
|
||||
- mvwprintw(details_pad.pPad, 0, 0, szTemp);
|
||||
+ mvwprintw(details_pad.pPad, 0, 0, "%s", szTemp);
|
||||
|
||||
snprintf(szTemp, STRING_LENGTH,
|
||||
"%*s %-*s%*s",
|
||||
width[0], _("#"),
|
||||
width[1], _("Test Name"),
|
||||
width[2], _("Active?"));
|
||||
- mvwprintw(details_pad.pPad, 1, 0, szTemp);
|
||||
+ mvwprintw(details_pad.pPad, 1, 0, "%s", szTemp);
|
||||
|
||||
for (i = 0, pCurTest = pSuite->pTest ;
|
||||
NULL != pCurTest ;
|
||||
@@ -1158,7 +1158,7 @@
|
||||
|
||||
snprintf(szTemp, STRING_LENGTH, _(" 1 - Inactive suites/tests treated as runtime failures %s"),
|
||||
(CU_FALSE != CU_get_fail_on_inactive()) ? _("Yes") : _("No "));
|
||||
- mvwprintw(details_pad.pPad, 2, 0, szTemp);
|
||||
+ mvwprintw(details_pad.pPad, 2, 0, "%s", szTemp);
|
||||
refresh_details_window();
|
||||
read_input_string(_("Enter number of option to change : "), szTemp, STRING_LENGTH);
|
||||
option_num = atol(szTemp);
|
@ -0,0 +1,13 @@
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 157b915..50c729a 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -91,7 +91,7 @@ endif()
|
||||
|
||||
|
||||
include(CMakePackageConfigHelpers)
|
||||
-set(CMAKE_MODULES_INSTALL_DIR "${CMAKE_INSTALL_DATADIR}/${PROJECT_NAME}/cmake")
|
||||
+set(CMAKE_MODULES_INSTALL_DIR "${CMAKE_INSTALL_LIBDIR}/cmake/${PROJECT_NAME}")
|
||||
configure_package_config_file("${PROJECT_NAME}Config.cmake.in" "${PROJECT_BINARY_DIR}/${PROJECT_NAME}Config.cmake"
|
||||
INSTALL_DESTINATION "${CMAKE_MODULES_INSTALL_DIR}"
|
||||
NO_SET_AND_CHECK_MACRO
|
@ -0,0 +1,49 @@
|
||||
From: Jan Engelhardt <jengelh@medozas.de>
|
||||
Date: 2012-02-09 03:48:24.650731239 +0100
|
||||
|
||||
bcunit uses ncurses, therefore, link with ncurses. Otherwise building
|
||||
this can fail if e.g. -Wl,--no-undefined is used.
|
||||
|
||||
And for -lncurses to trickle down into libbcunit.la, libcunit.la must
|
||||
use the .la files as objects, not the .lo files.
|
||||
|
||||
---
|
||||
BCUnit/Sources/Curses/Makefile.am | 1 +
|
||||
BCUnit/Sources/Makefile.am | 15 +++++----------
|
||||
2 files changed, 6 insertions(+), 10 deletions(-)
|
||||
|
||||
Index: bcunit/BCUnit/Sources/Curses/Makefile.am
|
||||
===================================================================
|
||||
--- bcunit.orig/BCUnit/Sources/Curses/Makefile.am
|
||||
+++ bcunit/BCUnit/Sources/Curses/Makefile.am
|
||||
@@ -3,3 +3,4 @@
|
||||
noinst_LTLIBRARIES = libbcunitcurses.la
|
||||
libbcunitcurses_la_SOURCES = \
|
||||
Curses.c
|
||||
+libbcunitcurses_la_LIBADD = -lncurses
|
||||
Index: bcunit/BCUnit/Sources/Makefile.am
|
||||
===================================================================
|
||||
--- bcunit.orig/BCUnit/Sources/Makefile.am
|
||||
+++ bcunit/BCUnit/Sources/Makefile.am
|
||||
@@ -1,15 +1,10 @@
|
||||
## Process this file with automake to produce Makefile.in
|
||||
|
||||
-BASIC_OBJECTS_SHARED = Basic/Basic.lo
|
||||
-AUTOMATED_OBJECTS_SHARED = Automated/Automated.lo
|
||||
-CONSOLE_OBJECTS_SHARED = Console/Console.lo
|
||||
-CURSES_OBJECTS_SHARED = Curses/Curses.lo
|
||||
-FRAMEWORK_OBJECTS_SHARED = \
|
||||
- Framework/CUError.lo \
|
||||
- Framework/MyMem.lo \
|
||||
- Framework/TestDB.lo \
|
||||
- Framework/TestRun.lo \
|
||||
- Framework/Util.lo
|
||||
+BASIC_OBJECTS_SHARED = Basic/libbcunitbasic.la
|
||||
+AUTOMATED_OBJECTS_SHARED = Automated/libbcunitautomated.la
|
||||
+CONSOLE_OBJECTS_SHARED = Console/libbcunitconsole.la
|
||||
+CURSES_OBJECTS_SHARED = Curses/libbcunitcurses.la
|
||||
+FRAMEWORK_OBJECTS_SHARED = Framework/libbcunitfmk.la
|
||||
|
||||
FRAMEWORK_OBJECT_FILES_SHARED = $(FRAMEWORK_OBJECTS_SHARED)
|
||||
FRAMEWORK_COMPILE_DIRS = Framework
|
||||
|
@ -0,0 +1,47 @@
|
||||
--- a/BCUnit/Sources/Curses/Curses.c
|
||||
+++ b/BCUnit/Sources/Curses/Curses.c
|
||||
@@ -256,10 +256,10 @@ static bool initialize_windows(void)
|
||||
|
||||
start_color();
|
||||
|
||||
- f_nLeft = application_windows.pMainWin->_begx;
|
||||
- f_nTop = application_windows.pMainWin->_begy;
|
||||
- f_nWidth = application_windows.pMainWin->_maxx;
|
||||
- f_nHeight = application_windows.pMainWin->_maxy;
|
||||
+ f_nLeft = getbegx(application_windows.pMainWin);
|
||||
+ f_nTop = getbegy(application_windows.pMainWin);
|
||||
+ f_nWidth = getmaxx(application_windows.pMainWin);
|
||||
+ f_nHeight = getmaxy(application_windows.pMainWin);
|
||||
|
||||
if (NULL == (application_windows.pTitleWin = newwin(3, f_nWidth, 0, 0))) {
|
||||
goto title_fail;
|
||||
@@ -358,10 +358,10 @@ static void refresh_windows(void)
|
||||
{
|
||||
refresh();
|
||||
|
||||
- f_nLeft = application_windows.pMainWin->_begx;
|
||||
- f_nTop = application_windows.pMainWin->_begy;
|
||||
- f_nWidth = application_windows.pMainWin->_maxx;
|
||||
- f_nHeight = application_windows.pMainWin->_maxy;
|
||||
+ f_nLeft = getbegx(application_windows.pMainWin);
|
||||
+ f_nTop = getbegy(application_windows.pMainWin);
|
||||
+ f_nWidth = getmaxx(application_windows.pMainWin);
|
||||
+ f_nHeight = getmaxy(application_windows.pMainWin);
|
||||
|
||||
refresh_title_window();
|
||||
refresh_progress_window();
|
||||
@@ -907,10 +907,10 @@ static bool create_pad(APPPAD* pPad, WIN
|
||||
pPad->uiColumns = uiCols;
|
||||
pPad->uiPadRow = 0;
|
||||
pPad->uiPadCol = 0;
|
||||
- pPad->uiWinLeft = application_windows.pDetailsWin->_begx + 1;
|
||||
- pPad->uiWinTop = application_windows.pDetailsWin->_begy + 1;
|
||||
- pPad->uiWinColumns = application_windows.pDetailsWin->_maxx - 2;
|
||||
- pPad->uiWinRows = application_windows.pDetailsWin->_maxy - 2;
|
||||
+ pPad->uiWinLeft = getbegx(application_windows.pDetailsWin) + 1;
|
||||
+ pPad->uiWinTop = getbegy(application_windows.pDetailsWin) + 1;
|
||||
+ pPad->uiWinColumns = getmaxx(application_windows.pDetailsWin) - 2;
|
||||
+ pPad->uiWinRows = getmaxy(application_windows.pDetailsWin) - 2;
|
||||
|
||||
bStatus = true;
|
||||
|
@ -0,0 +1,43 @@
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 2287a32..2b09d5c 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -49,7 +49,7 @@ configure_file(${PROJECT_SOURCE_DIR}/config.h.cmake ${PROJECT_BINARY_DIR}/config
|
||||
set(exec_prefix ${CMAKE_INSTALL_BINDIR})
|
||||
set(libdir ${CMAKE_INSTALL_LIBDIR})
|
||||
set(includedir ${CMAKE_INSTALL_INCLUDEDIR})
|
||||
-configure_file(${PROJECT_SOURCE_DIR}/bcunit.pc.in ${PROJECT_BINARY_DIR}/bcunit.pc)
|
||||
+configure_file(${PROJECT_SOURCE_DIR}/bcunit.pc.in ${PROJECT_BINARY_DIR}/bcunit.pc @ONLY)
|
||||
install(FILES ${PROJECT_BINARY_DIR}/bcunit.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
|
||||
|
||||
|
||||
diff --git a/bcunit.pc.in b/bcunit.pc.in
|
||||
index 1b43b15..160e6fd 100644
|
||||
--- a/bcunit.pc.in
|
||||
+++ b/bcunit.pc.in
|
||||
@@ -1,10 +1,10 @@
|
||||
-prefix=@prefix@
|
||||
-exec_prefix=@exec_prefix@
|
||||
-libdir=@libdir@
|
||||
-includedir=@includedir@
|
||||
+prefix=@CMAKE_INSTALL_PREFIX@
|
||||
+exec_prefix=@CMAKE_INSTALL_PREFIX@
|
||||
+libdir=@CMAKE_INSTALL_FULL_LIBDIR@
|
||||
+includedir=@CMAKE_INSTALL_FULL_INCLUDEDIR@
|
||||
|
||||
Name: BCUnit
|
||||
Description: C Unit Testing Framework
|
||||
-Version: @VERSION@-@RELEASE@
|
||||
+Version: @PROJECT_VERSION@
|
||||
Libs: -L${libdir} -lbcunit
|
||||
Cflags: -I${includedir}
|
||||
diff --git a/bcunit.pc.in b/bcunit.pc.in
|
||||
index 160e6fd..faaa942 100644
|
||||
--- a/bcunit.pc.in
|
||||
+++ b/bcunit.pc.in
|
||||
@@ -7,4 +7,4 @@ Name: BCUnit
|
||||
Description: C Unit Testing Framework
|
||||
Version: @PROJECT_VERSION@
|
||||
Libs: -L${libdir} -lbcunit
|
||||
-Cflags: -I${includedir}
|
||||
+Cflags: -I${includedir}/BCUnit
|
@ -0,0 +1,12 @@
|
||||
diff --git a/BCUnit/Sources/CMakeLists.txt b/BCUnit/Sources/CMakeLists.txt
|
||||
index d472458..84dd8e4 100644
|
||||
--- a/BCUnit/Sources/CMakeLists.txt
|
||||
+++ b/BCUnit/Sources/CMakeLists.txt
|
||||
@@ -161,6 +161,7 @@ target_include_directories(bcunit PUBLIC
|
||||
$<BUILD_INTERFACE:${PROJECT_SOURCE_DIR}/BCUnit/Headers>
|
||||
$<BUILD_INTERFACE:${PROJECT_BINARY_DIR}/BCUnit/Headers>
|
||||
)
|
||||
+set_target_properties(bcunit PROPERTIES SOVERSION 1)
|
||||
set_target_properties(bcunit PROPERTIES VERSION 1.0.1)
|
||||
|
||||
if(ANDROID)
|
@ -0,0 +1,182 @@
|
||||
%define major 1
|
||||
%define libname %{name}-libs
|
||||
%define develname %{name}-devel
|
||||
|
||||
Name: bcunit
|
||||
Version: 5.3.5
|
||||
Release: %{major}%{?dist}.inferit
|
||||
Summary: Provide C programmers basic testing functionality
|
||||
License: LGPLv2+
|
||||
Group: Development/C++
|
||||
Url: https://linphone.org/
|
||||
Source: https://gitlab.linphone.org/BC/public/bcunit/-/archive/%{version}/bcunit-%{version}.tar.gz
|
||||
# PATCH-FIX-OPENSUSE bcunit-link-ncurses.patch jengelh@medozas.de
|
||||
Patch0: bcunit-link-ncurses.patch
|
||||
# PATCH-FIX-OPENSUSE bcunit-ncurses6.patch idonmez@suse.com -- Compile with ncurses6.
|
||||
Patch1: bcunit-ncurses6.patch
|
||||
# PATCH-FIX-OPENSUSE bcunit-sover.patch sor.alexei@meowr.ru -- Correctly set the sover.
|
||||
Patch2: bcunit-sover.patch
|
||||
# mga patches
|
||||
Patch100: bcunit-pkg-conf-pc.patch
|
||||
Patch101: bcunit-CMake-files-location.patch
|
||||
Patch102: bcunit-3.0.2-mga-string-format.patch
|
||||
BuildRequires: cmake
|
||||
BuildRequires: ncurses-devel
|
||||
BuildRequires: pkgconfig
|
||||
|
||||
%description
|
||||
BCUnit is a unit testing framework for C, derived from CUnit.
|
||||
(B)CUnit provides various interfaces to the framework, some of which
|
||||
are platform dependent (e.g. curses on *nix). The framework complies
|
||||
with the conventional structure of test cases bundled into suites
|
||||
which are registered with the framework for running.
|
||||
|
||||
%package -n %{develname}
|
||||
Summary: BCUnit development files
|
||||
Group: Development/C++
|
||||
Requires: %{libname} = %{version}-%{release}
|
||||
Provides: %{name}-devel = %{version}-%{release}
|
||||
Obsoletes: %{name}-devel < 3.0.2-5
|
||||
|
||||
%description -n %{develname}
|
||||
BCUnit is a unit testing framework for C.
|
||||
This package installs the BCUnit development files.
|
||||
|
||||
%package -n %{libname}
|
||||
Summary: BCUnit shared library
|
||||
Group: System/Libraries
|
||||
|
||||
%description -n %{libname}
|
||||
BCUnit is a unit testing framework for C.
|
||||
This package installs the BCUnit shared library.
|
||||
|
||||
%prep
|
||||
%autosetup -p1 -n %{name}-%{version}
|
||||
|
||||
# Fix version
|
||||
sed -i -e '/^project/s/\(VERSION\)\s\+"\?[0-9]\+\(\.[0-9]\+\)\+"\?/\1 %{version}/' CMakeLists.txt
|
||||
|
||||
%build
|
||||
%cmake \
|
||||
-DENABLE_STATIC:BOOL=OFF \
|
||||
-DENABLE_AUTOMATED:BOOL=ON \
|
||||
-DENABLE_BASIC:BOOL=ON \
|
||||
-DENABLE_CONSOLE:BOOL=ON \
|
||||
-DENABLE_CURSES:BOOL=ON \
|
||||
-DENABLE_EXAMPLES:BOOL=OFF
|
||||
%cmake_build
|
||||
|
||||
%install
|
||||
%cmake_install
|
||||
|
||||
%files -n %{libname}
|
||||
%license COPYING
|
||||
%{_libdir}/libbcunit.so.%{major}{,.*}
|
||||
|
||||
%files -n %{develname}
|
||||
%doc AUTHORS ChangeLog NEWS README* TODO
|
||||
%{_includedir}/BCUnit/
|
||||
%{_datadir}/BCUnit/
|
||||
%{_libdir}/libbcunit.so
|
||||
%{_libdir}/pkgconfig/bcunit.pc
|
||||
%{_libdir}/cmake/BCUnit/
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed May 29 2024 Sergey Cherevko <s.cherevko@msvsphere-os.ru> - 5.3.5-1.inferit
|
||||
- Rebuilt for MSVSphere 9.4
|
||||
|
||||
* Sat Dec 30 2023 wally <wally> 5.3.5-1.mga10
|
||||
+ Revision: 2024659
|
||||
- new version 5.3.5
|
||||
|
||||
* Sat Dec 24 2022 wally <wally> 3.0.2-4.git20221116.1.mga9
|
||||
+ Revision: 1926252
|
||||
- update to 20221116 git snapshot
|
||||
|
||||
* Sat Nov 05 2022 danf <danf> 3.0.2-4.git20210211.2.mga9
|
||||
+ Revision: 1903898
|
||||
- Add string-format.patch to fix gcc12 error
|
||||
|
||||
* Sat Apr 10 2021 wally <wally> 3.0.2-4.git20210211.1.mga9
|
||||
+ Revision: 1714604
|
||||
- new git snapshot 20210211
|
||||
|
||||
* Sat Mar 28 2020 wally <wally> 3.0.2-4.git20191119.2.mga8
|
||||
+ Revision: 1561357
|
||||
- fix devel pkg name
|
||||
|
||||
* Sat Mar 28 2020 wally <wally> 3.0.2-4.git20191119.1.mga8
|
||||
+ Revision: 1561352
|
||||
- update to latest git snapshot
|
||||
|
||||
* Wed Feb 12 2020 umeabot <umeabot> 3.mga8-current
|
||||
+ Revision: 1510680
|
||||
- Mageia 8 Mass Rebuild
|
||||
+ wally <wally>
|
||||
- build with new cmake macros
|
||||
|
||||
* Fri Sep 21 2018 umeabot <umeabot> 3.0.2-2.mga7
|
||||
+ Revision: 1295355
|
||||
- Mageia 7 Mass Rebuild
|
||||
+ wally <wally>
|
||||
- fix license
|
||||
|
||||
* Sat Nov 04 2017 zezinho <zezinho> 3.0.2-1.mga7
|
||||
+ Revision: 1175949
|
||||
- follow mageia policies
|
||||
- imported package bcunit
|
||||
|
||||
|
||||
* Fri Jul 21 2017 sor.alexei@meowr.ru
|
||||
- Update to version 3.0.2:
|
||||
* Version bump.
|
||||
* Tue Jun 13 2017 jengelh@inai.de
|
||||
- Rewrite incorrect %%description of main RPM.
|
||||
* Wed May 17 2017 sor.alexei@meowr.ru
|
||||
- Update to version 3.0+git20170404:
|
||||
* No changelog available.
|
||||
- Rename the package to bcunit for the fork.
|
||||
- Rename and rebase cunit-link-ncurses.dif to
|
||||
bcunit-link-ncurses.patch,
|
||||
cunit-ncurses6.patch to bcunit-ncurses6.patch.
|
||||
- Switch to cmake.
|
||||
- Add bcunit-sover.patch: Correctly set the sover.
|
||||
- Disable test: doesn't compile correctly.
|
||||
- Correct the licence to LGPL-2.0+ (nothing limits to LGPL-2.0).
|
||||
- Add baselibs.conf.
|
||||
- Minor spec clean up.
|
||||
* Thu Oct 22 2015 idonmez@suse.com
|
||||
- Add cunit-ncurses6.patch to compile with ncurses6
|
||||
* Tue May 26 2015 ddiss@suse.com
|
||||
- Don't tag Recommends on RHEL, it yields an "Unknown tag" error.
|
||||
* Tue Aug 12 2014 tchvatal@suse.com
|
||||
- Use proper group for the library.
|
||||
* Mon Aug 4 2014 tchvatal@suse.com
|
||||
- The license is actually LGPL
|
||||
* Mon Aug 4 2014 tchvatal@suse.com
|
||||
- Update to release 2.1.3:
|
||||
* prune the static-devel subpackage as it is pointless.
|
||||
* Various upstream fixes with no changelog.
|
||||
- Cleanup with spec-cleaner to have the spec pretty
|
||||
* Thu Feb 9 2012 jengelh@medozas.de
|
||||
- Update to new upstream release 2.1.2
|
||||
* modified dtd and xsl files to support inactive suites/tests
|
||||
* Added ability to deactivate suite/tests dynamically
|
||||
* Removed constraint that suite/test names be unique
|
||||
- Remove redundant tags/sections
|
||||
- Parallel build with %%_smp_mflags
|
||||
- Add autotools BuildRequires for factory/12.2
|
||||
- Fix use of implicitly defined function in source
|
||||
(do not declare that post-build-checks's output was wrong)
|
||||
- Add missing DT_NEEDED entry on ncurses
|
||||
* Tue Jun 8 2010 andrea@opensuse.org
|
||||
- fixed 'no-pkg-config-provides'
|
||||
* Wed Apr 21 2010 prusnak@suse.cz
|
||||
- cleaned up spec, split devel-static subpackage
|
||||
* Sat Mar 13 2010 andrea@opensuse.org
|
||||
- added CUnit-2.1-pkgconfig.patch to provide cunit.pc
|
||||
* Wed Mar 3 2010 andrea@opensuse.org
|
||||
- split into 3 subpackages
|
||||
* Tue Mar 2 2010 andrea@opensuse.org
|
||||
- New package
|
Loading…
Reference in new issue