commit
8a2f8cdd5b
@ -0,0 +1 @@
|
|||||||
|
58a8f6e7bc95ae9480ddb656c2ebde56f061d1b7 SOURCES/bcmatroska2-5.3.54.tar.gz
|
@ -0,0 +1 @@
|
|||||||
|
SOURCES/bcmatroska2-5.3.54.tar.gz
|
@ -0,0 +1,25 @@
|
|||||||
|
From 058792da6f5c9558a9f5cd7c2837cbb8a76d251d Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Jani=20V=C3=A4limaa?= <wally@mageia.org>
|
||||||
|
Date: Tue, 23 Aug 2022 17:44:37 +0300
|
||||||
|
Subject: [PATCH] Fix linking
|
||||||
|
|
||||||
|
---
|
||||||
|
libmatroska2/CMakeLists.txt | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/libmatroska2/CMakeLists.txt b/libmatroska2/CMakeLists.txt
|
||||||
|
index 0fca094..0ef7490 100644
|
||||||
|
--- a/libmatroska2/CMakeLists.txt
|
||||||
|
+++ b/libmatroska2/CMakeLists.txt
|
||||||
|
@@ -26,7 +26,7 @@ set(MATROSKA2_SOURCE_FILES
|
||||||
|
matroska_sem.c
|
||||||
|
)
|
||||||
|
|
||||||
|
-set(LIBS )
|
||||||
|
+set(LIBS bctoolbox)
|
||||||
|
if(WIN32 AND NOT CMAKE_SYSTEM_NAME STREQUAL "WindowsPhone" AND NOT CMAKE_SYSTEM_NAME STREQUAL "WindowsStore")
|
||||||
|
list(APPEND LIBS Winmm)
|
||||||
|
endif()
|
||||||
|
--
|
||||||
|
2.37.2
|
||||||
|
|
@ -0,0 +1,24 @@
|
|||||||
|
From 03d9159fac9aa1afadf4f310520eab3a4c1a241c Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Jani=20V=C3=A4limaa?= <wally@mageia.org>
|
||||||
|
Date: Tue, 23 Aug 2022 17:20:22 +0300
|
||||||
|
Subject: [PATCH] Fix multiple definitions
|
||||||
|
|
||||||
|
---
|
||||||
|
corec/corec/CMakeLists.txt | 1 -
|
||||||
|
1 file changed, 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/corec/corec/CMakeLists.txt b/corec/corec/CMakeLists.txt
|
||||||
|
index fc8b908..af40f72 100644
|
||||||
|
--- a/corec/corec/CMakeLists.txt
|
||||||
|
+++ b/corec/corec/CMakeLists.txt
|
||||||
|
@@ -52,7 +52,6 @@ if(WIN32)
|
||||||
|
else()
|
||||||
|
list(APPEND COREC_SOURCES
|
||||||
|
helpers/date/date_libc.c
|
||||||
|
- helpers/file/file_libc.c
|
||||||
|
helpers/file/file_bctbx.c
|
||||||
|
multithread/multithread_pthread.c
|
||||||
|
)
|
||||||
|
--
|
||||||
|
2.37.2
|
||||||
|
|
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||||
|
index db82b89..97e0567 100644
|
||||||
|
--- a/CMakeLists.txt
|
||||||
|
+++ b/CMakeLists.txt
|
||||||
|
@@ -77,7 +77,7 @@ install(FILES ${CMAKE_BINARY_DIR}/config.h
|
||||||
|
)
|
||||||
|
|
||||||
|
include(CMakePackageConfigHelpers)
|
||||||
|
-set(CONFIG_PACKAGE_LOCATION "${CMAKE_INSTALL_DATADIR}/${PROJECT_NAME}/cmake")
|
||||||
|
+set(CONFIG_PACKAGE_LOCATION "${CMAKE_INSTALL_DATADIR}/${PROJECT_NAME}/cmake" CACHE PATH "CMake configuration file location")
|
||||||
|
|
||||||
|
write_basic_package_version_file(
|
||||||
|
${CMAKE_BINARY_DIR}/BcMatroska2ConfigVersion.cmake
|
@ -0,0 +1,102 @@
|
|||||||
|
Summary: C Library to Deal with Matroska Files
|
||||||
|
Name: bcmatroska2
|
||||||
|
Version: 5.3.54
|
||||||
|
Release: 1%{?dist}.inferit
|
||||||
|
|
||||||
|
License: BSD and Zlib and GPLv2+
|
||||||
|
URL: https://linphone.org/
|
||||||
|
Source0: https://gitlab.linphone.org/BC/public/bcmatroska2/-/archive/%{version}/bcmatroska2-%{version}.tar.gz
|
||||||
|
Patch1: 0001-Fix-multiple-definitions.patch
|
||||||
|
Patch2: 0001-Fix-linking.patch
|
||||||
|
# (wally) alow overriding cmake config file location from cmd line
|
||||||
|
Patch51: bcmatroska2-0.23-cmake-config-location.patch
|
||||||
|
|
||||||
|
BuildRequires: cmake
|
||||||
|
BuildRequires: cmake(bctoolbox) >= %{version}
|
||||||
|
|
||||||
|
%description
|
||||||
|
Bcmatroska2 is a C library to parse Matroska files (.mkv and .mka).
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development files for %{name}
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
This package contains development files for %{name}
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -qn %{name}-%{?gitdate}%{!?gitdate:%version}
|
||||||
|
%autopatch -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cmake \
|
||||||
|
-DCMAKE_SKIP_RPATH:BOOL=YES \
|
||||||
|
-DENABLE_STATIC:BOOL=NO \
|
||||||
|
-DENABLE_STRICT:BOOL=NO \
|
||||||
|
-DCMAKE_INSTALL_INCLUDEDIR:PATH=include/bcmatroska2 \
|
||||||
|
-DCONFIG_PACKAGE_LOCATION:PATH=%{_libdir}/cmake/%{name}
|
||||||
|
%cmake_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cmake_install
|
||||||
|
|
||||||
|
%files
|
||||||
|
%{_libdir}/lib%{name}.so.*
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%{_includedir}/%{name}/
|
||||||
|
%{_libdir}/lib%{name}.so
|
||||||
|
%{_libdir}/cmake/%{name}/
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri May 31 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 5.3.54-1R.inferit
|
||||||
|
- Rebuilt for MSVSphere 9.4
|
||||||
|
|
||||||
|
* Fri May 31 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 5.3.54-1.inferit
|
||||||
|
- Rebuilt for MSVSphere 9.4
|
||||||
|
|
||||||
|
* Fri Jan 06 2023 wally <wally> 5.2.1-1.mga9
|
||||||
|
+ Revision: 1930688
|
||||||
|
- new version 5.2.1
|
||||||
|
|
||||||
|
* Tue Aug 23 2022 wally <wally> 5.1.20-1.mga9
|
||||||
|
+ Revision: 1879604
|
||||||
|
- new version 5.1.20
|
||||||
|
|
||||||
|
* Tue Aug 23 2022 wally <wally> 0.25-4.git20210209.3.mga9
|
||||||
|
+ Revision: 1879587
|
||||||
|
- properly fix RPATH
|
||||||
|
|
||||||
|
* Thu Mar 17 2022 umeabot <umeabot> 0.25-4.git20210209.2.mga9
|
||||||
|
+ Revision: 1796956
|
||||||
|
- Mageia 9 Mass Rebuild
|
||||||
|
|
||||||
|
* Fri Mar 11 2022 mrambo3501 <mrambo3501> 0.25-4.git20210209.1.mga9
|
||||||
|
+ Revision: 1790419
|
||||||
|
- bump rel
|
||||||
|
- remove the global rpath disable
|
||||||
|
- ignore the standard 0x0001 rpath
|
||||||
|
|
||||||
|
* Wed Mar 09 2022 mrambo3501 <mrambo3501> 0.24-4.git20210209.1.mga9
|
||||||
|
+ Revision: 1790123
|
||||||
|
- disable rpath checking
|
||||||
|
|
||||||
|
* Sat Jul 31 2021 wally <wally> 0.23-4.git20210209.1.mga9
|
||||||
|
+ Revision: 1738389
|
||||||
|
- update to latest git snapshot
|
||||||
|
|
||||||
|
* Wed Feb 12 2020 umeabot <umeabot> 3.mga8-current
|
||||||
|
+ Revision: 1510673
|
||||||
|
- Mageia 8 Mass Rebuild
|
||||||
|
+ wally <wally>
|
||||||
|
- build with new cmake macros
|
||||||
|
|
||||||
|
* Fri Sep 21 2018 umeabot <umeabot> 0.23-2.mga7
|
||||||
|
+ Revision: 1295352
|
||||||
|
- Mageia 7 Mass Rebuild
|
||||||
|
|
||||||
|
* Sun Dec 31 2017 wally <wally> 0.23-1.mga7
|
||||||
|
+ Revision: 1188350
|
||||||
|
- imported package bcmatroska2
|
||||||
|
|
Loading…
Reference in new issue