Merge branch 'f34' into f35

epel9
Dominik 'Rathann' Mierzejewski 3 years ago
commit 5ebfa49f6c

@ -0,0 +1,12 @@
diff -up src/Makefile.am.icb src/Makefile.am
--- src/Makefile.am.icb 2020-12-07 11:40:45.000000000 +0100
+++ src/Makefile.am 2021-09-02 23:55:29.346733967 +0200
@@ -1,7 +1,7 @@
ACLOCAL_AMFLAGS = -I m4
pkgincludedir = $(includedir)/arpack
-pkginclude_HEADERS = debug.h stat.h arpackdef.h
+pkginclude_HEADERS = debug.h stat.h arpackdef.h arpackicb.h
AM_DISTCHECK_CONFIGURE_FLAGS =
if MPI

@ -1,45 +1,27 @@
%global build64 0 %global build64 0
%if 0%{?fedora} >= 26 || 0%{?rhel} >= 7
%{!?openblas_arches:%global openblas_arches x86_64 %{ix86} armv7hl %{power64} aarch64}
%ifnarch %{openblas_arches}
# matches openblas ExclusiveArch
%bcond_without atlas
%else
%if 0%{?__isa_bits} == 64 %if 0%{?__isa_bits} == 64
%global build64 1 %global build64 1
%endif %endif
%endif
%endif
%if 0%{?fedora} >= 33
%bcond_without flexiblas
%endif
# We are linking FORTRAN symbols. Thus we cannot link --as-needed. # We are linking FORTRAN symbols. Thus we cannot link --as-needed.
%undefine _ld_as_needed %undefine _ld_as_needed
Name: arpack Name: arpack
Version: 3.8.0 Version: 3.8.0
Release: 2%{dist} Release: 3%{dist}
Summary: Fortran 77 subroutines for solving large scale eigenvalue problems Summary: Fortran 77 subroutines for solving large scale eigenvalue problems
License: BSD License: BSD
URL: https://github.com/opencollab/arpack-ng URL: https://github.com/opencollab/arpack-ng
Source0: https://github.com/opencollab/arpack-ng/archive/%{version}/arpack-ng-%{version}.tar.gz Source0: https://github.com/opencollab/arpack-ng/archive/%{version}/arpack-ng-%{version}.tar.gz
# https://bugzilla.redhat.com/show_bug.cgi?id=1990366
Patch0: arpack-install-arpackicb_h.patch
BuildRequires: gcc-c++ BuildRequires: gcc-c++
BuildRequires: gcc-gfortran BuildRequires: gcc-gfortran
%if %{with flexiblas} BuildRequires: pkgconfig(flexiblas)
BuildRequires: pkgconfig(flexiblas)
%else
%if %{with atlas}
BuildRequires: atlas-devel
%else
BuildRequires: openblas-devel
%endif
%endif
BuildRequires: libtool >= 2.4.2 BuildRequires: libtool >= 2.4.2
BuildRequires: make BuildRequires: make
Provides: arpack-ng = %{version}-%{release} Provides: arpack-ng = %{version}-%{release}
Provides: arpack-ng%{?_isa} = %{version}-%{release} Provides: arpack-ng%{?_isa} = %{version}-%{release}
@ -92,6 +74,7 @@ library and so links used for building arpack based applications.
%setup -qc %setup -qc
mv arpack-ng-%{version} src mv arpack-ng-%{version} src
pushd src pushd src
%patch0 -p1
autoreconf -vif autoreconf -vif
popd popd
%if %{build64} %if %{build64}
@ -100,23 +83,10 @@ cp -pr src src64
%build %build
%if %{with flexiblas}
%global blaslib -lflexiblas
%else
%if %{with atlas}
%if 0%{?fedora} || 0%{?rhel} >= 7
%global blaslib -L%{_libdir}/atlas -ltatlas
%else
%global blaslib -L%{_libdir}/atlas -lf77blas -latlas
%endif
%else
%global blaslib -lopenblasp
%endif
%endif
pushd src pushd src
%configure --enable-shared --enable-static \ %configure --enable-shared --enable-static \
--with-blas="%{blaslib}" \ --with-blas=-lflexiblas \
--with-lapack="%{blaslib}" \ --with-lapack=-lflexiblas \
--enable-icb --enable-icb
%make_build %make_build
popd popd
@ -125,8 +95,8 @@ pushd src64
%configure --enable-shared --enable-static \ %configure --enable-shared --enable-static \
LIBSUFFIX=64 \ LIBSUFFIX=64 \
INTERFACE64=1 \ INTERFACE64=1 \
--with-blas=%{blaslib}64 \ --with-blas=-lflexiblas64 \
--with-lapack=%{blaslib}64 \ --with-lapack=-lflexiblas64 \
--enable-icb --enable-icb
%make_build %make_build
popd popd
@ -143,7 +113,6 @@ popd
%endif %endif
# Get rid of .la files # Get rid of .la files
rm -r %{buildroot}%{_libdir}/*.la rm -r %{buildroot}%{_libdir}/*.la
# Get rid of generic file names (https://github.com/opencollab/arpack-ng/issues/130)
%check %check
pushd src pushd src
@ -157,8 +126,6 @@ pushd EXAMPLES ; make clean ; popd
popd popd
%endif %endif
%ldconfig_scriptlets
%files %files
%doc src/CHANGES src/README.md %doc src/CHANGES src/README.md
%license src/COPYING %license src/COPYING
@ -192,6 +159,11 @@ popd
%changelog %changelog
* Thu Sep 02 2021 Dominik Mierzejewski <rpm@greysector.net> - 3.8.0-3
- ensure arpackicb.h is installed (#1990366)
- spec clean-up: drop support for building with other blas libs on F34+
- drop obsolete ldconfig scriptlet macro
* Wed Jul 21 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.8.0-2 * Wed Jul 21 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.8.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild

Loading…
Cancel
Save