Signed-off-by: Robert-André Mauchin <zebob.m@gmail.com>i9ce
parent
7aec743e45
commit
038d7b2164
@ -1,2 +1,4 @@
|
||||
/aom-1.0.0.tar.gz
|
||||
/aom-d0076f5.tar.gz
|
||||
/aom-cfd59e9.tar.gz
|
||||
/aom-9666276.tar.gz
|
||||
|
@ -1,45 +0,0 @@
|
||||
From 4b90cc60118f0aed08853ae102c560762fb74627 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Robert-Andr=C3=A9=20Mauchin?= <zebob.m@gmail.com>
|
||||
Date: Fri, 14 Sep 2018 23:17:10 +0200
|
||||
Subject: [PATCH] Add symbol exports needed by examples/analyzer and
|
||||
examples/inspect
|
||||
|
||||
Added to aom/exports_com:
|
||||
aom_free
|
||||
|
||||
Added to av1/exports_com:
|
||||
ifd_init
|
||||
ifd_inspect
|
||||
|
||||
BUG= aomedia:2161
|
||||
|
||||
Change-Id: Ide307b949c886fa8a0398e200980c80b58e3e74e
|
||||
---
|
||||
aom/exports_com | 1 +
|
||||
av1/exports_com | 2 ++
|
||||
2 files changed, 3 insertions(+)
|
||||
|
||||
diff --git a/aom/exports_com b/aom/exports_com
|
||||
index 2798bd51a..cf99bc5d9 100644
|
||||
--- a/aom/exports_com
|
||||
+++ b/aom/exports_com
|
||||
@@ -9,6 +9,7 @@ text aom_codec_iface_name
|
||||
text aom_codec_version
|
||||
text aom_codec_version_extra_str
|
||||
text aom_codec_version_str
|
||||
+text aom_free
|
||||
text aom_img_alloc
|
||||
text aom_img_alloc_with_border
|
||||
text aom_img_flip
|
||||
diff --git a/av1/exports_com b/av1/exports_com
|
||||
index 5c8e0e09d..e49e0dc5f 100644
|
||||
--- a/av1/exports_com
|
||||
+++ b/av1/exports_com
|
||||
@@ -1,2 +1,4 @@
|
||||
text aom_read_obu_header_and_size
|
||||
text av1_resize_frame420
|
||||
+text ifd_init
|
||||
+text ifd_inspect
|
||||
--
|
||||
2.17.1
|
||||
|
@ -1,25 +0,0 @@
|
||||
#!/bin/bash
|
||||
|
||||
NAME=$(basename $PWD)
|
||||
VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
|
||||
COMMIT=$(sed -n '/^%global commit/{s/.* //;p}' $NAME.spec)
|
||||
SHORT=${COMMIT:0:7}
|
||||
|
||||
echo -e "\nCreate git snapshot\n"
|
||||
|
||||
echo "Cloning..."
|
||||
rm -rf $NAME-$COMMIT
|
||||
git clone https://aomedia.googlesource.com/aom $NAME-$COMMIT
|
||||
|
||||
echo "Getting commit..."
|
||||
pushd $NAME-$COMMIT
|
||||
git checkout $COMMIT
|
||||
popd
|
||||
|
||||
echo "Archiving..."
|
||||
tar czf $NAME-$SHORT.tar.gz $NAME-$COMMIT/
|
||||
|
||||
echo "Cleaning..."
|
||||
rm -rf $NAME-$COMMIT
|
||||
|
||||
echo "Done."
|
@ -1 +1 @@
|
||||
SHA512 (aom-d0076f5.tar.gz) = 6fcbe7d76788544f59e1338084d4245077a986308e2405199531ca9b4d24c9b81d5a51e012118d9cedb4e3b813b7a608f8c000e746941c5886a95462f2438369
|
||||
SHA512 (aom-9666276.tar.gz) = 2c979cd2d1229016e5a6336993144d7b5161fd2f2e8b3023177be3d954c2abade5bb17957e4aeeeedd6132fbaf5e2daf79f0cdddf3ad625213dc267761490d7c
|
||||
|
Loading…
Reference in new issue