delegates.mgk could use some care (#527117)

perl build is bad (#527143)
wrong default font paths (#661664)
need for 16-bit support, f16+ for now (#699414)
tighten subpkg deps via %_isa
epel9
Rex Dieter 14 years ago
parent 0fa1f09a65
commit a68a98bf0f

@ -0,0 +1,12 @@
diff -up GraphicsMagick-1.3.12/PerlMagick/Makefile.PL.in.perl_linkage GraphicsMagick-1.3.12/PerlMagick/Makefile.PL.in
--- GraphicsMagick-1.3.12/PerlMagick/Makefile.PL.in.perl_linkage 2009-07-24 14:34:32.000000000 -0500
+++ GraphicsMagick-1.3.12/PerlMagick/Makefile.PL.in 2011-04-26 14:22:47.101574777 -0500
@@ -67,7 +67,7 @@ WriteMakefile
'INSTALLBIN' => '@BIN_DIR@',
# Library specification
- 'LIBS' => ['-L@MAGICKLIBDIR@ -lGraphicsMagick @LDFLAGS@ @MAGICK_DEP_LIBS@'],
+ 'LIBS' => ['-L@MAGICKLIBDIR@ -L../magick/.libs -lGraphicsMagick @LDFLAGS@ @MAGICK_DEP_LIBS@'],
# Perl binary name (if a Perl binary is built)
'MAP_TARGET' => 'PerlMagick',

@ -1,14 +1,22 @@
%if 0%{?fedora} > 15
# should seriously consider using this as default everywhere -- Rex
%global quantum_depth 16
%endif
Summary: An ImageMagick fork, offering faster image generation and better quality Summary: An ImageMagick fork, offering faster image generation and better quality
Name: GraphicsMagick Name: GraphicsMagick
Version: 1.3.12 Version: 1.3.12
Release: 3%{?dist} Release: 4%{?dist}
License: MIT License: MIT
Group: Applications/Multimedia Group: Applications/Multimedia
Source0: http://downloads.sourceforge.net/sourceforge/graphicsmagick/GraphicsMagick-%{version}.tar.lzma Source0: http://downloads.sourceforge.net/sourceforge/graphicsmagick/GraphicsMagick-%{version}.tar.lzma
Url: http://www.graphicsmagick.org/ Url: http://www.graphicsmagick.org/
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX) BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
## upstreamable patches
Patch50: GraphicsMagick-1.3.12-perl_linkage.patch
BuildRequires: bzip2-devel BuildRequires: bzip2-devel
BuildRequires: freetype-devel BuildRequires: freetype-devel
BuildRequires: jasper-devel BuildRequires: jasper-devel
@ -36,7 +44,7 @@ of the software.
%package devel %package devel
Summary: Libraries and header files for GraphicsMagick app development Summary: Libraries and header files for GraphicsMagick app development
Group: Development/Libraries Group: Development/Libraries
Requires: %{name} = %{version}-%{release} Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: ghostscript-devel, bzip2-devel, libtiff-devel, libjpeg-devel Requires: ghostscript-devel, bzip2-devel, libtiff-devel, libjpeg-devel
Requires: lcms-devel, pkgconfig, libX11-devel, libXext-devel, libXt-devel Requires: lcms-devel, pkgconfig, libX11-devel, libXext-devel, libXt-devel
@ -53,7 +61,7 @@ however.
%package perl %package perl
Summary: GraphicsMagick perl bindings Summary: GraphicsMagick perl bindings
Group: System Environment/Libraries Group: System Environment/Libraries
Requires: %{name} = %{version}-%{release} Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version)) Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
%description perl %description perl
@ -65,7 +73,7 @@ GraphicsMagick.
%package c++ %package c++
Summary: GraphicsMagick Magick++ library (C++ bindings) Summary: GraphicsMagick Magick++ library (C++ bindings)
Group: System Environment/Libraries Group: System Environment/Libraries
Requires: %{name} = %{version}-%{release} Requires: %{name}%{?_isa} = %{version}-%{release}
%description c++ %description c++
This package contains the GraphicsMagick++ library, a C++ binding to the This package contains the GraphicsMagick++ library, a C++ binding to the
@ -77,8 +85,8 @@ GraphicsMagick++.
%package c++-devel %package c++-devel
Summary: C++ bindings for the GraphicsMagick library Summary: C++ bindings for the GraphicsMagick library
Group: Development/Libraries Group: Development/Libraries
Requires: %{name}-c++ = %{version}-%{release} Requires: %{name}-c++%{?_isa} = %{version}-%{release}
Requires: %{name}-devel = %{version}-%{release} Requires: %{name}-devel%{?_isa} = %{version}-%{release}
%description c++-devel %description c++-devel
GraphicsMagick-devel contains the Libraries and header files you'll GraphicsMagick-devel contains the Libraries and header files you'll
@ -95,6 +103,8 @@ however.
%prep %prep
%setup -q %setup -q
%patch50 -p1 -b .perl_linkage
iconv -f iso-8859-2 -t utf8 < ChangeLog > ChangeLog.utf8 iconv -f iso-8859-2 -t utf8 < ChangeLog > ChangeLog.utf8
mv -f ChangeLog.utf8 ChangeLog mv -f ChangeLog.utf8 ChangeLog
@ -103,14 +113,18 @@ mv -f ChangeLog.utf8 ChangeLog
sed -i.rpath -e 's|"/lib /usr/lib|"/%{_lib} %{_libdir}|' configure sed -i.rpath -e 's|"/lib /usr/lib|"/%{_lib} %{_libdir}|' configure
%endif %endif
sed -i -e "s|BrowseDelegateDefault=.*|BrowseDelegateDefault=\'xdg-open\'|" configure
%build %build
BrowseDelegate=xdg-open \
%configure --enable-shared --disable-static \ %configure --enable-shared --disable-static \
--with-lcms \ --with-lcms \
--with-magick_plus_plus \ --with-magick_plus_plus \
--with-modules \ --with-modules \
--with-perl \ --with-perl \
--with-perl-options="INSTALLDIRS=vendor %{?perl_prefix}" \ --with-perl-options="INSTALLDIRS=vendor %{?perl_prefix}" \
%{?quantum_depth:--with-quantum-depth=%{quantum_depth}} \
--with-threads \ --with-threads \
--with-wmf \ --with-wmf \
--with-x \ --with-x \
@ -118,8 +132,7 @@ sed -i.rpath -e 's|"/lib /usr/lib|"/%{_lib} %{_libdir}|' configure
--without-dps \ --without-dps \
--without-gslib \ --without-gslib \
--with-windows-font-dir=%{_datadir}/fonts/msttcorefonts \ --with-windows-font-dir=%{_datadir}/fonts/msttcorefonts \
--with-gs-font-dir=%{_datadir}/fonts/default/ghostscript --with-gs-font-dir=%{_datadir}/fonts/default/Type1
make %{?_smp_mflags} make %{?_smp_mflags}
make %{?_smp_mflags} perl-build make %{?_smp_mflags} perl-build
@ -187,9 +200,8 @@ EOF
%check %check
## expect (at least) 6 FAIL, one PerlMagic, 5 in Magick++/demo make check
## TODO: wtf? :) -- Rex make check-perl
make check ||:
%clean %clean
@ -251,6 +263,13 @@ rm -rf %{buildroot}
%changelog %changelog
* Tue Apr 26 2011 Rex Dieter <rdieter@fedoraproject.org> 1.3.12-4
- delegates.mgk could use some care (#527117)
- -perl build is bad (#527143)
- wrong default font paths (#661664)
- need for 16-bit support, f16+ for now (#699414)
- tighten subpkg deps via %%_isa
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.12-3 * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.12-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild

Loading…
Cancel
Save