Merge remote branch 'origin/master' into el6

Conflicts:
	.gitignore
	GraphicsMagick.spec
	sources
epel9
Rex Dieter 13 years ago
commit 3d2a6da909

4
.gitignore vendored

@ -1 +1,3 @@
GraphicsMagick-1.3.12.tar.lzma
/GraphicsMagick-1.3.12.tar.lzma
/GraphicsMagick-1.3.13.tar.xz
/GraphicsMagick-1.3.14.tar.xz

@ -0,0 +1,12 @@
diff -up GraphicsMagick-1.3.14/PerlMagick/Makefile.PL.in.perl_linkage GraphicsMagick-1.3.14/PerlMagick/Makefile.PL.in
--- GraphicsMagick-1.3.14/PerlMagick/Makefile.PL.in.perl_linkage 2012-02-25 14:43:38.000000000 -0600
+++ GraphicsMagick-1.3.14/PerlMagick/Makefile.PL.in 2012-02-26 07:35:38.542731280 -0600
@@ -78,7 +78,7 @@ WriteMakefile
'INSTALLBIN' => $magick_BIN_DIR,
# Library specification
- 'LIBS' => ["-L$magick_LIB_DIR -lGraphicsMagick $magick_LDFLAGS $magick_DEP_LIBS"],
+ 'LIBS' => ["-L$magick_LIB_DIR -L../magick/.libs -lGraphicsMagick $magick_LDFLAGS $magick_DEP_LIBS"],
# Perl binary name (if a Perl binary is built)
'MAP_TARGET' => 'PerlMagick',

@ -1,14 +1,22 @@
%if 0%{?fedora} > 15
# should seriously consider using this as default everywhere -- Rex
%global quantum_depth 16
%endif
Summary: An ImageMagick fork, offering faster image generation and better quality
Name: GraphicsMagick
Version: 1.3.12
Version: 1.3.14
Release: 1%{?dist}
License: MIT
Group: Applications/Multimedia
Source0: http://downloads.sourceforge.net/sourceforge/graphicsmagick/GraphicsMagick-%{version}.tar.lzma
Source0: http://downloads.sourceforge.net/sourceforge/graphicsmagick/GraphicsMagick-%{version}.tar.gz
Url: http://www.graphicsmagick.org/
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
## upstreamable patches
Patch50: GraphicsMagick-1.3.14-perl_linkage.patch
BuildRequires: bzip2-devel
BuildRequires: freetype-devel
BuildRequires: jasper-devel
@ -21,11 +29,14 @@ BuildRequires: libungif-devel
BuildRequires: libwmf-devel
BuildRequires: libxml2-devel
BuildRequires: libX11-devel libXext-devel libXt-devel
BuildRequires: perl
%if 0%{?fedora} > 8 || 0%{?rhel} > 5
BuildRequires: perl-devel
%endif
BuildRequires: perl(ExtUtils::MakeMaker)
BuildRequires: zlib-devel
## FIXME: %%check stuff
#BuildRequires: xorg-x11-server-Xvfb
# depend on stuff referenced below
# --with-gs-font-dir=%{_datadir}/fonts/default/Type1
Requires: urw-fonts
%description
GraphicsMagick is a comprehensive image processing package which is initially
@ -36,9 +47,7 @@ of the software.
%package devel
Summary: Libraries and header files for GraphicsMagick app development
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
Requires: ghostscript-devel, bzip2-devel, libtiff-devel, libjpeg-devel
Requires: lcms-devel, pkgconfig, libX11-devel, libXext-devel, libXt-devel
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
GraphicsMagick-devel contains the Libraries and header files you'll
@ -53,7 +62,7 @@ however.
%package perl
Summary: GraphicsMagick perl bindings
Group: System Environment/Libraries
Requires: %{name} = %{version}-%{release}
Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
%description perl
@ -65,7 +74,7 @@ GraphicsMagick.
%package c++
Summary: GraphicsMagick Magick++ library (C++ bindings)
Group: System Environment/Libraries
Requires: %{name} = %{version}-%{release}
Requires: %{name}%{?_isa} = %{version}-%{release}
%description c++
This package contains the GraphicsMagick++ library, a C++ binding to the
@ -77,8 +86,8 @@ GraphicsMagick++.
%package c++-devel
Summary: C++ bindings for the GraphicsMagick library
Group: Development/Libraries
Requires: %{name}-c++ = %{version}-%{release}
Requires: %{name}-devel = %{version}-%{release}
Requires: %{name}-c++%{?_isa} = %{version}-%{release}
Requires: %{name}-devel%{?_isa} = %{version}-%{release}
%description c++-devel
GraphicsMagick-devel contains the Libraries and header files you'll
@ -95,6 +104,8 @@ however.
%prep
%setup -q
%patch50 -p1 -b .perl_linkage
iconv -f iso-8859-2 -t utf8 < ChangeLog > ChangeLog.utf8
mv -f ChangeLog.utf8 ChangeLog
@ -103,6 +114,8 @@ mv -f ChangeLog.utf8 ChangeLog
sed -i.rpath -e 's|"/lib /usr/lib|"/%{_lib} %{_libdir}|' configure
%endif
sed -i -e "s|BrowseDelegateDefault=.*|BrowseDelegateDefault=\'xdg-open\'|" configure
%build
%configure --enable-shared --disable-static \
@ -111,15 +124,14 @@ sed -i.rpath -e 's|"/lib /usr/lib|"/%{_lib} %{_libdir}|' configure
--with-modules \
--with-perl \
--with-perl-options="INSTALLDIRS=vendor %{?perl_prefix}" \
%{?quantum_depth:--with-quantum-depth=%{quantum_depth}} \
--with-threads \
--with-wmf \
--with-x \
--with-xml \
--without-dps \
--without-gslib \
--with-windows-font-dir=%{_datadir}/fonts/msttcorefonts \
--with-gs-font-dir=%{_datadir}/fonts/default/ghostscript
--with-gs-font-dir=%{_datadir}/fonts/default/Type1
make %{?_smp_mflags}
make %{?_smp_mflags} perl-build
@ -187,9 +199,7 @@ EOF
%check
## expect (at least) 6 FAIL, one PerlMagic, 5 in Magick++/demo
## TODO: wtf? :) -- Rex
make check ||:
make check #|| cat PerlMagick/PerlMagickCheck.log ; make check-perl
%clean
@ -197,14 +207,8 @@ rm -rf %{buildroot}
%post -p /sbin/ldconfig
%post c++ -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%postun c++ -p /sbin/ldconfig
%files
%defattr(-,root,root,-)
%doc Copyright.txt
@ -231,6 +235,9 @@ rm -rf %{buildroot}
%{_mandir}/man1/GraphicsMagick-config.*
%{_mandir}/man1/GraphicsMagickWand-config.*
%post c++ -p /sbin/ldconfig
%postun c++ -p /sbin/ldconfig
%files c++
%defattr(-,root,root,-)
%{_libdir}/libGraphicsMagick++.so.3*
@ -251,6 +258,47 @@ rm -rf %{buildroot}
%changelog
* Sun Feb 26 2012 Rex Dieter <rdieter@fedoraproject.org> 1.3.14-1
- 1.3.14
* Mon Jan 23 2012 Rex Dieter <rdieter@fedoraproject.org> 1.3.13-4
- -devel: omit seemingly extraneous dependencies
* Mon Jan 23 2012 Rex Dieter <rdieter@fedoraproject.org> 1.3.13-3
- BR: perl(ExtUtils::MakeMaker)
* Mon Jan 23 2012 Rex Dieter <rdieter@fedoraproject.org> 1.3.13-2
- Bad font configuration (#783906)
- re-introduce perl_linkage patch, fixes %%check
* Thu Jan 12 2012 Rex Dieter <rdieter@fedoraproject.org> 1.3.13-1
- 1.3.13
* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.12-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
* Tue Dec 06 2011 Adam Jackson <ajax@redhat.com> - 1.3.12-7
- Rebuild for new libpng
* Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.3.12-6
- Perl mass rebuild
* Fri Jun 10 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.3.12-5
- Perl 5.14 mass rebuild
* Tue Apr 26 2011 Rex Dieter <rdieter@fedoraproject.org> 1.3.12-4
- delegates.mgk could use some care (#527117)
- -perl build is bad (#527143)
- wrong default font paths (#661664)
- need for 16-bit support, f16+ for now (#699414)
- tighten subpkg deps via %%_isa
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.12-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Tue Jun 01 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.3.12-2
- Mass rebuild with perl-5.12.0
* Mon Mar 08 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.3.12-1
- GraphicsMagick-1.3.12

@ -1 +1 @@
1b91c37daa9640440a91a83727607269 GraphicsMagick-1.3.12.tar.lzma
a67ef2942550ddfa69b07dd944e2a096 GraphicsMagick-1.3.14.tar.xz

Loading…
Cancel
Save