|
|
|
@ -1,31 +1,32 @@
|
|
|
|
|
diff -u -r GConf-2.26.0/configure.in hacked/configure.in
|
|
|
|
|
--- GConf-2.26.0/configure.in 2009-03-16 22:54:22.000000000 -0400
|
|
|
|
|
+++ hacked/configure.in 2009-05-11 22:12:16.772360600 -0400
|
|
|
|
|
@@ -172,7 +172,7 @@
|
|
|
|
|
[enable_defaults_service="$enableval"],
|
|
|
|
|
[enable_defaults_service=auto])
|
|
|
|
|
diff -up GConf-2.26.2/configure.in.polkit1 GConf-2.26.2/configure.in
|
|
|
|
|
--- GConf-2.26.2/configure.in.polkit1 2009-05-14 11:18:34.000000000 -0400
|
|
|
|
|
+++ GConf-2.26.2/configure.in 2009-06-09 21:12:21.335927355 -0400
|
|
|
|
|
@@ -181,7 +181,7 @@ AC_ARG_ENABLE(defaults_service,
|
|
|
|
|
, enable_defaults_service=auto)
|
|
|
|
|
|
|
|
|
|
if test "x$enable_defaults_service" != "xno" ; then
|
|
|
|
|
- PKG_CHECK_MODULES(DEFAULTS, glib-2.0 gobject-2.0 dbus-1 dbus-glib-1 polkit-dbus, HAVE_POLKIT=yes, HAVE_POLKIT=no)
|
|
|
|
|
+ PKG_CHECK_MODULES(DEFAULTS, glib-2.0 gobject-2.0 dbus-1 dbus-glib-1 polkit-gobject-1, HAVE_POLKIT=yes, HAVE_POLKIT=no)
|
|
|
|
|
- PKG_CHECK_MODULES(DEFAULTS, glib-2.0 gobject-2.0 dbus-1 dbus-glib-1 polkit-dbus, HAVE_POLKIT=yes)
|
|
|
|
|
+ PKG_CHECK_MODULES(DEFAULTS, glib-2.0 gobject-2.0 dbus-1 dbus-glib-1 polkit-gobject-1, HAVE_POLKIT=yes)
|
|
|
|
|
if test "x$HAVE_POLKIT" = "xno"; then
|
|
|
|
|
if test "x$enable_defaults_service" = "xyes" ; then
|
|
|
|
|
AC_MSG_ERROR([[
|
|
|
|
|
@@ -187,12 +187,6 @@
|
|
|
|
|
@@ -194,13 +194,6 @@ fi
|
|
|
|
|
|
|
|
|
|
if test "x$enable_defaults_service" != "xno" ; then
|
|
|
|
|
AC_DEFINE(ENABLE_DEFAULTS_SERVICE, 1, [enable defaults DBus service])
|
|
|
|
|
-
|
|
|
|
|
- AC_CHECK_PROG([POLKIT_POLICY_FILE_VALIDATE],
|
|
|
|
|
- [polkit-policy-file-validate], [polkit-policy-file-validate])
|
|
|
|
|
- [polkit-policy-file-validate], [polkit-policy-file-validate])
|
|
|
|
|
-
|
|
|
|
|
- if test -z "$POLKIT_POLICY_FILE_VALIDATE"; then
|
|
|
|
|
- AC_MSG_ERROR([polkit-policy-file-validate not found])
|
|
|
|
|
- AC_MSG_ERROR([polkit-policy-file-validate not found])
|
|
|
|
|
- fi
|
|
|
|
|
fi
|
|
|
|
|
|
|
|
|
|
AM_CONDITIONAL(ENABLE_DEFAULTS_SERVICE, [test "x$enable_defaults_service" != "xno"])
|
|
|
|
|
diff -u -r GConf-2.26.0/defaults/gconf-defaults.c hacked/defaults/gconf-defaults.c
|
|
|
|
|
--- GConf-2.26.0/defaults/gconf-defaults.c 2009-02-16 13:17:44.000000000 -0500
|
|
|
|
|
+++ hacked/defaults/gconf-defaults.c 2009-05-13 17:44:52.474938376 -0400
|
|
|
|
|
diff -up GConf-2.26.2/defaults/gconf-defaults.c.polkit1 GConf-2.26.2/defaults/gconf-defaults.c
|
|
|
|
|
--- GConf-2.26.2/defaults/gconf-defaults.c.polkit1 2009-05-14 11:13:40.000000000 -0400
|
|
|
|
|
+++ GConf-2.26.2/defaults/gconf-defaults.c 2009-06-09 21:07:45.472634301 -0400
|
|
|
|
|
@@ -1,6 +1,6 @@
|
|
|
|
|
/* -*- Mode: C; tab-width: 8; indent-tabs-mode: nil; c-basic-offset: 8 -*-
|
|
|
|
|
*
|
|
|
|
@ -42,7 +43,7 @@ diff -u -r GConf-2.26.0/defaults/gconf-defaults.c hacked/defaults/gconf-defaults
|
|
|
|
|
#include <polkit/polkit.h>
|
|
|
|
|
|
|
|
|
|
#define GCONF_ENABLE_INTERNALS
|
|
|
|
|
@@ -56,10 +55,14 @@
|
|
|
|
|
@@ -56,10 +55,14 @@ do_exit (gpointer user_data)
|
|
|
|
|
}
|
|
|
|
|
|
|
|
|
|
static guint timer_id = 0;
|
|
|
|
@ -57,7 +58,7 @@ diff -u -r GConf-2.26.0/defaults/gconf-defaults.c hacked/defaults/gconf-defaults
|
|
|
|
|
if (timer_id > 0) {
|
|
|
|
|
g_source_remove (timer_id);
|
|
|
|
|
timer_id = 0;
|
|
|
|
|
@@ -69,15 +72,38 @@
|
|
|
|
|
@@ -69,15 +72,38 @@ stop_killtimer (void)
|
|
|
|
|
static void
|
|
|
|
|
start_killtimer (void)
|
|
|
|
|
{
|
|
|
|
@ -99,7 +100,7 @@ diff -u -r GConf-2.26.0/defaults/gconf-defaults.c hacked/defaults/gconf-defaults
|
|
|
|
|
};
|
|
|
|
|
|
|
|
|
|
static void gconf_defaults_finalize (GObject *object);
|
|
|
|
|
@@ -105,7 +131,7 @@
|
|
|
|
|
@@ -105,7 +131,7 @@ GType
|
|
|
|
|
gconf_defaults_error_get_type (void)
|
|
|
|
|
{
|
|
|
|
|
static GType etype = 0;
|
|
|
|
@ -108,7 +109,7 @@ diff -u -r GConf-2.26.0/defaults/gconf-defaults.c hacked/defaults/gconf-defaults
|
|
|
|
|
if (etype == 0)
|
|
|
|
|
{
|
|
|
|
|
static const GEnumValue values[] =
|
|
|
|
|
@@ -114,12 +140,12 @@
|
|
|
|
|
@@ -114,12 +140,12 @@ gconf_defaults_error_get_type (void)
|
|
|
|
|
ENUM_ENTRY (GCONF_DEFAULTS_ERROR_NOT_PRIVILEGED, "NotPrivileged"),
|
|
|
|
|
{ 0, 0, 0 }
|
|
|
|
|
};
|
|
|
|
@ -124,7 +125,7 @@ diff -u -r GConf-2.26.0/defaults/gconf-defaults.c hacked/defaults/gconf-defaults
|
|
|
|
|
return etype;
|
|
|
|
|
}
|
|
|
|
|
|
|
|
|
|
@@ -191,56 +217,18 @@
|
|
|
|
|
@@ -191,56 +217,18 @@ gconf_defaults_finalize (GObject *object
|
|
|
|
|
|
|
|
|
|
g_return_if_fail (mechanism->priv != NULL);
|
|
|
|
|
|
|
|
|
@ -183,7 +184,7 @@ diff -u -r GConf-2.26.0/defaults/gconf-defaults.c hacked/defaults/gconf-defaults
|
|
|
|
|
|
|
|
|
|
error = NULL;
|
|
|
|
|
mechanism->priv->system_bus_connection = dbus_g_bus_get (DBUS_BUS_SYSTEM, &error);
|
|
|
|
|
@@ -252,7 +240,7 @@
|
|
|
|
|
@@ -252,7 +240,7 @@ register_mechanism (GConfDefaults *mecha
|
|
|
|
|
goto error;
|
|
|
|
|
}
|
|
|
|
|
|
|
|
|
@ -192,7 +193,7 @@ diff -u -r GConf-2.26.0/defaults/gconf-defaults.c hacked/defaults/gconf-defaults
|
|
|
|
|
G_OBJECT (mechanism));
|
|
|
|
|
|
|
|
|
|
mechanism->priv->system_bus_proxy = dbus_g_proxy_new_for_name (mechanism->priv->system_bus_connection,
|
|
|
|
|
@@ -288,33 +276,37 @@
|
|
|
|
|
@@ -288,33 +276,37 @@ gconf_defaults_new (void)
|
|
|
|
|
|
|
|
|
|
static const char *
|
|
|
|
|
polkit_action_for_gconf_path (GConfDefaults *mechanism,
|
|
|
|
@ -241,7 +242,7 @@ diff -u -r GConf-2.26.0/defaults/gconf-defaults.c hacked/defaults/gconf-defaults
|
|
|
|
|
*p = 0;
|
|
|
|
|
}
|
|
|
|
|
|
|
|
|
|
@@ -323,56 +315,158 @@
|
|
|
|
|
@@ -323,56 +315,158 @@ polkit_action_for_gconf_path (GConfDefau
|
|
|
|
|
return action;
|
|
|
|
|
}
|
|
|
|
|
|
|
|
|
@ -446,7 +447,7 @@ diff -u -r GConf-2.26.0/defaults/gconf-defaults.c hacked/defaults/gconf-defaults
|
|
|
|
|
}
|
|
|
|
|
|
|
|
|
|
static char *
|
|
|
|
|
@@ -398,11 +492,11 @@
|
|
|
|
|
@@ -398,11 +492,11 @@ gconf_address_for_caller (GConfDefaults
|
|
|
|
|
dbus_error_free (&error);
|
|
|
|
|
return NULL;
|
|
|
|
|
}
|
|
|
|
@ -461,7 +462,7 @@ diff -u -r GConf-2.26.0/defaults/gconf-defaults.c hacked/defaults/gconf-defaults
|
|
|
|
|
"Failed to get passwd information for uid %d", uid);
|
|
|
|
|
return NULL;
|
|
|
|
|
}
|
|
|
|
|
@@ -434,13 +528,13 @@
|
|
|
|
|
@@ -434,13 +528,13 @@ copy_tree (GConfClient *src,
|
|
|
|
|
GSList *list, *l;
|
|
|
|
|
GConfEntry *entry;
|
|
|
|
|
|
|
|
|
@ -477,7 +478,7 @@ diff -u -r GConf-2.26.0/defaults/gconf-defaults.c hacked/defaults/gconf-defaults
|
|
|
|
|
gconf_change_set_set (changes, entry->key, entry->value);
|
|
|
|
|
}
|
|
|
|
|
g_slist_foreach (list, (GFunc)gconf_entry_free, NULL);
|
|
|
|
|
@@ -461,7 +555,7 @@
|
|
|
|
|
@@ -461,7 +555,7 @@ copy_entry (GConfClient *src,
|
|
|
|
|
{
|
|
|
|
|
GConfValue *value;
|
|
|
|
|
|
|
|
|
@ -486,7 +487,7 @@ diff -u -r GConf-2.26.0/defaults/gconf-defaults.c hacked/defaults/gconf-defaults
|
|
|
|
|
return;
|
|
|
|
|
|
|
|
|
|
value = gconf_client_get (src, path, NULL);
|
|
|
|
|
@@ -471,69 +565,66 @@
|
|
|
|
|
@@ -471,69 +565,66 @@ copy_entry (GConfClient *src,
|
|
|
|
|
}
|
|
|
|
|
}
|
|
|
|
|
|
|
|
|
@ -598,7 +599,7 @@ diff -u -r GConf-2.26.0/defaults/gconf-defaults.c hacked/defaults/gconf-defaults
|
|
|
|
|
goto cleanup;
|
|
|
|
|
|
|
|
|
|
source = gconf_client_get_for_engine (engine);
|
|
|
|
|
@@ -542,45 +633,175 @@
|
|
|
|
|
@@ -542,45 +633,175 @@ do_copy (GConfDefaults *mechani
|
|
|
|
|
changes = gconf_change_set_new ();
|
|
|
|
|
|
|
|
|
|
/* recursively copy each include, leaving out the excludes */
|
|
|
|
@ -792,7 +793,7 @@ diff -u -r GConf-2.26.0/defaults/gconf-defaults.c hacked/defaults/gconf-defaults
|
|
|
|
|
}
|
|
|
|
|
|
|
|
|
|
static void
|
|
|
|
|
@@ -594,20 +815,13 @@
|
|
|
|
|
@@ -594,20 +815,13 @@ append_key (GConfChangeSet *cs,
|
|
|
|
|
g_ptr_array_add (keys, (gpointer) key);
|
|
|
|
|
}
|
|
|
|
|
|
|
|
|
@ -817,7 +818,7 @@ diff -u -r GConf-2.26.0/defaults/gconf-defaults.c hacked/defaults/gconf-defaults
|
|
|
|
|
keys = g_ptr_array_new ();
|
|
|
|
|
gconf_change_set_foreach (changes, append_key, keys);
|
|
|
|
|
g_ptr_array_add (keys, NULL);
|
|
|
|
|
@@ -615,7 +829,15 @@
|
|
|
|
|
@@ -615,7 +829,15 @@ gconf_defaults_set_system (GConfDefaults
|
|
|
|
|
g_signal_emit (mechanism, signals[SYSTEM_SET], 0, keys->pdata);
|
|
|
|
|
|
|
|
|
|
g_ptr_array_free (keys, TRUE);
|
|
|
|
@ -834,7 +835,7 @@ diff -u -r GConf-2.26.0/defaults/gconf-defaults.c hacked/defaults/gconf-defaults
|
|
|
|
|
}
|
|
|
|
|
|
|
|
|
|
void
|
|
|
|
|
@@ -624,7 +846,7 @@
|
|
|
|
|
@@ -624,7 +846,7 @@ gconf_defaults_set_mandatory (GConfDefau
|
|
|
|
|
const char **excludes,
|
|
|
|
|
DBusGMethodInvocation *context)
|
|
|
|
|
{
|
|
|
|
@ -843,7 +844,7 @@ diff -u -r GConf-2.26.0/defaults/gconf-defaults.c hacked/defaults/gconf-defaults
|
|
|
|
|
}
|
|
|
|
|
|
|
|
|
|
static void
|
|
|
|
|
@@ -636,13 +858,13 @@
|
|
|
|
|
@@ -636,13 +858,13 @@ unset_tree (GConfClient *dest,
|
|
|
|
|
GSList *list, *l;
|
|
|
|
|
GConfEntry *entry;
|
|
|
|
|
|
|
|
|
@ -859,7 +860,7 @@ diff -u -r GConf-2.26.0/defaults/gconf-defaults.c hacked/defaults/gconf-defaults
|
|
|
|
|
gconf_change_set_unset (changes, entry->key);
|
|
|
|
|
}
|
|
|
|
|
g_slist_foreach (list, (GFunc)gconf_entry_free, NULL);
|
|
|
|
|
@@ -654,25 +876,25 @@
|
|
|
|
|
@@ -654,25 +876,25 @@ unset_tree (GConfClient *dest,
|
|
|
|
|
g_slist_foreach (list, (GFunc)g_free, NULL);
|
|
|
|
|
g_slist_free (list);
|
|
|
|
|
}
|
|
|
|
@ -893,7 +894,7 @@ diff -u -r GConf-2.26.0/defaults/gconf-defaults.c hacked/defaults/gconf-defaults
|
|
|
|
|
{
|
|
|
|
|
GConfEngine *engine;
|
|
|
|
|
GConfClient *dest = NULL;
|
|
|
|
|
@@ -680,7 +902,7 @@
|
|
|
|
|
@@ -680,7 +902,7 @@ unset_in_db (GConfDefaults *mechanism,
|
|
|
|
|
int i;
|
|
|
|
|
|
|
|
|
|
engine = gconf_engine_get_local (address, error);
|
|
|
|
@ -902,7 +903,7 @@ diff -u -r GConf-2.26.0/defaults/gconf-defaults.c hacked/defaults/gconf-defaults
|
|
|
|
|
goto out;
|
|
|
|
|
|
|
|
|
|
dest = gconf_client_get_for_engine (engine);
|
|
|
|
|
@@ -706,48 +928,219 @@
|
|
|
|
|
@@ -706,48 +928,219 @@ out:
|
|
|
|
|
gconf_change_set_unref (changes);
|
|
|
|
|
}
|
|
|
|
|
|
|
|
|
@ -1150,10 +1151,10 @@ diff -u -r GConf-2.26.0/defaults/gconf-defaults.c hacked/defaults/gconf-defaults
|
|
|
|
|
+ do_check (mechanism, TRUE, includes, context);
|
|
|
|
|
+}
|
|
|
|
|
+
|
|
|
|
|
diff -u -r GConf-2.26.0/defaults/gconf-defaults.h hacked/defaults/gconf-defaults.h
|
|
|
|
|
--- GConf-2.26.0/defaults/gconf-defaults.h 2008-12-02 11:06:14.000000000 -0500
|
|
|
|
|
+++ hacked/defaults/gconf-defaults.h 2009-05-12 13:27:54.300540238 -0400
|
|
|
|
|
@@ -83,6 +83,14 @@
|
|
|
|
|
diff -up GConf-2.26.2/defaults/gconf-defaults.h.polkit1 GConf-2.26.2/defaults/gconf-defaults.h
|
|
|
|
|
--- GConf-2.26.2/defaults/gconf-defaults.h.polkit1 2009-05-14 11:13:40.000000000 -0400
|
|
|
|
|
+++ GConf-2.26.2/defaults/gconf-defaults.h 2009-06-09 21:07:45.474639261 -0400
|
|
|
|
|
@@ -83,6 +83,14 @@ void gconf_defaults_unset_mand
|
|
|
|
|
const char **excludes,
|
|
|
|
|
DBusGMethodInvocation *context);
|
|
|
|
|
|
|
|
|
@ -1168,10 +1169,10 @@ diff -u -r GConf-2.26.0/defaults/gconf-defaults.h hacked/defaults/gconf-defaults
|
|
|
|
|
G_END_DECLS
|
|
|
|
|
|
|
|
|
|
#endif /* GCONF_DEFAULTS_H */
|
|
|
|
|
diff -u -r GConf-2.26.0/defaults/gconf-defaults-main.c hacked/defaults/gconf-defaults-main.c
|
|
|
|
|
--- GConf-2.26.0/defaults/gconf-defaults-main.c 2008-12-02 11:06:14.000000000 -0500
|
|
|
|
|
+++ hacked/defaults/gconf-defaults-main.c 2009-05-12 13:37:59.046345548 -0400
|
|
|
|
|
@@ -122,6 +122,29 @@
|
|
|
|
|
diff -up GConf-2.26.2/defaults/gconf-defaults-main.c.polkit1 GConf-2.26.2/defaults/gconf-defaults-main.c
|
|
|
|
|
--- GConf-2.26.2/defaults/gconf-defaults-main.c.polkit1 2009-05-05 20:37:32.000000000 -0400
|
|
|
|
|
+++ GConf-2.26.2/defaults/gconf-defaults-main.c 2009-06-09 21:07:45.475644220 -0400
|
|
|
|
|
@@ -122,6 +122,29 @@ get_system_bus (void)
|
|
|
|
|
return bus;
|
|
|
|
|
}
|
|
|
|
|
|
|
|
|
@ -1201,7 +1202,7 @@ diff -u -r GConf-2.26.0/defaults/gconf-defaults-main.c hacked/defaults/gconf-def
|
|
|
|
|
int
|
|
|
|
|
main (int argc, char **argv)
|
|
|
|
|
{
|
|
|
|
|
@@ -130,6 +153,8 @@
|
|
|
|
|
@@ -130,6 +153,8 @@ main (int argc, char **argv)
|
|
|
|
|
DBusGProxy *bus_proxy;
|
|
|
|
|
DBusGConnection *connection;
|
|
|
|
|
int ret;
|
|
|
|
@ -1210,7 +1211,7 @@ diff -u -r GConf-2.26.0/defaults/gconf-defaults-main.c hacked/defaults/gconf-def
|
|
|
|
|
|
|
|
|
|
ret = 1;
|
|
|
|
|
|
|
|
|
|
@@ -139,8 +164,22 @@
|
|
|
|
|
@@ -139,8 +164,22 @@ main (int argc, char **argv)
|
|
|
|
|
dbus_g_thread_init ();
|
|
|
|
|
g_type_init ();
|
|
|
|
|
|
|
|
|
@ -1233,9 +1234,9 @@ diff -u -r GConf-2.26.0/defaults/gconf-defaults-main.c hacked/defaults/gconf-def
|
|
|
|
|
goto out;
|
|
|
|
|
}
|
|
|
|
|
|
|
|
|
|
diff -u -r GConf-2.26.0/defaults/gconf-defaults.xml hacked/defaults/gconf-defaults.xml
|
|
|
|
|
--- GConf-2.26.0/defaults/gconf-defaults.xml 2008-12-02 11:06:14.000000000 -0500
|
|
|
|
|
+++ hacked/defaults/gconf-defaults.xml 2009-05-12 13:18:12.873380233 -0400
|
|
|
|
|
diff -up GConf-2.26.2/defaults/gconf-defaults.xml.polkit1 GConf-2.26.2/defaults/gconf-defaults.xml
|
|
|
|
|
--- GConf-2.26.2/defaults/gconf-defaults.xml.polkit1 2009-05-14 11:13:40.000000000 -0400
|
|
|
|
|
+++ GConf-2.26.2/defaults/gconf-defaults.xml 2009-06-09 21:07:45.476638353 -0400
|
|
|
|
|
@@ -2,12 +2,12 @@
|
|
|
|
|
<node name="/">
|
|
|
|
|
<interface name="org.gnome.GConf.Defaults">
|
|
|
|
@ -1307,10 +1308,10 @@ diff -u -r GConf-2.26.0/defaults/gconf-defaults.xml hacked/defaults/gconf-defaul
|
|
|
|
|
+
|
|
|
|
|
</interface>
|
|
|
|
|
</node>
|
|
|
|
|
diff -u -r GConf-2.26.0/defaults/Makefile.am hacked/defaults/Makefile.am
|
|
|
|
|
--- GConf-2.26.0/defaults/Makefile.am 2009-02-16 13:17:44.000000000 -0500
|
|
|
|
|
+++ hacked/defaults/Makefile.am 2009-05-11 22:12:16.773368001 -0400
|
|
|
|
|
@@ -20,13 +20,13 @@
|
|
|
|
|
diff -up GConf-2.26.2/defaults/Makefile.am.polkit1 GConf-2.26.2/defaults/Makefile.am
|
|
|
|
|
--- GConf-2.26.2/defaults/Makefile.am.polkit1 2009-04-25 02:44:06.000000000 -0400
|
|
|
|
|
+++ GConf-2.26.2/defaults/Makefile.am 2009-06-09 21:07:45.478662799 -0400
|
|
|
|
|
@@ -20,13 +20,13 @@ INCLUDES = \
|
|
|
|
|
|
|
|
|
|
gconf_defaults_mechanism_LDADD = \
|
|
|
|
|
$(top_builddir)/gconf/libgconf-2.la \
|
|
|
|
@ -1326,7 +1327,7 @@ diff -u -r GConf-2.26.0/defaults/Makefile.am hacked/defaults/Makefile.am
|
|
|
|
|
|
|
|
|
|
dbus_services_in_files = org.gnome.GConf.Defaults.service.in
|
|
|
|
|
polkit_in_files = org.gnome.gconf.defaults.policy.in
|
|
|
|
|
@@ -41,9 +41,6 @@
|
|
|
|
|
@@ -41,9 +41,6 @@ dbus_conf_DATA = org.gnome.GConf.Default
|
|
|
|
|
@INTLTOOL_POLICY_RULE@
|
|
|
|
|
polkit_DATA = $(polkit_in_files:.policy.in=.policy)
|
|
|
|
|
|
|
|
|
|