Update to 2.0.0

epel9
Ankur Sinha (Ankur Sinha Gmail) 5 years ago
parent 04ddc85744
commit 9b308b2e7e
No known key found for this signature in database
GPG Key ID: F8D8C0BEBAC898BD

1
.gitignore vendored

@ -1,2 +1,3 @@
CharLS-1.0_beta.zip CharLS-1.0_beta.zip
/CharLS-source-1.0.zip /CharLS-source-1.0.zip
/CharLS-2.0.0.tar.gz

@ -1,21 +1,14 @@
Name: CharLS Name: CharLS
Version: 1.0 Version: 2.0.0
Release: 19%{?dist} Release: 1%{?dist}
Summary: An optimized implementation of the JPEG-LS standard Summary: An optimized implementation of the JPEG-LS standard
License: BSD License: BSD
URL: https://github.com/team-charls/charls URL: https://github.com/team-charls/charls
# CharLS uses an interactive download link that asks you to accept the Source0: https://github.com/team-charls/charls/archive/%{version}/%{name}-%{version}.tar.gz
# (BSD-like) license before obtaining the source code.
# You can find the download link at http://charls.codeplex.com/
Source0: CharLS-source-1.0.zip
Patch0: charls_add_cmake_install_target.patch
Patch1: charls_add_sharedlib_soname.patch
Patch2: charls_fix_tests.patch
BuildRequires: gcc BuildRequires: gcc
BuildRequires: gcc-c++ BuildRequires: gcc-c++
BuildRequires: cmake >= 2.6.0 BuildRequires: cmake >= 2.6.0
BuildRequires: dos2unix
%description %description
An optimized implementation of the JPEG-LS standard for loss less and An optimized implementation of the JPEG-LS standard for loss less and
@ -29,60 +22,52 @@ compression ratios, similar to JPEG 2000. JPEG-LS is more similar to the old
loss less JPEG than to JPEG 2000, but interestingly the two different techniques loss less JPEG than to JPEG 2000, but interestingly the two different techniques
result in vastly different performance characteristics. result in vastly different performance characteristics.
%prep %package devel
%setup -c -q Summary: Libraries and headers for CharLS
Requires: %{name}%{?_isa} = %{version}-%{release}
rm CharLS.vcproj %description devel
rm CharLS.sln CharLS Library Header Files and Link Libraries.
dos2unix *.h
dos2unix *.c*
dos2unix *.txt
%patch0 -p1 %prep
%patch1 -p1 %autosetup -n charls-%{version}
%patch2 -p1 rm CharLS*.sln* -v
%build %build
%cmake -DBUILD_SHARED_LIBS:BOOL=ON\ %cmake -DBUILD_SHARED_LIBS:BOOL=ON\
-Dcharls_BUILD_SHARED_LIBS:BOOL=ON\
-DCMAKE_BUILD_TYPE:STRING="Release"\ -DCMAKE_BUILD_TYPE:STRING="Release"\
-DCMAKE_VERBOSE_MAKEFILE=ON\ -DCMAKE_VERBOSE_MAKEFILE=ON\
-DBUILD_TESTING=ON . -DBUILD_TESTING=ON .
make %{?_smp_mflags} %make_build
%install %install
make install DESTDIR=$RPM_BUILD_ROOT %make_install
%check %check
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:. # Enter a key + enter to finish
ctest . echo "a" | ./charlstest
%ldconfig_scriptlets
%files %files
%license License.txt %license License.txt
%{_libdir}/*.so.* %{_libdir}/lib%{name}.so.2
%{_libdir}/lib%{name}.so.2.0
%package devel
Summary: Libraries and headers for CharLS
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
CharLS Library Header Files and Link Libraries.
%files devel %files devel
%dir %{_includedir}/%{name}/ %dir %{_includedir}/%{name}/
%{_includedir}/%{name}/* %{_includedir}/%{name}/*
%{_libdir}/*.so %{_libdir}/lib%{name}.so
%changelog %changelog
* Sun Jul 28 2019 Ankur Sinha <ankursinha AT fedoraproject DOT org> - 2.0.0-1
- Update to version 2.0.0
- Remove unneded patches
- Note: soname changes here
* Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0-19 * Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0-19
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

@ -1,24 +0,0 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8304f0d..88f0949 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,6 +12,11 @@ SET(CMAKE_CXX_FLAGS "-D NDEBUG -O3" )
ENDIF(CMAKE_COMPILER_IS_GNUCC)
ENDIF(NOT CMAKE_BUILD_TYPE)
+SET( charls_HEADERS "colortransform.h" "context.h" "decoderstrategy.h" "encoderstrategy.h" "interface.h"
+ "losslesstraits.h" "scan.h" "streams.h" "config.h" "contextrunmode.h" "defaulttraits.h"
+ "header.h" "lookuptable.h" "processline.h" "util.h" "publictypes.h"
+)
+
OPTION(charls_BUILD_SHARED_LIBS "Build CharLS with shared libraries." OFF)
SET(BUILD_SHARED_LIBS ${charls_BUILD_SHARED_LIBS})
@@ -21,3 +26,7 @@ add_library(CharLS header.cpp interface.cpp jpegls.cpp )
add_executable(charlstest test/main.cpp test/time.cpp test/util.cpp test/bitstreamdamage.cpp test/compliance.cpp test/performance.cpp test/dicomsamples.cpp)
target_link_libraries (charlstest CharLS)
+# Installs the header files into the {build_dir}/include/libcharls directory
+install(FILES ${charls_HEADERS} DESTINATION include/CharLS)
+
+

@ -1,36 +0,0 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 88f0949..c57ef72 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,8 +20,21 @@ SET( charls_HEADERS "colortransform.h" "context.h" "decoderstrategy.h" "encode
OPTION(charls_BUILD_SHARED_LIBS "Build CharLS with shared libraries." OFF)
SET(BUILD_SHARED_LIBS ${charls_BUILD_SHARED_LIBS})
-add_library(CharLS header.cpp interface.cpp jpegls.cpp )
+# Add soname to generated shared lib
+SET(CHARLS_LIB_MAJOR_VERSION 1)
+SET(CHARLS_LIB_MINOR_VERSION 0)
+
+IF(BUILD_SHARED_LIBS)
+ add_library(CharLS SHARED header.cpp interface.cpp jpegls.cpp
+ stdafx.cpp
+ )
+ set_target_properties( CharLS PROPERTIES
+ VERSION ${CHARLS_LIB_MAJOR_VERSION}.${CHARLS_LIB_MINOR_VERSION}
+ SOVERSION ${CHARLS_LIB_MAJOR_VERSION}
+ )
+
+ENDIF(BUILD_SHARED_LIBS)
add_executable(charlstest test/main.cpp test/time.cpp test/util.cpp test/bitstreamdamage.cpp test/compliance.cpp test/performance.cpp test/dicomsamples.cpp)
target_link_libraries (charlstest CharLS)
@@ -29,4 +42,8 @@ target_link_libraries (charlstest CharLS)
# Installs the header files into the {build_dir}/include/libcharls directory
install(FILES ${charls_HEADERS} DESTINATION include/CharLS)
+# Installs the target file (libCharLS.so) into the {build_dir}/lib directory
+install(TARGETS CharLS LIBRARY DESTINATION lib${LIB_SUFFIX})
+
+

@ -1,13 +0,0 @@
diff --git a/defaulttraits.h b/defaulttraits.h
index 5032f7d..734bcea 100644
--- a/defaulttraits.h
+++ b/defaulttraits.h
@@ -2,7 +2,7 @@
// (C) Jan de Vaan 2007-2010, all rights reserved. See the accompanying "License.txt" for licensed use.
//
-
+#include "header.h"
#ifndef CHARLS_DEFAULTTRAITS
#define CHARLS_DEFAULTTRAITS

@ -1,2 +1 @@
b364b6b56f474327ad186d8e6b8f740d CharLS-1.0_beta.zip SHA512 (CharLS-2.0.0.tar.gz) = 0a2862fad6d65b941c81f5f838db1fdc6a4625887281ddbf27e21be9084f607d27c8a27d246d6252e08358b2ed4aa0c2b7407048ca559fb40e94313ca72487dd
4694f02fbe2c4e1897ff2188d6e3cefc CharLS-source-1.0.zip

Loading…
Cancel
Save