Initial import.

f41
Jon Ciesla 13 years ago
parent 62e207256b
commit 759f852a9e

1
.gitignore vendored

@ -0,0 +1 @@
/Box2D_v2.2.1.zip

@ -0,0 +1,44 @@
--- CMakeLists.txt~ 2011-03-06 18:29:20.000000000 -0600
+++ CMakeLists.txt 2012-07-28 14:23:58.712181310 -0500
@@ -25,7 +25,7 @@
# Testbed and dependencies.
find_package(OpenGL REQUIRED)
- add_subdirectory(freeglut)
+# add_subdirectory(freeglut)
add_subdirectory(glui)
add_subdirectory(Testbed)
endif(BOX2D_BUILD_EXAMPLES)
--- Testbed/Framework/Render.cpp~ 2011-09-11 20:52:20.000000000 -0500
+++ Testbed/Framework/Render.cpp 2012-08-02 10:20:24.235457638 -0500
@@ -21,7 +21,7 @@
#ifdef __APPLE__
#include <GLUT/glut.h>
#else
- #include "freeglut/freeglut.h"
+ #include <GL/freeglut.h>
#endif
#include <cstdio>
--- Testbed/Tests/TestEntries.cpp~ 2011-09-11 23:55:26.000000000 -0500
+++ Testbed/Tests/TestEntries.cpp 2012-08-02 10:22:09.535455225 -0500
@@ -22,7 +22,7 @@
#ifdef __APPLE__
#include <GLUT/glut.h>
#else
- #include "freeglut/freeglut.h"
+ #include <GL/freeglut.h>
#endif
#include <cstring>
--- Testbed/CMakeLists.txt~ 2011-09-06 17:47:48.000000000 -0500
+++ Testbed/CMakeLists.txt 2012-08-02 10:26:16.954449762 -0500
@@ -85,7 +85,7 @@
target_link_libraries (
Testbed
Box2D
- freeglut_static
+# freeglut_static
glui
${ADDITIONAL_LIBRARIES}
${OPENGL_LIBRARIES}

@ -0,0 +1,52 @@
--- CMakeLists.txt~ 2012-08-02 10:08:39.000000000 -0500
+++ CMakeLists.txt 2012-08-02 10:09:28.467472258 -0500
@@ -26,7 +26,7 @@
# Testbed and dependencies.
find_package(OpenGL REQUIRED)
# add_subdirectory(freeglut)
- add_subdirectory(glui)
+# add_subdirectory(glui)
add_subdirectory(Testbed)
endif(BOX2D_BUILD_EXAMPLES)
--- Testbed/Framework/Main.cpp~ 2011-09-11 23:36:08.000000000 -0500
+++ Testbed/Framework/Main.cpp 2012-08-02 10:12:15.007468514 -0500
@@ -18,7 +18,7 @@
#include "Render.h"
#include "Test.h"
-#include "glui/glui.h"
+#include <GL/glui.h>
#include <cstdio>
using namespace std;
--- Testbed/Framework/Main.cpp~ 2012-08-02 10:12:47.000000000 -0500
+++ Testbed/Framework/Main.cpp 2012-08-02 10:18:30.138460153 -0500
@@ -19,6 +19,7 @@
#include "Render.h"
#include "Test.h"
#include <GL/glui.h>
+#include <GL/freeglut_ext.h>
#include <cstdio>
using namespace std;
--- Testbed/CMakeLists.txt~ 2012-08-02 10:26:16.000000000 -0500
+++ Testbed/CMakeLists.txt 2012-08-02 10:26:54.562448928 -0500
@@ -86,7 +86,7 @@
Testbed
Box2D
# freeglut_static
- glui
+# glui
${ADDITIONAL_LIBRARIES}
${OPENGL_LIBRARIES}
)
--- Testbed/CMakeLists.txt~ 2012-08-02 10:27:10.000000000 -0500
+++ Testbed/CMakeLists.txt 2012-08-02 10:32:25.082441562 -0500
@@ -1,5 +1,5 @@
# Some flags for Freeglut and GLUI.
-add_definitions( -DFREEGLUT_EXPORTS -DFREEGLUT_STATIC -D_CRT_SECURE_NO_WARNINGS )
+#add_definitions( -DFREEGLUT_EXPORTS -DFREEGLUT_STATIC -D_CRT_SECURE_NO_WARNINGS )
# Define the framework files.
set(Testbed_Framework_SRCS

@ -0,0 +1,85 @@
Name: Box2D
Version: 2.2.1
Release: 3%{?dist}
Summary: A 2D Physics Engine for Games
Group: Development/Libraries
License: zlib
URL: http://box2d.org/
#http://code.google.com/p/box2d/downloads
#Not using URL since I can't find one code.google.com will produce.
Source0: Box2D_v2.2.1.zip
Patch0: Box2D-2.2.1-unbundle-freeglut.patch
Patch1: Box2D-2.2.1-unbundle-glui.patch
BuildRequires: cmake freeglut-devel libXi-devel glui-devel
%package devel
Summary: Development files for %{name}
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
%description
Box2D is an open source C++ engine for simulating rigid bodies in 2D.
Box2D is developed by Erin Catto and has the zlib license.
While the zlib license does not require acknowledgement,
we encourage you to give credit to Box2D in your product.
%description devel
Box2D is an open source C++ engine for simulating rigid bodies in 2D.
Box2D is developed by Erin Catto and has the zlib license.
While the zlib license does not require acknowledgement,
we encourage you to give credit to Box2D in your product.
These are the development files.
%prep
%setup -qn Box2D_v2.2.1
%patch0 -p0 -b .freeglut
%patch1 -p0 -b .glui
rm -rf freeglut
rm -rf glui
%build
sed -i 's/\r//' License.txt
sed -i 's/\r//' Readme.txt
pushd Box2D
%cmake -DBOX2D_INSTALL=ON -DBOX2D_BUILD_SHARED=ON -DCMAKE_EXE_LINKER_FLAGS="-lglut -lglui -lGLU" ..
make
%install
pushd Box2D
make install DESTDIR=%{buildroot}
#ugly hack
%if %{__isa_bits} == 64
mv %{buildroot}/usr/lib %{buildroot}/usr/lib64
%endif
find %{buildroot} -name '*.cmake' | xargs rm
find %{buildroot} -name '*.a' | xargs rm
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%doc License.txt
%{_libdir}/*.so.*
%files devel
%doc Readme.txt Documentation/
%{_libdir}/*.so
%{_includedir}/Box2D
%changelog
* Mon Aug 06 2012 Jon Ciesla <limburgher@gmail.com> - 2.2.1-3
- Review fixes from BZ 844090 comment 6.
* Thu Aug 02 2012 Jon Ciesla <limburgher@gmail.com> - 2.2.1-2
- Unbundle freeglut and glui.
* Sat Jul 28 2012 Jon Ciesla <limburgher@gmail.com> - 2.2.1-1
- create.

@ -0,0 +1 @@
9e9d32a34fb5554c47f0f9cade0fa611 Box2D_v2.2.1.zip
Loading…
Cancel
Save