You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
Box2D/Box2D-2.2.1-unbundle-glui.p...

53 lines
1.6 KiB

--- CMakeLists.txt~ 2012-08-02 10:08:39.000000000 -0500
+++ CMakeLists.txt 2012-08-02 10:09:28.467472258 -0500
@@ -26,7 +26,7 @@
# Testbed and dependencies.
find_package(OpenGL REQUIRED)
# add_subdirectory(freeglut)
- add_subdirectory(glui)
+# add_subdirectory(glui)
add_subdirectory(Testbed)
endif(BOX2D_BUILD_EXAMPLES)
--- Testbed/Framework/Main.cpp~ 2011-09-11 23:36:08.000000000 -0500
+++ Testbed/Framework/Main.cpp 2012-08-02 10:12:15.007468514 -0500
@@ -18,7 +18,7 @@
#include "Render.h"
#include "Test.h"
-#include "glui/glui.h"
+#include <GL/glui.h>
#include <cstdio>
using namespace std;
--- Testbed/Framework/Main.cpp~ 2012-08-02 10:12:47.000000000 -0500
+++ Testbed/Framework/Main.cpp 2012-08-02 10:18:30.138460153 -0500
@@ -19,6 +19,7 @@
#include "Render.h"
#include "Test.h"
#include <GL/glui.h>
+#include <GL/freeglut_ext.h>
#include <cstdio>
using namespace std;
--- Testbed/CMakeLists.txt~ 2012-08-02 10:26:16.000000000 -0500
+++ Testbed/CMakeLists.txt 2012-08-02 10:26:54.562448928 -0500
@@ -86,7 +86,7 @@
Testbed
Box2D
# freeglut_static
- glui
+# glui
${ADDITIONAL_LIBRARIES}
${OPENGL_LIBRARIES}
)
--- Testbed/CMakeLists.txt~ 2012-08-02 10:27:10.000000000 -0500
+++ Testbed/CMakeLists.txt 2012-08-02 10:32:25.082441562 -0500
@@ -1,5 +1,5 @@
# Some flags for Freeglut and GLUI.
-add_definitions( -DFREEGLUT_EXPORTS -DFREEGLUT_STATIC -D_CRT_SECURE_NO_WARNINGS )
+#add_definitions( -DFREEGLUT_EXPORTS -DFREEGLUT_STATIC -D_CRT_SECURE_NO_WARNINGS )
# Define the framework files.
set(Testbed_Framework_SRCS