You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
zxing-cpp/0001-test-update-to-libfmt-...

43 lines
1.5 KiB

From 3872abbb33ebb8d6c891baff33778aae04f0c546 Mon Sep 17 00:00:00 2001
From: axxel <awagger@gmail.com>
Date: Tue, 26 Jul 2022 22:42:00 +0200
Subject: [PATCH] test: update to libfmt v9.0.0
---
test/blackbox/BlackboxTestRunner.cpp | 8 ++++----
test/blackbox/CMakeLists.txt | 2 +-
2 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/test/blackbox/BlackboxTestRunner.cpp b/test/blackbox/BlackboxTestRunner.cpp
index 7e126a62..85c5b9d4 100644
--- a/test/blackbox/BlackboxTestRunner.cpp
+++ b/test/blackbox/BlackboxTestRunner.cpp
@@ -158,8 +158,7 @@
auto folderName = directory.stem();
if (Size(imgPaths) != totalTests)
- fmt::print("TEST {} => Expected number of tests: {}, got: {} => FAILED\n", folderName, totalTests,
- imgPaths.size());
+ fmt::print("TEST {} => Expected number of tests: {}, got: {} => FAILED\n", folderName.string(), totalTests, imgPaths.size());
for (auto& test : tests) {
fmt::print("{:20} @ {:3}, {:3}", folderName.string(), test.rotation, Size(imgPaths));
@@ -234,7 +233,7 @@
}
if (Size(imageGroups) != totalTests)
- fmt::print("TEST {} => Expected number of tests: {}, got: {} => FAILED\n", folderName, totalTests,
+ fmt::print("TEST {} => Expected number of tests: {}, got: {} => FAILED\n", folderName.string(), totalTests,
imageGroups.size());
for (auto& test : tests) {
@@ -445,7 +444,7 @@
{ 17, 20, 0 },
{ 19, 20, 180 },
});
-
+
runTests("upca-extension-1", "UPC-A", 6, {
{ 3, 6, 0 },
{ 4, 6, 180 },