You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
zxing-cpp/zxing-cpp-1.2.0-system-pybi...

38 lines
1.6 KiB

diff -Naur zxing-cpp-1.2.0-original/wrappers/python/CMakeLists.txt zxing-cpp-1.2.0/wrappers/python/CMakeLists.txt
--- zxing-cpp-1.2.0-original/wrappers/python/CMakeLists.txt 2021-05-28 06:47:09.000000000 -0400
+++ zxing-cpp-1.2.0/wrappers/python/CMakeLists.txt 2021-12-13 20:31:22.286170793 -0500
@@ -1,8 +1,7 @@
cmake_minimum_required(VERSION 3.14)
project(ZXingPython)
-set (pybind11_git_repo https://github.com/pybind/pybind11.git)
-set (pybind11_git_rev v2.10.2)
+find_package(pybind11)
# check if we are called from the top-level ZXing project
get_directory_property(hasParent PARENT_DIRECTORY)
@@ -21,14 +20,8 @@
add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/../../core ZXing EXCLUDE_FROM_ALL)
include(${CMAKE_CURRENT_SOURCE_DIR}/../../zxing.cmake)
- zxing_add_package(pybind11 pybind11 ${pybind11_git_repo} ${pybind11_git_rev})
else()
# we don't have access to the top-level cmake helpers -> simply fetch it unconditional
- include(FetchContent)
- FetchContent_Declare (pybind11
- GIT_REPOSITORY ${pybind11_git_repo}
- GIT_TAG ${pybind11_git_rev})
- FetchContent_MakeAvailable (pybind11)
# Building from python source distribution (which does not include the whole repository but only python part)
# so we need to get c++ source git to build the python extension. The python distribution version (given in
@@ -54,8 +47,6 @@
add_subdirectory(${zxing-cpp_SOURCE_DIR}/core ZXing EXCLUDE_FROM_ALL)
endif()
endif()
-else()
- zxing_add_package(pybind11 pybind11 ${pybind11_git_repo} ${pybind11_git_rev})
endif()
# build the python module