You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
51 lines
1.3 KiB
51 lines
1.3 KiB
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index c64ccc1f..deae8efe 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -1,12 +1,7 @@
|
|
# CMake build script for ZeroMQ
|
|
+cmake_minimum_required(VERSION 3.5..3.27)
|
|
project(ZeroMQ)
|
|
|
|
-if(${CMAKE_SYSTEM_NAME} STREQUAL Darwin)
|
|
- cmake_minimum_required(VERSION 3.0.2)
|
|
-else()
|
|
- cmake_minimum_required(VERSION 2.8.12)
|
|
-endif()
|
|
-
|
|
include(CheckIncludeFiles)
|
|
include(CheckCCompilerFlag)
|
|
include(CheckCXXCompilerFlag)
|
|
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
|
|
index c1bda3bd..ce157c1e 100644
|
|
--- a/tests/CMakeLists.txt
|
|
+++ b/tests/CMakeLists.txt
|
|
@@ -1,10 +1,15 @@
|
|
# CMake build script for ZeroMQ tests
|
|
-cmake_minimum_required(VERSION "2.8.1")
|
|
+cmake_minimum_required(VERSION 3.5..3.27)
|
|
|
|
# On Windows: solution file will be called tests.sln
|
|
project(tests)
|
|
|
|
set(tests
|
|
+ test_bind_stream_fuzzer
|
|
+ test_bind_ws_fuzzer
|
|
+ test_connect_stream_fuzzer
|
|
+ test_connect_ws_fuzzer
|
|
+ test_socket_options_fuzzer
|
|
test_ancillaries
|
|
test_system
|
|
test_pair_inproc
|
|
diff --git a/unittests/CMakeLists.txt b/unittests/CMakeLists.txt
|
|
index 7132f00b..f76c3a1b 100644
|
|
--- a/unittests/CMakeLists.txt
|
|
+++ b/unittests/CMakeLists.txt
|
|
@@ -1,5 +1,5 @@
|
|
# CMake build script for ZeroMQ unit tests
|
|
-cmake_minimum_required(VERSION "2.8.1")
|
|
+cmake_minimum_required(VERSION 3.5..3.27)
|
|
|
|
set(unittests
|
|
unittest_ypipe
|