diff --git a/.gitignore b/.gitignore
index e69de29..3533efb 100644
--- a/.gitignore
+++ b/.gitignore
@@ -0,0 +1 @@
+zathura-0.0.8.1.tar.gz
diff --git a/sources b/sources
index e69de29..be4c6f1 100644
--- a/sources
+++ b/sources
@@ -0,0 +1 @@
+67351e5ab66cfdda9a71c9ce6c47a970  zathura-0.0.8.1.tar.gz
diff --git a/zathura-add-desktop-file.patch b/zathura-add-desktop-file.patch
new file mode 100644
index 0000000..fa7f50c
--- /dev/null
+++ b/zathura-add-desktop-file.patch
@@ -0,0 +1,13 @@
+diff -rU4 --new-file zathura-0.0.8.1-orig/zathura.desktop zathura-0.0.8.1/zathura.desktop
+--- zathura-0.0.8.1-orig/zathura.desktop	1970-01-01 01:00:00.000000000 +0100
++++ zathura-0.0.8.1/zathura.desktop	2010-08-15 00:28:25.955480839 +0200
+@@ -0,0 +1,9 @@
++[Desktop Entry]
++Version=1.0
++Type=Application
++Name=Zathura PDF Viewer
++Comment=Easy to use, keyboard-driven, Cairo-enabled PDF viewer
++TryExec=zathura
++Exec=zathura %F
++Categories=Office;GTK;Viewer;
++MimeType=application/pdf;
diff --git a/zathura-dso-buildfix.patch b/zathura-dso-buildfix.patch
new file mode 100644
index 0000000..895eb66
--- /dev/null
+++ b/zathura-dso-buildfix.patch
@@ -0,0 +1,14 @@
+diff -rU4 zathura-0.0.8.1-orig/config.mk zathura-0.0.8.1/config.mk
+--- zathura-0.0.8.1-orig/config.mk	2010-07-30 12:18:07.000000000 +0200
++++ zathura-0.0.8.1/config.mk	2010-08-10 15:11:29.707180315 +0200
+@@ -11,9 +11,9 @@
+ GTK_INC = $(shell pkg-config --cflags gtk+-2.0 poppler-glib)
+ GTK_LIB = $(shell pkg-config --libs gtk+-2.0 gthread-2.0 poppler-glib)
+ 
+ INCS = -I. -I/usr/include ${GTK_INC}
+-LIBS = -lc ${GTK_LIB} -lpthread
++LIBS = -lc ${GTK_LIB} -lpthread  -lm
+ 
+ # flags
+ CFLAGS += -std=c99 -pedantic -Wall -Wno-format-zero-length $(INCS)
+ 
diff --git a/zathura.spec b/zathura.spec
new file mode 100644
index 0000000..8287ae3
--- /dev/null
+++ b/zathura.spec
@@ -0,0 +1,76 @@
+
+Name:           zathura
+Version:        0.0.8.1
+Release:        5%{?dist}
+Summary:        A lightweight PDF viewer
+Group:          Applications/Publishing 
+License:        zlib
+URL:            http://zathura.pwmt.org/projects/zathura
+Source0:        http://zathura.pwmt.org/attachments/download/10/zathura-0.0.8.1.tar.gz
+Patch0:         zathura-dso-buildfix.patch
+Patch1:         zathura-add-desktop-file.patch
+BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires:  gdk-pixbuf-devel, gtk2-devel, poppler-glib-devel, cairo-devel, glib2-devel
+BuildRequires:  desktop-file-utils
+
+
+%description
+Zathura is a highly configurable and functional PDF viewer based on the Poppler
+rendering library and the GTK+ toolkit. The idea behind zathura is an
+application that provides a minimalist and space saving interface as well as
+an easy usage that mainly focuses on keyboard interaction.
+
+
+%prep
+%setup -q
+%patch0 -p1
+%patch1 -p1
+# don't rebuid at install time
+sed -ie "s/install:\ all/install:\ /g" Makefile
+
+
+%build
+export CFLAGS="%{optflags}"
+make debug
+mv zathura-debug zathura
+
+
+%install
+rm -rf %{buildroot}
+make DESTDIR=%{buildroot} install
+mkdir -p %{buildroot}%{_datadir}/applications
+install -m 644 zathura.desktop %{buildroot}%{_datadir}/applications/
+desktop-file-validate %{buildroot}/%{_datadir}/applications/%{name}.desktop
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%doc LICENSE README
+%{_bindir}/*
+%{_mandir}/man*/*
+%{_datadir}/applications/*
+
+
+%changelog
+* Sun Aug 15 2010 François Cami <fcami@fedoraproject.org> 0.0.8.1-5
+- switch to sed (Kevin Fenzi).
+- use desktop-file-validate on the desktop file (Kevin Fenzi).
+
+* Sun Aug 15 2010 François Cami <fcami@fedoraproject.org> 0.0.8.1-4
+- change zathura.desktop Version to 1.0.
+
+* Sat Aug 14 2010 François Cami <fcami@fedoraproject.org> 0.0.8.1-3
+- add CFLAGS (Kevin Fenzi).
+- use the debug target to generate the debuginfo rpm properly.
+- add zathura.desktop file and install it.
+
+* Sat Aug 14 2010 François Cami <fcami@fedoraproject.org> 0.0.8.1-2
+- fix licensing, thanks to Dennis Johnson's review.
+
+* Tue Aug 10 2010 François Cami <fcami@fedoraproject.org> 0.0.8.1-1
+- initial package.
+