parent
58c9eedf42
commit
34ae1734cf
@ -0,0 +1 @@
|
||||
SOURCES/zathura-pdf-mupdf-0.4.0.tar.xz
|
@ -0,0 +1 @@
|
||||
8ad67999272ba481327ec6d9031fb873a9d99f63 SOURCES/zathura-pdf-mupdf-0.4.0.tar.xz
|
@ -0,0 +1,84 @@
|
||||
From 10c8edffbf9b814bb95e74b04a6a1d7fb729b4b4 Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <10c8edffbf9b814bb95e74b04a6a1d7fb729b4b4.1644786121.git.mjg@fedoraproject.org>
|
||||
From: Michael J Gruber <mjg@fedoraproject.org>
|
||||
Date: Sun, 13 Feb 2022 22:00:59 +0100
|
||||
Subject: [PATCH] Revert "Rework detection of mupdf"
|
||||
|
||||
This reverts commit 49a85efb915bfed933d251f6074b807d0e1ef385.
|
||||
|
||||
On Fedora, neither pkconfig nor cmake find mupdf the way meson looks for
|
||||
it. Also, we don't mujs since mupdf builds against the in-tree copy.
|
||||
|
||||
Signed-off-by: Michael J Gruber <mjg@fedoraproject.org>
|
||||
---
|
||||
meson.build | 17 +++++------------
|
||||
meson_options.txt | 6 ++++++
|
||||
2 files changed, 11 insertions(+), 12 deletions(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index c8c19dc..07abdf5 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -19,7 +19,7 @@ zathura = dependency('zathura', version: '>=0.3.9')
|
||||
girara = dependency('girara-gtk3')
|
||||
glib = dependency('glib-2.0')
|
||||
cairo = dependency('cairo')
|
||||
-mupdf = dependency('mupdf', required: false)
|
||||
+mupdf = cc.find_library('mupdf')
|
||||
mupdfthird = cc.find_library('mupdf-third')
|
||||
|
||||
build_dependencies = [
|
||||
@@ -27,23 +27,17 @@ build_dependencies = [
|
||||
girara,
|
||||
glib,
|
||||
cairo,
|
||||
+ mupdf,
|
||||
+ mupdfthird
|
||||
]
|
||||
|
||||
-if not mupdf.found()
|
||||
- # normal build of mupdf
|
||||
- mupdf = cc.find_library('mupdf')
|
||||
- build_dependencies += [mupdf, mupdfthird]
|
||||
-else
|
||||
- # build from Debian's libmupdf-dev
|
||||
- build_dependencies += [mupdf, mupdfthird]
|
||||
-
|
||||
+if get_option('link-external')
|
||||
libjpeg = dependency('libjpeg')
|
||||
libjbig2dec = cc.find_library('jbig2dec')
|
||||
libopenjp2 = dependency('libopenjp2')
|
||||
gumbo = dependency('gumbo')
|
||||
tesseract = dependency('tesseract')
|
||||
leptonica = dependency('lept')
|
||||
- mujs = dependency('mujs')
|
||||
|
||||
build_dependencies += [
|
||||
libjpeg,
|
||||
@@ -51,8 +45,7 @@ else
|
||||
libopenjp2,
|
||||
gumbo,
|
||||
tesseract,
|
||||
- leptonica,
|
||||
- mujs
|
||||
+ leptonica
|
||||
]
|
||||
endif
|
||||
|
||||
diff --git a/meson_options.txt b/meson_options.txt
|
||||
index c8df610..db9d0c5 100644
|
||||
--- a/meson_options.txt
|
||||
+++ b/meson_options.txt
|
||||
@@ -1,3 +1,9 @@
|
||||
+option('link-external',
|
||||
+ type: 'boolean',
|
||||
+ value: false,
|
||||
+ description: 'Link external libraries required by mupdf.'
|
||||
+)
|
||||
+
|
||||
option('plugindir',
|
||||
type: 'string',
|
||||
value: '',
|
||||
--
|
||||
2.35.1.306.ga00bde9711
|
||||
|
@ -0,0 +1,236 @@
|
||||
# Desired jbig2dec header files and library version
|
||||
# Apparantly, jbig2dec complains even about newer versions.
|
||||
# Please update if needed.
|
||||
%global jbig2dec_version 0.19
|
||||
|
||||
Name: zathura-pdf-mupdf
|
||||
|
||||
Version: 0.4.0
|
||||
Release: 8%{?dist}
|
||||
Summary: PDF support for zathura via mupdf
|
||||
License: Zlib
|
||||
URL: https://pwmt.org/projects/%{name}/
|
||||
Source0: %{url}/download/%{name}-%{version}.tar.xz
|
||||
Patch1: 0001-Revert-Rework-detection-of-mupdf.patch
|
||||
|
||||
BuildRequires: binutils
|
||||
BuildRequires: cairo-devel
|
||||
# Needed to validate the desktop file
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: gcc
|
||||
BuildRequires: git-core
|
||||
BuildRequires: girara-devel
|
||||
BuildRequires: glib2-devel
|
||||
# Needed to validate appdata
|
||||
BuildRequires: libappstream-glib
|
||||
BuildRequires: libjpeg-turbo-devel
|
||||
BuildRequires: meson >= 0.43
|
||||
BuildRequires: mupdf-static >= 1.20
|
||||
BuildRequires: openjpeg2-devel
|
||||
BuildRequires: zathura-devel >= 0.3.9
|
||||
BuildRequires: gumbo-parser-devel
|
||||
BuildRequires: leptonica-devel
|
||||
BuildRequires: tesseract-devel
|
||||
Requires: zathura >= 0.3.9
|
||||
# Depend on exact versions like mupdf does
|
||||
# https://src.fedoraproject.org/rpms/mupdf/c/02d93ee0f097415aa095ffcea4d768e5f43fac91?branch=master
|
||||
BuildRequires: jbig2dec-devel = %{jbig2dec_version}
|
||||
BuildRequires: jbig2dec-libs = %{jbig2dec_version}
|
||||
Requires: jbig2dec-libs = %{jbig2dec_version}
|
||||
|
||||
# Old plugins used alternatives
|
||||
Conflicts: zathura-pdf-poppler < 0.2.9
|
||||
|
||||
%description
|
||||
This plugin adds PDF support to zathura using the mupdf rendering engine.
|
||||
|
||||
%prep
|
||||
%autosetup -S git -p1
|
||||
|
||||
%build
|
||||
%meson -Dlink-external=true
|
||||
%meson_build
|
||||
|
||||
%install
|
||||
%meson_install
|
||||
desktop-file-validate %{buildroot}/%{_datadir}/applications/*.desktop
|
||||
appstream-util validate-relax --nonet %{buildroot}%{_datadir}/metainfo/*.metainfo.xml
|
||||
|
||||
# Clean the old alternatives link
|
||||
%pre
|
||||
[ -L %{_libdir}/zathura/pdf.so ] && rm -f %{_libdir}/zathura/pdf.so || :
|
||||
|
||||
%files
|
||||
%license LICENSE
|
||||
%doc AUTHORS
|
||||
%{_libdir}/zathura/libpdf-mupdf.so
|
||||
%{_datadir}/applications/org.pwmt.zathura-pdf-mupdf.desktop
|
||||
%{_datadir}/metainfo/org.pwmt.zathura-pdf-mupdf.metainfo.xml
|
||||
|
||||
%changelog
|
||||
* Thu May 11 2023 Michael J Gruber <mjg@fedoraproject.org> - 0.4.0-8
|
||||
- build against mupdf 1.22.1
|
||||
|
||||
* Sat Apr 15 2023 Michael J Gruber <mjg@fedoraproject.org> - 0.4.0-7
|
||||
- build against mupdf 1.22.0
|
||||
|
||||
* Thu Apr 06 2023 Sandro Mani <manisandro@gmail.com> - 0.4.0-6
|
||||
- Rebuild (tesseract)
|
||||
|
||||
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.0-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Sat Dec 24 2022 Michael J Gruber <mjg@fedoraproject.org> - 0.4.0-4
|
||||
- SPDX migration
|
||||
|
||||
* Fri Dec 23 2022 Sandro Mani <manisandro@gmail.com> - 0.4.0-3
|
||||
- Rebuild (tesseract)
|
||||
|
||||
* Wed Dec 21 2022 Sandro Mani <manisandro@gmail.com> - 0.4.0-2
|
||||
- Rebuild (leptonica)
|
||||
|
||||
* Mon Nov 28 2022 Michael J Gruber <mjg@fedoraproject.org> - 0.4.0-1
|
||||
- Update to 0.4.0 (rhbz#2148751)
|
||||
|
||||
* Mon Nov 28 2022 Michael J Gruber <mjg@fedoraproject.org> - 0.3.9-2
|
||||
- build against mupdf 1.21.0
|
||||
|
||||
* Tue Aug 23 2022 Michael J Gruber <mjg@fedoraproject.org> - 0.3.9-1
|
||||
- Update to 0.3.9 (rhbz#2120429)
|
||||
|
||||
* Fri Aug 12 2022 Michael J Gruber <mjg@fedoraproject.org> - 0.3.8-8
|
||||
- build against mupdf 1.20.3
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.8-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Fri Jul 08 2022 Sandro Mani <manisandro@gmail.com> - 0.3.8-6
|
||||
- Rebuild (tesseract)
|
||||
|
||||
* Wed Jun 15 2022 Michael J Gruber <mjg@fedoraproject.org> - 0.3.8-5
|
||||
- build against mupdf 1.20.0
|
||||
|
||||
* Fri May 20 2022 Sandro Mani <manisandro@gmail.com> - 0.3.8-4
|
||||
- Rebuild for gdal-3.5.0 and/or openjpeg-2.5.0
|
||||
|
||||
* Wed Apr 13 2022 Ankur Sinha <ankursinha AT fedoraproject DOT org> - 0.3.8-2
|
||||
- merge https://src.fedoraproject.org/rpms/zathura-pdf-mupdf/pull-request/12
|
||||
- Remove upstreamed patch
|
||||
- Restore build with external libraries
|
||||
|
||||
* Sat Apr 02 2022 Ankur Sinha <ankursinha AT fedoraproject DOT org> - 0.3.8-1
|
||||
- update to latest release
|
||||
|
||||
* Thu Mar 10 2022 Sandro Mani <manisandro@gmail.com> - 0.3.7-7
|
||||
- Rebuild for tesseract 5.1.0
|
||||
|
||||
* Fri Feb 25 2022 Sandro Mani <manisandro@gmail.com> - 0.3.7-6
|
||||
- Rebuild (leptonica)
|
||||
|
||||
* Sat Jan 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.7-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Sun Dec 19 2021 Sandro Mani <manisandro@gmail.com> - 0.3.7-4
|
||||
- Rebuild (tesseract)
|
||||
|
||||
* Tue Dec 14 2021 Sandro Mani <manisandro@gmail.com> - 0.3.7-3
|
||||
- Rebuild (tesseract)
|
||||
|
||||
* Tue Oct 12 2021 Michael J Gruber <mjg@fedoraproject.org> - 0.3.7-2
|
||||
- rebuild for mupdf 1.19.0
|
||||
|
||||
* Sat Aug 28 2021 Ankur Sinha <ankursinha AT fedoraproject DOT org> - 0.3.7-1
|
||||
- merge PR from @mjg manually: https://src.fedoraproject.org/rpms/zathura-pdf-mupdf/pull-request/10#
|
||||
- Update to 0.3.7 (bz #1982324)
|
||||
- Remove upstreamed patch
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.6-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Wed Feb 24 2021 Michael J Gruber <mjg@fedoraproject.org> - 0.3.6-6
|
||||
- rebuild for mupdf CVE-2021-3407
|
||||
|
||||
* Thu Jan 28 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.6-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Fri Oct 09 2020 Michael J Gruber <mjg@fedoraproject.org> - 0.3.6-4
|
||||
- link against gumbo
|
||||
|
||||
* Thu Oct 08 2020 Michael J Gruber <mjg@fedoraproject.org> - 0.3.6-3
|
||||
- rebuild for mupdf 1.18.0
|
||||
|
||||
* Fri Sep 18 2020 Michael J Gruber <mjg@fedoraproject.org> - 0.3.6-2
|
||||
- rebuild with jbig2dec 0.19
|
||||
|
||||
* Mon Sep 07 2020 Ankur Sinha <ankursinha AT fedoraproject DOT org> - 0.3.6-1
|
||||
- Update to new release
|
||||
|
||||
* Tue Jul 28 2020 Ankur Sinha <ankursinha AT fedoraproject DOT org> - 0.3.5-4
|
||||
- Rebuild to require exact jgib2dec version
|
||||
- #1860987
|
||||
|
||||
* Sat May 16 2020 Michael J Gruber <mjg@fedoraproject.org> - 0.3.5-3
|
||||
- Adjust to mupdf 1.17
|
||||
|
||||
* Fri Jan 31 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.5-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Thu Nov 21 2019 Ankur Sinha <ankursinha AT fedoraproject DOT org> - 0.3.5-1
|
||||
- Update to 0.3.5
|
||||
|
||||
* Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.4-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Thu Nov 15 2018 Petr Šabata <contyk@redhat.com> - 0.3.4-1
|
||||
- 0.3.4 bump
|
||||
- Fixes rhbz#1645552
|
||||
|
||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Mon Apr 09 2018 Petr Šabata <contyk@redhat.com> - 0.3.3-1
|
||||
- 0.3.3 bump
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.1-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Tue Apr 04 2017 Petr Šabata <contyk@redhat.com> - 0.3.1-1
|
||||
- 0.3.1 bump
|
||||
- Don't link against the no longer provided libmupdfthird,
|
||||
see rhbz#1438824 for more info
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Wed Nov 16 2016 Petr Šabata <contyk@redhat.com> - 0.3.0-3
|
||||
- Rebuild against mujs-0-6.20161031gita0ceaf5
|
||||
|
||||
* Thu Sep 29 2016 Petr Šabata <contyk@redhat.com> - 0.3.0-2
|
||||
- Rebuild against mujs-0-5.20160921git5c337af
|
||||
|
||||
* Fri Feb 26 2016 Petr Šabata <contyk@redhat.com> - 0.3.0-1
|
||||
- 0.3.0 bump
|
||||
|
||||
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.8-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Mon Nov 16 2015 Petr Šabata <contyk@redhat.com> - 0.2.8-4
|
||||
- Rebuild with mujs-0-1.20150929git0827611
|
||||
|
||||
* Wed Jul 01 2015 Petr Šabata <contyk@redhat.com> - 0.2.8-3
|
||||
- Handle the desktop file properly
|
||||
|
||||
* Tue Jun 23 2015 Petr Šabata <contyk@redhat.com> - 0.2.8-2
|
||||
- Correct the %%files section
|
||||
|
||||
* Tue Jun 09 2015 Petr Šabata <contyk@redhat.com> - 0.2.8-1
|
||||
- Initial packaging
|
Loading…
Reference in new issue