diff --git a/index.html b/index.html
new file mode 100644
index 0000000..9fd6cf0
--- /dev/null
+++ b/index.html
@@ -0,0 +1,165 @@
+
+
+
+
+ youtube-dl: Download videos from YouTube.com
+
+
+
+youtube-dl: Download videos from YouTube.com
+
+What is it?
+
+youtube-dl is a small command-line program to download videos
+from YouTube.com. It requires the Python
+interpreter, version 2.4 or later, and it's not platform specific.
+It should work in your Unix box, in Windows or in Mac OS X. The latest version
+is 2008.01.24. It's licensed under the MIT License, which
+means you can modify it, redistribute it or use it however you like
+complying with a few simple conditions.
+
+I'll try to keep it updated if YouTube.com changes the way you access
+their videos. After all, it's a simple and short program. However, I can't
+guarantee anything. If you detect it stops working, check for new versions
+and/or inform me about the problem, indicating the program version you
+are using. If the program stops working and I can't solve the problem but
+you have a solution, I'd like to know it. If that happens and you feel you
+can maintain the program yourself, tell me. My contact information is
+at freshmeat.net.
+
+Thanks for all the feedback received so far. I'm glad people find my
+program useful.
+
+Related projects:
+metacafe-dl
+pornotube-dl
+
+
+Usage instructions
+
+In Windows, once you have installed the Python interpreter, save the
+program with the .py extension and put it somewhere in the PATH.
+Try to follow the
+guide to
+install youtube-dl under Windows XP.
+
+In Unix, download it, give it execution permission and copy it to one
+of the PATH directories (typically, /usr/local/bin).
+
+After that, you should be able to call it from the command line as
+youtube-dl or youtube-dl.py. I will use youtube-dl
+in the following examples. Usage instructions are easy. Use youtube-dl
+followed by a video URL or identifier. Example: youtube-dl
+"http://www.youtube.com/watch?v=foobar". The video will be saved
+to the file foobar.flv in that example. As YouTube.com
+videos are in Flash Video format, their extension should be flv.
+In Linux and other unices, video players using a recent version of
+ffmpeg can play them. That includes MPlayer, VLC, etc. Those two
+work under Windows and other platforms, but you could also get a
+specific FLV player of your taste.
+
+If you try to run the program and you receive an error message containing the
+keyword SyntaxError near the end, it means your Python interpreter
+is too old.
+
+More usage tips
+
+
+
+- You can change the file name of the video using the -o option, like in
+youtube-dl -o vid.flv "http://www.youtube.com/watch?v=foobar".
+
+- Some videos require an account to be downloaded, mostly because they're
+flagged as mature content. You can pass the program a username and password
+for a YouTube.com account with the -u and -p options, like youtube-dl
+-u myusername -p mypassword "http://www.youtube.com/watch?v=foobar".
+
+- The account data can also be read from the user .netrc file by indicating
+the -n or --netrc option. The machine name is youtube in that
+case.
+
+- The simulate mode (activated with -s or --simulate) can be used
+to just get the real video URL and use it with a download manager if you
+prefer that option.
+
+- The quiet mode (activated with -q or --quiet) can be used to
+supress all output messages. This allows, in systems featuring /dev/stdout
+and other similar special files, outputting the video data to standard output
+in order to pipe it to another program without interferences.
+
+- The program can be told to simply print the final video URL to standard
+output using the -g or --get-url option.
+
+- Combined with the above option, the -2 or --title-too option tells the
+program to print the video title too.
+
+- The default filename is video_id.flv. But you can also use the
+video title in the filename with the -t or --title option.
+
+- youtube-dl honors the http_proxy environment variable
+if you want to use a proxy. Set it to something like
+http://proxy.example.com:8080, and do not leave the http://
+prefix out.
+
+- You can get the program version by calling it as youtube-dl
+-v or youtube-dl --version.
+
+- For usage instructions, use youtube-dl -h or youtube-dl
+--help.
+
+- You can cancel the program at any time pressing Ctrl+C. It may print
+some error lines saying something about KeyboardInterrupt.
+That's ok.
+
+
+
+Download it
+
+Note that if you directly click on these hyperlinks, your web browser will
+most likely display the program contents. It's usually better to
+right-click on it and choose the appropriate option, normally called Save
+Target As or Save Link As, depending on the web browser you
+are using.
+
+2008.01.24
+
+ - MD5: 48a7df743398bbfdf2710962000886cb
+ - SHA1: 05ab118a157dbeedf7430d8445963c0340188c04
+ - SHA256: 6e98f3abfa79a038e578d45441bb6675ac6d4880bae4b801d5125e364e60d5c5
+
+
+Copyright © 2006-2007 Ricardo Garcia Gonzalez
+
+
diff --git a/youtube-dl b/youtube-dl
new file mode 100644
index 0000000..1aa6123
--- /dev/null
+++ b/youtube-dl
@@ -0,0 +1,387 @@
+#!/usr/bin/env python
+#
+# Copyright (c) 2006-2008 Ricardo Garcia Gonzalez
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
+# and/or sell copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice shall be included
+# in all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+# THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR
+# OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+# ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+# OTHER DEALINGS IN THE SOFTWARE.
+#
+# Except as contained in this notice, the name(s) of the above copyright
+# holders shall not be used in advertising or otherwise to promote the
+# sale, use or other dealings in this Software without prior written
+# authorization.
+#
+import getpass
+import httplib
+import math
+import netrc
+import optparse
+import os
+import re
+import socket
+import string
+import sys
+import time
+import urllib2
+
+# Global constants
+const_1k = 1024
+const_initial_block_size = 10 * const_1k
+const_epsilon = 0.0001
+const_timeout = 120
+
+const_video_url_str = 'http://www.youtube.com/watch?v=%s'
+const_video_url_re = re.compile(r'^((?:http://)?(?:\w+\.)?youtube\.com/(?:v/|(?:watch(?:\.php)?)?\?(?:.+&)?v=))?([0-9A-Za-z_-]+)(?(1)[&/].*)?$')
+const_login_url_str = 'http://www.youtube.com/login?next=/watch%%3Fv%%3D%s'
+const_login_post_str = 'current_form=loginForm&next=%%2Fwatch%%3Fv%%3D%s&username=%s&password=%s&action_login=Log+In'
+const_age_url_str = 'http://www.youtube.com/verify_age?next_url=/watch%%3Fv%%3D%s'
+const_age_post_str = 'next_url=%%2Fwatch%%3Fv%%3D%s&action_confirm=Confirm'
+const_url_t_param_re = re.compile(r', "t": "([^"]+)"')
+const_video_url_real_str = 'http://www.youtube.com/get_video?video_id=%s&t=%s'
+const_video_title_re = re.compile(r'YouTube - ([^<]*)', re.M | re.I)
+
+# Print error message, followed by standard advice information, and then exit
+def error_advice_exit(error_text):
+ sys.stderr.write('Error: %s.\n' % error_text)
+ sys.stderr.write('Try again several times. It may be a temporary problem.\n')
+ sys.stderr.write('Other typical problems:\n\n')
+ sys.stderr.write('* Video no longer exists.\n')
+ sys.stderr.write('* Video requires age confirmation but you did not provide an account.\n')
+ sys.stderr.write('* You provided the account data, but it is not valid.\n')
+ sys.stderr.write('* The connection was cut suddenly for some reason.\n')
+ sys.stderr.write('* YouTube changed their system, and the program no longer works.\n')
+ sys.stderr.write('\nTry to confirm you are able to view the video using a web browser.\n')
+ sys.stderr.write('Use the same video URL and account information, if needed, with this program.\n')
+ sys.stderr.write('When using a proxy, make sure http_proxy has http://host:port format.\n')
+ sys.stderr.write('Try again several times and contact me if the problem persists.\n')
+ sys.exit('\n')
+
+# Wrapper to create custom requests with typical headers
+def request_create(url, data=None):
+ retval = urllib2.Request(url)
+ if data is not None:
+ retval.add_data(data)
+ # Try to mimic Firefox, at least a little bit
+ retval.add_header('User-Agent', 'Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11')
+ retval.add_header('Accept-Charset', 'ISO-8859-1,utf-8;q=0.7,*;q=0.7')
+ retval.add_header('Accept', 'text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5')
+ retval.add_header('Accept-Language', 'en-us,en;q=0.5')
+ return retval
+
+# Perform a request, process headers and return response
+def perform_request(url, data=None):
+ request = request_create(url, data)
+ response = urllib2.urlopen(request)
+ return response
+
+# Conditional print
+def cond_print(str):
+ global cmdl_opts
+ if not (cmdl_opts.quiet or cmdl_opts.get_url):
+ sys.stdout.write(str)
+ sys.stdout.flush()
+
+# Title string normalization
+def title_string_norm(title):
+ title = ''.join((x in string.ascii_letters or x in string.digits) and x or ' ' for x in title)
+ title = '_'.join(title.split())
+ title = title.lower()
+ return title
+
+# Generic download step
+def download_step(return_data_flag, step_title, step_error, url, post_data=None):
+ try:
+ cond_print('%s... ' % step_title)
+ data = perform_request(url, post_data).read()
+ cond_print('done.\n')
+ if return_data_flag:
+ return data
+ return None
+
+ except (urllib2.URLError, ValueError, httplib.HTTPException, TypeError, socket.error):
+ cond_print('failed.\n')
+ error_advice_exit(step_error)
+
+ except KeyboardInterrupt:
+ sys.exit('\n')
+
+# Generic extract step
+def extract_step(step_title, step_error, regexp, data):
+ try:
+ cond_print('%s... ' % step_title)
+ match = regexp.search(data)
+
+ if match is None:
+ cond_print('failed.\n')
+ error_advice_exit(step_error)
+
+ extracted_data = match.group(1)
+ cond_print('done.\n')
+ return extracted_data
+
+ except KeyboardInterrupt:
+ sys.exit('\n')
+
+# Calculate new block size based on previous block size
+def new_block_size(before, after, bytes):
+ new_min = max(bytes / 2.0, 1.0)
+ new_max = max(bytes * 2.0, 1.0)
+ dif = after - before
+ if dif < const_epsilon:
+ return int(new_max)
+ rate = bytes / dif
+ if rate > new_max:
+ return int(new_max)
+ if rate < new_min:
+ return int(new_min)
+ return int(rate)
+
+# Get optimum 1k exponent to represent a number of bytes
+def optimum_k_exp(num_bytes):
+ global const_1k
+ if num_bytes == 0:
+ return 0
+ return long(math.log(num_bytes, const_1k))
+
+# Get optimum representation of number of bytes
+def format_bytes(num_bytes):
+ global const_1k
+ try:
+ exp = optimum_k_exp(num_bytes)
+ suffix = 'bkMGTPEZY'[exp]
+ if exp == 0:
+ return '%s%s' % (num_bytes, suffix)
+ converted = float(num_bytes) / float(const_1k**exp)
+ return '%.2f%s' % (converted, suffix)
+ except IndexError:
+ sys.exit('Error: internal error formatting number of bytes.')
+
+# Calculate ETA and return it in string format as MM:SS
+def calc_eta(start, now, total, current):
+ dif = now - start
+ if current == 0 or dif < const_epsilon:
+ return '--:--'
+ rate = float(current) / dif
+ eta = long((total - current) / rate)
+ (eta_mins, eta_secs) = divmod(eta, 60)
+ if eta_mins > 99:
+ return '--:--'
+ return '%02d:%02d' % (eta_mins, eta_secs)
+
+# Calculate speed and return it in string format
+def calc_speed(start, now, bytes):
+ dif = now - start
+ if bytes == 0 or dif < const_epsilon:
+ return 'N/A b'
+ return format_bytes(float(bytes) / dif)
+
+
+# Title string minimal transformation
+def title_string_touch(title):
+ return title.replace(os.sep, '%')
+
+# Create the command line options parser and parse command line
+cmdl_usage = 'usage: %prog [options] video_url'
+cmdl_version = '2008.01.24'
+cmdl_parser = optparse.OptionParser(usage=cmdl_usage, version=cmdl_version, conflict_handler='resolve')
+cmdl_parser.add_option('-h', '--help', action='help', help='print this help text and exit')
+cmdl_parser.add_option('-v', '--version', action='version', help='print program version and exit')
+cmdl_parser.add_option('-u', '--username', dest='username', metavar='USERNAME', help='account username')
+cmdl_parser.add_option('-p', '--password', dest='password', metavar='PASSWORD', help='account password')
+cmdl_parser.add_option('-o', '--output', dest='outfile', metavar='FILE', help='output video file name')
+cmdl_parser.add_option('-q', '--quiet', action='store_true', dest='quiet', help='activates quiet mode')
+cmdl_parser.add_option('-s', '--simulate', action='store_true', dest='simulate', help='do not download video')
+cmdl_parser.add_option('-t', '--title', action='store_true', dest='use_title', help='use title in file name')
+cmdl_parser.add_option('-l', '--literal', action='store_true', dest='use_literal', help='use literal title in file name')
+cmdl_parser.add_option('-n', '--netrc', action='store_true', dest='use_netrc', help='use .netrc authentication data')
+cmdl_parser.add_option('-g', '--get-url', action='store_true', dest='get_url', help='print final video URL only')
+cmdl_parser.add_option('-2', '--title-too', action='store_true', dest='get_title', help='used with -g, print title too')
+(cmdl_opts, cmdl_args) = cmdl_parser.parse_args()
+
+# Set socket timeout
+socket.setdefaulttimeout(const_timeout)
+
+# Get video URL
+if len(cmdl_args) != 1:
+ cmdl_parser.print_help()
+ sys.exit('\n')
+video_url_cmdl = cmdl_args[0]
+
+# Verify video URL format and convert to "standard" format
+video_url_mo = const_video_url_re.match(video_url_cmdl)
+if video_url_mo is None:
+ sys.exit('Error: URL does not seem to be a youtube video URL. If it is, report a bug.')
+video_url_id = video_url_mo.group(2)
+video_url = const_video_url_str % video_url_id
+
+# Check conflicting options
+if cmdl_opts.outfile is not None and (cmdl_opts.simulate or cmdl_opts.get_url):
+ sys.stderr.write('Warning: video file name given but will not be used.\n')
+
+if cmdl_opts.outfile is not None and (cmdl_opts.use_title or cmdl_opts.use_literal):
+ sys.exit('Error: using the video title conflicts with using a given file name.')
+
+if cmdl_opts.use_title and cmdl_opts.use_literal:
+ sys.exit('Error: cannot use title and literal title at the same time.')
+
+if cmdl_opts.quiet and cmdl_opts.get_url:
+ sys.exit('Error: cannot be quiet and print final URL at the same time.')
+
+# Incorrect option formatting
+if cmdl_opts.username is None and cmdl_opts.password is not None:
+ sys.exit('Error: password give but username is missing.')
+
+if cmdl_opts.use_netrc and (cmdl_opts.username is not None or cmdl_opts.password is not None):
+ sys.exit('Error: cannot use netrc and username/password at the same time.')
+
+if cmdl_opts.get_url is None and cmdl_opts.get_title is not None:
+ sys.exit('Error: getting title requires getting URL.')
+
+# Get account information if any
+account_username = None
+account_password = None
+
+if cmdl_opts.use_netrc:
+ try:
+ info = netrc.netrc().authenticators('youtube')
+ if info is None:
+ sys.exit('Error: no authenticators for machine youtube.')
+ account_username = info[0]
+ account_password = info[2]
+ except IOError:
+ sys.exit('Error: unable to read .netrc file.')
+ except netrc.NetrcParseError:
+ sys.exit('Error: unable to parse .netrc file.')
+else:
+ account_username = cmdl_opts.username
+ if account_username is not None:
+ if cmdl_opts.password is None:
+ account_password = getpass.getpass('Type YouTube password and press return: ')
+ else:
+ account_password = cmdl_opts.password
+
+# Get output file name
+if cmdl_opts.outfile is None:
+ video_filename = '%s.flv' % video_url_id
+else:
+ video_filename = cmdl_opts.outfile
+
+# Install cookie and proxy handlers
+urllib2.install_opener(urllib2.build_opener(urllib2.ProxyHandler()))
+urllib2.install_opener(urllib2.build_opener(urllib2.HTTPCookieProcessor()))
+
+# Log in and confirm age if needed
+if account_username is not None:
+ url = const_login_url_str % video_url_id
+ post = const_login_post_str % (video_url_id, account_username, account_password)
+ download_step(False, 'Logging in', 'unable to log in', url, post)
+
+ url = const_age_url_str % video_url_id
+ post = const_age_post_str % video_url_id
+ download_step(False, 'Confirming age', 'unable to confirm age', url, post)
+
+# Retrieve video webpage
+video_webpage = download_step(True, 'Retrieving video webpage', 'unable to retrieve video webpage', video_url)
+
+# Extract video title if needed
+if cmdl_opts.use_title or cmdl_opts.use_literal or cmdl_opts.get_title:
+ video_title = extract_step('Extracting video title', 'unable to extract video title', const_video_title_re, video_webpage)
+
+# Extract needed video URL parameters
+video_url_t_param = extract_step('Extracting URL "t" parameter', 'unable to extract URL "t" parameter', const_url_t_param_re, video_webpage)
+video_url_real = const_video_url_real_str % (video_url_id, video_url_t_param)
+
+# Rebuild filename if needed
+if cmdl_opts.use_title or cmdl_opts.use_literal:
+ if cmdl_opts.use_title:
+ prefix = title_string_norm(video_title)
+ else:
+ prefix = title_string_touch(video_title)
+ video_filename = '%s-%s.flv' % (prefix, video_url_id)
+
+# Check name
+if not video_filename.lower().endswith('.flv'):
+ sys.stderr.write('Warning: video file name does not end in .flv\n')
+
+# Retrieve video data
+try:
+ cond_print('Requesting video file... ')
+ video_data = perform_request(video_url_real)
+ cond_print('done.\n')
+ cond_print('Video data found at %s\n' % video_data.geturl())
+
+ if cmdl_opts.get_title:
+ print video_title
+
+ if cmdl_opts.get_url:
+ print video_data.geturl()
+
+ if cmdl_opts.simulate or cmdl_opts.get_url:
+ sys.exit()
+
+ try:
+ video_file = open(video_filename, 'wb')
+ except (IOError, OSError):
+ sys.exit('Error: unable to open "%s" for writing.' % video_filename)
+ try:
+ video_len = long(video_data.info()['Content-length'])
+ video_len_str = format_bytes(video_len)
+ except KeyError:
+ video_len = None
+ video_len_str = 'N/A'
+
+ byte_counter = 0
+ block_size = const_initial_block_size
+ start_time = time.time()
+ while True:
+ if video_len is not None:
+ percent = float(byte_counter) / float(video_len) * 100.0
+ percent_str = '%.1f' % percent
+ eta_str = calc_eta(start_time, time.time(), video_len, byte_counter)
+ else:
+ percent_str = '---.-'
+ eta_str = '--:--'
+ counter = format_bytes(byte_counter)
+ speed_str = calc_speed(start_time, time.time(), byte_counter)
+ cond_print('\rRetrieving video data: %5s%% (%8s of %s) at %8s/s ETA %s ' % (percent_str, counter, video_len_str, speed_str, eta_str))
+
+ before = time.time()
+ video_block = video_data.read(block_size)
+ after = time.time()
+ dl_bytes = len(video_block)
+ if dl_bytes == 0:
+ break
+ byte_counter += dl_bytes
+ video_file.write(video_block)
+ block_size = new_block_size(before, after, dl_bytes)
+
+ if video_len is not None and byte_counter != video_len:
+ error_advice_exit('server did not send the expected ammount of data')
+
+ video_file.close()
+ cond_print('done.\n')
+ cond_print('Video data saved to %s\n' % video_filename)
+
+except (urllib2.URLError, ValueError, httplib.HTTPException, TypeError, socket.error):
+ cond_print('failed.\n')
+ error_advice_exit('unable to download video data')
+
+except KeyboardInterrupt:
+ sys.exit('\n')
+
+# Finish
+sys.exit()
diff --git a/youtube-dl.spec b/youtube-dl.spec
new file mode 100644
index 0000000..80d0cd9
--- /dev/null
+++ b/youtube-dl.spec
@@ -0,0 +1,61 @@
+Name: youtube-dl
+Version: 2008.01.24
+Release: 1%{?dist}
+Summary: Small command-line program to download videos from YouTube
+Summary(pl): Tekstowy program do pobierania filmów z youtube.com
+Group: Applications/Multimedia
+License: MIT
+URL: http://www.arrakis.es/~rggi3/youtube-dl/
+Source0: http://www.arrakis.es/~rggi3/youtube-dl/youtube-dl
+Source1: http://www.arrakis.es/~rggi3/youtube-dl/index.html
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+Requires: python >= 2.4
+
+%description
+Small command-line program to download videos from YouTube.
+
+%description -l pl
+youtube-dl to mały tekstowy program służący do pobierania filmów z
+youtube.com.
+
+%prep
+cp %{SOURCE1} .
+
+%build
+#nothing to build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+mkdir -p $RPM_BUILD_ROOT%{_bindir}
+install -m 755 %{SOURCE0} $RPM_BUILD_ROOT%{_bindir}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-,root,root,-)
+%{_bindir}/%{name}
+%doc index.html
+
+%changelog
+* Sat Jan 26 2008 Krzysztof Kurzawski 2008.01.24-1
+- Update to v2008.01.24
+- Add polish summary and description.
+
+* Wed Jan 02 2008 Krzysztof Kurzawski 2007.10.12-5
+- Correct install.
+- Correct documentation.
+
+* Sat Dec 29 2007 Krzysztof Kurzawski 2007.10.12-4
+- Correct requires.
+- Add documentation.
+
+* Sun Dec 23 2007 Krzysztof Kurzawski 2007.10.12-3
+- Correct version tag.
+
+* Fri Dec 14 2007 Krzysztof Kurzawski 1-2
+- Update to v2007.10.12, correct license and update summary.
+
+* Sun Dec 9 2007 Krzysztof Kurzawski 1-1
+- First release