* Wed Dec 03 2008 Dominik Mierzejewski <rpm at greysector.net> - 1.2.0-1

- 1.2.0
- drop upstreamed noexec stack patch
- BR recent nasm instead of yasm
- licence seems to be just GPLv2+
- move TODO from main to -devel doc
- update summary and description
- small spec file fixes
el8
Dominik Mierzejewski 16 years ago
parent 6b05e11ba2
commit 8fb783091d

2
.gitignore vendored

@ -1 +1 @@
xvidcore-1.1.3.tar.bz2
xvidcore-1.2.0.tar.bz2

@ -1 +1 @@
29c60d4d991ac18f687a8fd13cfe64b7 xvidcore-1.1.3.tar.bz2
07c31ebf7d4e7aa6fcd17e8e4a0d1aca xvidcore-1.2.0.tar.bz2

@ -1,514 +0,0 @@
--- xvidcore-1.1.2/src/bitstream/x86_asm/cbp_3dne.asm~ 2007-02-15 09:57:50.000000000 +0100
+++ xvidcore-1.1.2/src/bitstream/x86_asm/cbp_3dne.asm 2007-02-15 09:57:50.000000000 +0100
@@ -123,3 +123,8 @@
ret
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/bitstream/x86_asm/cbp_mmx.asm~ 2007-02-15 09:57:50.000000000 +0100
+++ xvidcore-1.1.2/src/bitstream/x86_asm/cbp_mmx.asm 2007-02-15 09:57:50.000000000 +0100
@@ -148,3 +148,8 @@
ret
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/bitstream/x86_asm/cbp_sse2.asm~ 2007-02-15 09:57:50.000000000 +0100
+++ xvidcore-1.1.2/src/bitstream/x86_asm/cbp_sse2.asm 2007-02-15 09:57:50.000000000 +0100
@@ -140,3 +140,8 @@
ret
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/dct/x86_64_asm/fdct_mmx_skal.asm~ 2007-02-15 09:57:50.000000000 +0100
+++ xvidcore-1.1.2/src/dct/x86_64_asm/fdct_mmx_skal.asm 2007-02-15 09:57:50.000000000 +0100
@@ -461,3 +461,8 @@
;-----------------------------------------------------------------------------
MAKE_FDCT_FUNC fdct_skal_x86_64, fMTX_MULT_XMM
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/dct/x86_64_asm/idct_mmx.asm~ 2007-02-15 09:57:50.000000000 +0100
+++ xvidcore-1.1.2/src/dct/x86_64_asm/idct_mmx.asm 2007-02-15 09:57:50.000000000 +0100
@@ -523,3 +523,8 @@
ret
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/dct/x86_asm/fdct_mmx_ffmpeg.asm~ 2007-02-15 09:57:50.000000000 +0100
+++ xvidcore-1.1.2/src/dct/x86_asm/fdct_mmx_ffmpeg.asm 2007-02-15 09:57:50.000000000 +0100
@@ -422,3 +422,8 @@
;-----------------------------------------------------------------------------
MAKE_FDCT_FUNC fdct_xmm_ffmpeg, FDCT_ROW_XMM
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/dct/x86_asm/fdct_mmx_skal.asm~ 2007-02-15 09:57:50.000000000 +0100
+++ xvidcore-1.1.2/src/dct/x86_asm/fdct_mmx_skal.asm 2007-02-15 09:57:50.000000000 +0100
@@ -523,3 +523,8 @@
;-----------------------------------------------------------------------------
MAKE_FDCT_FUNC fdct_xmm_skal, fMTX_MULT_XMM
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/dct/x86_asm/fdct_sse2_skal.asm~ 2007-02-15 09:57:50.000000000 +0100
+++ xvidcore-1.1.2/src/dct/x86_asm/fdct_sse2_skal.asm 2007-02-15 09:57:50.000000000 +0100
@@ -620,3 +620,8 @@
ret
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/dct/x86_asm/idct_3dne.asm~ 2007-02-15 09:57:50.000000000 +0100
+++ xvidcore-1.1.2/src/dct/x86_asm/idct_3dne.asm 2007-02-15 09:57:50.000000000 +0100
@@ -720,3 +720,8 @@
ret
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/dct/x86_asm/idct_mmx.asm~ 2007-02-15 09:57:50.000000000 +0100
+++ xvidcore-1.1.2/src/dct/x86_asm/idct_mmx.asm 2007-02-15 09:57:50.000000000 +0100
@@ -630,3 +630,8 @@
ret
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/dct/x86_asm/idct_sse2_dmitry.asm~ 2007-02-15 09:57:50.000000000 +0100
+++ xvidcore-1.1.2/src/dct/x86_asm/idct_sse2_dmitry.asm 2007-02-15 09:57:50.000000000 +0100
@@ -345,3 +345,8 @@
ret
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/dct/x86_asm/simple_idct_mmx.asm~ 2007-02-15 09:57:50.000000000 +0100
+++ xvidcore-1.1.2/src/dct/x86_asm/simple_idct_mmx.asm 2007-02-15 09:57:50.000000000 +0100
@@ -1254,3 +1254,8 @@
ret
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/image/x86_64_asm/interpolate8x8_mmx.asm~ 2007-02-15 09:57:50.000000000 +0100
+++ xvidcore-1.1.2/src/image/x86_64_asm/interpolate8x8_mmx.asm 2007-02-15 09:57:50.000000000 +0100
@@ -706,4 +706,8 @@
pop rbx
ret
-.endfunc
\ No newline at end of file
+.endfunc
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/image/x86_64_asm/interpolate8x8_xmm.asm~ 2007-02-15 09:57:50.000000000 +0100
+++ xvidcore-1.1.2/src/image/x86_64_asm/interpolate8x8_xmm.asm 2007-02-15 09:57:50.000000000 +0100
@@ -704,3 +704,8 @@
EPILOG
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/image/x86_64_asm/qpel_mmx.asm~ 2007-02-15 09:57:50.000000000 +0100
+++ xvidcore-1.1.2/src/image/x86_64_asm/qpel_mmx.asm 2007-02-15 09:57:50.000000000 +0100
@@ -1152,3 +1152,8 @@
.endfunc
;//////////////////////////////////////////////////////////////////////
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/image/x86_asm/colorspace_rgb_mmx.asm~ 2007-02-15 09:57:50.000000000 +0100
+++ xvidcore-1.1.2/src/image/x86_asm/colorspace_rgb_mmx.asm 2007-02-15 09:57:50.000000000 +0100
@@ -429,3 +429,8 @@
MAKE_COLORSPACE yv12_to_bgr_mmx,48, 3,8,2, YV12_TO_BGR, 3, -1
MAKE_COLORSPACE yv12_to_bgra_mmx,48, 4,8,2, YV12_TO_BGR, 4, -1
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/image/x86_asm/colorspace_yuv_mmx.asm~ 2007-02-15 09:57:50.000000000 +0100
+++ xvidcore-1.1.2/src/image/x86_asm/colorspace_yuv_mmx.asm 2007-02-15 09:57:50.000000000 +0100
@@ -279,3 +279,8 @@
MAKE_YV12_TO_YV12 yv12_to_yv12_mmx, 0
MAKE_YV12_TO_YV12 yv12_to_yv12_xmm, 1
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/image/x86_asm/colorspace_yuyv_mmx.asm~ 2007-02-15 09:57:50.000000000 +0100
+++ xvidcore-1.1.2/src/image/x86_asm/colorspace_yuyv_mmx.asm 2007-02-15 09:57:50.000000000 +0100
@@ -329,3 +329,8 @@
MAKE_COLORSPACE yv12_to_yuyvi_mmx,0, 2,8,4, YV12_TO_YUYVI, 0, -1
MAKE_COLORSPACE yv12_to_uyvyi_mmx,0, 2,8,4, YV12_TO_YUYVI, 1, -1
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/image/x86_asm/interpolate8x8_3dn.asm~ 2007-02-15 09:57:50.000000000 +0100
+++ xvidcore-1.1.2/src/image/x86_asm/interpolate8x8_3dn.asm 2007-02-15 09:57:50.000000000 +0100
@@ -485,3 +485,8 @@
ret
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/image/x86_asm/interpolate8x8_3dne.asm~ 2007-02-15 09:57:50.000000000 +0100
+++ xvidcore-1.1.2/src/image/x86_asm/interpolate8x8_3dne.asm 2007-02-15 09:57:50.000000000 +0100
@@ -579,3 +579,8 @@
ret
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/image/x86_asm/interpolate8x8_mmx.asm~ 2007-02-15 09:57:50.000000000 +0100
+++ xvidcore-1.1.2/src/image/x86_asm/interpolate8x8_mmx.asm 2007-02-15 09:57:50.000000000 +0100
@@ -1367,3 +1367,8 @@
ret
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/image/x86_asm/interpolate8x8_xmm.asm~ 2007-02-15 09:57:50.000000000 +0100
+++ xvidcore-1.1.2/src/image/x86_asm/interpolate8x8_xmm.asm 2007-02-15 09:57:50.000000000 +0100
@@ -841,3 +841,8 @@
EPILOG
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/image/x86_asm/postprocessing_mmx.asm~ 2007-02-15 09:57:50.000000000 +0100
+++ xvidcore-1.1.2/src/image/x86_asm/postprocessing_mmx.asm 2007-02-15 09:57:50.000000000 +0100
@@ -124,3 +124,8 @@
ret
.endfunc
;//////////////////////////////////////////////////////////////////////
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/image/x86_asm/postprocessing_sse2.asm~ 2007-02-15 09:57:50.000000000 +0100
+++ xvidcore-1.1.2/src/image/x86_asm/postprocessing_sse2.asm 2007-02-15 09:57:50.000000000 +0100
@@ -140,3 +140,8 @@
ret
.endfunc
;//////////////////////////////////////////////////////////////////////
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/image/x86_asm/qpel_mmx.asm~ 2007-02-15 09:57:51.000000000 +0100
+++ xvidcore-1.1.2/src/image/x86_asm/qpel_mmx.asm 2007-02-15 09:57:51.000000000 +0100
@@ -1060,3 +1060,8 @@
.endfunc
;//////////////////////////////////////////////////////////////////////
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/image/x86_asm/reduced_mmx.asm~ 2007-02-15 09:57:51.000000000 +0100
+++ xvidcore-1.1.2/src/image/x86_asm/reduced_mmx.asm 2007-02-15 09:57:51.000000000 +0100
@@ -1002,3 +1002,8 @@
; pfeewwww... Never Do That On Stage Again. :)
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/motion/x86_64_asm/sad_mmx.asm~ 2007-02-15 09:57:51.000000000 +0100
+++ xvidcore-1.1.2/src/motion/x86_64_asm/sad_mmx.asm 2007-02-15 09:57:51.000000000 +0100
@@ -162,4 +162,8 @@
;; All done
ret
-.endfunc
\ No newline at end of file
+.endfunc
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/motion/x86_64_asm/sad_xmm.asm~ 2007-02-15 09:57:51.000000000 +0100
+++ xvidcore-1.1.2/src/motion/x86_64_asm/sad_xmm.asm 2007-02-15 09:57:51.000000000 +0100
@@ -439,4 +439,8 @@
movd eax, mm7
pop rbx
ret
-.endfunc
\ No newline at end of file
+.endfunc
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/motion/x86_asm/sad_3dn.asm~ 2007-02-15 09:57:51.000000000 +0100
+++ xvidcore-1.1.2/src/motion/x86_asm/sad_3dn.asm 2007-02-15 09:57:51.000000000 +0100
@@ -228,3 +228,8 @@
ret
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/motion/x86_asm/sad_3dne.asm~ 2007-02-15 09:57:51.000000000 +0100
+++ xvidcore-1.1.2/src/motion/x86_asm/sad_3dne.asm 2007-02-15 09:57:51.000000000 +0100
@@ -502,3 +502,8 @@
ret
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/motion/x86_asm/sad_mmx.asm~ 2007-02-15 09:57:51.000000000 +0100
+++ xvidcore-1.1.2/src/motion/x86_asm/sad_mmx.asm 2007-02-15 09:57:51.000000000 +0100
@@ -747,3 +747,8 @@
ret
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/motion/x86_asm/sad_sse2.asm~ 2007-02-15 09:57:51.000000000 +0100
+++ xvidcore-1.1.2/src/motion/x86_asm/sad_sse2.asm 2007-02-15 09:57:51.000000000 +0100
@@ -170,3 +170,8 @@
ret
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/motion/x86_asm/sad_xmm.asm~ 2007-02-15 09:57:51.000000000 +0100
+++ xvidcore-1.1.2/src/motion/x86_asm/sad_xmm.asm 2007-02-15 09:57:51.000000000 +0100
@@ -444,3 +444,8 @@
ret
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/quant/x86_64_asm/quantize_h263_mmx.asm~ 2007-02-15 09:57:51.000000000 +0100
+++ xvidcore-1.1.2/src/quant/x86_64_asm/quantize_h263_mmx.asm 2007-02-15 09:57:51.000000000 +0100
@@ -505,3 +505,8 @@
xor rax, rax
ret
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/quant/x86_64_asm/quantize_mpeg_xmm.asm~ 2007-02-15 09:57:51.000000000 +0100
+++ xvidcore-1.1.2/src/quant/x86_64_asm/quantize_mpeg_xmm.asm 2007-02-15 09:57:51.000000000 +0100
@@ -807,4 +807,8 @@
xor rax, rax
ret
-.endfunc
\ No newline at end of file
+.endfunc
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/quant/x86_asm/quantize_h263_3dne.asm~ 2007-02-15 09:57:51.000000000 +0100
+++ xvidcore-1.1.2/src/quant/x86_asm/quantize_h263_3dne.asm 2007-02-15 09:57:51.000000000 +0100
@@ -784,3 +784,8 @@
ret
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/quant/x86_asm/quantize_h263_mmx.asm~ 2007-02-15 09:57:51.000000000 +0100
+++ xvidcore-1.1.2/src/quant/x86_asm/quantize_h263_mmx.asm 2007-02-15 09:57:51.000000000 +0100
@@ -1039,3 +1039,8 @@
ret
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/quant/x86_asm/quantize_mpeg_mmx.asm~ 2007-02-15 09:57:51.000000000 +0100
+++ xvidcore-1.1.2/src/quant/x86_asm/quantize_mpeg_mmx.asm 2007-02-15 09:57:51.000000000 +0100
@@ -750,3 +750,8 @@
ret
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/quant/x86_asm/quantize_mpeg_xmm.asm~ 2007-02-15 09:57:51.000000000 +0100
+++ xvidcore-1.1.2/src/quant/x86_asm/quantize_mpeg_xmm.asm 2007-02-15 09:57:51.000000000 +0100
@@ -815,3 +815,8 @@
ret
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/utils/x86_64_asm/cpuid.asm~ 2007-02-15 09:57:51.000000000 +0100
+++ xvidcore-1.1.2/src/utils/x86_64_asm/cpuid.asm 2007-02-15 09:57:51.000000000 +0100
@@ -216,3 +216,8 @@
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/utils/x86_64_asm/interlacing_mmx.asm~ 2007-02-15 09:57:51.000000000 +0100
+++ xvidcore-1.1.2/src/utils/x86_64_asm/interlacing_mmx.asm 2007-02-15 09:57:51.000000000 +0100
@@ -212,3 +212,8 @@
ret
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/utils/x86_64_asm/mem_transfer_mmx.asm~ 2007-02-15 09:57:51.000000000 +0100
+++ xvidcore-1.1.2/src/utils/x86_64_asm/mem_transfer_mmx.asm 2007-02-15 09:57:51.000000000 +0100
@@ -434,3 +434,8 @@
COPY_8_TO_8
ret
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/utils/x86_asm/cpuid.asm~ 2007-02-15 09:57:51.000000000 +0100
+++ xvidcore-1.1.2/src/utils/x86_asm/cpuid.asm 2007-02-15 09:57:51.000000000 +0100
@@ -226,3 +226,8 @@
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/utils/x86_asm/interlacing_mmx.asm~ 2007-02-15 09:57:51.000000000 +0100
+++ xvidcore-1.1.2/src/utils/x86_asm/interlacing_mmx.asm 2007-02-15 09:57:51.000000000 +0100
@@ -217,3 +217,8 @@
ret
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/utils/x86_asm/mem_transfer_3dne.asm~ 2007-02-15 09:57:51.000000000 +0100
+++ xvidcore-1.1.2/src/utils/x86_asm/mem_transfer_3dne.asm 2007-02-15 09:57:51.000000000 +0100
@@ -459,3 +459,8 @@
ret
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+
--- xvidcore-1.1.2/src/utils/x86_asm/mem_transfer_mmx.asm~ 2007-02-15 09:57:51.000000000 +0100
+++ xvidcore-1.1.2/src/utils/x86_asm/mem_transfer_mmx.asm 2007-02-15 09:57:51.000000000 +0100
@@ -568,3 +568,8 @@
ret
.endfunc
+
+%ifidn __OUTPUT_FORMAT__,elf
+section ".note.GNU-stack" noalloc noexec nowrite progbits
+%endif
+

@ -0,0 +1,21 @@
diff -up xvidcore/src/xvid.c.r xvidcore/src/xvid.c
--- xvidcore/src/xvid.c.r 2008-11-30 17:38:31.000000000 +0100
+++ xvidcore/src/xvid.c 2008-12-03 00:47:15.000000000 +0100
@@ -27,6 +27,9 @@
#include <stdlib.h>
#include <string.h>
#include <time.h>
+#ifndef _WIN32
+#include <unistd.h>
+#endif
#include "xvid.h"
#include "decoder.h"
@@ -675,7 +678,6 @@ xvid_gbl_info(xvid_gbl_info_t * info)
#else
- #include <unistd.h>
info->num_threads = sysconf(_SC_NPROCESSORS_CONF);
#endif

@ -1,38 +1,43 @@
Name: xvidcore
Version: 1.1.3
Release: 4%{?dist}
Summary: Free reimplementation of the OpenDivX video codec
Version: 1.2.0
Release: 1%{?dist}
Summary: MPEG-4 Simple and Advanced Simple Profile codec
Group: System Environment/Libraries
License: XVID (GPL with specific restrictions)
License: GPLv2+
URL: http://www.xvid.org/
Source0: http://downloads.xvid.org/downloads/xvidcore-%{version}.tar.bz2
Patch0: %{name}-noexecstack.patch
Patch0: %{name}-rpm.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
%ifarch %{ix86} x86_64
BuildRequires: yasm
BuildRequires: nasm >= 2.0
%endif
%description
Free reimplementation of the OpenDivX video codec. You can play OpenDivX
and DivX4 videos with it, as well as encode compatible files.
The Xvid video codec implements MPEG-4 Simple Profile and Advanced Simple
Profile standards. It permits compressing and decompressing digital video
in order to reduce the required bandwidth of video data for transmission
over computer networks or efficient storage on CDs or DVDs. Due to its
unrivalled quality Xvid has gained great popularity and is used in many
other GPLed applications, like e.g. Transcode, MEncoder, MPlayer, Xine and
many more.
%package devel
Summary: Development files for the XviD video codec
Summary: Development files for the Xvid video codec
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
%description devel
This package contains header files, static library and API
documentation for the XviD video codec.
documentation for the Xvid video codec.
%prep
%setup -q
%patch0 -p1 -b .noexec
%setup -q -n %{name}
%patch0 -p1 -b .r
chmod -x examples/*.pl
f=AUTHORS ; iconv -f iso-8859-1 -t utf-8 -o $f.utf8 $f ; mv $f.utf8 $f
f=AUTHORS ; iconv -f iso-8859-1 -t utf-8 -o $f.utf8 $f && touch -r $f $f.utf8 && mv $f.utf8 $f
# Yes, we want to see the build output.
%{__perl} -pi -e 's/^\t@(?!echo\b)/\t/' build/generic/Makefile
@ -48,7 +53,7 @@ cd -
%install
rm -rf $RPM_BUILD_ROOT
make -C build/generic install DESTDIR=$RPM_BUILD_ROOT
rm -f $RPM_BUILD_ROOT%{_libdir}/libxvidcore.a
rm $RPM_BUILD_ROOT%{_libdir}/libxvidcore.a
cd $RPM_BUILD_ROOT%{_libdir}
chmod 755 libxvidcore.so*
/sbin/ldconfig -n .
@ -67,17 +72,26 @@ rm -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root,-)
%doc LICENSE README AUTHORS ChangeLog TODO
%doc LICENSE README AUTHORS ChangeLog
%{_libdir}/libxvidcore.so.*
%files devel
%defattr(-,root,root,-)
%doc CodingStyle examples/
%doc CodingStyle TODO examples/
%{_includedir}/xvid.h
%{_libdir}/libxvidcore.so
%changelog
* Wed Dec 03 2008 Dominik Mierzejewski <rpm at greysector.net> - 1.2.0-1
- 1.2.0
- drop upstreamed noexec stack patch
- BR recent nasm instead of yasm
- licence seems to be just GPLv2+
- move TODO from main to -devel doc
- update summary and description
- small spec file fixes
* Sun Aug 03 2008 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info - 1.1.3-4
- rebuild

Loading…
Cancel
Save