diff --git a/parse-readme.py b/parse-readme.py
index 0baff3c..3a5d140 100755
--- a/parse-readme.py
+++ b/parse-readme.py
@@ -1,61 +1,61 @@
#!/usr/bin/python3
# -*- coding: utf-8 -*-
#
-# Copyright (C) 2016 Richard Hughes
+# Copyright (C) 2021 Simone Caronni
# Licensed under the GNU General Public License Version or later
-from __future__ import print_function
import sys
def main():
- if len(sys.argv) != 3:
- print("usage: %s README.txt \"header to match\"" % sys.argv[0])
+ if len(sys.argv) != 2:
+ print("usage: %s README.txt" % sys.argv[0])
return 1
- # open file
f = open(sys.argv[1])
in_section = False
in_table = False
pids = []
- for line in f.readlines():
-
- # find the right data table
- if line.find(sys.argv[2]) != -1:
- in_section = True
- continue
- if not in_section:
- continue
-
- # remove Windows and Linux line endings
- line = line.replace('\r', '')
- line = line.replace('\n', '')
-
- # end of section
- if len(line) > 0 and not line.startswith(' '):
- in_section = False
- in_table = False
- continue
-
- # empty line
- if len(line) == 0:
- continue
-
- # skip the header
- if line.startswith(' ---'):
- in_table = True
- continue
- if not in_table:
- continue
-
- # get name
- pid = int(line[42:46], 16)
- if not pid in pids:
- pids.append(pid)
-
- # output
+ sections = ["NVIDIA GEFORCE GPUS", "NVIDIA RTX/QUADRO GPUS", "NVIDIA NVS GPUS", "NVIDIA TESLA GPUS", "NVIDIA GRID GPUS"]
+ for section in sections:
+
+ for line in f.readlines():
+
+ # Find the right data tables
+ if line.find(section) != -1:
+ in_section = True
+ continue
+ if not in_section:
+ continue
+
+ # Remove Windows and Linux line endings
+ line = line.replace('\r', '')
+ line = line.replace('\n', '')
+
+ # End of section
+ if len(line) > 0 and not line.startswith(' '):
+ in_section = False
+ in_table = False
+ continue
+
+ if len(line) == 0:
+ continue
+
+ # Skip the header
+ if line.startswith(' ---'):
+ in_table = True
+ continue
+ if not in_table:
+ continue
+
+ # PCI ID
+ pid = int(line[50:54], 16)
+ if not pid in pids:
+ pids.append(pid)
+
for pid in pids:
vid = 0x10de
print("pci:v%08Xd%08Xsv*sd*bc*sc*i*" % (vid, pid))
if __name__ == "__main__":
main()
+
diff --git a/xorg-x11-drv-nvidia.metainfo.xml b/xorg-x11-drv-nvidia.metainfo.xml
index 9c8248a..858cc5c 100644
--- a/xorg-x11-drv-nvidia.metainfo.xml
+++ b/xorg-x11-drv-nvidia.metainfo.xml
@@ -17,20 +17,32 @@
graphics driver supports all modern NVIDIA GPUs.
-
http://www.nvidia.com/
/usr/share/pixmaps/xorg-x11-drv-nvidia.png
CC0-1.0
LicenseRef-proprietary:NVIDIA
NVIDIA Corporation
- NVIDIA
- driver
- GeForce
CUDA
+ GeForce
+ NVIDIA
+ OpenGL
Quadro
+ Tesla
+ Video
Vulkan
- OpenGL
+ av1
+ avc
+ driver
+ h264
+ h265
+ hevc
+ jpeg
+ mpeg2
+ vaapi
+ vc-1
+ vp8
+ vp9
https://bugzilla.rpmfusion.org
xorg-x11-drv-nvidia-owner@rpmfusion.org
diff --git a/xorg-x11-drv-nvidia.spec b/xorg-x11-drv-nvidia.spec
index 18db718..1b92612 100644
--- a/xorg-x11-drv-nvidia.spec
+++ b/xorg-x11-drv-nvidia.spec
@@ -22,7 +22,7 @@
Name: xorg-x11-drv-nvidia
Epoch: 3
Version: 465.24.02
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: NVIDIA's proprietary display driver for NVIDIA graphic cards
License: Redistributable, no modification permitted
@@ -332,11 +332,7 @@ EOF
# install AppData and add modalias provides
mkdir -p %{buildroot}%{_metainfodir}/
install -pm 0644 %{SOURCE8} %{buildroot}%{_metainfodir}/
-#fn=%{buildroot}%{_datadir}/appdata/xorg-x11-drv-nvidia.metainfo.xml
-#%{SOURCE9} README.txt "NVIDIA GEFORCE GPUS" | xargs appstream-util add-provide ${fn} modalias
-#%{SOURCE9} README.txt "NVIDIA RTX/QUADRO GPUS" | xargs appstream-util add-provide ${fn} modalias
-#%{SOURCE9} README.txt "NVIDIA NVS GPUS" | xargs appstream-util add-provide ${fn} modalias
-#%{SOURCE9} README.txt "NVIDIA TESLA GPUS" | xargs appstream-util add-provide ${fn} modalias
+%{SOURCE9} README.txt | xargs appstream-util add-provide %{buildroot}%{_metainfodir}/xorg-x11-drv-nvidia.metainfo.xml modalias
mkdir -p %{buildroot}%{_datadir}/pixmaps
install -pm 0644 nvidia-settings.png %{buildroot}%{_datadir}/pixmaps/%{name}.png
%endif
@@ -531,6 +527,9 @@ fi ||:
%{_libdir}/libnvidia-encode.so
%changelog
+* Thu Apr 15 2021 Leigh Scott - 3:465.24.02-2
+- Update AppStream metadata generation
+
* Wed Apr 14 2021 Leigh Scott - 3:465.24.02-1
- Update to 465.24.02 release