You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
xdotool/xdotool-20090330-prefix.patch

21 lines
777 B

diff -up xdotool-20090330/Makefile.orig xdotool-20090330/Makefile
--- xdotool-20090330/Makefile.orig 2009-05-29 15:56:05.000000000 +0200
+++ xdotool-20090330/Makefile 2009-05-29 15:57:47.000000000 +0200
@@ -1,4 +1,4 @@
-PREFIX?=/usr/local
+PREFIX?=/usr
INSTALLBIN?=$(PREFIX)/bin
INSTALLMAN?=$(PREFIX)/man
@@ -10,8 +10,8 @@ WARNFLAGS+=-pedantic -Wall -W -Wundef \
CFLAGS=-pipe -std=c99 $(WARNFLAGS)
-DEFAULT_LIBS=-L/usr/X11R6/lib -L/usr/local/lib -lX11 -lXtst
-DEFAULT_INC=-I/usr/X11R6/include -I/usr/local/include
+DEFAULT_LIBS=-L/usr/X11R6/lib -L/usr/lib -lX11 -lXtst
+DEFAULT_INC=-I/usr/X11R6/include -I/usr/include
LIBS=`pkg-config --libs x11 xtst 2> /dev/null || echo "$(DEFAULT_LIBS)"`
INC=`pkg-config --cflags x11 xtst 2> /dev/null || echo "$(DEFAULT_INC)"`