quick fix for arm builds

rdtsc is an x86 assembly instruction to read the processors

https://www.spinics.net/lists/fedora-devel/msg224266.html
el8
Sérgio M. Basto 7 years ago
parent 02291ab9e6
commit fd9b4d23ce

@ -42,3 +42,18 @@ diff -up x265_2.2/source/CMakeLists.txt.orig x265_2.2/source/CMakeLists.txt
else()
message(STATUS "CMAKE_SYSTEM_PROCESSOR value `${CMAKE_SYSTEM_PROCESSOR}` is unknown")
message(STATUS "Please add this value near ${CMAKE_CURRENT_LIST_FILE}:${CMAKE_CURRENT_LIST_LINE}")
--- x265_v2.6/source/test/testharness.h.orig 2017-12-30 22:27:49.827620181 +0000
+++ x265_v2.6/source/test/testharness.h 2017-12-30 22:30:53.239500941 +0000
@@ -70,9 +70,10 @@ protected:
#include <intrin.h>
#elif (!defined(__APPLE__) && (defined (__GNUC__) && (defined(__x86_64__) || defined(__i386__))))
#include <x86intrin.h>
-#elif ( !defined(__APPLE__) && defined (__GNUC__) && defined(__ARM_NEON__))
-#include <arm_neon.h>
#elif defined(__GNUC__)
+#if ( !defined(__APPLE__) && defined(__ARM_NEON__))
+#include <arm_neon.h>
+#endif
/* fallback for older GCC/MinGW */
static inline uint32_t __rdtsc(void)
{

Loading…
Cancel
Save