- fix building as PIC
- update SO version in file list
el8
Dominik 'Rathann' Mierzejewski 9 years ago
parent 7d6654ca70
commit 6ae556a6f7

@ -0,0 +1,24 @@
diff -up x265_1.8/source/CMakeLists.txt.pic x265_1.8/source/CMakeLists.txt
--- x265_1.8/source/CMakeLists.txt.pic 2015-09-22 10:10:07.000000000 +0200
+++ x265_1.8/source/CMakeLists.txt 2015-10-25 22:43:12.666153586 +0100
@@ -158,7 +162,7 @@ if(GCC)
add_definitions(-Wall -Wextra -Wshadow)
add_definitions(-D__STDC_LIMIT_MACROS=1)
if(ENABLE_PIC)
- add_definitions(-fPIC)
+ add_definitions(-fPIC -DPIC)
endif(ENABLE_PIC)
if(NATIVE_BUILD)
if(INTEL_CXX)
diff -up x265_1.8/source/test/checkasm-a.asm.pic x265_1.8/source/test/checkasm-a.asm
--- x265_1.8/source/test/checkasm-a.asm.pic 2015-09-22 10:10:07.000000000 +0200
+++ x265_1.8/source/test/checkasm-a.asm 2015-10-25 23:23:45.041877640 +0100
@@ -154,7 +154,7 @@ cglobal checkasm_call, 2,15,16,max_args*
mov r9, rax
mov r10, rdx
lea r0, [error_message]
- call puts
+ call puts wrt ..plt
mov r1, [rsp+max_args*8]
mov dword [r1], 0
mov rdx, r10

@ -6,6 +6,8 @@ URL: http://x265.org/
Source0: http://ftp.videolan.org/pub/videolan/x265/x265_%{version}.tar.gz
# link test binaries with shared library
Patch1: x265-test-shared.patch
# fix building as PIC
Patch2: x265-pic.patch
Patch4: x265-detect_cpu_armhfp.patch
# source/Lib/TLibCommon - BSD
# source/Lib/TLibEncoder - BSD
@ -45,11 +47,13 @@ This package contains the shared library development files.
%prep
%setup -q -n x265_%{version}
%patch1 -p1 -b .ts
%patch2 -p1 -b .pic
%patch4 -p1 -b .armhfp
%build
%cmake -G "Unix Makefiles" \
-DCMAKE_SKIP_RPATH:BOOL=YES \
-DCMAKE_POSITION_INDEPENDENT_CODE:BOOL=ON \
-DENABLE_PIC:BOOL=ON \
-DENABLE_TESTS:BOOL=ON \
source
@ -73,7 +77,7 @@ LD_LIBRARY_PATH=%{buildroot}%{_libdir} test/TestBench || :
%files libs
%dir %{_pkgdocdir}
%{_pkgdocdir}/COPYING
%{_libdir}/libx265.so.51
%{_libdir}/libx265.so.68
%files devel
%doc doc/*
@ -83,6 +87,10 @@ LD_LIBRARY_PATH=%{buildroot}%{_libdir} test/TestBench || :
%{_libdir}/pkgconfig/x265.pc
%changelog
* Sun Oct 25 2015 Dominik Mierzejewski <rpm@greysector.net> 1.8-2
- fix building as PIC
- update SO version in file list
* Sat Oct 24 2015 Nicolas Chauvet <kwizart@gmail.com> - 1.8-1
- Update to 1.8
- Avoid tests for now

Loading…
Cancel
Save