enable NUMA support

make sure Fedora compiler flags are used on ARM
el8
Dominik Mierzejewski 9 years ago
parent 64bad5316d
commit 3542971166

@ -1,7 +1,7 @@
diff -up x265_1.8/source/CMakeLists.txt.armhfp x265_1.8/source/CMakeLists.txt
--- x265_1.8/source/CMakeLists.txt.armhfp 2015-09-22 10:10:07.000000000 +0200
+++ x265_1.8/source/CMakeLists.txt 2015-10-24 12:17:17.675572785 +0200
@@ -57,9 +57,13 @@ elseif(POWERMATCH GREATER "-1")
diff -up x265_1.9/source/CMakeLists.txt.armhfp x265_1.9/source/CMakeLists.txt
--- x265_1.9/source/CMakeLists.txt.armhfp 2016-07-19 03:10:51.163733946 +0200
+++ x265_1.9/source/CMakeLists.txt 2016-07-19 03:13:15.638665651 +0200
@@ -59,9 +59,12 @@ elseif(POWERMATCH GREATER "-1")
set(POWER 1)
add_definitions(-DX265_ARCH_POWER=1)
elseif(${SYSPROC} STREQUAL "armv6l")
@ -11,7 +11,6 @@ diff -up x265_1.8/source/CMakeLists.txt.armhfp x265_1.8/source/CMakeLists.txt
add_definitions(-DX265_ARCH_ARM=1 -DHAVE_ARMV6=1)
+elseif(${SYSPROC} STREQUAL "armv7l")
+ message(STATUS "Detected ARMv7 system processor")
+ set(ARM 1)
+ add_definitions(-DX265_ARCH_ARM=1 -DHAVE_ARMV7=1)
else()
message(STATUS "CMAKE_SYSTEM_PROCESSOR value `${CMAKE_SYSTEM_PROCESSOR}` is unknown")

@ -1,7 +1,7 @@
Summary: H.265/HEVC encoder
Name: x265
Version: 1.9
Release: 1%{?dist}
Release: 2%{?dist}
URL: http://x265.org/
Source0: https://ftp.videolan.org/pub/videolan/x265/x265_%{version}.tar.gz
# link test binaries with shared library
@ -14,6 +14,9 @@ Patch4: x265-detect_cpu_armhfp.patch
# everything else - GPLv2+
License: GPLv2+ and BSD
BuildRequires: cmake
%ifnarch armv7hl armv7hnl s390 s390x
BuildRequires: numactl-devel
%endif
BuildRequires: yasm
%description
@ -87,6 +90,11 @@ LD_LIBRARY_PATH=%{buildroot}%{_libdir} test/TestBench || :
%{_libdir}/pkgconfig/x265.pc
%changelog
* Tue Jul 19 2016 Dominik Mierzejewski <rpm@greysector.net> - 1.9-2
- use https for source URL
- enable NUMA support
- make sure Fedora compiler flags are used on ARM
* Fri Apr 08 2016 Adrian Reber <adrian@lisas.de> - 1.9-1
- Update to 1.9

Loading…
Cancel
Save