You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
x264/x264-shared.patch

35 lines
1.1 KiB

diff -up x264-20100620/configure.shared x264-20100620/configure
--- x264-20100620/configure.shared 2010-06-20 00:13:02.000000000 +0200
+++ x264-20100620/configure 2010-06-20 00:13:31.000000000 +0200
@@ -686,7 +686,7 @@ if [ "$shared" = "yes" ]; then
echo "SONAME=libx264.so.$API" >> config.mak
echo 'SOFLAGS=-Wl,-soname,$(SONAME)' >> config.mak
fi
- echo 'default: $(SONAME)' >> config.mak
+ echo 'default: libx264.a $(SONAME)' >> config.mak
fi
cat version.h >> config.h
diff -up x264-20100620/Makefile.shared x264-20100620/Makefile
--- x264-20100620/Makefile.shared 2010-06-20 00:12:43.000000000 +0200
+++ x264-20100620/Makefile 2010-06-20 00:13:02.000000000 +0200
@@ -109,6 +109,9 @@ ifneq ($(SONAME),)
ifeq ($(SYS),MINGW)
SRCSO += x264dll.c
endif
+LIB=$(SONAME)
+else
+LIB=libx264.a
endif
OBJS = $(SRCS:%.c=%.o)
@@ -127,7 +130,7 @@ libx264.a: .depend $(OBJS) $(OBJASM)
$(SONAME): .depend $(OBJS) $(OBJASM) $(OBJSO)
$(CC) -shared -o $@ $(OBJS) $(OBJASM) $(OBJSO) $(SOFLAGS) $(LDFLAGS)
-x264$(EXE): $(OBJCLI) libx264.a
+x264$(EXE): $(OBJCLI) $(LIB)
$(CC) -o $@ $+ $(LDFLAGS) $(LDFLAGSCLI)
checkasm: tools/checkasm.o libx264.a