- 20100116 snapshot (SO version bump) - don't remove config.h and don't re-run version.sh - link x264 binary to the shared library - really don't strip if debug is enabledel8
parent
52839d7d15
commit
c80312f9fe
@ -1 +1 @@
|
||||
x264-20091026.tar.bz2
|
||||
x264-20100116.tar.bz2
|
||||
|
@ -1 +1 @@
|
||||
1a2a758b237859391d802e9b9ffe2ce9 x264-20091026.tar.bz2
|
||||
e3e2f2150f240dfaf5abfb1832bb23d7 x264-20100116.tar.bz2
|
||||
|
@ -0,0 +1,12 @@
|
||||
diff -up x264-20100116/configure.nostrip x264-20100116/configure
|
||||
--- x264-20100116/configure.nostrip 2010-01-16 13:19:59.000000000 +0100
|
||||
+++ x264-20100116/configure 2010-01-16 13:40:39.000000000 +0100
|
||||
@@ -491,6 +491,8 @@ fi
|
||||
if [ "$debug" != "yes" -a "$gprof" != "yes" ]; then
|
||||
CFLAGS="$CFLAGS -s -fomit-frame-pointer"
|
||||
LDFLAGS="$LDFLAGS -s"
|
||||
+else
|
||||
+ STRIP="/bin/true"
|
||||
fi
|
||||
|
||||
if [ "$debug" = "yes" ]; then
|
@ -0,0 +1,21 @@
|
||||
diff -up x264-20100116/configure.nover x264-20100116/configure
|
||||
--- x264-20100116/configure.nover 2010-01-16 13:45:48.000000000 +0100
|
||||
+++ x264-20100116/configure 2010-01-16 13:46:41.000000000 +0100
|
||||
@@ -44,7 +44,7 @@ die() {
|
||||
exit 1
|
||||
}
|
||||
|
||||
-rm -f config.h config.mak x264.pc conftest*
|
||||
+rm -f config.mak x264.pc conftest*
|
||||
|
||||
prefix='/usr/local'
|
||||
exec_prefix='${prefix}'
|
||||
@@ -560,8 +562,6 @@ if [ "$shared" = "yes" ]; then
|
||||
echo 'default: $(SONAME)' >> config.mak
|
||||
fi
|
||||
|
||||
-./version.sh
|
||||
-
|
||||
pclibs="-L$libdir -lx264 $libpthread"
|
||||
|
||||
cat > x264.pc << EOF
|
@ -0,0 +1,34 @@
|
||||
diff -up x264-20100116/configure.shared x264-20100116/configure
|
||||
--- x264-20100116/configure.shared 2010-01-16 13:48:11.000000000 +0100
|
||||
+++ x264-20100116/configure 2010-01-16 13:53:15.000000000 +0100
|
||||
@@ -559,7 +559,7 @@ if [ "$shared" = "yes" ]; then
|
||||
echo "SONAME=libx264.so.$API" >> config.mak
|
||||
echo 'SOFLAGS=-Wl,-soname,$(SONAME)' >> config.mak
|
||||
fi
|
||||
- echo 'default: $(SONAME)' >> config.mak
|
||||
+ echo 'default: libx264.a $(SONAME)' >> config.mak
|
||||
fi
|
||||
|
||||
pclibs="-L$libdir -lx264 $libpthread"
|
||||
diff -up x264-20100116/Makefile.shared x264-20100116/Makefile
|
||||
--- x264-20100116/Makefile.shared 2010-01-16 13:45:48.000000000 +0100
|
||||
+++ x264-20100116/Makefile 2010-01-16 13:52:55.000000000 +0100
|
||||
@@ -105,6 +105,9 @@ ifneq ($(SONAME),)
|
||||
ifeq ($(SYS),MINGW)
|
||||
SRCSO += x264dll.c
|
||||
endif
|
||||
+LIB=$(SONAME)
|
||||
+else
|
||||
+LIB=libx264.a
|
||||
endif
|
||||
|
||||
OBJS = $(SRCS:%.c=%.o)
|
||||
@@ -123,7 +126,7 @@ libx264.a: .depend $(OBJS) $(OBJASM)
|
||||
$(SONAME): .depend $(OBJS) $(OBJASM) $(OBJSO)
|
||||
$(CC) -shared -o $@ $(OBJS) $(OBJASM) $(OBJSO) $(SOFLAGS) $(LDFLAGS)
|
||||
|
||||
-x264$(EXE): $(OBJCLI) libx264.a
|
||||
+x264$(EXE): $(OBJCLI) $(LIB)
|
||||
$(CC) -o $@ $+ $(LDFLAGS) $(LDFLAGSCLI)
|
||||
|
||||
checkasm: tools/checkasm.o libx264.a
|
Loading…
Reference in new issue