- push forgotten rebased patch

el8
Dominik Mierzejewski 14 years ago
parent 0ca4aad657
commit af3a0eebe1

@ -1,7 +1,7 @@
diff -up x264-20100620/configure.shared x264-20100620/configure
--- x264-20100620/configure.shared 2010-06-20 00:13:02.000000000 +0200
+++ x264-20100620/configure 2010-06-20 00:13:31.000000000 +0200
@@ -686,7 +686,7 @@ if [ "$shared" = "yes" ]; then
diff -up x264-20101211/configure.shared x264-20101211/configure
--- x264-20101211/configure.shared 2010-12-11 19:47:37.000000000 +0100
+++ x264-20101211/configure 2010-12-11 19:48:05.000000000 +0100
@@ -796,7 +796,7 @@ if [ "$shared" = "yes" ]; then
echo "SONAME=libx264.so.$API" >> config.mak
echo 'SOFLAGS=-Wl,-soname,$(SONAME)' >> config.mak
fi
@ -10,10 +10,10 @@ diff -up x264-20100620/configure.shared x264-20100620/configure
fi
cat version.h >> config.h
diff -up x264-20100620/Makefile.shared x264-20100620/Makefile
--- x264-20100620/Makefile.shared 2010-06-20 00:12:43.000000000 +0200
+++ x264-20100620/Makefile 2010-06-20 00:13:02.000000000 +0200
@@ -109,6 +109,9 @@ ifneq ($(SONAME),)
diff -up x264-20101211/Makefile.shared x264-20101211/Makefile
--- x264-20101211/Makefile.shared 2010-12-11 19:46:33.000000000 +0100
+++ x264-20101211/Makefile 2010-12-11 19:47:37.000000000 +0100
@@ -124,6 +124,9 @@ ifneq ($(SONAME),)
ifeq ($(SYS),MINGW)
SRCSO += x264dll.c
endif
@ -23,12 +23,12 @@ diff -up x264-20100620/Makefile.shared x264-20100620/Makefile
endif
OBJS = $(SRCS:%.c=%.o)
@@ -127,7 +130,7 @@ libx264.a: .depend $(OBJS) $(OBJASM)
@@ -142,7 +145,7 @@ libx264.a: .depend $(OBJS) $(OBJASM)
$(SONAME): .depend $(OBJS) $(OBJASM) $(OBJSO)
$(CC) -shared -o $@ $(OBJS) $(OBJASM) $(OBJSO) $(SOFLAGS) $(LDFLAGS)
-x264$(EXE): $(OBJCLI) libx264.a
+x264$(EXE): $(OBJCLI) $(LIB)
$(CC) -o $@ $+ $(LDFLAGS) $(LDFLAGSCLI)
$(CC) -o $@ $+ $(LDFLAGSCLI) $(LDFLAGS)
checkasm: tools/checkasm.o libx264.a

Loading…
Cancel
Save