Revert last commit. The removed patch is not merged upstream and has nothing

to do with the SONAME.
el8
Dominik Mierzejewski 14 years ago
parent f068a8280b
commit 484573d8e5

@ -0,0 +1,34 @@
diff -up x264-20101211/configure.shared x264-20101211/configure
--- x264-20101211/configure.shared 2010-12-11 19:47:37.000000000 +0100
+++ x264-20101211/configure 2010-12-11 19:48:05.000000000 +0100
@@ -796,7 +796,7 @@ if [ "$shared" = "yes" ]; then
echo "SONAME=libx264.so.$API" >> config.mak
echo 'SOFLAGS=-Wl,-soname,$(SONAME)' >> config.mak
fi
- echo 'default: $(SONAME)' >> config.mak
+ echo 'default: libx264.a $(SONAME)' >> config.mak
fi
cat version.h >> config.h
diff -up x264-20101211/Makefile.shared x264-20101211/Makefile
--- x264-20101211/Makefile.shared 2010-12-11 19:46:33.000000000 +0100
+++ x264-20101211/Makefile 2010-12-11 19:47:37.000000000 +0100
@@ -124,6 +124,9 @@ ifneq ($(SONAME),)
ifeq ($(SYS),MINGW)
SRCSO += x264dll.c
endif
+LIB=$(SONAME)
+else
+LIB=libx264.a
endif
OBJS = $(SRCS:%.c=%.o)
@@ -142,7 +145,7 @@ libx264.a: .depend $(OBJS) $(OBJASM)
$(SONAME): .depend $(OBJS) $(OBJASM) $(OBJSO)
$(CC) -shared -o $@ $(OBJS) $(OBJASM) $(OBJSO) $(SOFLAGS) $(LDFLAGS)
-x264$(EXE): $(OBJCLI) libx264.a
+x264$(EXE): $(OBJCLI) $(LIB)
$(CC) -o $@ $+ $(LDFLAGSCLI) $(LDFLAGS)
checkasm: tools/checkasm.o libx264.a

@ -3,7 +3,7 @@
Summary: H264/AVC video streams encoder
Name: x264
Version: 0.0.0
Release: 0.30.%{snapshot}%{?dist}
Release: 0.29.%{snapshot}%{?dist}
License: GPLv2+
Group: System Environment/Libraries
URL: http://developers.videolan.org/x264.html
@ -11,6 +11,8 @@ Source0: %{name}-%{snapshot}.tar.bz2
Source1: x264-snapshot.sh
# don't remove config.h and don't re-run version.sh
Patch0: x264-nover.patch
# link with shared libx264
Patch1: x264-shared.patch
# don't strip if configured with --enable-debug
Patch2: x264-nostrip.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
@ -63,6 +65,7 @@ This package contains the development files.
%prep
%setup -q -n %{name}-%{snapshot}
%patch0 -p1 -b .nover
%patch1 -p1 -b .shared
%patch2 -p1 -b .nostrip
# AUTHORS file is in iso-8859-1
iconv -f iso-8859-1 -t utf-8 -o AUTHORS.utf8 AUTHORS
@ -134,9 +137,6 @@ popd
%endif
%changelog
* Thu Mar 10 2011 Nicolas Chauvet <kwizart@gmail.com> - 0.0.0-0.30.20110227
- Remove merged x264-shared.patch
* Mon Jan 10 2011 Dominik Mierzejewski <rpm@greysector.net> 0.0.0-0.29.20110227
- 20110227 snapshot (ABI bump)

Loading…
Cancel
Save