|
|
|
@ -1,7 +1,7 @@
|
|
|
|
|
diff -up x264-20100116/configure.shared x264-20100116/configure
|
|
|
|
|
--- x264-20100116/configure.shared 2010-01-16 13:48:11.000000000 +0100
|
|
|
|
|
+++ x264-20100116/configure 2010-01-16 13:53:15.000000000 +0100
|
|
|
|
|
@@ -559,7 +559,7 @@ if [ "$shared" = "yes" ]; then
|
|
|
|
|
diff -up x264-20100620/configure.shared x264-20100620/configure
|
|
|
|
|
--- x264-20100620/configure.shared 2010-06-20 00:13:02.000000000 +0200
|
|
|
|
|
+++ x264-20100620/configure 2010-06-20 00:13:31.000000000 +0200
|
|
|
|
|
@@ -686,7 +686,7 @@ if [ "$shared" = "yes" ]; then
|
|
|
|
|
echo "SONAME=libx264.so.$API" >> config.mak
|
|
|
|
|
echo 'SOFLAGS=-Wl,-soname,$(SONAME)' >> config.mak
|
|
|
|
|
fi
|
|
|
|
@ -9,11 +9,11 @@ diff -up x264-20100116/configure.shared x264-20100116/configure
|
|
|
|
|
+ echo 'default: libx264.a $(SONAME)' >> config.mak
|
|
|
|
|
fi
|
|
|
|
|
|
|
|
|
|
pclibs="-L$libdir -lx264 $libpthread"
|
|
|
|
|
diff -up x264-20100116/Makefile.shared x264-20100116/Makefile
|
|
|
|
|
--- x264-20100116/Makefile.shared 2010-01-16 13:45:48.000000000 +0100
|
|
|
|
|
+++ x264-20100116/Makefile 2010-01-16 13:52:55.000000000 +0100
|
|
|
|
|
@@ -105,6 +105,9 @@ ifneq ($(SONAME),)
|
|
|
|
|
cat version.h >> config.h
|
|
|
|
|
diff -up x264-20100620/Makefile.shared x264-20100620/Makefile
|
|
|
|
|
--- x264-20100620/Makefile.shared 2010-06-20 00:12:43.000000000 +0200
|
|
|
|
|
+++ x264-20100620/Makefile 2010-06-20 00:13:02.000000000 +0200
|
|
|
|
|
@@ -109,6 +109,9 @@ ifneq ($(SONAME),)
|
|
|
|
|
ifeq ($(SYS),MINGW)
|
|
|
|
|
SRCSO += x264dll.c
|
|
|
|
|
endif
|
|
|
|
@ -23,7 +23,7 @@ diff -up x264-20100116/Makefile.shared x264-20100116/Makefile
|
|
|
|
|
endif
|
|
|
|
|
|
|
|
|
|
OBJS = $(SRCS:%.c=%.o)
|
|
|
|
|
@@ -123,7 +126,7 @@ libx264.a: .depend $(OBJS) $(OBJASM)
|
|
|
|
|
@@ -127,7 +130,7 @@ libx264.a: .depend $(OBJS) $(OBJASM)
|
|
|
|
|
$(SONAME): .depend $(OBJS) $(OBJASM) $(OBJSO)
|
|
|
|
|
$(CC) -shared -o $@ $(OBJS) $(OBJASM) $(OBJSO) $(SOFLAGS) $(LDFLAGS)
|
|
|
|
|
|
|
|
|
|