Update x264 to 0.155

Rebase x264-10b.patch
Add a patch to fix linking with --system-libx264 on x86
  ( https://patches.videolan.org/patch/21704/ )
el8
Sérgio M. Basto 6 years ago
parent 2a70c746d2
commit 31da68aca7

1
.gitignore vendored

@ -7,3 +7,4 @@ x264-0.148-20160118-5c65704.tar.bz2
/x264-0.148-20170519-d32d7bf.tar.bz2
/x264-0.148-20170521-aaa9aa8.tar.bz2
/x264-0.152-20171224-e9a5903.tar.bz2
/x264-0.155-20180806-0a84d98.tar.bz2

@ -1 +1 @@
78e70a1a5d60d4f8562c49e9b8c7a07c x264-0.152-20171224-e9a5903.tar.bz2
38666b9a1b712f3d0c1073105af2e6a5 x264-0.155-20180806-0a84d98.tar.bz2

@ -1,7 +1,7 @@
diff -up generic10/configure.10b generic10/configure
--- generic10/configure.10b 2016-08-26 19:48:41.447839506 +0200
+++ generic10/configure 2016-08-26 19:49:26.902033893 +0200
@@ -1372,6 +1374,12 @@ PROF_USE_LD=$PROF_USE_LD
@@ -1466,6 +1466,12 @@ PROF_USE_LD=$PROF_USE_LD
HAVE_OPENCL=$opencl
EOF
@ -12,9 +12,9 @@ diff -up generic10/configure.10b generic10/configure
+fi
+
if [ $compiler_style = MS ]; then
echo '%.o: %.c' >> config.mak
echo ' $(CC) $(CFLAGS) -c -Fo$@ $<' >> config.mak
@@ -1410,7 +1418,7 @@ if [ "$shared" = "yes" ]; then
echo 'CC_O=-Fo$@' >> config.mak
else
@@ -1505,7 +1511,7 @@ if [ "$shared" = "yes" ]; then
echo "SOFLAGS=-shared -Wl,-h,\$(SONAME) $SOFLAGS" >> config.mak
else
echo "SOSUFFIX=so" >> config.mak
@ -26,7 +26,7 @@ diff -up generic10/configure.10b generic10/configure
diff -up generic10/Makefile.10b generic10/Makefile
--- generic10/Makefile.10b 2016-06-14 14:04:37.000000000 +0200
+++ generic10/Makefile 2016-08-26 19:48:41.449839514 +0200
@@ -302,7 +302,7 @@ ifneq ($(IMPLIBNAME),)
@@ -405,7 +405,7 @@ ifneq ($(IMPLIBNAME),)
$(INSTALL) -m 755 $(SONAME) $(DESTDIR)$(bindir)
$(INSTALL) -m 644 $(IMPLIBNAME) $(DESTDIR)$(libdir)
else ifneq ($(SONAME),)

@ -0,0 +1,34 @@
From b63c73dc5c37e5405bf032c9113c1daced3e45a4 Mon Sep 17 00:00:00 2001
From: Henrik Gramner <henrik@gramner.com>
Date: Tue, 7 Aug 2018 22:42:22 +0200
Subject: [PATCH] cli: Fix linking with --system-libx264 on x86
---
common/x86/cpu-a.asm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/common/x86/cpu-a.asm b/common/x86/cpu-a.asm
index d94f7d54..a41d67f8 100644
--- a/common/x86/cpu-a.asm
+++ b/common/x86/cpu-a.asm
@@ -83,7 +83,7 @@ cglobal cpu_sfence
;-----------------------------------------------------------------------------
; intptr_t stack_align( void (*func)(void*), ... ); (up to 5 args)
;-----------------------------------------------------------------------------
-cglobal stack_align
+cvisible stack_align
mov rax, r0mp
mov r0, r1mp
mov r1, r2mp
@@ -131,7 +131,7 @@ cglobal cpu_cpuid_test
popfd
ret
-cglobal stack_align
+cvisible stack_align
push ebp
mov ebp, esp
sub esp, 20
--
2.11.0

@ -1,7 +1,7 @@
# globals for x264-0.152-20171224-e9a5903.tar.bz2
%global api 152
%global gitdate 20171224
%global gitversion e9a5903
# globals for x264-0.155-20180806-0a84d98.tar.bz2
%global api 155
%global gitdate 20180806
%global gitversion 0a84d98
%global snapshot %{gitdate}-%{gitversion}
%global gver .%{gitdate}git%{gitversion}
@ -31,7 +31,7 @@
Summary: H264/AVC video streams encoder
Name: x264
Version: 0.%{api}
Release: 7%{?gver}%{?_with_bootstrap:_bootstrap}%{?dist}
Release: 1%{?gver}%{?_with_bootstrap:_bootstrap}%{?dist}
License: GPLv2+
URL: https://www.videolan.org/developers/x264.html
Source0: %{name}-0.%{api}-%{snapshot}.tar.bz2
@ -42,6 +42,7 @@ Patch0: x264-nover.patch
# add 10b suffix to high bit depth build
Patch1: x264-10b.patch
Patch10: x264-gpac.patch
Patch20: x264-sandbox.git-b63c73dc5c37e5405bf032c9113c1daced3e45a4.patch
%{!?_without_gpac:BuildRequires: gpac-devel-static zlib-devel openssl-devel libpng-devel libjpeg-devel}
%{!?_without_libavformat:BuildRequires: ffmpeg-devel}
@ -97,6 +98,7 @@ pushd %{name}-0.%{api}-%{snapshot}
%patch0 -p1 -b .nover
%patch1 -p1 -b .10b
%patch10 -p1 -b .gpac
%patch20 -p1 -b .stack_align
popd
variants="generic generic10"
@ -201,6 +203,12 @@ install -pm644 generic/{AUTHORS,COPYING} %{buildroot}%{_pkgdocdir}/
%endif
%changelog
* Thu Oct 04 2018 Sérgio Basto <sergio@serjux.com> - 0.155-8.20180806git0a84d98
- Update x264 to 0.155
- Rebase x264-10b.patch
- Add a patch to fix linking with --system-libx264 on x86
( https://patches.videolan.org/patch/21704/ )
* Sun Aug 19 2018 Leigh Scott <leigh123linux@googlemail.com> - 0.152-7.20171224gite9a5903
- Rebuilt for Fedora 29 Mass Rebuild binutils issue

Loading…
Cancel
Save