You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
224 lines
8.2 KiB
224 lines
8.2 KiB
--- wine-1.3.25/configure.winepulse-configure 2011-07-22 19:32:43.000000000 +0200
|
|
+++ wine-1.3.25/configure 2011-08-01 19:53:18.268715283 +0200
|
|
@@ -628,6 +628,8 @@
|
|
ALSALIBS
|
|
GSTREAMER_INCL
|
|
GSTREAMER_LIBS
|
|
+PULSEINCL
|
|
+PULSELIBS
|
|
LIBGETTEXTPO
|
|
ZLIB
|
|
FREETYPEINCL
|
|
@@ -799,6 +801,7 @@
|
|
with_oss
|
|
with_png
|
|
with_pthread
|
|
+with_pulse
|
|
with_sane
|
|
with_tiff
|
|
with_v4l
|
|
@@ -1488,6 +1491,7 @@
|
|
--without-oss do not use the OSS sound support
|
|
--without-png do not use PNG
|
|
--without-pthread do not use the pthread library
|
|
+ --without-pulse do not use PulseAudio sound support
|
|
--without-sane do not use SANE (scanner support)
|
|
--without-tiff do not use TIFF
|
|
--without-v4l do not use v4l1 (v4l support)
|
|
@@ -2661,6 +2665,12 @@
|
|
fi
|
|
|
|
|
|
+# Check whether --with-pulse was given.
|
|
+if test "${with_pulse+set}" = set; then :
|
|
+ withval=$with_pulse;
|
|
+fi
|
|
+
|
|
+
|
|
# Check whether --with-sane was given.
|
|
if test "${with_sane+set}" = set; then :
|
|
withval=$with_sane;
|
|
@@ -10504,6 +10514,87 @@
|
|
fi
|
|
fi
|
|
|
|
+PULSELIBS=""
|
|
+
|
|
+PULSEINCL=""
|
|
+
|
|
+if test "x$with_pulse" != "xno";
|
|
+then
|
|
+ ac_save_CPPFLAGS="$CPPFLAGS"
|
|
+ if test "$PKG_CONFIG" != "false";
|
|
+ then
|
|
+ ac_pulse_libs="`$PKG_CONFIG --libs libpulse 2>/dev/null`"
|
|
+ ac_pulse_cflags="`$PKG_CONFIG --cflags-only-I libpulse 2>/dev/null`"
|
|
+
|
|
+ CPPFLAGS="$CPPFLAGS $ac_pulse_cflags"
|
|
+ for ac_header in pulse/pulseaudio.h
|
|
+do :
|
|
+ ac_fn_c_check_header_mongrel "$LINENO" "pulse/pulseaudio.h" "ac_cv_header_pulse_pulseaudio_h" "$ac_includes_default"
|
|
+if test "x$ac_cv_header_pulse_pulseaudio_h" = xyes; then :
|
|
+ cat >>confdefs.h <<_ACEOF
|
|
+#define HAVE_PULSE_PULSEAUDIO_H 1
|
|
+_ACEOF
|
|
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for pa_stream_is_corked in -lpulse" >&5
|
|
+$as_echo_n "checking for pa_stream_is_corked in -lpulse... " >&6; }
|
|
+if ${ac_cv_lib_pulse_pa_stream_is_corked+:} false; then :
|
|
+ $as_echo_n "(cached) " >&6
|
|
+else
|
|
+ ac_check_lib_save_LIBS=$LIBS
|
|
+LIBS="-lpulse $ac_pulse_libs $LIBS"
|
|
+cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
|
+/* end confdefs.h. */
|
|
+
|
|
+/* Override any GCC internal prototype to avoid an error.
|
|
+ Use char because int might match the return type of a GCC
|
|
+ builtin and then its argument prototype would still apply. */
|
|
+#ifdef __cplusplus
|
|
+extern "C"
|
|
+#endif
|
|
+char pa_stream_is_corked ();
|
|
+int
|
|
+main ()
|
|
+{
|
|
+return pa_stream_is_corked ();
|
|
+ ;
|
|
+ return 0;
|
|
+}
|
|
+_ACEOF
|
|
+if ac_fn_c_try_link "$LINENO"; then :
|
|
+ ac_cv_lib_pulse_pa_stream_is_corked=yes
|
|
+else
|
|
+ ac_cv_lib_pulse_pa_stream_is_corked=no
|
|
+fi
|
|
+rm -f core conftest.err conftest.$ac_objext \
|
|
+ conftest$ac_exeext conftest.$ac_ext
|
|
+LIBS=$ac_check_lib_save_LIBS
|
|
+fi
|
|
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_pulse_pa_stream_is_corked" >&5
|
|
+$as_echo "$ac_cv_lib_pulse_pa_stream_is_corked" >&6; }
|
|
+if test "x$ac_cv_lib_pulse_pa_stream_is_corked" = xyes; then :
|
|
+
|
|
+$as_echo "#define HAVE_PULSEAUDIO 1" >>confdefs.h
|
|
+
|
|
+ PULSELIBS="$ac_pulse_libs"
|
|
+ PULSEINCL="$ac_pulse_cflags"
|
|
+fi
|
|
+
|
|
+
|
|
+fi
|
|
+
|
|
+done
|
|
+
|
|
+ fi
|
|
+ CPPFLAGS="$ac_save_CPPFLAGS"
|
|
+fi
|
|
+if test "$ac_cv_lib_pulse_pa_stream_is_corked" != "yes"; then :
|
|
+ case "x$with_pulse" in
|
|
+ x) as_fn_append wine_warnings "|libpulse ${notice_platform}development files not found or too old, Pulse won't be supported." ;;
|
|
+ xno) ;;
|
|
+ *) as_fn_error $? "libpulse ${notice_platform}development files not found or too old, Pulse won't be supported.
|
|
+This is an error since --with-pulse was requested." "$LINENO" 5 ;;
|
|
+esac
|
|
+fi
|
|
+
|
|
if test "x$with_gstreamer" != "xno"
|
|
then
|
|
ac_save_CPPFLAGS="$CPPFLAGS"
|
|
@@ -11742,12 +11833,13 @@
|
|
|
|
test -n "$ALSALIBS" || enable_winealsa_drv=${enable_winealsa_drv:-no}
|
|
test -n "$COREAUDIO" || enable_winecoreaudio_drv=${enable_winecoreaudio_drv:-no}
|
|
+test -n "$PULSELIBS" || enable_winepulse_drv=${enable_winepulse_drv:-no}
|
|
test "x$ac_cv_member_oss_sysinfo_numaudioengines" = xyes || enable_wineoss_drv=${enable_wineoss_drv:-no}
|
|
test "$ac_cv_header_linux_joystick_h" = "yes" || enable_winejoystick_drv=${enable_winejoystick_drv:-no}
|
|
|
|
-if test "x$ALSALIBS$COREAUDIOLIBS" = "x" -a \
|
|
+if test "x$ALSALIBS$COREAUDIOLIBS$PULSELIBS" = "x" -a \
|
|
"x$ac_cv_member_oss_sysinfo_numaudioengines" != xyes -a \
|
|
- "x$with_alsa$with_coreaudio$with_oss" != xnonono
|
|
+ "x$with_alsa$with_coreaudio$with_oss$with_pulse" != xnonono
|
|
then
|
|
as_fn_append wine_warnings "|No sound system was found. Windows applications will be silent."
|
|
fi
|
|
@@ -15155,10 +15247,12 @@
|
|
wine_fn_config_dll winegstreamer enable_winegstreamer
|
|
wine_fn_config_dll winejoystick.drv enable_winejoystick_drv
|
|
wine_fn_config_dll winemapi enable_winemapi
|
|
+wine_fn_config_dll winemmaudio.drv enable_winemmaudio_drv
|
|
wine_fn_config_dll winemp3.acm enable_winemp3_acm
|
|
wine_fn_config_dll wineoss.drv enable_wineoss_drv
|
|
wine_fn_config_dll wineps.drv enable_wineps_drv install-lib
|
|
wine_fn_config_dll wineps16.drv16 enable_win16
|
|
+wine_fn_config_dll winepulse.drv enable_winepulse_drv
|
|
wine_fn_config_dll wineqtdecoder enable_wineqtdecoder
|
|
wine_fn_config_dll winequartz.drv enable_winequartz_drv
|
|
wine_fn_config_dll winex11.drv enable_winex11_drv
|
|
--- wine-1.3.25/configure.ac.winepulse-configure 2011-07-22 19:32:43.000000000 +0200
|
|
+++ wine-1.3.25/configure.ac 2011-08-01 19:51:41.206755129 +0200
|
|
@@ -73,6 +73,7 @@
|
|
[if test "x$withval" = "xno"; then ac_cv_header_png_h=no; fi])
|
|
AC_ARG_WITH(pthread, AS_HELP_STRING([--without-pthread],[do not use the pthread library]),
|
|
[if test "x$withval" = "xno"; then ac_cv_header_pthread_h=no; fi])
|
|
+AC_ARG_WITH(pulse, AC_HELP_STRING([--without-pulse],[do not use PulseAudio sound support]))
|
|
AC_ARG_WITH(sane, AS_HELP_STRING([--without-sane],[do not use SANE (scanner support)]))
|
|
AC_ARG_WITH(tiff, AS_HELP_STRING([--without-tiff],[do not use TIFF]),
|
|
[if test "x$withval" = "xno"; then ac_cv_header_tiffio_h=no; fi])
|
|
@@ -1435,6 +1436,30 @@
|
|
WINE_WARNING_WITH(gettextpo,[test "x$LIBGETTEXTPO" = "x"],[GetText ${notice_platform}development files not found (or too old). Internationalization won't be fully supported.])
|
|
fi
|
|
|
|
+dnl **** Check for PulseAudio ****
|
|
+AC_SUBST(PULSELIBS,"")
|
|
+AC_SUBST(PULSEINCL,"")
|
|
+if test "x$with_pulse" != "xno";
|
|
+then
|
|
+ ac_save_CPPFLAGS="$CPPFLAGS"
|
|
+ if test "$PKG_CONFIG" != "false";
|
|
+ then
|
|
+ ac_pulse_libs="`$PKG_CONFIG --libs libpulse 2>/dev/null`"
|
|
+ ac_pulse_cflags="`$PKG_CONFIG --cflags-only-I libpulse 2>/dev/null`"
|
|
+
|
|
+ CPPFLAGS="$CPPFLAGS $ac_pulse_cflags"
|
|
+ AC_CHECK_HEADERS(pulse/pulseaudio.h,
|
|
+ [AC_CHECK_LIB(pulse, pa_stream_is_corked,
|
|
+ [AC_DEFINE(HAVE_PULSEAUDIO, 1, [Define if you have pulseaudio])
|
|
+ PULSELIBS="$ac_pulse_libs"
|
|
+ PULSEINCL="$ac_pulse_cflags"],,$ac_pulse_libs)
|
|
+ ])
|
|
+ fi
|
|
+ CPPFLAGS="$ac_save_CPPFLAGS"
|
|
+fi
|
|
+WINE_WARNING_WITH(pulse, [test "$ac_cv_lib_pulse_pa_stream_is_corked" != "yes"],
|
|
+ [libpulse ${notice_platform}development files not found or too old, Pulse won't be supported.])
|
|
+
|
|
dnl **** Check for gstreamer ****
|
|
if test "x$with_gstreamer" != "xno"
|
|
then
|
|
@@ -1636,13 +1661,14 @@
|
|
dnl **** Disable unsupported winmm drivers ****
|
|
test -n "$ALSALIBS" || enable_winealsa_drv=${enable_winealsa_drv:-no}
|
|
test -n "$COREAUDIO" || enable_winecoreaudio_drv=${enable_winecoreaudio_drv:-no}
|
|
+test -n "$PULSELIBS" || enable_winepulse_drv=${enable_winepulse_drv:-no}
|
|
test "x$ac_cv_member_oss_sysinfo_numaudioengines" = xyes || enable_wineoss_drv=${enable_wineoss_drv:-no}
|
|
test "$ac_cv_header_linux_joystick_h" = "yes" || enable_winejoystick_drv=${enable_winejoystick_drv:-no}
|
|
|
|
dnl **** Check for any sound system ****
|
|
-if test "x$ALSALIBS$COREAUDIOLIBS" = "x" -a \
|
|
+if test "x$ALSALIBS$COREAUDIOLIBS$PULSELIBS" = "x" -a \
|
|
"x$ac_cv_member_oss_sysinfo_numaudioengines" != xyes -a \
|
|
- "x$with_alsa$with_coreaudio$with_oss" != xnonono
|
|
+ "x$with_alsa$with_coreaudio$with_oss$with_pulse" != xnonono
|
|
then
|
|
WINE_WARNING([No sound system was found. Windows applications will be silent.])
|
|
fi
|
|
@@ -2832,6 +2858,7 @@
|
|
WINE_CONFIG_DLL(wineoss.drv)
|
|
WINE_CONFIG_DLL(wineps.drv,,[install-lib])
|
|
WINE_CONFIG_DLL(wineps16.drv16,enable_win16)
|
|
+WINE_CONFIG_DLL(winepulse.drv)
|
|
WINE_CONFIG_DLL(wineqtdecoder)
|
|
WINE_CONFIG_DLL(winequartz.drv)
|
|
WINE_CONFIG_DLL(winex11.drv)
|