You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
59 lines
2.8 KiB
59 lines
2.8 KiB
--- configure.ac.orig 2010-12-13 10:58:43.000000000 +0100
|
|
+++ configure.ac 2010-12-13 11:01:06.000000000 +0100
|
|
@@ -81,6 +81,7 @@
|
|
[if test "x$withval" = "xno"; then ac_cv_header_png_h=no; fi])
|
|
AC_ARG_WITH(pthread, AS_HELP_STRING([--without-pthread],[do not use the pthread library]),
|
|
[if test "x$withval" = "xno"; then ac_cv_header_pthread_h=no; fi])
|
|
+AC_ARG_WITH(pulse, AC_HELP_STRING([--without-pulse],[do not use PulseAudio sound support]))
|
|
AC_ARG_WITH(sane, AS_HELP_STRING([--without-sane],[do not use SANE (scanner support)]))
|
|
AC_ARG_WITH(tiff, AS_HELP_STRING([--without-tiff],[do not use TIFF]),
|
|
[if test "x$withval" = "xno"; then ac_cv_header_tiffio_h=no; fi])
|
|
@@ -1464,6 +1465,30 @@
|
|
[gstreamer-0.10 ${notice_platform}development files not found, gstreamer support disabled])
|
|
test "x$ac_cv_lib_gstapp_0_10_gst_app_buffer_new" = xyes || enable_winegstreamer=${enable_winegstreamer:-no}
|
|
|
|
+dnl **** Check for PulseAudio ****
|
|
+AC_SUBST(PULSELIBS,"")
|
|
+AC_SUBST(PULSEINCL,"")
|
|
+if test "x$with_pulse" != "xno";
|
|
+then
|
|
+ ac_save_CPPFLAGS="$CPPFLAGS"
|
|
+ if test "$PKG_CONFIG" != "false";
|
|
+ then
|
|
+ ac_pulse_libs="`$PKG_CONFIG --libs libpulse 2>/dev/null`"
|
|
+ ac_pulse_cflags="`$PKG_CONFIG --cflags-only-I libpulse 2>/dev/null`"
|
|
+
|
|
+ CPPFLAGS="$CPPFLAGS $ac_pulse_cflags"
|
|
+ AC_CHECK_HEADERS(pulse/pulseaudio.h,
|
|
+ [AC_CHECK_LIB(pulse, pa_stream_is_corked,
|
|
+ [AC_DEFINE(HAVE_PULSEAUDIO, 1, [Define if you have pulseaudio])
|
|
+ PULSELIBS="$ac_pulse_libs"
|
|
+ PULSEINCL="$ac_pulse_cflags"],,$ac_pulse_libs)
|
|
+ ])
|
|
+ fi
|
|
+ CPPFLAGS="$ac_save_CPPFLAGS"
|
|
+fi
|
|
+WINE_WARNING_WITH(pulse, [test "$ac_cv_lib_pulse_pa_stream_is_corked" != "yes"],
|
|
+ [libpulse ${notice_platform}development files not found or too old, Pulse won't be supported.])
|
|
+
|
|
dnl **** Check for ALSA 1.x ****
|
|
AC_SUBST(ALSALIBS,"")
|
|
if test "$ac_cv_header_sys_asoundlib_h" = "yes" -o "$ac_cv_header_alsa_asoundlib_h" = "yes"
|
|
@@ -1642,7 +1667,7 @@
|
|
WINE_CHECK_SONAME(odbc,SQLConnect,,[AC_DEFINE_UNQUOTED(SONAME_LIBODBC,["libodbc.$LIBEXT"])])
|
|
|
|
dnl **** Check for any sound system ****
|
|
-if test "x$ALSALIBS$AUDIOIOLIBS$COREAUDIO$NASLIBS$ESDLIBS$ac_cv_lib_soname_jack" = "x" -a \
|
|
+if test "x$ALSALIBS$AUDIOIOLIBS$COREAUDIO$NASLIBS$ESDLIBS$PULSELIBS$ac_cv_lib_soname_jack" = "x" -a \
|
|
"$ac_cv_header_sys_soundcard_h" != "yes" -a \
|
|
"$ac_cv_header_machine_soundcard_h" != "yes" -a \
|
|
"$ac_cv_header_soundcard_h" != "yes" -a \
|
|
@@ -2797,6 +2822,7 @@
|
|
WINE_CONFIG_DLL(wineoss.drv)
|
|
WINE_CONFIG_DLL(wineps.drv)
|
|
WINE_CONFIG_DLL(wineps16.drv16,enable_win16)
|
|
+WINE_CONFIG_DLL(winepulse.drv)
|
|
WINE_CONFIG_DLL(wineqtdecoder)
|
|
WINE_CONFIG_DLL(winequartz.drv)
|
|
WINE_CONFIG_DLL(winex11.drv)
|