You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
59 lines
2.5 KiB
59 lines
2.5 KiB
--- wine-1.3.16/configure.ac.winepulse 2011-03-18 20:48:03.000000000 +0100
|
|
+++ wine-1.3.16/configure.ac 2011-03-18 21:28:27.000000000 +0100
|
|
@@ -79,6 +79,7 @@
|
|
[if test "x$withval" = "xno"; then ac_cv_header_png_h=no; fi])
|
|
AC_ARG_WITH(pthread, AS_HELP_STRING([--without-pthread],[do not use the pthread library]),
|
|
[if test "x$withval" = "xno"; then ac_cv_header_pthread_h=no; fi])
|
|
+AC_ARG_WITH(pulse, AC_HELP_STRING([--without-pulse],[do not use PulseAudio sound support]))
|
|
AC_ARG_WITH(sane, AS_HELP_STRING([--without-sane],[do not use SANE (scanner support)]))
|
|
AC_ARG_WITH(tiff, AS_HELP_STRING([--without-tiff],[do not use TIFF]),
|
|
[if test "x$withval" = "xno"; then ac_cv_header_tiffio_h=no; fi])
|
|
@@ -1476,6 +1477,30 @@
|
|
CFLAGS="$save_CFLAGS"
|
|
fi
|
|
|
|
+dnl **** Check for PulseAudio ****
|
|
+AC_SUBST(PULSELIBS,"")
|
|
+AC_SUBST(PULSEINCL,"")
|
|
+if test "x$with_pulse" != "xno";
|
|
+then
|
|
+ ac_save_CPPFLAGS="$CPPFLAGS"
|
|
+ if test "$PKG_CONFIG" != "false";
|
|
+ then
|
|
+ ac_pulse_libs="`$PKG_CONFIG --libs libpulse 2>/dev/null`"
|
|
+ ac_pulse_cflags="`$PKG_CONFIG --cflags-only-I libpulse 2>/dev/null`"
|
|
+
|
|
+ CPPFLAGS="$CPPFLAGS $ac_pulse_cflags"
|
|
+ AC_CHECK_HEADERS(pulse/pulseaudio.h,
|
|
+ [AC_CHECK_LIB(pulse, pa_stream_is_corked,
|
|
+ [AC_DEFINE(HAVE_PULSEAUDIO, 1, [Define if you have pulseaudio])
|
|
+ PULSELIBS="$ac_pulse_libs"
|
|
+ PULSEINCL="$ac_pulse_cflags"],,$ac_pulse_libs)
|
|
+ ])
|
|
+ fi
|
|
+ CPPFLAGS="$ac_save_CPPFLAGS"
|
|
+fi
|
|
+WINE_WARNING_WITH(pulse, [test "$ac_cv_lib_pulse_pa_stream_is_corked" != "yes"],
|
|
+ [libpulse ${notice_platform}development files not found or too old, Pulse won't be supported.])
|
|
+
|
|
dnl **** Check for gstreamer ****
|
|
if test "x$with_gstreamer" != "xno"
|
|
then
|
|
@@ -1672,7 +1697,7 @@
|
|
test "$ac_cv_header_linux_joystick_h" = "yes" || enable_winejoystick_drv=${enable_winejoystick_drv:-no}
|
|
|
|
dnl **** Check for any sound system ****
|
|
-if test "x$ALSALIBS$COREAUDIO$NASLIBS$ESDLIBS$ac_cv_lib_soname_jack" = "x" -a \
|
|
+if test "x$ALSALIBS$COREAUDIO$NASLIBS$ESDLIBS$PULSELIBS$ac_cv_lib_soname_jack" = "x" -a \
|
|
"$ac_cv_header_sys_soundcard_h" != "yes" -a \
|
|
"$ac_cv_header_machine_soundcard_h" != "yes" -a \
|
|
"$ac_cv_header_soundcard_h" != "yes" -a \
|
|
@@ -2849,6 +2874,7 @@
|
|
WINE_CONFIG_DLL(wineoss.drv)
|
|
WINE_CONFIG_DLL(wineps.drv)
|
|
WINE_CONFIG_DLL(wineps16.drv16,enable_win16)
|
|
+WINE_CONFIG_DLL(winepulse.drv)
|
|
WINE_CONFIG_DLL(wineqtdecoder)
|
|
WINE_CONFIG_DLL(winequartz.drv)
|
|
WINE_CONFIG_DLL(winex11.drv)
|